Jump to content

Prisma project started


Recommended Posts

The first attempt at starting has failed . I've replaced the bust fuel pipes but still nothing . Tonight I've fetched my noid lights home , plugged on into a injector connector and there not flashing when cranking . Ive tested the crank sensor resistance and it's open circuit so that will be the culprit . One is ordered and will be fitted when it arrives .

Link to post
Share on other sites

This era of lancias are really well put together . Yes it's a bit boxy and dated by 1990 . But they are better built than the dedra which replaced it . As with most Italian cars it's the earth's that cause issues . I've got a dedra turbo engine sat in garage ,I'm in 2 minds whether to fit it to this ,it's a straight bolt in .

Link to post
Share on other sites
  • lanciamatt changed the title to Prisma project started

I love these Prismas. My old man had the chance to get one as a company car back in the day. Lancia were trying to win over the uk public by getting AA staffers to drive around in them. He chickened out and went for a Montego (or was it a Cav?). What a dunderhead! 😁

I had two of its Delta brothers - a 1.3lx and a gtie. Great cars and pretty well put together too. 👍

Link to post
Share on other sites

Bit more work done . Replaced all rear brake pipes , bled brakes and we now have a nice pedal , all brakes are free too. Starter motor was weak , so I removed a known good one off a dedra turbo engine I've got in garage and fitted that . It's now running , I've freed off the stuck injector , engine runs smooth . Ideally I need to do cambelt before I run it again . 

Link to post
Share on other sites
5 hours ago, Mr_Bo11ox said:

Looks absolutely GR9 this, I love these. Has someone picked it up by the roof? Gutters look mildly chewed, though it could just be my eyes.

Yes it's been picked up by roof . I do need to try straighten those gutters out . Luckily they don't let water in . Tomorrow I'm going to do another brake pipe thats a bit past it's best and replace the other rear Flexi hose . Also going to strip and clean front brakes . Wipers only work on full speed so multi meter will be coming out to start trying to find the issue . 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...