Jump to content

Huge yank shite - odd jobs.


danthecapriman

Recommended Posts

Fuck sticks!

 

Failed the MOT today.

Not on much though, and tbh I didn't think to check this part as I'd forgotten it'd become an MOT failable item.

 

Top N/S/F ball joint dust cover ripped. That is all though!

Tester said the top one is torn and hanging off, ball joint itself is perfectly fine though so just needs a new rubber cover. He did say the bottom one on the same side is ok for now but is starting to perish.

 

I've got a set of four dust covers on order, they're an odd size here and are much bigger than the ones cars here seem to use. I've also ordered a complete top and bottom ball joint set, it's not needed this time but I'm keeping stuff like this 'in stock' at home just in case since parts for this car aren't always easy to get here in the UK.

I've got various parts in stock already but I'll just add stuff as/when. Might save me a bit of time in future.

 

Anyway, not bad really and the good thing is it's a very easy thing to put right once the part arrives.

  • Like 3
Link to comment
Share on other sites

Oh, and I forgot to add, I'm pissed off now too.

 

The car got wet today! Fucking wet! It pissed down on the way home from the MOT. I hate my cars getting wet!!

It's hilarious driving this in the rain. It smokes up the rear wheels very very easily!

Link to comment
Share on other sites

Bastard.   Fortunately it is still (just about) warm and daylight enough to dry out.   Something to think about for MOT timing - not much good having to renew in the middle of winter and aquaplaning home in three inches of salt water.....

  • Like 1
Link to comment
Share on other sites

Bastard.   Fortunately it is still (just about) warm and daylight enough to dry out.   Something to think about for MOT timing - not much good having to renew in the middle of winter and aquaplaning home in three inches of salt water.....

I could do with getting this car MOT'd earlier in the year really, at the mo it's due a week after my Transits MOT. Not ideal really as I like to stagger the MOT and tax due times to spread costs out and it makes it easier getting the car to and from the test. I've got to blag an hour off work to do that and with two being due so close together it gets noticed by work sometimes.

So far I've got the Volvo due end March, Transit and Mercury due mid September.

I try to avoid having the classics MOT's early in the year too, mine don't get used over winter and it's better to have a bit of time to use the car and free it off a bit over summer before the test.

Link to comment
Share on other sites

I hate my cars getting wet!!

Britain is probably not the best country for you to be residing in then! Glad to hear your MOT fail was minor and easily sortable.

  • Like 3
Link to comment
Share on other sites

Britain is probably not the best country for you to be residing in then! Glad to hear your MOT fail was minor and easily sortable.

Tell me about it!

A trailer home on a patch of desert in Nevada or somewhere would do me just nicely! I could sit on my porch polishing my shotgun watching the tumble weeds blow past all the while knowing I wouldn't be getting rained on today! That's the dream.

 

 

The bottom of my Capri hasn't been wet from the rain since about 2004! It'll not get rained on again either now it gets its own garage. Rain fucks things up.

Link to comment
Share on other sites

I wonder if he's got children that might remember the car? Any of you 'across the pond' shiters fancy just nipping over?!

 

I would, but it's about 823 miles so will have to pass this time...

 

Shame about the MOT but not too serious to fix once parts arrive.

  • Like 1
Link to comment
Share on other sites

Do you pay a lot of import duty on your parts from the States Dan? I've got a few bits coming from rock auto... hopefully...

No not really. Most of the time the postage costs are the highest cost as is the case here. The parts cost very little.

I think the biggest import duty cost was on the new fuel tank and even then it wasn't that much. Can't remember exact costs but I've never been particularly offended by it put it that way.

I've even found it cheaper before to get a part for my Volvo from Rockauto in the states than here in the UK, and there's much more available than here. The quality is also often much better on the US parts.

 

What you got coming? Converting one of your Mondies to a contour?!

  • Like 2
Link to comment
Share on other sites

Just odds and sods, that again, subject to duty are far cheaper in the states. E.g. PCV valve, sensors, that sort of thing. I'm just slowly stocking up for long term ownership a bit like you :-)

 

The consensus is that contour indicators don't fit the Mondy, but expect I'll try one day! I like them.

Link to comment
Share on other sites

Just odds and sods, that again, subject to duty are far cheaper in the states. E.g. PCV valve, sensors, that sort of thing. I'm just slowly stocking up for long term ownership a bit like you :-)

The consensus is that contour indicators don't fit the Mondy, but expect I'll try one day! I like them.

It's well worth doing it if you've got space to store it all. I often top up my orders with small stuff and consumables (oil filters, air filters etc) so you only pay the one lot of postage for stuff.

So far I've got a pair of recon callipers, alternator, starter, various oil and coolant sensors etc, brake pads, oil filters, air filters, plugs... well handy to have it all sat ready to use.

 

It'd be good to find an old Mondeo and get some Contour or even better Mystique parts from the US to convert the Mondy into US style! A bit like I did with my Volvo 740 really!

Link to comment
Share on other sites

The last time my 323 got caught in the wet, it had a full clean and the garage heaters turned up to around 27c to dry it out properly.

 

Like you say Dan - wet messes things up.

  • Like 1
Link to comment
Share on other sites

The last time my 323 got caught in the wet, it had a full clean and the garage heaters turned up to around 27c to dry it out properly.

Like you say Dan - wet messes things up.

I'm glad it's not just me that treats my cars like this!!

Link to comment
Share on other sites

I'm glad it's not just me that treats my cars like this!!

I'm the same, I hate my cars getting wet and dirty especially as I now have trouble cleaning them properly what with arthritis etc. I won't take the Anglia out if it's wet as it's never been restored and I want to keep it like that. The Impala has been through some nasty wetness at times, including both times that it has been 'officially' invited to Goodwood. It has survived pretty well but has had to have some rust repairs done and it now has a couple of bubbles on the left rear wheel arch. 

  • Like 1
Link to comment
Share on other sites

I've got an MOT again! Probably the last one I'll have to endure on this car given the MOT exemption next year!

 

I got the ball joint dust boot changed. Piece of piss to do, I've got a spare ball joint a some spare dust boots just in case but the old ball joint was fine so I've only changed the boot.

 

37130004952_641e9d68cb_o.jpgIMG_0697 by Dan Clark, on Flickr

 

Old boot was well ripped to bits.

37159995591_e0ec679930_o.jpgIMG_0696 by Dan Clark, on Flickr

 

New boot on and all good.

37111845976_b122568275_o.jpgIMG_0695 by Dan Clark, on Flickr

 

Took it for a retest which it passed fine.

Of course there's always a 'but' isn't there!

The cars behaving like a twat again! It fired up and drove to the test centre no problem. Ran perfectly through the test.

It was parked back outside for me to go home, try to start it up and nothing!!

Eventually I just floored it and cranked it over which got it to catch in the end. It's running horribly though and is back to its old trick of cutting out at junctions, traffic lights, or any obstacle really that forces me to stop.

Of course the 2 miles back home from the test centre couldn't be easier usually but just my shit luck every light was red, two buses forced me to stop, people refusing to give way forced me to stop, idiots parking forced me to stop... you name it it got in my way in that two miles and every time the car cut out and was a complete cunt to start again.

Eventually got home and it stinks of petrol. It also smokes thick black when revved or started.

Somehow it seems it's now inexplicably running rich, or the choke has got stuck on. Fuck knows, it's hot so I've let it cool down before I start poking around with it.

 

I'm beginning to get rather fucking irritated now though! This should not be happening now given everything that's been done on this ungrateful shit of a car. It's basically new again ffs.

  • Like 2
Link to comment
Share on other sites

I'm certainly no expert on these matters, but is the carb float getting stuck and flooding the car? Obviously sounds like its badly overfuelling.

Possible.

God knows why it's done it like it has though. It was spot on before it was parked up after the test! Nothing's been altered or messed with either as I was stood watching it get retested.

It's almost as if it's now been fixed and the bastard thing watched me walk back to it and thought 'think your getting me fixed that easy, ave some of this you cunt!'.

I'll have a look in a min but I'm rapidly losing patience with this fucker.

  • Like 2
Link to comment
Share on other sites

Right then.

 

I've just scared myself shitless and burnt my arm!

The scare was from reconnecting the two vacuum actuators, which, when the engine was started made two big bangs as the headlight doors closed. I shit myself and thought I'd just put a rod through the block or something!

Anyway rational thinking back again,

 

37112852846_36569bf7a8_o.jpgIMG_0698 by Dan Clark, on Flickr

Carb is fine. Choke working as it should.

 

37304493365_31886ca08d_o.jpgIMG_0699 by Dan Clark, on Flickr

Predictably, a sample of the plugs. One from each bank.

Black and sooty = running too rich. The carb must be over rich. Could it be that it's been like this a while but it's just coincidence it's playing up now?

I'll back the carb off a bit I reckon.

Link to comment
Share on other sites

Britain is probably not the best country for you to be residing in then! Glad to hear your MOT fail was minor and easily sortable.

.... poor old ToMM© lives on the street >> sure it must have been a 'cossetted garage queen' in a previous life [no UK Toyyo makes 26yr on a diet of saltsoup :( ]

 

Ah well...

 

 

TS

Link to comment
Share on other sites

When you disconnected the vacuum actuators, I guess you remembered to plug the holes/pipes?

Yes, I pulled the hoses and taped up the ends to stop shit getting in. Everything is now back on and connected as it should be. No change in running at all.

 

 

This is what it's left behind.

37132478932_40a1899733_o.jpgIMG_0701 by Dan Clark, on Flickr

The only way to make it run is to put your foot flat to the floor on the gas and just keep cranking it over. Eventually it catches but it runs awfully.

Once it's running it idles ok-ish. If it's revved it struggles and runs rough until it either clears or dies.

If it's running it'll keep idling for about 30 seconds but consistently then gets progressively worse until it just cuts out.

It's smoking like a mother fucker too when started, and then when it's running rough just before it cuts out.

 

Nothing I can do is having any effect either. I've pulled all plugs out and cleaned them (all thick black sooty) I've also tried weakening the mix a fair bit too but it's made fuck all difference.

 

 

 

Is your thermo switch connected and working properly?

These have to be able to switch to preheated air when not entirely hot.

Connected and seems to work.

 

 

I'm getting fucking sick of this shit now. I've had this shit pile of a car four years now and still after spending a fortune in parts, repairs and time it's still fucked. It's never managed to run consistently for a single year so far despite everything having been replaced or repaired.

It's like a sick fucking joke tbh. Talk about being repeatedly fucked up the ass when your already down.

It might be just because I'm already fucking seething mad but I just can't be arsed with all this shit anymore. I'm tempted to just get rid of the cunt tbh, straight to the oval with it.

Link to comment
Share on other sites

Yes, I pulled the hoses and taped up the ends to stop shit getting in. Everything is now back on and connected as it should be. No change in running at all.

 

 

This is what it's left behind.

 

The only way to make it run is to put your foot flat to the floor on the gas and just keep cranking it over. Eventually it catches but it runs awfully.

Once it's running it idles ok-ish. If it's revved it struggles and runs rough until it either clears or dies.

If it's running it'll keep idling for about 30 seconds but consistently then gets progressively worse until it just cuts out.

It's smoking like a mother fucker too when started, and then when it's running rough just before it cuts out.

 

Nothing I can do is having any effect either. I've pulled all plugs out and cleaned them (all thick black sooty) I've also tried weakening the mix a fair bit too but it's made fuck all difference.

 

 

I'm getting fucking sick of this shit now. I've had this shit pile of a car four years now and still after spending a fortune in parts, repairs and time it's still fucked. It's never managed to run consistently for a single year so far despite everything having been replaced or repaired.

It's like a sick fucking joke tbh. Talk about being repeatedly fucked up the ass when your already down.

It might be just because I'm already fucking seething mad but I just can't be arsed with all this shit anymore. I'm tempted to just get rid of the cunt tbh, straight to the oval with it.

 

As previously mentioned - my AMC has been behaving in a very similarly annoying way.  I sympathise - you have laid out a lot more than I have on trying to fix yours.

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...