Jump to content

Audi Allroad - the Dad Wagon.


djim

Recommended Posts

Too late now but I found that there are loads of Bluetooth adaptors that are meant to connect to the CD changer that just don't work.

In my A4 I ended up getting a more expensive one (£30 or so) from a German seller on eBay, which includes some level of electronics to tell the OEM head unit that there is a CF changer there doing it's thing.

I have repeatedly been tempted by those android double DIN jobs but mine is single DIN so I need to get a new Aircon panel etc etc so I just have my phone in a holder via the Bluetooth adapter.

Link to comment
Share on other sites

Thanks, yes looking back now I went down a bit of a rabbit hole and spent nearly as much on dongles and harnesses as I spent on the head unit, whereas a better Bluetooth adaptor would probably have done the job 99% as well. I think I’ve been lucky so far as the dongles I’ve bought (for a Passat, A4 and Seat EXEO respectively) have just worked. Anyway I’m quite pleased with it and my 10yo thinks it is ‘very cool’ so I’ll take that as a win! 

Link to comment
Share on other sites

  • 1 month later...

How's this going, all well I hope?

I came across this while reading VAG documentation for a bedtime story as I'm that cool.

https://drive.google.com/file/d/1RAvRYaYjxb3Ty-8FR19jxlaBOzuLPV0S/view?usp=drive_link

Don't know if you've seen it before but it's a VAG internal training document for staff to familiarise themselves with the allroad.

Plenty other interesting stuff at the totally SFW (but not the name I would have chosen) vag-hub.

https://www.vag-hub.com/audi-ssp/

https://www.vag-hub.com/vw-ssp/

Link to comment
Share on other sites

Hi Dave, thanks for the info, there look to be a load of useful docs there, I'm also a cool dude who loves reading a good manual so the vag-hub could be a gold mine. Probably won't tell my lady friend that is where I'm getting my reading material these days though. 

The old bus is doing fine thanks, I started drafting a post the other week but bored myself into submission. Basically since the garage fixed it it has been working fine and has hauled the fam around without too many issues. The snag list includes such delights as replacing the headliner (a 4+ hour job apparently if you can find one) and replacing the drivers door lock mechanism, or at least fixing it so that it recognises when the door is open and doesn't try and lock me out with the keys inside.  Classic VAG fair really but I'm starting to enjoy it again and it handles the crappy roads and potholes much better than my last car. 

 

 

Link to comment
Share on other sites

  • 2 months later...

Right, time for a long update on the old girl. 

I had yet another problem with the air suspension in November.  No leaks that I could identify and none of the shocks were losing air over night but the pump would struggle to charge up the air tank and would stop running and time out with an error on the dash. This was OK on short journeys and tended to happen at the end of longer drives, presumably when the pump got hot and was getting worse as days went by. 

I ran a VCDS scan and it showed a pump overheating error and given that the car now has 2x  new front air shocks and a replacement valve block I self diagnosed a tired pump (even through I rebuilt the pump seals) and fired the parts cannon at a replacement pump for around £120 from the ebay. 

I fitted it in a fun* evening on the drive at llpm to my neighbours delight, and there are no pictures because it was fairly unpleasant work lying on my back  with a head torch trying not to drop a heavy pump on my face while being showered with rust and crap. (and it was windy, it is ALWAYS windy whenever I'm under a car, it can be calm as you like until I crawl upder and then it is a blizard of leaves and dust swirling around, does anyone else find this or have I angered the wind gods somehow?)

The good news is that cured the problem and made a noticeable improvement to height adjustments if I make them so I'm pleased with how it worked out. 

image.thumb.gif.002ed1b973c661344d020731cdd80558.gif

Next up, I started getting a damp passenger footwell so I went looking for leaks, and cleared a load of crap out from around the engine bay and under the battery. There was water there but not enough to cause an issue I don't think, but it is definitely draining now. 

image.thumb.png.29a3f7bb42be4d3c271c55b7bfe6a64e.png

My daughter later confessed to spilling her water bottle in the car so it may have been a false alarm but I'm feeling better that it is done. 

As it was winter and I really couldn't be arsed to be out dealing with it in the cold and thankfully it has largely worked as hoped, hauling things, bouncing over potholes and on one occasion fording a flooded road. 

 

image.png.96a06c8c6bc37fdfb94f45d6cdf1e46f.png

After a rocky start I'm really pleased with it. 

 

Link to comment
Share on other sites

Now that we are out of the longest month I'm also starting to get some mojo back about some of the many small jobs so here are a few from this week. 

First up, the rear washer stopped working again. I could hear the pump and on investigation I opened the boot and was greeted with a dribble of blue water, thankfully not finding its way into the cabin but clearly spraying around in the door. 

image.thumb.png.b8760f0d79440166ab8f02e47c722a52.png

Yep, there's the problem. I struggled to get the pipe on when I replaced it but it clearly needed more to stop it flapping about so it was cable ties to the rescue and it should hold for a while now. 

Next up, soundz. 

one of the rear door speakers was buzzing away and harshing my mellow so a new second hand one was purchased and replaced. The door cards are pleasantly simple to remove on these, probably the simplest of any car I have had to work on, unlike the boot inner trim. 

There are no clips to break or ping off, just 2 screws at the top of the door and then a good tug upwards to lift the whole thing off and swing it away. 

IMG_6304.thumb.png.eb4549c880662f19c565ce2f6e441d25.pngIMG_6302.thumb.png.e6b165eccc546e42931b87ee5b62fe8c.pngIMG_6305.png.6746111d9699d2409a3f78dfc6d329b2.png

The speaker was just 4 screw and the cable to swap over. It looked like there was nothing at all wrong with the old one although it sounded terrible, but with the new one installed, no more buzzing. WIN. 

Next was the front door mechanism. These, along with I think all other VAG stuff of this era have a delightful trick which is that the microswitch that senses the door being opened is built into the lock. Once this stops working, the car doesn't know the door has been opened and so tries to lock your keys and children in the car unless you either start the car or open a door where the switch does work. On my old B5 A4 I had the pleasure of coming back from a 5 mile run, tossing my keys on the drivers seat and then shutting the door, whereupon the car locked and I had to hobble another 4 miles home and then back on my bike with the spare to get them back. 

The front door card is a bit harder to remove because it has more stuff on it, but still the basic 2 tiny screws and a good tug to get it off, then unclip a bunch of wires and stuff. 

Getting the lock mechanism out is just 2 of those not-torx star head screws that VW love, some clips, and then you need about 3 tiny hands to wriggle and fiddle it out through the opening. I managed to break the bit that connects the external key lock to the mechanism so it all has to come out again when the new bit arrives but I now know exactly where I will cut my hands up so it should be easier next time. 

This is the microswitch that doesn't

image.thumb.png.ed7704cc6382cbf6474d50c7ec291131.png

and this is the cam it rides on that activates it. some combination of wear and time just does for it and it is obviously quite a close tolerance as in the summer it fixed itself on hot days. 

image.thumb.png.7d0245540f939dae6a2197bc90946129.png

I feel like I could have made it work by elongating the holes to move the switch slightly closer or something but a new mechanism is not expensive so on it went. 

Lastly, was the front headlight washer. This has 2 jets on each side and one had lost its nozzle meaning that washing the screen also gave a big jet of water 10 ft over the car. You can't get replacement nozzles, just the whole washer mechanism and full replacement is a whole under-tray off, bumper off palaver, however you can replace the jetty-bit with some careful unclipping. 

First up, with your favourite plastic spudger, prize open the washer flap. It is spring loaded and it is vitally important that it doesn't pop back in once you take it apart or it will be a bugger to get the mechanism out again to reassemble. I just used mole grips.

image.png.44733fa34418befff38db2a866333c6a.png

 

Unclip the cover and then you can release the spray jet head thing which has a sort of ratchet clip holding it in on the top that can be gently lifted with a small screwdriver. the jets then just slide out. 

image.png.3b1a6c90bcf3b2cb436aceef4d2931ac.png

Take the new one apart in the same way and pop it in and you are good to go. 

image.thumb.png.f4da67a2539834941cbb5ab93f029e0e.png

 

So that is it for now. 

Next up I have a height sensor to replace as it is throwing an error code every now and then, and then it will need a fluids service in the next 1k or so but I'll save that as a treat for when the weather warms up again. 

Thanks for reading. 

Link to comment
Share on other sites

10 hours ago, djim said:

it was windy, it is ALWAYS windy whenever I'm under a car, it can be calm as you like until I crawl under and then it is a blizzard of leaves and dust swirling around, does anyone else find this or have I angered the wind gods somehow?

Oh good, I thought this was just me.

Best one is usually trying to do an oil change; all lovely and calm until the plug's pulled, and then suddenly a Force 8 gale springs up, causing the free-flow oil to blow backwards horizontally and miss the catch bowl by about three feet.

Every.

Damn.

Time.

Link to comment
Share on other sites

  • 3 weeks later...

I had a bit of time last weekend so it was time to get the height sensor fixed to stop the car complaining and to get the headlight height adjustment working again. The car has height sensors on all 4 corners and they work together to let it adjust to the selected ride height and trim the height as required. This one was working kind of OK when driving locally, presumably because the pot holed roads around here are bouncy enough that the sensor is always working up and down and giving plenty of signals.  The error comes up when I'm cruising on the motorway so I'm guessing the sensor had developed a worn/dead spot at its most common height so when the car is relatively stable for a while the lack of signal from the one sensor compared to the others causes the error. That is my complete guess anyway, the sensors themselves are completely sealed so there is no way to diagnose or repair, just throw a new one on. 

A VCDS scan showed it was the front left sensor giving spurious readings and some googling revealed the part numbers (4Z7941285 for LH and 4Z7941286 for RH fact fans) which includes the linkage. You can get the sensor by itself as it is shared across a bunch of VAG and other models but worth getting the linkage too as it will be inevitably seized. I rolled the dice and went with one from Ali-Express as they are less than half the price of getting even an eBay one here and I'm 99% sure in this case it is exactly the same thing and the quality was fine. 

Ease of replacement is largely down to how corroded the old fittings are. Set the height adjustment into service mode by holding both up and down buttons together and then once the wheel is off you can get easy access. It is pretty obvious that they have a hard life exposed in the wheel well. 

image.thumb.jpeg.808c4f871b4bd561584ec39dd79d9650.jpeg

Here it is. I was fully expecting the bolts holding the sensor to snap or round but they came out after bit of a clean and were good enough to re-use. I'm surprised that the wiring for the connector is so exposed but the connector itself was clean and dry inside so I guess it is fine. 

Old Vs New

image.thumb.jpeg.7481db5c38726111eed8900716cbe06e.jpeg

The old sensor was very stiff compared to the new and the bottom joint was frozen solid which can't have been helping. Of course the bolts holding the fixing plate to the sensor were completely goosed. they needed a 5mm allen key which I managed to get into the head after a bit of cleaning but of course it rounded out right away. 

To the vice. 

Some saw and file action got them off. 

image.thumb.jpeg.d4fe2fcc4f62556295d5fd2765d465df.jpeg

I found a couple of new bolts, cut them to length and cleaned up the bracket and then it all went together OK.

I didn't take a picture of the finished article but I'm sure you get the idea, it all went together smoothly and connected up.

I also expected to need to adjust the ride height with the new sensor in place but the car is perfectly happy with it as-is and no adjustment was needed. 

I'm quite tempted to do the other side too as it is only another £30 for a new ali-express sensor but knowing me I'd break something taking it apart so I think I'll leave it for now. 

I didn't mention previously but the car passed its MOT in January too with a few advisories for rear subframe rust (3rd year running) and it needs front drop links so that is now on the list too. I'll probably have the garage service it and do the droplinks at the same time as it is coming up for a fluids service and I want them to check the levels in the transmission and diff etc. The subframe rust will have to wait for better weather and a big dose of motivation from me but I'll get there. 

 

Link to comment
Share on other sites

  • 4 weeks later...

Righto, quick update on the latest trials and tribulations. 

First up, the passenger carpet was getting damp again, like really damp. I have already cleaned out the scuttle drains and I suspect that some small amount of water is getting in through the cabin air intake but while poking around i found the real culprit

image.jpeg.cb74d1084fb9e688b8bd3b3c5737e975.jpeg

this is up above the footwell behind the glove box and the little bit of sponge visible is wet and was visibly dripping. turns out this is a very sensible* place to put the drain spout for the air con. 

Yet another common-ish problem apparently in these is that the bottom of the drain comes out under the car and if it gets blocked at the bottom it fills up and drips into the cabin instead. 

Taking the glove box off gets better access

image.jpeg.f0baedf605ee76b524c54cebbba64367.jpeg

 

the spout thing on the right is the drain, conveniently running past some kind of delicate electronics in the silver box. 

image.jpeg.92482231ca3ac540fc0938fe584fc47b.jpeg

 

Yep, that'll be blocked then. 

image.jpeg.e27241194daf6dd379a69a66b166b121.jpeg

Good jab with various implements and all back together, hopefully the weather will warm up and dry the carpet and 2" of sponge underlay before it starts to smell too bad. 

The next job was the drivers window. This failed with various nasty grinding clunking noises a week or two ago and stopped going up and down, diagnosis: window regulator, another common failure on these apparently. 

I opted for the cheaper repair kit of cables and fittings rather than the full kit which includes sliders and is assembled, partly due to cost (£8 vs £20 or so) and partly because the full replacement needs rivets to be drilled out and replaced but I don't have a rivet gun. 

How hard can it be? 

Turns out not too bad of a job but it took me a few hours and naturally it was raining. 

First up the door needs to be stripped down and the the windows, runners and frame can be unbolted and removed as a whole unit. Quite a clever solution actually, once the door card is removed (2 screws and some wires) then mark up the position of the bolts and shims to make it easier to put back and it is just 4 torx bolts and a couple of minor trim bits to be separated. 

image.jpeg.0136d5a2cb6eac6db69c69111936eff1.jpeg

image.jpeg.9066a800ae1840027308925d4bb5abe0.jpeg

There are a couple of these shims, this one does the L/R angle and another the front back. 

Removed

image.jpeg.73d5c8f922f4a79f4d5df1843d723024.jpeg

On the workbench/dining table with the glass already removed. 

image.jpeg.ab0ad170123b046cf78b19325b9c3a3a.jpeg

The cable had snapped and bound up in the mechanism so I just cut it loose. I couldn't find any instructions on how to repair rather than replace this mechanism so I was a bit worried that I would mess it up but it mostly went together easily. 

image.jpeg.4a1e3bff9ab5b37434e84b59defbfbcd.jpeg

The real bugger was the cable winding spindle thing. I didn't take any pictures of this part but the cable is wound around a drum and the motor turns it to wind it up and down. the repair kit came with a new drum and housing but to keep the cable tight it is spring loaded at both ends and you need 7 hands to hold it all together and a special trick to do the last wind of the cable otherwise it is not tight enough. 

Here it is after i wiped my actual blood off it. note the 2 springs are fully compressed, there is literally no extra slack in the system. 

image.jpeg.8b5c86c1a182f4058540cb81fbb745c4.jpeg

After many false starts I found this video of a different window regulator cable being wound and it gave me the secret. 

the key bit is from 2 mins and the trick is to mostly wind the drum but leave enough slack to get it all together then twist the drum (2.25 in the vid) to put the last wind it and it juuuuuuuust about pops into place. I lubricated the system, replaced the glass and then it was back on to the car. 

image.jpeg.1be15a37e62773b8d3bfc72db354cb1d.jpeg

No pictures because i was losing the will at that point but it went back together OK and now the window works again. Hopefully I can stay out of that front door for a while now. 

Next I'm getting it serviced and I need to fix the tailgate inner trim/cover and then it is rustproofing the rear subframe so that will be a fun one. 

 

 

 

Link to comment
Share on other sites

  • 2 weeks later...

I did some more fixerating on this today, this time the inside boot trim/cover. 

This is it

image.jpeg.025a63cffe03acbe931052843d5d2b5d.jpeg

The problem is that it is held on with a bunch of little metal spring clips held in plastic mounts on the back of the panel.

image.jpeg.210aa4403657a745af8ae34e6b205e76.jpeg

These locate in metal holes in the boot door but they grip far better than they need to and need a firm tug to remove, leading to the the inevitable breakage of the plastic. 

image.jpeg.eb066bfc88950adc733ae848bcb7eedf.jpeg

On mine all the top 4 clips had broken leaving it held on by just the bottom clips and flapping and rattling about when the boot is opened. 

My solution; rather than try and repair the brittle plastic I bought a bunch of m4 countersunk bolts and washers and I put rivnuts into the mounting slots used to locate the clips

image.jpeg.38da51bdd0242b0f20c5e3e0065d72e8.jpeg

 

image.jpeg.f8decbc2ea9a5ceed84c3c39bbe92b2b.jpeg\\

then it was just a case of drilling some holes in the panel to line up with the broken clip mounts and FIXED. 

image.jpeg.7c8f6b441e527cf233b5cfa3ac3998ff.jpeg

It is way more secure than it was before and doesn't look too bad. I might go back with a black marker and colour in the bolt heads but otherwise i'm calling it fixed. 

I'm off to Wales with the dog tomorrow, a 500+ mile round trip, ending with some light off-roading across a couple of fields at my parents which should be a fun test. 

 

 

 

Link to comment
Share on other sites

Yep, they bloody love a flimsy clip, I've mostly had VAG shite in the past and the plastics on this tailgate are the most brittle and easily broken I've come across. I've had a saved search on eBay for another tailgate trim for this for 9 months and there are none without broken clips any more it seems.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...