Jump to content

Maestro, please. - Winga Dinga


vulgalour
 Share

Recommended Posts

Used it for an errand today, which was nice, got to know it a bit better.  It would benefit from getting the tracking done since it likes to pull left.  The tracking being off is making the tyres on it seem worse than they are, I think, it can be a bit snatchy and alarming when turning sharp rights.  It quietens down a lot once it's off the choke and presumably warmed up (no working temp gauge yet) and now I've put a couple of miles on it, the brakes are really very good.  The headlight/sidelight telltale on the dashboard has stopped working, which isn't an issue because I can address that when I get the dashboard apart to see if I can find a fault on the back of the gauges, the telltale will no doubt be a blown bulb.  Hopefully have some time and light this weekend to start investigating, for now I can use it for what I need and not worry.

 

Link to comment
Share on other sites

I'm going to be venturing into more regular Youtube videos, see how we go, should serve as a bit of work diversity and help me get stuff done.  So those subscriptions and likes and viewing times really help promote the channel and get more folks on board.  I doubt I'm going to be the next Ronald Finger when it comes to sudden viral success from working on a rubbish red 80s car, but who knows.

Link to comment
Share on other sites

I'll still be doing the picture and word updates alongside the video ones, but I'll be saving video updates for a more regular schedule.  That way, you can enjoy the updates in the best way that suits and I can keep track of what I've been doing in an easy-to-browse format so I don't have to sit through videos of me.

So, I wanted to get to the bottom of why the engine seemed quite loud and 'inductiony' at idle and my first port of call was to check there's an air filter in the air box.  There is, and it's in excellent shape.

202012-18.thumb.jpg.bf8054cee58e4486be96ceaa6f33e0ad.jpg

Next, check the oil.  Exactly where it needs to be on the stick, if a little black.  An oil change will happen in the near future.

202012-19.thumb.jpg.705f6c47517118e7ded5e7ae47808bd0.jpg

Then I went and watched an old @dollywobbler video from when he had the 1.3 Maestro van and you know what, it's just as loud as this Maestro so I think there's nothing wrong, I've just forgotten how loud this engine is in the Maestro.  Good.  Problem solved.  NEXT!

Why isn't the fuel gauge and temperature gauge working?  I know there's coolant in it, and fuel in it, so my next stop is fuses.  The fuse for the instrument panel was fine, but there's something odd about a couple of fuses in the box, can you see?

202012-20.thumb.jpg.2aee8d5dc7290c8159c6f3f0557a2a48.jpg

Rather than replace the two fuses, someone has soldered suitable gauge fuse wire to bridge them.  I'm actually pretty impressed with this, especially considering how difficult it would be to solder these in situ and how cheap and plentiful blade fuses of this type are.  That's a proper engineer's solution is that.

202012-21.thumb.jpg.49c14bb5a1c5b1cab0d22b7fbdec3b22.jpg

I used the spare fuses and the fuse puller in the glovebox to put new fuses in.  Gauges still don't work, but nothing else is broken, so it's fine.  I couldn't see anything amiss without delving into the dashboard and if I was doing that, I might as well try and fit the NOS gauge pack I bought on eBay for about £12.  Getting to the cluster was a bit of a nuisance because the speedo cable does not easily detach with things in situ, I'll go into more detail on the how and why in the video, but suffice to say I ended up unscrewing the bolt that holds the drive end of the cable to the gearbox (oil in the gearbox was a bit smelly so that's going to benefit from a change too) to give me enough slack to pull the cluster out easier.

202012-22.thumb.jpg.a2fa5173da1fa6cb35b290da6e311c15.jpg

Next problem was the steering wheel was in the way.  No bother, a simple case of popping out the boss, undoing the bolt, and getting it out the way.  The joy of pre-airbag cars.

202012-23.thumb.jpg.aa3200fa9bf78fb47849838c1cbf9250.jpg

202012-24.thumb.jpg.8d13e62ac9608a67427f29b09cff7dac.jpg

There's two multiplugs on top of the binnacle to disconnect.  There's no need to disconnect the clock from the surround, the wire is long enough that you can flip it onto the top of the dashboard out of the way.  I had found the NOS item on eBay when casually browsing for useful things - there's about £100 worth of Useful Things currently on the watch list - and thought it worth picking up even before the car arrived, just in case.

202012-28.thumb.jpg.6a861cb3354beeaac7cdb8f886307b57.jpg

I don't have a photo of the one that came in the box, so instead here's the one that came out of the car.  Nothing obviously wrong with it, some testing will be required to get to the bottom of what had gone wrong.  These are solid state modules which isn't something I'm used to, a nice bit of hi-tech 80s electronics.  I couldn't see any burnt traces or swollen components, no obvious sign of problems anywhere really so I can't tell you what was amiss with this.  I've kept hold of it for now, I'd like to understand what had gone wrong with it but I'm crap with this sort of thing so I likely never will.  I made sure to put a 'dead unit' note in the box so I don't accidentally fit it thinking it will work.

202012-27.thumb.jpg.223d22060348f2e6062461a6a3d04623.jpg

202012-26.thumb.jpg.a87c0fb4adb8683ee51254a84eceeb12.jpg

202012-25.thumb.jpg.d703504184b9e45e1ccd0194ddffae30.jpg

Then it's simply a case of fighting everything back in the hole and plugging things back in.  Before fitting all the trims, I did just test the unit to see if it worked.

202012-29.thumb.jpg.1bad4c531f8568db3517c4d81c188b38.jpg

I was delighted to be greeted with the low fuel warning light coming on and then the needle slowly climbing up...

202012-30.thumb.jpg.746badbc1bc9ef89c845bc2c56278fd2.jpg

.... eventually to about 3/4, which sounds about right since there's been about 55-60 miles done since Six-Cylinder filled it up.  Temperature gauge probably works too, I didn't get the car warmed up today to find out.

202012-31.thumb.jpg.0c2ed6e2c75db4c8e0a159f6cc3e557b.jpg

I'm very happy.  Unfortunately the only spare bulb I had for the head/sidelight telltale that looked like it wasn't blown actually was so I'll need to order some new bulbs.  Fortunately, getting to these bulbs isn't that difficult.  The biggest worry for me with this car at purchase was the non-functioning fuel gauge, I'm glad it was an easy fix.

Link to comment
Share on other sites

Let's start with some more good news which is that I managed to drive the Maestro for long enough to get it warmed up.  Seems to take a while to get the gauge to actually move but this is probably normal, the radiator hoses are both getting warm, the heater is heating, the coolant isn't leaking out anywhere.

202012-32.thumb.jpg.feaa2522656db4b6227066f5ac59ab90.jpg

Also gave the car its first bath.  Unfortunately weather cut play short so I couldn't go into as much detail as I would have liked.  The red hides a LOT of cosmetic sins and much of the paint is very flat.  That said, a lot of the paint looks like it will come around with some polish and time so I'll probably do a bit of that.  A clay bar, some tar spot removal, and a good dose of good old T-Cut will probably remedy quite a lot.  What it won't remedy is the bits where there's filler.  It's all the usual Maestro places to the usual degree so it's all very repairable.  Because it's not crunchy or falling off I'm choosing to ignore it for now, some T-cut will reduce a lot of the rusty marks so that's all I plan to do.  Later on when my welder is operational again I might fix these areas properly if I still have the car (I'll probably still have the car).

202012-33.thumb.jpg.edf5b17198ae6f4dd3b0ac81be80ede5.jpg

202012-34.thumb.jpg.374585bf9c3f980b5bd65d828816813c.jpg

202012-35.thumb.jpg.eb37e53d5d19a07d591870742258fc68.jpg

202012-37.thumb.jpg.598eb30e85e070901a0652426c8bb882.jpg

There's even a couple of those weirdly located blobs on one rear door, which have been painted to keep the rust at bay.  There's a lot of that all over this car, in fact, and it's probably what's kept it happy.  Lots of practical preventative treatment just to keep things from getting worse, and I'm very much okay with that.

202012-36.thumb.jpg.dd67eac6da176138e14ece9b10323291.jpg

The roof looks like someone might have tried machine polishing it and gone a bit heavy, what I thought was lacquer peel is actually very smooth, and there's a lot of swirl marks burned into the paint on this panel.  It will probably come back around with some effort and care, we'll see.

202012-38.thumb.jpg.e990f6174961796507bcfa6e60102a37.jpg

In the arches I thought it was black underseal, it's actually dirt.  I need to take the wheels off to clean this out properly and I will.  I didn't really find any signs of loose underseal or problems so this should all clean up quite well when I've time to get the wheels off and give it a good scrub out.

202012-39.thumb.jpg.a9c876d73c4de350dd8d0907c9080df1.jpg

202012-40.thumb.jpg.ffd593d9e2e2f2a0b1eadd08ed1ee10b.jpg

202012-41.thumb.jpg.dd7896605bc4e5c11f59c7c8f92c3a01.jpg

Inside, I found the source of an annoying rattle is the passenger seat head rest, it's missing the little plastic guide finisher/tubes.  When I'm driving I just pop the head rest out so I don't have to listen to it.  If anyone has a pair of these plastic trims please do let me know, I'd quite like some. Colour isn't important, though grey would obviously be preferred.

202012-43.thumb.jpg.51c44c0363db9adc6075749e9665fa4c.jpg

202012-42.thumb.jpg.860aff9e5e2f53b91c531f24a41b7cbf.jpg

Here it is after a very quick one-bucket wash.  The rain didn't hold off long enough for me to do the polishing and deeper clean I would have liked.  It scrubs up okay really.

202012-44.thumb.jpg.aefb97c4f76daa186a9a028dd7d91f2a.jpg

202012-45.thumb.jpg.358c33ad7cc3d379a38776798c871e7e.jpg

202012-46.thumb.jpg.0e3562d7b36d4460698f237454c38bb9.jpg

 

Link to comment
Share on other sites

On 12/9/2020 at 11:37 PM, Mrs6C said:

The chap who had it before us passed away and his family was disposing of the car. He had owned it from new and kept it garaged all its life. Other than its brief sojourn at ours, it is essentially the 'one owner car'.

Holy shit. That’s the sort of car to buy. And four hundred pounds. Incredible. 

 

Link to comment
Share on other sites

On 12/9/2020 at 10:40 PM, vulgalour said:

I was delighted to see the original head unit is still in place.  I don't know if it works or not yet, I'm just happy it's still there.

202012-14.thumb.jpg.6828dad806f340f412b5c8e9d62ab8ea.jpg

 

It does work. I took @Six-cylinder to fetch this motor and while he was dealing with the paperwork I amused myself by checking everything over.  Found a cassette in the car so was able to check both the radio and the cassette player. The only things I found that didn't work were the fuel and temperature gauges and the nearside rear foglamp. I followed him back to his place and it seems to get down the road pretty well with no problems on the maybe 5 mile trip. When we arrived at his place I managed to fix the foglamp (just cleaned up a bad connection on the bulb) then spent about two hours sitting in it in the pouring rain checking the gauges. You can actually just about get the dashboard out without removing the steering wheel and after struggling with the speedo cable for quite a while I discovered that it comes off quite easily if you simply push the white plastic ring at the top of it sideways at the appropriate point opposite the latch then pull the cable backwards. Couldn't see anything obviously wrong on the back of the dash so gave up and reinstalled it, intending to have a more in-depth look later, but it was sold before I got the chance. Glad you managed to sort them out fairly easily with your ebay bargain buy. I am sure that in your custody it will probably become one of the best Maestros left on the road.
 

Link to comment
Share on other sites

On 12/8/2020 at 2:11 PM, Six-cylinder said:

The ZX TD Avantage estate is a fully working car in use. We have had it for 9 years. 

The room above the garage is a guest bedroom, unfortunately it restricts height in the garage so we can't have a lift.

I have my study on the ground floor, but in the crook between the original house and the garage so I have a restricted view of the cars on the drive. However this week the Maestro has been in prime spot outside my window for me to ogle at.

IMG_20201208_135451 broad.jpg

Your Mrs' Bush needs trimming

Link to comment
Share on other sites

when the working gauge went in and you commented on the pez i thought you were gonna say hed left 2 quid in it cos the light was on :D

2.0i next obvs :D

does the japanese on the gauge say 'THIS IS NOT LUCAS'

edit the car just started - is it a talbot? (KIDDING)

edit 2 itll be reet once it gets used regular

edit 3 where you comment about the interior light and mess with the switch it def sounds like the exhaust is blowing

and it sounds meaty when you pull away after that

APPROVE

Link to comment
Share on other sites

It's really weird the noise it makes.  It sounds exactly like the exhaust is blowing, but it isn't.  Once you've got it up to temperature it quietens right down, to the point that sometimes at lights I think I've stalled it.  It must be the valves being out of adjustment or something, it chugs along just fine and gets up to speed no bother providing you can find the gear you're after.

Today I've been locating water leaks, trying to fix them, and unbending the rear bumper.  Moderate success was had.  When I've more time I'll do a proper update.

Link to comment
Share on other sites

While I wait for food to arrive it gives me some time to do a little update here.  As you've seen, it's a capable enough thing to get me out and about, but it also has a condensation problem.  This isn't surprising, every single car I've ever owned seems to let water in where it shouldn't so I always spend ages tracking down and then trying to resolve the issue.  The Maestro is, unsurprisingly, no different.  Since I pulled all the extra floor mats out I found the footwell on the driver's side was getting really wet where your feet go, at first I dismissed this as being because of getting in and out with wet feet, but it wasn't drying out so I was fairly certain that meant there was water getting in and being held in.  Out with the carpet then.  Fortunately the Maestro carpet is in separate pieces so the front section can be removed without taking the seats out, you just have to remove four screws from the centre console.  Two screws are hidden under the cubby - which just pulls out - at the front of the console, and two are exposed screws at the back near the seatbelt stalks.

202012-48.thumb.jpg.1c02ac8a1a79c8684281d9a2efa09315.jpg

202012-49.thumb.jpg.05d781121304a93e243bb645364233f4.jpg

I'd already glimpsed some bright blue carpet under the factory carpet so I wasn't entirely sure what to expect.  Once I got the factory carpet out, the blue household carpet under it was found to be saturated and fallen apart, never a good sign.  On the passenger side, the original felt insulation pad was still present over the blue carpet...

202012-50.thumb.jpg.c5c074faa41bb2e534b8efa96da2b13e.jpg

.... and something else...

202012-51.thumb.jpg.b6bff726083f791d0fa74dfd047848c8.jpg

... that's a first.  I'm guessing this was supposed to be some sort of moisture membrane?  No idea.  I do know it was put directly over some old welding which still looks perfectly fine as these things go.  Passenger side footwell is bone dry and while there's a few bits of painted over surface rust that would probably benefit from being cut out and replaced with fresh steel, we're not going to do that just now.

202012-52.thumb.jpg.27dc1ef250dd8c62a2ae44a6ba747add.jpg

Driver's side, once the sodden blue carpet was removed, also dried out really well.  No obvious sign of water ingress here at all which was strange.  I opted to leave the carpet out to drain overnight and to see if the water leak presented itself anew the next day, which it did.  I'm still not entirely sure how the water is getting in on this side so more investigation is required.  I do know it's coming from the sill side and no higher than the door seal and that might be why there's black paint on the door jamb, an investigation of the door seal revealed no rust or damage to the seal in the area so I don't know on this one yet.

202012-53.thumb.jpg.70c1c4e28394d039312d7431053a6dde.jpg

At the back is where the other water leak is.  This is evidenced by the condensation on the rear window...

202012-54.thumb.jpg.2476817dc64b6f1ea78003d5b38a8db5.jpg

... and the water in the boot.

202012-55.thumb.jpg.708e5dbe5ca6db4ef01414f784ee96ae.jpg

Some investigation revealed some water was getting past the old seal on the light cluster.  I made and fitted a new seal today and water was still getting into the boot but not through the light cluster.  It was also getting in through one of the bumper bolt holes, that turned out to be a slightly deformed rubber washer and was easy to resolve.  A bit more investigation revealed that water is coming through a seam in the rear panel where the rear quarter and valance overlap, this seam is sound from the outside but water can get to it through the light cluster hole so that's how I think that's getting in.

202012-56.thumb.jpg.b58d66ebf7fc77f1e6d73aa95d33c656.jpg

I dried it all out and loaded the seam up with seam sealer on both sides as much as I could.  Hopefully this keeps the water out, or at least encourages it to drain out in the proper place.

202012-57.thumb.jpg.f636dc2a934782b4ff12fb7266e59975.jpg

The other job today was the bumper, since I had it off to sort out the water leak at the bumper bolt hole.  After literally hitting it with hammers and jumping up and down on it with it attached to the car, I got the brackets and mounting points much straighter than they were.  Also threw some satin black at the metal bit to tidy it up and replace the bits of paint I'd bashed off.  It's still not perfectly straight but it is a lot better.  On the driver's side, the bumper bracket is deformed and I couldn't get it to straighten out enough, so I spaced it out with a couple of washers.  These washers also help squash the rubber washer and the mounting hole on the valance a bit flatter so you get a better seal.  I reckon the bumper bar itself is bent, now it's painted you can see where it's been walloped, probably reversing into a low wall that was hiding in the blind spot.

202012-58.thumb.jpg.4e092b95ae4abb37622c209f2bcc97aa.jpg

202012-59.thumb.jpg.bc7d316b84def858d52f1d6727230439.jpg

202012-60.thumb.jpg.29108118e2a95f24fabaf5f6a1435ca2.jpg

202012-61.thumb.jpg.288753137fbcbbfe2a0f1cbb65b2d7c5.jpg

Amazingly, the allen key headed bolts on the bumper corners weren't all rusty and seized up and came undone really easily.  The plastic mounting blocks that I believe should be there are long gone, probably broken when the rear end damage was done, but the solution works well enough that it's not really an issue aside from the slightly ugly bolt heads.

 

Link to comment
Share on other sites

the exhaust is blowing prolly the flex joint but it may just be expanding when hot so it sounds beterer& the valve clearances need doing!

interior light will be one of two things 1. switch on light itself, 2. pin switch TADTS

temp gauge should sit just below 1/2 and go upto about the same above half when the fan cuts in (the led on gauge is red)

chech fuse box for interior light relay location- there should be a metal bridge plate across 2 of the pin holes to make lights work- take it out and replace with relay and voila timed delay

fuse box looks like a few missing to me on row 8/9

i had 2- a 1.3 bASe & 2 litta* mg efi

*pronounced in a Geordie accent

Link to comment
Share on other sites

1 hour ago, Noel Tidybeard said:

the exhaust is blowing prolly the flex joint but it may just be expanding when hot so it sounds beterer& the valve clearances need doing!

interior light will be one of two things 1. switch on light itself, 2. pin switch TADTS

temp gauge should sit just below 1/2 and go upto about the same above half when the fan cuts in (the led on gauge is red)

chech fuse box for interior light relay location- there should be a metal bridge plate across 2 of the pin holes to make lights work- take it out and replace with relay and voila timed delay

fuse box looks like a few missing to me on row 8/9

i had 2- a 1.3 bASe & 2 litta* mg efi

*pronounced in a Geordie accent

Bet a 2l efi one flew! They don't look heavy! Could the brakes steering gearbox and suspension keep up though? 

Link to comment
Share on other sites

  • vulgalour changed the title to Maestro, please. - Winga Dinga

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Similar Content

    • By tommotech
      Having fetched this French delight from deepest, darkest Norfolk (well Norwich actually) in an underwhelming collection, for no other reason than the van was scooped up onto a trailer for its journey home, it was time to see what was needed.
       
      I knew a RH side load door was needed, luckily an item was procured for £20 from a guy breaking a Scudo. I drove across to Swadlincote in the van and it proved to drive well, as expected from wuvvum’s write up. On the way home it started surging when the fuel level dropped below quarter on the gauge, again as expected.
       
      Door was fitted and adjusted on return, it was even the same colour!
       
      During the week I looked at the rear doors and fettled and adjusted the locks / latches.
       
      Today I dropped the fuel tank and found a loose baffle, along with crud in the fuel pick up / tank unit. A road test will be the proof of this repair.
       
      I also achieved a working temperature gauge today and changed the power steering fluid out.
       
      The to do list includes a coolant flush, new tyres (cracked side walls), new discs and pads, LH door slider and lock handle, a deep interior clean and removal of the ladder rack. In the meantime have some photos.
       

       

       

    • By rusty_vw_man
      Been a serial lurker and occasional poster of nonsense, but have never quite got round to posting some pictures and the ongoing tribulations of being a serial VW licker.
      First a disclaimer - I like old VWs, partly as I grew up with them and partly because I understand how the work and I can fix* them. I do not like the 'scene' attached to them, it seems to attract too many of a certain type of person I am often allergic to - they bring me out in a shouty rage. 
      First car was a'69 beetle in red, driven flat out everywhere  until the rust took it. This was followed by a succession of Mk2 golf , vauxhall omega (vauxhall being close to VW in the sales ads)  a free Mk3 golf which was dire and tried to kill me multiple times. I have no photos of any of these as they were pre-camera phone and mostly awful. 
      Then came a T25 camper bought using generous donations from friends and family at our wedding . Bought, and a week later after hovering 15 years of dog hair out of it, we drove it all the way to northern Norway on honeymoon. Used it for a while.
      Bought a vauxhall astra estate (again, it was almost a VW in the sales section). It sucked. It did a year of commuting then it was scrapped. Was gifted a skoda fabia estate by my dad as a sensible run around. 
      During this time my wife wanted a sensible runaround for her and the kids, so we bought a bright orange 1971 beetle (rusty of course) which was excellent fun. People were openly critical of apparent lack of regard for our offsprings safety. I pointed out it had seat belts.
       Due to rusting the T25 was sold as a project, the Skoda was sold for being too dull and a T2 purchased.
      Here is the peak of VW ownership, where the beetle, bay and T25 are all in one place just before sale:

      So now we had two aircooled vehicles, the newest of which was  made in 1973.
      This lasted for exactly 9 months., during which I did lots of this:

      to be repeatedly rewarded with this:
       
      When the breakdown driver asks how the kids are getting on, you know you've seen him too much....
      I also conducted some invisible repairs on the rusty bits of the beetle. I'll point them out if anyone can't see them:

      A promotion and car allowance then allowed me to purchase a C3 Picasso (best not ask, I hate it). Its purple. I feel like a dick when I drive it. 
      Beetle then had to go due to third child and not enough seats, but it had the good engine, the van did not. A swap occurred. My neighbors love* me and find my antics endearing*. I clearly have no need for a drive or garage.

      After 1 too many FTPs, I was told van or family. I chose family and the van left. 
      I then went a looked at another T25 minibus (three kids now) and was in much trouble for even considering another van. 
      Two weeks later, after some small* arguments* we were in total agreement* and the van was purchased. 
      Roughly 18 months ago - note lovely laqueer peel, mismatched rear wing and low level tide mark:

       

      After some light fiddling I have made a very basic day van affair, and we dragged it with camping gear and the three kids all the way up to the arctic circle in Finland last summer (wife has family in that part of the world).
      6 days before departure I noticed the rear suspension had a bit of paint hanging off. I pulled and it showed this below:

       
      Trip to machine mart, a google of "mig wleding for numpties" and a youtube video later and I'd made this:

      and away we went. 
      Here it is in a moody B&W photo  in the land of the midnight sun, which really brings out the high quality paint. the rear suspension is still attached though, so winning. 
       
      That's an epic catch up post really, but will use this space now to document the exciting* repairs and work done on it to keep everything attached .and working.... 
    • By Broadsword
      I think the Broadsword fleet has become sufficiently complicated to merit a combined thread so that gradually all new additions will appear in one place.
       
      As of Sunday 17th March the situation is interesting.
       
      Two Citoren Xantias (remember the white Xantia of Excellence is for sale people!)
      http://autoshite.com/topic/34699-w-reg-citroen-xantia-20-hdi-xantia-of-excellence-%C2%A3999/
      http://autoshite.com/topic/34596-citroen-xantia-double-madness-rust/page-2
       
      A turquoise XJR6 pending overdue-collection (need that gone now!)
      http://autoshite.com/topic/34003-jaguar-xjr6-double-madness-double-sold
       
      An XJS 3.6 manual project which will get in high gear soonish. Wont be a keeper but will be fun getting it back to something presentable. Drivers fantastic!
      http://autoshite.com/topic/34664-jaguar-xjs-36-manual
       
      A Range Rover P38, which is turning out to be really rather good.
       
      And to mix things up even more I'm off on a collection caper today. Had first refusal on it and was expecting it to come around in a year, but things soon changed and no way was I going to pass up on it. It may well render the second Xantia redundant as I've got a really good feeling about this motor.
       
      In the meantime here are some snaps of the Range Rover. As usual it was a car I said I would probably never buy due to their reliability*. I have said the same of Jag XJR, XJS, XK8 and I have had all of those now. Basically the moment I declare buying a particular car is impractical or improbable, I end up buying one.
       
      Things to note on the P38. It's a nice colour with tidy body. The EAS has been removed. It runs and drives lovely and it doesn't have enough electrical problems to hinder progress. The main one is the driver's side window not working, but that should be fixable. I've tried changing the outstation, that didn't fix it. Might be wiring under the seat. Other than that I bought it and took it for an MOT the very next day, and it passed. Since then it had what seemed like a battery drain, but since unplugging the RF thingy for the remote locking and putting on a proper lead-acid battery, which the car can actually charge, unlike the modern lead-calcium batteries, it has been perfect. I will treat it to a full service soon.
       
      Stay tuned for the latest collection later today!



    • By Zelandeth
      Well I've been meaning to sign up here in forever, but kept forgetting. Thanks to someone over on another forum I frequent poking me about it recently the subject was forced back into my very brief attention span for long enough to get me to act on the instruction.

      I figure that my little varied fleet might bring you lot some amusement...

      So...we've got:

      1993 Lada Riva 1.5E Estate (now fuel injected, as I reckon the later cars should have been from the factory...).
      1989 Saab 900i Automatic.
      1987 Skoda 120LX 21st Anniversary Special Edition.
      1985 Sinclair C5.
      2009 Peugeot 107 Verve.

      Now getting the photos together has taken me far longer than I'd expected...so you're gonna get a couple of photos of each car for now, and I'll come back with some more information tomorrow when I've got a bit more time...

      Firstly...The Lada. Before anyone asks - in response to the single question I get asked about this car: No, it is not for sale. Took me 13 years and my father's inheritance to find the thing.


      Yes, it's got the usual rusty wings...Hoping that will be resolved in the next couple of months.

       






      Next, a proper old Saab. One of the very last 8 valve cars apparently, and all the better for it. I've driven two 16v autos and they were horrible - the auto box works sooooo much better with the torque curve of the 8 valve engine. Just wish it had an overdrive for motorway cruising...









      Next up a *real* Skoda...back when they put the engine where it belongs, right out the back. In the best possible colour of course...eye-searingly bright orange.







      Seat covers have been added since that photo was taken as it suffers from the usual rotting seat cloth problem that affects virtually all Estelles.

      Then we have possibly the world's scruffiest Sinclair C5...



      Realised when looking for this that I really need to get some more photos of the thing...I use it often enough after all! We have a dog who's half husky, so this is a really good way of getting him some exercise.

      Finally - again, I really need to take more photos of - we have the little Pug 107.



      Included for the sake of variety even if it's a bit mainstream! First (and probably to be the only) new car I've bought, and has been a cracking little motor and has asked for very little in return for putting up with nearly three years of Oxford-Milton Keynes commuter traffic, before finally escaping that fate when my housemate moved to a new job. Now it doesn't do many miles and is my default car for "when I've managed to break everything else."

      I'll fill in some more details tomorrow - I warn you though that I do tend to ramble...
    • By Tickman
      First some background:
      I was brought up with no car interest, a car was transport and nothing more which resulted in a selection of poor cheap cars being the cars of my youth.
       
      Fast forward many years (just over 9 years ago) and I have a wonderful* Vauxhall Vectra estate to carry us about. Unfortunately it is crap and throws fault codes at us with nothing being there when it is checked (even at Vauxhall)
       
      As Mrs T is the main pilot of this chariot with the two little miss T's on board, it has to go.
      The hunt is on for the new steed to safely and comfortably carry the family around. I have a company car at the time so big journeys are not an issue.
       
      ebay is my weapon of choice to find the new family car. It has to be good value cheap for no other reason than I am tight.
       
      Weeks of research with lots of cars that are too expensive and too far away for easy collection end up in my watch list.
      Finally a possible is spotted in Fife. I go and have a look and find a poor looking but solid car. One previous owner and lots of history.
       
      The auction was to end on the Saturday at midday, we were going to be out! I decided on how much I was willing to gamble on it and on the Saturday morning I put in my max bid but straight away it went to my max bid, I was winning but it had three hours to go with no room for me to go up! We went out anyway.
       
      I spent the next three hours kicking myself for not bidding more while we were out as it was the first car I had seen that fitted my criteria. Fate was in charge.

      On returning home I go straight on ebay to find 'Congratulations.............'
      For the grand total of £500 I had just won this fine vehicle!
       

       
      It has 5 months MOT and after fitting seat belts in the rear for the girls car seats it is pushed into daily service.
      My gamble and subsequent use results in a perfectly reliable car that actually does what it is supposed to do.
       
      Even more importantly Mrs T loves it so a win all round.
       
      All my cars have names (most are earned over a bit of time) and this one is called 'Gwendolen' ( G reg car and from Wales originally. I hate the name but I am not going to argue)
       
      That sums up part one, more will be along later (probably much later)
×
×
  • Create New...