Jump to content

Citroen C6 bought, low cost big liability ?


Recommended Posts

The Internet reckoned that the one way drive clutch on the alternator would be the cause of the charging issue.

Slackening the accessory belt and turning the center section revealed that the clutch was indeed goosed.

IMG_20200815_140730.thumb.jpg.dc87df53285f830af30a3d6917581984.jpg

A Sealey clutch removal tool was purchased.

However the torx bolt has been battered in the past so the tool wouldn't  engage.

IMG_20200816_143414.thumb.jpg.bd8b094c8fbc4c0f1cd2356bad127fa2.jpg

So the alternator had to come out. It's not a bad job, just need to remove the arch liner, undertray , intercooler boost pipe and the air-con compressor. Worst bit was physically getting to the boost pipe attachments.

IMG_20200816_162311.thumb.jpg.e5174bd8304d2535c883145285fbb767.jpg

With the alternator off a bit of violence got the tool to fit. 

More violence with a 2 foot breaker bar couldn't shift the pulley. 

I gave up and ordered a new alternator complete with pulley.

That was ordered on Tuesday with 48hr delivery so I'd have it for this weekend.

The bloody suppliers waited until Thursday before they dispatched it so it wont be here until tomorrow :(

I'm also waiting on a lexia computer code reader thing. Never used one before, hopefully I wont deprogram all the onboard computers.

More news soon...

Link to post
Share on other sites
14 minutes ago, Macscrooge said:

Luverly. I’ve never mustered the nerve to take on a big Citroen - hats off to those who do!  

Older big Citroens are no bother, don't be put off by the hydraulics. 

XM, CX and DS are relativly simple beasts.

This C6 does scare me a bit, mostly the electronics.

I'm taking brave pills . Well,liquid pills...

20200823_195854.thumb.jpg.1b66966964567b293c80382335d37e5c.jpg

Link to post
Share on other sites
16 minutes ago, Daviemck2006 said:

A low battery or poor charging can cause all sorts of electrical problems. I hope when the lexia arrives that 1 - you can figure the lexia out, and 2 - the lexia can figure the c6 out!

Sent from my SM-T585 using Tapatalk
 

That's what I'm hopeing. Not checked the tracking on the Lexia, no point on a weekend as France is mostly shut anyway.

 

Link to post
Share on other sites

A parcel arrived today. 

IMG_20200824_164903.thumb.jpg.40f7d6e3dd141cc200627cf4753c8782.jpg

Looks like they've sent the right part ?

IMG_20200824_165152.thumb.jpg.242f5b6cffec80ebcfd2a7a72eee589f.jpg

From the website site I was under the impression that it was remanufactured in France. 

The quality control report that came with it is in Chinese. So I guess by remanufactured they mean repackaged. 

If work goes well tomorrow, I'll be trying to remember which bolt goes where on Wednesday. 

 

 

Link to post
Share on other sites

The number of broken C6s for sale make it the sensible thing to buy a broken one. 

Paying top dollar for a non broken one can only be a temporary reprive as it will surely become a broken one soon. 

Fingers crossed the alternator swap solved multiple problems. 

Link to post
Share on other sites

freewheeling pulley means it charges only on eithe acceleration or deceleration. cant remember which. its for less stress on components and battery. 

im sure the clutch bolts a re left hand thread btw.

Link to post
Share on other sites
5 hours ago, sloth said:

freewheeling pulley means it charges only on eithe acceleration or deceleration. cant remember which. its for less stress on components and battery. 

im sure the clutch bolts a re left hand thread btw.

Not technically true . It allows the belt to “ jump “ forward quietly when the crank pulses forward violently with each power stroke . Mainly needed on 4 cylinder modern diesels . Makes for quite belt running and gives the tensioner an easier life . 
A sign that one has failed( locked both ways ) is the belt and tensioner dancing up and down 

Link to post
Share on other sites

The computer was asking to connect, but as my garage is way out of WiFi range there is no danger.

There's probably more danger with me attempting to use diagbox for the first time.

I've managed to read and reset a bucket load of codes. Particularly an egr error which was flagged on the last CT (mot) and managed to acctuate said egr solenoid and here it clicking away.

ABS and Esp fault seems to be right rear speed sensor.  Hopefully that'll be a simple fix.

There was a couple of can bus errors that I'm not thinking about until the weekend...

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...