Jump to content
Sign in to follow this  
Sunny Jim

Sunny Jim's BX 16 RS Estate: New Carb Fitted

Recommended Posts

After using it for my daily 20 mile commute this past week I'm starting to compile a list of what requires attention.

1) Choke - the car has a manual choke but the cable has been disconnected from the carb. Today was my first chance to look at it so of course it's pissed it down nearly all day. When it finally stopped I took the plastic cover off the side of the carb and discovered that at some stage someone has taken it upon themselves to jam the choke flap in the pull down position by means of an artfully placed M13 nylock nut!

IMG_20200718_185239.thumb.jpg.e68115c3f31538e6fc18a8820ccc0e03.jpg

Not sure why this has been done or how I'm going to reconnect the cable - perhaps some of these bits that I found on top of the battery might help?

IMG_20200718_185209.thumb.jpg.592d2a6a72ed699b6451dd2890378135.jpg

By this stage I was getting hungry and I learnt a long time ago not to work on vehicles when I'm hungry. I'll come back to this tomorrow.

2) Speedometer not working. A conversation with a previous owner revealed the plastic fitting on the end of the cable where it fits into the speedo is broken. I've read an account on the BX forum of someone successfully repairing one with superglue and araldite but have bitten the bullet and ordered a new cable from Chevronics. This became more of a priority when I received my first ever NIP in the post today - I was caught doing 35mph in a 30 on the A5 in Llangollen on my way home from Norfolk last weekend - hopefully I'll just get a Speed Awareness Course.

IMG_20200718_232652.thumb.jpg.d153fef8b2f878a78e579da82dce89bd.jpg

3) Heater control stuck on hot. I'm hoping this is just a case of a cable having come adrift, I'll dismantle the centre console and have a look.

4) There was an advisory on the last MOT for a fluid leak from the NSR. On the advice of @dollywobbler I've been in touch with @mat_the_cat and will be making arrangements for him to take a look. This is my first hydropneumatic and I'm going to have to get my head round it but for now I want someone who knows what they're doing to have a look.

5) While not filthy the oil looks like it could do with a change so a new filter is also on order. In any case unless it's obviously just been done I like to service a car I've just bought.

6) There doesn't seem to be much in the way of antifreeze in the coolant so a flush and replenish is also on the cards.

7) While it appears generally solid there is some surface rust which will need attention before it gets worse. At some stage the car has been stored under an ill-fitting cover. On the plus side the usual places BXs go such as the inner wings and the bulkhead behind the washer bottles are all sound but unfortunately it's rubbed through the paint on the wheel arches and the window surrounds. @BertiePuntoCabrio was very upfront about this before I bought the car so I knew what I was getting into. 

IMG_20200719_085230.thumb.jpg.9eac361e47ad4e24b6750068f9e8a90d.jpg

The MOT is next month so hopefully it won't throw up too many surprises. For now I hope we have some good weather for the next few weekends while I work my way through this lot.

Share this post


Link to post
Share on other sites

Good progress already! 

Yes, I made sure any little piles of bits - like on the battery - where kept with the car just in case!

As for the upcoming mot, my favourite garage (see other thread) were confident and complimentary of the state of this underneath so fingers crossed for you! 

Share this post


Link to post
Share on other sites

Not a very successful day. Further investigation has revealed that the moving parts of the auto choke are seized and I'm not sure they're repairable. I'm therefore now hunting for new parts to repair the auto choke or a kit to properly convert it to a manual choke - I'm not sure that the cable that's been routed from the cabin was ever connected to the choke. So far I'm drawing blanks on either option so I might have to go down the route of sourcing a new carb. Ah, bugger.

Share this post


Link to post
Share on other sites

Those carbs are pretty crap anyway, so I'd personally be thinking about a Weber conversion. Some friends did this on a 1.9 with good success. 

Heater is almost certainly a stuck tap. If you jam your hand up behind the dashboard near the clutch pedal, you should be able to get your hand on it. Horrible job (on RHD) to get the matrix out to fix, but turning the heater fan to fully off should stop airflow I think. Been a while since I owned a BX.

Share this post


Link to post
Share on other sites
On 7/18/2020 at 11:08 PM, Sunny Jim said:

3) Heater control stuck on hot. I'm hoping this is just a case of a cable having come adrift, I'll dismantle the centre console and have a look.

I had to have my stuck value stripped and cleaned last year, horrid job so I had it done at Chevronics who have experience, but it cost £260 in just labour.

Mine also had the dash rotary control broken by being forced which was extra.

 

Share this post


Link to post
Share on other sites
On 7/18/2020 at 11:08 PM, Sunny Jim said:

After using it for my daily 20 mile commute this past week I'm starting to compile a list of what requires attention.

1) Choke - the car has a manual choke but the cable has been disconnected from the carb. Today was my first chance to look at it so of course it's pissed it down nearly all day. When it finally stopped I took the plastic cover off the side of the carb and discovered that at some stage someone has taken it upon themselves to jam the choke flap in the pull down position by means of an artfully placed M13 nylock nut!

IMG_20200718_185239.thumb.jpg.e68115c3f31538e6fc18a8820ccc0e03.jpg

Not sure why this has been done or how I'm going to reconnect the cable - perhaps some of these bits that I found on top of the battery might help?

IMG_20200718_185209.thumb.jpg.592d2a6a72ed699b6451dd2890378135.jpg

By this stage I was getting hungry and I learnt a long time ago not to work on vehicles when I'm hungry. I'll come back to this tomorrow.

2) Speedometer not working. A conversation with a previous owner revealed the plastic fitting on the end of the cable where it fits into the speedo is broken. I've read an account on the BX forum of someone successfully repairing one with superglue and araldite but have bitten the bullet and ordered a new cable from Chevronics. This became more of a priority when I received my first ever NIP in the post today - I was caught doing 35mph in a 30 on the A5 in Llangollen on my way home from Norfolk last weekend - hopefully I'll just get a Speed Awareness Course.

IMG_20200718_232652.thumb.jpg.d153fef8b2f878a78e579da82dce89bd.jpg

3) Heater control stuck on hot. I'm hoping this is just a case of a cable having come adrift, I'll dismantle the centre console and have a look.

4) There was an advisory on the last MOT for a fluid leak from the NSR. On the advice of @dollywobbler I've been in touch with @mat_the_cat and will be making arrangements for him to take a look. This is my first hydropneumatic and I'm going to have to get my head round it but for now I want someone who knows what they're doing to have a look.

5) While not filthy the oil looks like it could do with a change so a new filter is also on order. In any case unless it's obviously just been done I like to service a car I've just bought.

6) There doesn't seem to be much in the way of antifreeze in the coolant so a flush and replenish is also on the cards.

7) While it appears generally solid there is some surface rust which will need attention before it gets worse. At some stage the car has been stored under an ill-fitting cover. On the plus side the usual places BXs go such as the inner wings and the bulkhead behind the washer bottles are all sound but unfortunately it's rubbed through the paint on the wheel arches and the window surrounds. @BertiePuntoCabrio was very upfront about this before I bought the car so I knew what I was getting into. 

IMG_20200719_085230.thumb.jpg.9eac361e47ad4e24b6750068f9e8a90d.jpg

The MOT is next month so hopefully it won't throw up too many surprises. For now I hope we have some good weather for the next few weekends while I work my way through this lot.

35 in a 30. Sorry to see. Without turning this thread into a speeding rant here in London we have 20 and 30 MPH zones. Hardly anybody complies except me and my little Citroen AX (yes there is Citroen content here) gets a fair amount of abuse for sticking to the limit. A crazy old world.

Nice car nice posts 👏- the carb is a lovely old bodge 🖼. I will be in France this summer I hope - if you are stuck for a carb let me know - gives me an excuse to hang about French scrap yards. 😁

Share this post


Link to post
Share on other sites
1 hour ago, Six-cylinder said:

I had to have my stuck value stripped and cleaned last year, horrid job so I had it done at Chevronics who have experience, but it cost £260 in just labour.

Mine also had the dash rotary control broken by being forced which was extra.

 

Agreed that it's a horrible job, especially on a RHD car as the steering column gets in the way rather! Be gentle with the valve too, as the sliding part is brittle so can break easily. If it is jammed then removal and stripping is likely the only option.

Share this post


Link to post
Share on other sites

Extensive googling and use of my schoolboy French has led me to track down a NOS Solex on a French website at a price I'm willing* to pay. If the vendor will accept PayPal will I get some sort of protection? He appears to be straight down the line but it's hard to tell in another language.

Hopefully I'm negotiating to buy a carburettor and not one of these!

solexindexthumb.jpg.d2918f00149225d3e4f3f6f5406d8d07.jpg

 

Share this post


Link to post
Share on other sites

Last Saturday I went over the mountain to @mat_the_cat who kindly had a look at the BX's suspension. The car had had an advisory for a fluid leak from the NSR at the last MOT but after removing the gaiter and cleaning it mat could find no trace of it so I'll put that down as solved. Mat also showed me how to lubricate the front struts. All in all a productive visit, I'm much indebted to mat for generously sharing his knowledge.

The rest of the week has been spent trying to track down a carburettor. After chasing up possible leads in France and the Netherlands one turned up in Leeds so on the hottest day of the year I did a six hour round trip to go and get it.

IMG_20200801_134422.thumb.jpg.6f6b2355740a876ac7108450414fe503.jpg

Getting the old one out was relatively straightforward but it was only when I had them side by side that I started to notice a few differences in spite of them having the same model number.

IMG_20200801_140759.thumb.jpg.de610acacb58fb1fa6547276a117608c.jpg

The bracket for the throttle cable was bent on the new one and not having a decent vice to hand I decided to just transfer the one from the old carb to the new.

Included with the new carb was a little bag containing the all important wax stat and associated bits for the automatic choke which is what was FUBARed on the old one. I admit to spending too long trying to figure out where the extra threaded pipe was supposed to go.

IMG_20200801_141746.thumb.jpg.18d9ef6a4f2344213555c9e5bf65ce99.jpg

After awhile (and feeling rather foolish) I finally twigged that it was nothing to do with the auto choke but in fact was an alternative smaller diameter fitting for the fuel inlet pipe! Some models had larger diameter fuel pipes I recall reading somewhere.

IMG_20200801_142807.thumb.jpg.21f3300316ed36e2aad4e41697e37f89.jpg

This left me with one more problem to solve. My old carb had no fuel return but the new one did. HBOL and google weren't providing any answers, just some pictures of carbs with and without fuel returns but no mention of how the fuel return should be plumbed in. I decided the best thing to do was see if the car had a return fuel pipe and where it ran. After tracing it under the car and into the engine bay I discovered that for some reason the fuel return on my car was plumbed into a T-piece on the fuel inlet to the carb.

IMG_20200801_164907_LI.thumb.jpg.848a9d086e345a8e11fd6b06c4ebf9c0.jpg

That piece of pipe looked past its best in any case so I replaced it with a new run straight onto the carb. Fortunately the return was long enough to reach onto the carb so I treated it to a proper clip dispensing with the old jubilee clip. I'm just assuming I've done the right thing here - all this is new to me - so please feel free to put me right if I've made a mistake.

I was much relieved when it started first time with no throttle!

I think it's idling too fast, tomorrow I'm going to check I haven't got too much tension in throttle cable holding it open a little. If that's not the case I'll let it warm up fully and try tweaking the idle speed screw to see what I can achieve.

All in all a satisfactory afternoon's work. I heard back from North Wales Police this week with the offer of an online speed awareness course. £88 for a Zoom meeting! Therefore next on the list is the speedo cable.

 

 

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Similar Content

    • By cobblers
      Train tickets booked from a train station 30 miles away to save £9 on the recommendation of the Mrs
      Mrs booked and primed ready to drop me off at said train station.




      Mobile tool kit primed and ready, missing almost every vital component due to EU regulations about leccy tape and screwdrivers on trains (I left them all at my mums house yesterday).
      If I do break down, I should have something to listen to while I work out whether I'm with the AA or RAC or none of the above.


      Not pictured: pile of cash
    • By Slowsilver
      For as long as I can remember I have been aware of a dead K-prefix Mondeo saloon languishing on the drive of a house about two streets away from here. It had obviously been sat there for many years without moving. I kept meaning to drop a note through the door enquiring about it, but as always I never got round to it.
      Until now.
      With Bob the Renault 6 currently on hold pending a possible sale after lockdown and the Maxi mothballed due to lack of places to take it to I was getting bored, so last Friday I did just that. Things moved on very rapidly from there.
      Timeline: Saturday morning.
      I received a phone call  from the owner's daughter, who informed me that her father had owned the car since it was 18 months old and cherished it for years, doing about 2 or 3 thousand miles a year in it until 2013, when it failed the MoT:
      Date tested 17 September 2013
      Fail
      Mileage 70,926 miles
      Reason(s) for failure
      Service brake: efficiency below requirements (3.7.B.7) Brakes imbalanced across an axle (3.7.B.5b) He was told by the local garage he used that it would cost about £1000 to fix even if they could get the parts, which they said was doubtful. How can inefficient and unbalanced rear brakes cost that much to fix? And can Mondeo parts be unobtainium already? Maybe I will find out in due course.
      Anyway, he decided that was more than the car was worth but, being very attached to it, he simply parked it on the drive and left it there.
      Apparently he died about 3 years ago but his wife couldn't bear to see it go, so there it stayed until now.
      Coincidentally his wife died a few weeks ago, so I hope my approach didn't seem like grave robbing. Their daughter was planning to have the car taken away for scrap, so I was intending to offer her scrap value for it and see if it could be saved. However, she was so pleased at the prospect of her dad's beloved motor being revived that, without me making an offer, she immediately offered it to me for the princely sum of zero pounds. She also agreed that quicksilver and myself could work on it where it sat until such time as we could move it. She said that she would endeavour to find the V5 and the keys.
      Timeline: Saturday afternoon.
      Checking the registration online showed it to be a 2.0i Ghia, built in Belgium in May 1993 and registered in the UK on 15th June 1993. K prefix registrations ran from August 1992 to July 1993 but the Mondeo was not launched in the UK until 22nd March 1993, so had been in production less than three months, making this a very early Mark 1. Has been on SORN since September 2013.
      Let's go and see what we have.
      It's walking distance so that counts as exercise doesn't it 😃.
      Didn't even know if it was a manual or an automatic. Turns out it's a 5-speed manual.
      Apart from flat tyres it doesn't look to bad from a distance.

      But what about the blind side next to the fence. Fortunately it had been parked far enough away to see it.

      Urgh! It's green instead of blue.

      Back of the roof has bloomed badly, but laquer doesn't appear to have peeled.
      We took a cordless tyre inflator so the first job was to attempt to pump the tyres up. We weren't very hopeful as it had been sitting here for 7 years. The two nearside tyres had 0psi in them, the offside front had about 7psi in it and the offside rear had about 12psi in it.
      They were all pumped up to a nominal 30psi and appeared to stay up.
      Timeline: Sunday afternoon.
      Let's take a bucket of soapy water round and give it a quick swill.
      Three tyres still up. Nearside rear flat again. 75% success rate. Not bad. Pumped the flat one back up again.
      Throw bucket of water over car and apply sponge and nylon brush.
      While washing it we noticed bubbles issuing from from a tiny pinhole in the bottom of the sidewall of the nearside rear tyre.
      That will be why it went flat again then. It looks like there may have been a thorn or a sharp piece of stone on the drive next to the bottom of the tyre and when it went completely flat the weight of the car pushed it through the sidewall. 

      That's looking better.
      Not much more we can do without the keys as it's all locked up.
      Timeline: Monday morning.
      Another phone call from the daughter. She is at the house and has found the V5 and one key. Also handbook and service record. Thinks there may be another key somewhere. We wander round there and do the necessary paper work. It is now offically ours!
      Timeline: Monday afternoon.
      Send off new keeper slip and SORN declaration.
      This time we have to take the Zafira full of tools in an attempt to get it moving.
      It has been left with the handbrake on and the front discs look well rusty, so I  bet the brakes have seized on.
      Takes 2 hands to lift the handbrake lever, then 2 hands to press the button and release the ratchet.
      Rock the car gently and, wonder of wonders, all four wheels appear to rotate. First hurdle overcome.
      Don't want to bore you guys but some of you might like to know our technique for attempting to revive a long-dead engine, honed at various Field of Dreams chod-tinkerings.
      Check oil and water levels. Oil  looks pretty clean so probably serviced not long before it was laid up.
      Remove spark plugs. These all look in good condition.
      Pour a spoonful of engine oil into each cylinder just to give some extra bore lubrication on initial turn over.
      Engine compartment is so cramped that can't see an easy way to try and turn the engine with a spanner, so drop a long screwdriver into one of the spark plug holes so that it rests on top the piston, engage fourth gear and attempt to push the car down the drive, which fortunately has a reasonable downward slope. Watch the screwdriver and, sure enough, we see it rising. The engine isn't seized, thank goodness we don't have another Bob on our hands.
      Because the owner's other car was parked alongside we could not get the Zafira in to jump the battery so we connected up one of the two knackered old batteries we had brought round. Didn't want to risk connecting across a totally dead battery and shorting out the other one, so left the positive terminal connected to the original battery but disconnected the earth wires from the original battery and connected the negative jump lead to the isolated leads, thus removing the original battery from the system. Doing it this way ensures that the positive connections are still kept clear of any metalwork that could cause a short and the negative connection is earthed anyway, so doesn't matter if that touches any other metal. Turned on the ignition and, lo and behold, we have assorted dashboard warning lights.
      Hit the starter. Click. We were right, this battery is knackered.
      Try the other one. Whirr, whirr, the engine spins over. Let it spin until the oil pressure light goes out.
      Clean the plugs with a wire brush (not that they appeared to need it) and replace them. Reconnect the HT leads, making sure they are in the right order. Chug, chug, chug. Engine reluctantly turns over but not fast enough to fire.
      Remember we have a the tiny but powerful Chinese jump pack in the glove box of the Zafira, so this is deployed. Chug, chug, cough, splutter, BLOODY HELL IT'S ONLY RUNNING!
      Remove jump pack and it is still running on the alternator output.
      Leave it running while we check the condition of the spare wheel. Full size alloy, not one of these horrible space-saver things. Appears to have some air in it. Pump it up and fit it to the nearside rear. Try driving it up and down the drive to test the brakes. As we expected they were not great, but worked well enough to stop it eventually. Unfortunately the handbrake would also stop the car but the ratchet would not re-engage so having freed off the brakes it now insisted on rolling down the drive. So we took a deep breath and, leaving everything behind, we set off for home.
      No collection thread as the distance involved was about 500 yards, but target achieved with no problems, except for the power-assisted steering, which apparently now isn't. Have a cup of tea then walk back round to pile all the detritus back into the Zafira and drive it home.

      Gone. Mossy piece of tarmac blinking in the sunlight for the first time in 7 years.

      In its new home. Bob is not impressed by this non-French interloper and turns his back on it.
      Let's see what we have.

      Nicely mouldy steering wheel. Oh look, footwell lights. I say, how posh, did I mention it's a Ghia.

      Illuminated vanity mirrors. Can this get any posher?

      Optional giffer pack included.

      Lots of damp and mouldy boot trim now basking in the sunshine.
      So, what is the overall assessment.
      On cursory inspection it appears to have zero rot on the bodywork or the underside.
      Haven't tried everything yet. A few of the lights don't work (hopefully just bulbs or mouldy connections). Nor do the screenwashers.
      The two main problems seem to be the non-working power steering and the ABS warning light being on. But haven't had time for in-depth investigations yet, so here's hoping an MoT can be passed eventually. No rush, it is a lockdown project after all.
      By now I am sure you are all bored to death so I will stop rambling.
      Bloody hell these threads take a long time to compile.
      Stay tuned for more developments. Or not.
       




















    • By L fallax
      I’ve been considering making a topic for progress with my Felicia for a little while, I want to reflect on what’s been done in a more organised fashion compared to flicking through photos on my phone. 
      I’ve had a keen interest on older generation Skoda for quite some time (100series-Facelift Felicia), I bought this 1999 T reg Skoda Felicia mid April. Would of loved to buy the pre-facelift model but sadly most seem to have been scrapped, however mine does come with the 1.3 OHC engine -the same used in Rapid 136’s, albeit slightly modernised and with Bosch fuel injection producing a whopping 67bhp. 

      First pic after a wash. Missing headlight trim, dinged rear OS door, NS fender is a bit bashed in as the original owner must of had a bit of a bash, the whole bumper sits a little lopsided. Hopefully can get the bodywork pulled at some point.

       
      This is my first car that I’ve bought with my own money, so naturally wanted to put in the effort to get her running smoothly with some maintenance: new oil & filter, air filter, coolant flush, wipers, bulbs, spark plugs, valve cover gasket etc.
        
      Engine bay needed multiple washes to clean up, looked a right bombsite when I bought it, some neglect was evident from past owner!
      Three and a half months later and my Felly is now road legal (due to issues with DVLA and V62), what a jolly little car to drive though! The exhaust blows like a wet fart when you press the accelerator but it’s very comical. (Obviously will fix this when I’ve the money, haha.) 

       Driving around aimlessly I’ve covered around 160 miles in a couple of days.  I decided to drain the gearbox and refreshed it with some 75W90 SS Gl4, after a few embarrasing car park CRUNCHES into reverse gear enough was enough, definitely was well overdue a change and now it’s silky smooth. 

      Blue Lagoon Metallic is the colour for anyone wondering.
      (Removed the faded Skoda badge and sprayed the 3D Favorit badge and grill black - perhaps not to everyone’s taste but it’s my car 😄)
      Next to do is fit new brake discs & yellowstuff pads which have been sat in the boot for a couple months, need to file the edge of the pads down a tad and find a way to remove the locking pin screw from the disc- I can’t seem to get them to turn using an impact screwdriver but perhaps I just need to hit harder!
      The goal is to fit a few unnecessary modifications,  just some stiffer lowering springs and alloy wheels with good tyres. Nothing too crazy. The ride is pretty good, very little body roll, the strut brace seems to work well. A very throwable and responsive supermini, town and rural road driving is an awful lot of fun. 
      If anyone has some Favorit "Skoda" mudflaps let me know as I really would like to replace the ones that are fitted!
      Updates to come.
      All welcome to share thoughts and stories alike 🙂 
       
    • By strangeangel
      I thought I'd start a thread for this as I'll probably end up asking all sorts of questions, given that this is my first 'proper' Citroën.
       
      So... the ground clearance lever won't go all the way to the highest setting (all others work), which is bad 'cos the book says I need it to do that in order to check the LHM level. It feels like something's seized, so I don't want to force it. Any ideas for a plan of attack would be much appreciated.
       
      Next up are the wheels. I now have a set of 205 pepperpots that have just gone off for powder coating & I need to get some tyres for them. The handbook says the car should have 165/70R14s on, the wheels came with 185/65R14 on. Any thoughts about what size I should get please? Cheers.
       
×
×
  • Create New...