Jump to content
phil_lihp

1977 Princess 1.8 HL - Saggy Brown Joy: Road Test!

Recommended Posts

Who wants Princess updates?  I do!

I had a full day on this yesterday - hooray for decent weather.  I started by fitting some of the parts I had ordered a while back - it now sports a shiny new rotor arm, distributor cap and plug leads.  I also refitted the air filter assembly which was in the passenger footwell and put a NOS air filter in it.

20200516_181058.thumb.jpg.a2acc4808cf9a103be07d7fed2293d94.jpg

The end result is that it doesn't really run any differently - fear not, I am going to keep hold of the old items even though they're ancient and a bit crusty, they did work and I am aware that modern components often are not the same quality as older stuff.  I still need to change the plugs and the oil - still waiting on some deliveries - and fit the correct mechanical fuel pump.  The electric one obviously does the job but I don't like it, it constantly runs when the ignition is on as you can hear it ticking and I have noticed a smell of petrol when it's running, I wonder if it's overfuelling the engine.

I then left it ticking over for a few minutes while I got ready for the next step and went inside the house for a minute.  I came back out and was concerned to noticed a bit of steam coming out from under the bonnet - this turned to mild panic when I realised it was not steam, it was smoke and there was a strong smell of burning.  I turned off the engine and opened the bonnet to be greeted with a smoking engine block - very odd, smoke was coming from the valve gasket and various other joints and the engine block was obviously extremely hot.  I then noticed the top radiator hose had a big split in it - however the header tank is still full of green coolant.  The engine block remained sizzling hot for several minutes afterwards, when I was washing all the leaves and muck out from the engine bay any water drops that hit the block sizzled.  I made sure not to spray any water on it to avoid any risk of cracking.

Fortunately it doesn't seem to have done it any harm (actually it's not running on so much any more so I think it's de-coked itself somewhat!) and it still runs as it did before with no horrible noises, smells or smoke, although I've only run it long enough to put it back off the road onto my driveway.  Having investigated, I think the waterpump has failed, it turns really easily by hand with no real resistance.  This might explain why the engine coolant temp gauge stayed in the middle despite it clearly being very hot.  I have a new waterpump to go on, that's now become a priority and I have ordered a set of new hoses and a thermostat as well, I don't want that to happen again.  It'll get a thorough flush through with detergent while I have it apart.  The cooling fan also did not appear to kick in and the seller did say it had stopped working, I have a video from last year of the car running and the fan was working then but that could be because there was no water in the top radiator hose, the sensor appears to be in the top of the radiator.  

Drama over, I then emptied all the detritus out of the boot - including what I think is a pair of Sierra wing mirrors (they'll be going on eBay unless anyone here wants them) and set to trying to clean 28 years of ground in filth off the paintwork.  I chose to use some very specialised detailing equipment for this first pass so I gathered up a bucket, an old sponge, a dustpan brush and some washing up liquid and got to work.  After that, I used some cutting polish and wax to see what I was left with.  The end result is...ummm...better?  It will need another couple of washes and I will dig out my clay towel to see if that helps, the paint is still rough and did not take the polish well.

20200516_142020.thumb.jpg.fe06f88c318398e1feec43705f4da2d0.jpg

I then made a bold decision and ripped off the tattered remains of the vinyl on the C pillars - it was ripped to pieces and was acting as a moisture trap to let water in but not out, so I was not surprised to find this - which actually looked a lot less terrifying after rubbing it down with a wire brush and applying vactan,

20200516_142200.thumb.jpg.cd406a1cacaae85a6fdb22590d2e124c.jpg20200516_141957.thumb.jpg.7d3765bf3a4d92fd90cc1c170b6d3690.jpg20200516_141941.thumb.jpg.928e286c139b7a546959d9d868c8b084.jpg

It wasn't a surprise to be honest, I could feel crunchy stuff behind the vinyl, could have been a lot worse.  I will contact a local bodyshop who have previously fixed some rust on the Rover 220SLi for me to see if they will do it.  Depending on how well the repair can be done I may or may not re-vinyl the pillars, not sure yet.  The bootlid might be saveable but it's crusty (although solid) along its bottom inner edge so I doubt it is worth the investment.  For now, some gaffer tape will suffice to keep the rain off it temporarily.  I covered every rusty scab I could find in vactan and the end result of all this skilled restoration work is that it looks slightly less horrible...the vactan had the unexpected reaction of acting like a coat of varnish so after getting as much loose paint off the bonnet as I could, I ended up covering the whole panel in it.  It has at least made it look the same colour as the paint.

20200516_180226.thumb.jpg.ad98d39cc2f1cb5993ecbae4de701236.jpg20200516_180246.thumb.jpg.c4d08a4b25fc43063d1ee39917ff3f8b.jpg

This rear door is too far gone, the bottom of it is missing entirely so I will keep my eye out for a replacement.  There's some holes under the front valance and around the rear lights but overall it isn't too bad.

20200516_142116.thumb.jpg.07788bc5797eb29dcfee742c80aa8dbb.jpg

Last job of the day, which took forever, was hoiking out the interior so the soaking wet underlay and damp carpets could be allowed to dry properly.  I found one nasty rust hole in the passenger side floor/sill area but it doesn't look hard to repair, the rest of it is thankfully solid.  @vulgalour was dead right, the scuttle panel was an inch deep in leaf mould and other debris, once that was all scooped out and flushed through with a hosepipe water ran straight down through the back of the wings so the drains are now clear.  With the carpets out I can experiment at some point to see if water's getting in anywhere else.

The carpet smells grim and is pretty mouldy, the fibres are matted down hard in a lot of places so I don't know if it's saveable.  I will experiment at some point with ways to clean it up, I would like to save it if I can.  I refitted the driver's seat so I can move the car around.

20200516_162917.thumb.jpg.29446021ea6ff6eb28c545a81381ff4b.jpg

20200516_173319.thumb.jpg.74f7a847bade26cc78bbebe21a3545d1.jpg

Under the back seat I found some slightly damp reciepts and garage bills from the 80s which I'll add to the service history, including one for a suspension regas in the 80s, plus these nostalgic items.  I am not opening the tin for any amount of money, the best before date is 1994.

20200516_154803.thumb.jpg.3112b0071e5e1bbbbbc2adb1ffa4d2bb.jpg 20200516_154034.thumb.jpg.e5d937b331875ed4411a1e658aa1f120.jpg

Today I tried to find out why the hazards work but the indicators don't - my Haynes manual says they use the same relay but I don't think they do.  There's a confusion of extra wiring for the aftermarket radio and a tow bar (which I may reinstate as it's all still with the car) under the dash which is not helping, I found that there's a couple of small square relays up behind the steering column which click when the hazards are on, nothing happens with the indicators at all so I suspect this flasher relay - which is hanging loose and had a blue wire out of it which I reattached to no avail.

20200517_114259.thumb.jpg.8003ce55172385617e24db0816c025f3.jpg

I am, for now, assuming that the indicator stalk is OK as the main beam selector and horn both work.  Still working my head around it, wiring is not my forte but I am learning slowly.  I will try applying power to that relay and see if it responds - it must be something like that as they did work a year ago.

Next steps are to decide what to do with the interior, change the oil when the filter turns up next week and find someone local who can patch up the holes without costing a fortune.  There's a nice new set of plugs on the way too, once that and the cooling system are as good as they can be I can see if any work needs to be done with the carb.  Oh, and while it's up on ramps for the oil change I need to find out where the exhaust is blowing.  Oh and get the suspension raised up.  And clean it a bit more.  

Oh, and drive it!

20200516_142106.jpg

20200516_142206.jpg

20200516_145115.jpg

Share this post


Link to post
Share on other sites

My waterpump theory is partly due to the fact that although the header tank is brim full of coolant, the split radiator hose didn't spill any water at all so it does not seem to be circulating.  I have also noticed that it's been split all along, I can see it in the first photos I put up, not sure how I missed that.  I prised the hoses off the thermostat housing and they're clear, the thermostat itself looks fairly clean and there's no sign of any blockages.  It looks like it has been flushed through but I will do it again and change all the bits that are suspect.

Share this post


Link to post
Share on other sites

At least with an old iron block engine like a B series overheating shouldn’t have caused terminal issues. 

The rust closest to the rear side windows on the C pillars looks to have been caused mainly by the ‘Princess’ badges that were (or should have been) there. One of the holes in the N/S Pic looks like one of their mounting points. 

Share this post


Link to post
Share on other sites

Great progress, Mr Lihp.  

I'm not sure I'd go too mental on the paintwork if it was mine.  I live in permanent conflict with myself over the Mini and Sierra.  One day I want them to look like someone loves them, the next I'm worrying about overdoing it.  Then I'll think "wouldn't it be nice to own something I'm really proud of" and then its "60 year old women look ridiculous with fake tits, and my car should look its age".  And we go on and on.

This seems to be a nice balance of "story" vs "respectability".  So don't worry what we might think, we all love it! 

Share this post


Link to post
Share on other sites

You're both right - yes, the holes are mainly from the Princess badges.  Fortunately they, plus all the stainless steel trim, came off perfectly intact.

This car will definitely retain its shabbiness - I have no intention of a respray or full restoration.  Bodywork isn't my thing and I only want cars to look as good as they can with the paint they have got, as you'll have seen from the magnificently shambolic XJ40.  Likewise the interior - as long as it's tidy and doesn't smell like a dead badger, I will be happy.  Like you say, I think it's great for a car to wear its history.

Oh, bonus good thing: the headlining is immaculate.  That's a relief, didn't want to get into that!

Share this post


Link to post
Share on other sites

Only just seen this thread, these are great cars that has a lovely feel to the suspension and a very comfy interior.

Looking forward to the updates.

Share this post


Link to post
Share on other sites

Indicators should be on a second relay, it seems fairly common for them to fail and be replaced.  That loose one you found is probably the replacement and probably also dead.  The square Lucas ones are of very variable quality, I resorted to a more modern 'electronic' one that has actually been perfectly reliable since.  Rear doors can be very difficult to source, and replacements are rarely any better than you currently have fitted unfortunately.  I would recommend getting original panels repaired where possible, even though Princesses were mass produced, the variation in panel fitment could easily lead you to believe otherwise.  If the floor portion of the carpet hasn't torn when you removed it then it's probably tough enough to survive a careful powerwashing and that should bring the fibres back up again nicely.  A carpet shampoo machine will certainly work and now you've got it out it's a whole world easier to clean it up.  The inner sill carpets are lighter weight than the floor pieces and more prone to rotting, especially where screws and bolts go through them, so these tend to need a little more care.

Astonishingly, your car could be on its original sills, the seam between the sill and the rear arch is still there and this is usually welded/fillered over when replacement sills are put on.  That bodes particularly well if true because it means you're unlikely to be undoing bad bodywork repairs to put the rust right.  Speaking of, the rust you've got visible there since removing the vinyl is also much better than usual and really localised so shouldn't be too horrendous to put right.  Access for rust protection on the C pillars is pretty good when the inner trims are removed (they're on with spring clips so just pull off).  If all you've got is a little hole in the floor and the car has been letting water in, you've done remarkably well.  I can offer you a spare Allegro hubcap to replace your presumably missing Princess one, Princess hubcaps are specific to the Princess even though they're the same size as Allegro ones.  I just realised as well that the beauty rings it wore in the barn find pictures seem to have gone missing, they can be a very difficult item to source, I did have three waiting for the right car and since appear to have lost them, or sold them and forgot that I did.

For the paint, invest in a claybar, they work wonders on paint that otherwise looks shot.  Follow up with as nice a wax as you can bear to afford, even Turtle Wax will get a reasonable amount of protection on it.  Metallic paints on Princesses do have a habit of looking a bit flatter than modern paints, they seem more toward 60s pearlescent paints than modern sparkly paints, so they can look a bit dusty even when they're in excellent condition.

Share this post


Link to post
Share on other sites

Oh, and your waterpump theory is sound, they do fail without warning sometimes and because the fan temperature switch is in the radiator that would definitely explain the fan not coming on even though the engine is scorchio.  Also, the radiator temperature switches fail, seemingly not long after a car is put back into service, but they are cheap and readily available and very easy to replace.

Share this post


Link to post
Share on other sites
16 hours ago, vulgalour said:

 If the floor portion of the carpet hasn't torn when you removed it then it's probably tough enough to survive a careful powerwashing and that should bring the fibres back up again nicely. 

I'd second that; a vigorous scrubbing with concentrated soapy water then a blast with a jet wash should have it looking much cheerier.

Share this post


Link to post
Share on other sites

Thanks for the advice on the carpets, I will give that a go - can't hurt!  Alas some of the side trims on the sills were already too far gone to save, they were absolutely rotten and disintegrated when I moved them but I have saved what I can.

The rust is not as scary as I first thought and I have been assured by the seller that it's structurally solid - it certainly seems to be, that door is the worst part of it I have found so far.  There's some missing metal at the bottom back of the rear wheelarches but not a lot, so far I have found one repair to the end of the passenger sill and that's about it.  Once I get it up on ramps for the oil change I will have a good poke around underneath.  The floor under the carpets is much better than what I found under my last Puma which was 23 years newer!

Thanks for the advice @vulgalour - that's all tremendously encouraging.  Will any flasher relay work or do you happen to know what yours is?  

If you would like some extra good news, I have all 4 trim rings, they were in the boot, and have refitted 2 - they're grubby and a bit scruffy but intact and circular.  One is visible in the duct tape photo above.

Share this post


Link to post
Share on other sites

Wonderful.  Good to see you cracking on with it Phil.  Just don't poke too hard when it's up on ramps...we all know how badly that can end.

Share this post


Link to post
Share on other sites

Nice progress, if the carpet is pretty bad I have heard of people sticking a pressure washer on them. I suppose it will either perform a miracle or destroy the carpet depending how solid backing is!

Share this post


Link to post
Share on other sites
3 hours ago, Shite Ron said:

Following your thread makes me wish I had bought this:

image.thumb.jpeg.d1364b5b5c6863e5e1070cb3f056dd7b.jpeg

 

That looks amazingly solid and a near identical clone of mine, right down to the tow bar.  I think that's the field full of classic cars that got auctioned off a while back, Smith & Sniff have an excellent walkaround video on YouTube, I'll have to revisit it to see if they looked at this one.

@RobT you're absolutely right - and ignorance is bliss.

Share this post


Link to post
Share on other sites
2 hours ago, HMC said:

PS -GK London registration?

Could be - the car's only had two owners from new prior to me, the first was Rank Leisure Services who seemed to be involved with motorway services and clubs from what I have found out.  They acquired the car brand new on 12/7/77 and were based in Surrey.  The second owner who had it until last year lived near Reading.  

Share this post


Link to post
Share on other sites

The flasher relay I fitted was like this one:  https://www.ebay.co.uk/itm/12V-ELECTRONIC-INDICATOR-FLASHER-RELAY-CLASSIC-CAR-WITH-OE-CLICK-X-L-P-2-3-PIN/181922797997 Providing you find a decent earth point for it, they're plug and play.  Fitted mine in about 2016/17 I think and it's not given me any bother in all that time, they seem really well made and make a good click.

Rank used to do bingo hall stuff, probably still do in fact, I remember my late gran having a passport blue plastic wallet with the gold Rank logo on it which she kept a membership card in for when she went to bingo on holiday.  The last Rank bingo hall I remember seeing turned into a Mecca bingo hall (it was formerly a small cinema, as many bingo halls are) so I wonder if Rank rebranded, or merged with another company or something.

Good news on the wheel trims!  I'd managed totally miss the one that's fitted in your pics, must be all the excitement.  From what I remember the wheel trims are stainless like the waist trims, so they should clean up really well and really easily.  For the green on the hubcaps, etc. you can use a bit of white vinegar on a cloth, or brasso, or better yet some Autosol and they'll come up really well, should even work on the radio controls.  Fortunate that the rust treatment is a similar sort of shade to the paint, it's made the bonnet look much better.

Share this post


Link to post
Share on other sites

Thanks @vulgalour - very helpful.  I was wondering what might clean the trims up.  I'll get that relay ordered and see if it does the trick.

@RobT it has a certain poetry about it.  I'd like to imagine some dodgy geezer with a large moustache who manages a chain of bingo halls and slightly seedy clubs driving around with his duffle coat on, the back seat piled up with boxes of absinthe and Lambrini, making deals in dimly lit back rooms and popping in to the betting shop on his way home.  

Share this post


Link to post
Share on other sites

Ah, the nostalgia evoked by the Rank Organisation.

On the subject of fuel, not sure if an LRP additive would help with the pinking, or whether the B-series needs it.  I've been using one for years in the Metro, and have sometimes wondered if I've been wasting my money.  A proper tune up is probably a more effective cure (as if I know what I'm talking about).

Share this post


Link to post
Share on other sites
8 hours ago, HMC said:

PS -GK London registration?

Yeah, SW London - we've had two Citroens in the family that started life at Lovekyn in Kingston and they were both -GK. 

Share this post


Link to post
Share on other sites

A quick tinkering session last night means Margaret now has new spark plugs and a NOS top radiator hose. 

IMG-20200521-WA0000.thumb.jpeg.f987d35933542bfce65b8d7ffe8be0fd.jpeg

At the weekend I will change the other two hoses I managed to get hold of along with the waterpump and thermostat and hopefully get the cooling system back where it should be.   While NOS rubber parts had me a bit concerned, they're still pretty flexible and a hundred times better than the rock-hard, rotten items it had before so for the tiny amount they cost, I'll take them.  I don't know about you but I find it really satisfying installing shiny new parts on an old car.

20200521_181035.thumb.jpg.90a33ffa5c4ea5b79c67622db8b57793.jpg

Old plugs looked ancient and very black, it starts and runs with a very brief test but I suspect the timing is off, it doesn't rev very cleanly and pops back through the inlet.  I'll have a play with that at the weekend.  It still has a water leak into the cabin when it rains, the old windscreen seal is very perished so I have bitten the bullet and purchased a brand new windscreen seal from the owner's club.  I hate damp interiors and it will just ruin the car if left unchecked.

I've also invested in a nice roll of black gaffer tape which has tidied up the rusty bits on the C pillars and boot lid for now, as well as making them more watertight.  Maybe I should just wrap the whole car in it.

Share this post


Link to post
Share on other sites

That was something I always loved about these cars was that there is so much room under the bonnet to work on them. With a modern car I open the bonnet and think 'nah, that can go down the garage'. With these you can see what you are trying work on and actually reach it! I do love these. Well done for saving it.

Share this post


Link to post
Share on other sites

Here is one for sale in S. Spain. Looks like a  UK holiday car that was rear ended then scrapped - not on DVLA database so poss an insurance write-off. Who knows what state the panels are in. Not sure if you can get a Princess door under the seat on an Easyjet flight!

https://www.milanuncios.com/venta-de-coches-clasicos/austin-princess-2-000cc-95625842.htm?

 

20200522_130411.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Fumbler
      To mark the genesis of my fleet project thread I here present my new car: a 1997 Nissan Micra Shape-


      It really looks that good. There is a reason for this: its previous owner was an old lady who loved the thing so much so she made every effort to keep it in good shape. It originally came from Fleet in the GU postcode which suggests to me it was bought by the present dealer at auction, hence arriving down here in Kent. Before seeing the car I checked its MOT history and its only fails were thanks to broken stoplights, which shows me that it was very well cared for. I suppose an example of this was that on the last MOT, an advisory was a corroded rear silencer. The silencer on the car when I saw it was new. Methinks the lady wanted to keep it as good as possible. It was kept in a garage and so all the bumpers and black trim are very black and the tyres are in very good condition. Spare never used! Also included a free Dettol first aid kit from 1997.
      This car has 15000 genuine miles on the clock. We clocked over 15000 during the test drive! The lady owner really only trundled around her village in it and the MOT shows that it only did some meagre miles between tests. This, of course, came at a price. We saw a cherry red Micra from 2002 at the same dealer. Paint was shoddy and when they washed it the boot had massive sections of bare metal and it wasn't very happy. This car, however, is in fabulous condition and there was no contest between the two cars- it really is that good, inside and out. Immaculate interior, driver's airbag, cassette player... all there and all functioning (apart from cassette thanks to new battery and failed display). This meant that I bought it for £1600, £100 over what was my uppermost limit, but I knew I wouldn't see another like this that was in as good shape for a fair while. It was priced very ambitiously, at £1990, so I'm content in the fact I managed to slash a few hundred off the price. There wasn't that much paperwork though. All the dealership received was the logbook with 3 service stamps from 1998, 1999 and 2000, the radio key pass, a National Trust sticker, and the original paperwork holder. I suspect the old lady died and had her car auctioned, and the massive file of paperwork is now someone's egg carton, along will everything else she owned.

      As always, this car isn't exactly in showroom condition. While the inside is great and the floor is solid, and the underseal is in great shape, the not undersealed parts need a small looking at. Mainly the rear of the driver's side sill. It's really the only bubbling on the car. I suspect a well aimed stonechip managed to fester over the wintery salted roads, making it rust even more. It's around the size of a 5p piece, and will give me the opportunity to spray the insides of the sill with some chain oil to prevent any further corrosion. Behind the fuel tank there are a few rusty joints- places where the spraygun cannot get paint onto- which some Vactan and Dynax should put to rights. Alternator belt looks original because of the cracking and Nissan badges and will need doing soon as well as the front plate. As much as I like the 90's font and original dealer surround, the dishevelled R and general water ingress is a persistant MOT advisory. It could be the MOT station being strict (and most likely is considering there's a Saxo down the road with far worse blackening), however for the sake of peace of mind and all that, I'll get a new one made. The rear has already been replaced indicating this has happened before.
      All in all, I think this is a nice plucky motor. I'll have it by the end of the week; just got to sort out tax, insurance, and it's going to have an MOT. As part of the deal it's getting the MOT and an oil and filter change which will be something ticked off the list. It has some love scratches and chips here and there, but it drives well, is stiff and controllable, and should make out to be a nice summer project!
    • By captain_70s
      Hullo,
       
      I'm a masochist from Leeds who is running two rusty, worn out Triumph Dolomites as my only transport in rural Aberdeenshire. You might recognise me from various other forums and Facebook groups. Realistically I need to buy a modern car of some sort, but instead I find myself looking at £300 Citroen BXs and Triumph Acclaims on Gumtree and thinking "yeah, that'd fit right in with the rest of the broken cars I can't afford".
       
      On to the cars, the main attraction being my 1976 1850HL "50 Shades of Yellow" that I bought for £850 and is currently my daily driver, here is a picture of it before I sanded off some surface rust and sprayed it badly in the wrong shade of yellow with rattle cans:
       

       
      Within a month of purchase I managed to plant it in to a steel fence backwards after a botched gear change on a wet roundabout and ruined the N/S rear wing, although judging by the other dent that's packed with filler it looks like somebody had already done the same. I also managed to destroy a halfshaft and one of my Sprint alloys (good for an extra 15hp) in the incident, so now it's sitting on it's original steelies but painted black (good for an extra 5hp).
       
      It's only broken down on me twice. once with some sort of fuel delivery related problem which may or may not have been an empty fuel tank and once when the thermostat jammed shut and it overheated and blew out some O-rings for the cooling system. It has recently developed a taste for coolant and oil which is rather annoying, although it's done 89,300 miles which is about 80,000 more miles than BL engineering is designed to last, I'm keeping my eye on eBay for replacement engines... 
      I tried to keep ahead of the rust a bit by rubbing down the arches and re-painting them, but apparently rattle can paint isn't great when you are spraying it at -5C, it also highlighted how although my car might have been Inca Yellow in 1976 it's now more of a "cat piss" sort of shade. So I ended up with the wrong shade of yellow which has rust coming back through after 5 weeks. Did I mention I'm incompetent?
       
      The other car is the first "classic" car I bought, so I can't bear to sell it. It's a '77 Dolomite 1300 and it cost £1400 (about £400 too much) and has been nothing but a pain in the arse:
       

       
      It looks much prettier (from 100 yards) but that's most due to the darker paintwork hiding the rust. It lives a mollycoddled life in my garage, where it somehow still manages to rust, and is utterly rubbish. 0-60 is measured on a calendar, top speed is 80ish but at that point it uses more oil than petrol, it rarely ventures over 50mph and if you encounter an incline of any sort you can kiss that sort of speed goodbye, along with about £20 of 20W50 as it vanishes out of the exhaust in the form of blue smoke.
       
      One of the PO's had clearly never heard of the term "oil change" so it developed into brown sludge that coated everything internally with the next owner(s) blissfully pouring fresh oil on top of it. This lasted until about 600 miles into my ownership when there was muffled "pop" from the engine bay and the car became a 3-cylinder. The cause was catastrophic wear to the top end causing a rocker arm to snap:
       

       
      As this was my first classic car I'd assumed it was supposed to sound like the engine was full of marbles, it wasn't.
       
      I put the engine back together with second hand bits declared it utterly fucked and promptly did another 5000 miles with it. After about 3500 of those miles the oil burning started, valve seals have gone so it's been relegated to my parent's garage as a backup car and something to take to local car shows as the 1850 is now embarrassingly ugly. I'm keeping my eye on eBay for replacement engines (deja vu, anybody?) Oh, I also recently reversed it into a parked Ford Fiesta and royally fucked up the rear bumper, rear panel and bootlid. Did I mention I'm incompetent?
       
      There have been two other cars in my life. My first car, a 2008 Toyota Yaris 1.0 an it's replacement a 2012 Corsa 1.4T. I didn't really want either of them, but it's a long story involving my parents and poor life choices. Ask if you want to hear it!
       
      So that's a brief summary of my current shite. If you want more pictures or details of anything do say as I've got photos of almost everything I'd done with the cars.
    • By Tickman
      First some background:
      I was brought up with no car interest, a car was transport and nothing more which resulted in a selection of poor cheap cars being the cars of my youth.
       
      Fast forward many years (just over 9 years ago) and I have a wonderful* Vauxhall Vectra estate to carry us about. Unfortunately it is crap and throws fault codes at us with nothing being there when it is checked (even at Vauxhall)
       
      As Mrs T is the main pilot of this chariot with the two little miss T's on board, it has to go.
      The hunt is on for the new steed to safely and comfortably carry the family around. I have a company car at the time so big journeys are not an issue.
       
      ebay is my weapon of choice to find the new family car. It has to be good value cheap for no other reason than I am tight.
       
      Weeks of research with lots of cars that are too expensive and too far away for easy collection end up in my watch list.
      Finally a possible is spotted in Fife. I go and have a look and find a poor looking but solid car. One previous owner and lots of history.
       
      The auction was to end on the Saturday at midday, we were going to be out! I decided on how much I was willing to gamble on it and on the Saturday morning I put in my max bid but straight away it went to my max bid, I was winning but it had three hours to go with no room for me to go up! We went out anyway.
       
      I spent the next three hours kicking myself for not bidding more while we were out as it was the first car I had seen that fitted my criteria. Fate was in charge.

      On returning home I go straight on ebay to find 'Congratulations.............'
      For the grand total of £500 I had just won this fine vehicle!
       

       
      It has 5 months MOT and after fitting seat belts in the rear for the girls car seats it is pushed into daily service.
      My gamble and subsequent use results in a perfectly reliable car that actually does what it is supposed to do.
       
      Even more importantly Mrs T loves it so a win all round.
       
      All my cars have names (most are earned over a bit of time) and this one is called 'Gwendolen' ( G reg car and from Wales originally. I hate the name but I am not going to argue)
       
      That sums up part one, more will be along later (probably much later)
×
×
  • Create New...