Jump to content
cpjitservices

New Saab - Somewhat of a project!

Recommended Posts

38 minutes ago, dozeydustman said:

Rear pads didn’t come with any anti-rattle springs when I fitted them last April, and there weren’t any on the old pads either, so lord know how long they were missing for then!

Garage had a quick look and couldnt find the source of the knock... could be exhuast. 

Will investigate come MOT time.

 

Share this post


Link to post
Share on other sites
Garage had a quick look and couldnt find the source of the knock... could be exhuast. 
Will investigate come MOT time.
 
I thought it felt like it could be surface mounts seemed as though things were moving about, also rear arbb's.

Have they sorted the lack of power?

Sent from my SM-A505FN using Tapatalk

Share this post


Link to post
Share on other sites
10 minutes ago, Floatylight said:

I thought it felt like it could be surface mounts seemed as though things were moving about, also rear arbb's.

Have they sorted the lack of power?

Sent from my SM-A505FN using Tapatalk
 

They took it for a spin and couldnt quite figure out where the knock was coming from But I think itll be ok to wait until MOT time now.

Power, well, it had warmed up when I picked it up - Temp gauge was half way, and drove spot on. Low down power. Seems to be only when she's cold and not quite woken up yet that shes down on power. But will investigate. 

Can investigate properly now that Cam belt is done. I didnt want to mess about running her too much until belts had been done. 

Aux belt has been replaced too. 

 

Can investigate properly now that I can hear the tone of the engine without that horrible tensioner whinning its tits off, garage said its been replaced at the right time because that tensioner was not far off falling apart.  Though the old belt itself did not look too old. 

 

Arbb's ?? Anti Roll Bar Bushes? 

 

Share this post


Link to post
Share on other sites
They took it for a spin and couldnt quite figure out where the knock was coming from But I think itll be ok to wait until MOT time now.

Power, well, it had warmed up when I picked it up - Temp gauge was half way, and drove spot on. Low down power. Seems to be only when she's cold and not quite woken up yet that shes down on power. But will investigate. 

Can investigate properly now that Cam belt is done. I didnt want to mess about running her too much until belts had been done. 

Aux belt has been replaced too. 

 

Can investigate properly now that I can hear the tone of the engine without that horrible tensioner whinning its tits off, garage said its been replaced at the right time because that tensioner was not far off falling apart.  Though the old belt itself did not look too old. 

 

Arbb's ?? Anti Roll Bar Bushes? 

 

Arbb's yes and rear drop links, loads of you tube videos on them.

 

Good news on the tensioner.

 

If you hold it on boost in 3rd through to 4k+ it may through an p0234 overboost code which may help diagnosis..

 

 

Sent from my SM-A505FN using Tapatalk

 

 

 

Share this post


Link to post
Share on other sites
1 hour ago, Floatylight said:

Arbb's yes and rear drop links, loads of you tube videos on them.

 

Good news on the tensioner.

 

If you hold it on boost in 3rd through to 4k+ it may through an p0234 overboost code which may help diagnosis..

 

 

Sent from my SM-A505FN using Tapatalk

 

 

 

Thanks Ill try that at some point.

Share this post


Link to post
Share on other sites

OOOOKKKK

 

Just did a quick trip in the Saab, she's firing up first time. And turning over much better. Turbo low down seems to be cured, its cutting in around 2k and can hear the whitle. Certainly seems more spritely... possible Timing was out slightly? Its running like a dream. Engine note seems quieter, there is no hesitiation/what feels like a misfire and no smoking now either. 

SO possibly the EGR Valve/MAF/MAP etc is ok. 

 

Wonderful.

 

Just need to sort the knock out!!!

 

Great car! 

Share this post


Link to post
Share on other sites
OOOOKKKK
 
Just did a quick trip in the Saab, she's firing up first time. And turning over much better. Turbo low down seems to be cured, its cutting in around 2k and can hear the whitle. Certainly seems more spritely... possible Timing was out slightly? Its running like a dream. Engine note seems quieter, there is no hesitiation/what feels like a misfire and no smoking now either. 
SO possibly the EGR Valve/MAF/MAP etc is ok. 
 
Wonderful.
 
Just need to sort the knock out!!!
 
Great car! 
Brilliant to hear..

Sent from my SM-A505FN using Tapatalk

Share this post


Link to post
Share on other sites

Great looking cars these. I had a black 9-3 wagon and always enjoyed seeing it’s reflection in shiny office windows. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...