Jump to content
Fumbler

Fumbler's Crocks: 12/08 ~Couple spottings

Recommended Posts

3 hours ago, Fumbler said:

They fit very well, plus the securing clip does a good job so it doesn't move. Job jobbed!

Good stuff. Was a bit worried about the clip falling about in the packet as it has sharp edges. Also was a bit worries that the mats were a bit flimsy. If I find anything else, like rubber mats I'll let you know.

Share this post


Link to post
Share on other sites

Apart from the front crossmsmber, I haven't done any real underbody inspection towards the front of the car. As Grandmother Fumbler is awaiting a hip replacement and cannot walk, she has to be driven everywhere by Mother Fumbler. Pretty hectic, especially when they were waiting to know when they could go in to investigate Grandmother's heart murmour. Because of this I decided it would be best to get out of the house, so I got up with Father Fumbler and we took the Micra to the the office so I could work on it.

This happened:
IMG_20191023_120931844.thumb.jpg.f85f1495345cad3a1c7461740653277b.jpg
Then I took the arch liners off and was greeted with this:
IMG_20191023_120946392.thumb.jpg.b0f1ae1cc8675e9633809f58455da5b0.jpgIMG_20191023_121012070.thumb.jpg.39d80cba2d47a237909dfbe616c888db.jpg

The bottom of the wing was completely gummed up with silt. Blew it out with the airgun and then let it dry. I passed the time by jetwashing the concrete outside the office door. Sparkly clean now.
IMG_20191023_121000232.thumb.jpg.0de2092fe53d73bb9628904ab1d17d62.jpg

I was pleasantly surprised to see that the arch liner was doing its job and keeping this area nice and dry. Blew the cobwebs out and then smothered everything in Dynax S50 as its a cavity in my mind. No photos because mess. A lot of mess.

IMG_20191023_163537139.thumb.jpg.7f3bb2d345c547ffe01afb858ccfff55.jpgIMG_20191023_163526477_MP.thumb.jpg.5dd6599a53435c4e11a1f13d518a6806.jpg

After doing that I jetwashed the wheels to see how corroded they were. Turns out that they are so I painted all along the seam with metal primer. Also did the tophat because I was a bit bored. I then went underneath the car to underseal the floor and sills, then drove the car out and cleaned up. There was a lot to clean.

I think now I can declare my car done corrosion wise, I've only got to spray inside the sills now! All that's left is cosmetic stuff like touching up places and cleaning the interior. Rather productive day's work I'd say!

Share this post


Link to post
Share on other sites

Really great Micra thread here...I admire your enthusiasm/attention to detail. I will be keeping an eye on this thread.

Im pretty sure i remember your Micra (before you bought it)  being advertised by a dealer/trader from T/Wells.

I know T/Wells quite well...i worked there for 7 years (back in the 1990's).

Ive been using my Micra Dot, as a daily, for the last 7 months, it never missed a beat.

Share this post


Link to post
Share on other sites
1 hour ago, volvoman said:

Really great Micra thread here...I admire your enthusiasm/attention to detail. I will be keeping an eye on this thread.

Im pretty sure i remember your Micra (before you bought it)  being advertised by a dealer/trader from T/Wells.

I know T/Wells quite well...i worked there for 7 years (back in the 1990's).

Ive been using my Micra Dot, as a daily, for the last 7 months, it never missed a beat.

Yeah, I saw the listing on Friday Ad. It was 60 days old at the time so all the other sites Axlr8 (the dealer) listed the car on had terminated the ads. Complete -but fortunate!- accident!

Share this post


Link to post
Share on other sites

Changed the alternator belt today. Was a bit of a faff because I didn't heat up the belt in some warm water to make it a bit more pliable but it slipped on without trouble!

IMG_0865.thumb.JPG.604286cbef6c152b6485f01d810e79bd.JPG

IMG_0868.thumb.JPG.d4d9b1e7566684ca701dc1ce5a67e17d.JPG

The old (and original Nissan fitted) belt seems a little past it.

 

Next up will be an oil and water pump belt change!

Share this post


Link to post
Share on other sites
Just now, Garythesnail said:

That looks easy* to get at.

It was alright, but the alternator side has a larger gap than the engine side and so you have to so some crafty offering and poking with a screwdriver to get it into place. THEN, you have to reach around the bottom* (oo-er) so you can slip the belt onto the crankshaft pulley and then the rest is easy. Waterpump is even more fun than this!

Share this post


Link to post
Share on other sites

Car's due for an oil change. Re-tensioned the alternator belt to what the Haynes manual says and looked at the waterpump belt. Interestingly enough it doesn't look that bad so I'll leave it be for now. Nearside front tyre is letting out a lot of air now. I think I'll need a new set soon!

Share this post


Link to post
Share on other sites

Well the day started well. I originally intended to change the oil in my car. I then found out I only had 2 litres of oil and no money because Doovla took £34.00 for my provisional licence, and I wasn't near a bank branch to pay in a cheque I received for Christmas. Post office didn't want it either as I had no generic paying-in slips. Still, I had a list of things to do, like inflate the relatively flat tyres, wash the thing, check the air filter and do the general checks one does on this occasion. I also made the decision to ditch the undertrays as they were doing nothing but cause the crossmember to be eaten alive.
So I remove the undertrays...

And uncovered this problem area I mentioned in August. Lots of rusty water dripped off too. I did some tapping around with the screwdriver to make sure the metal was solid. In the video I said it seems to be solid, BUT:

Ha ha nope. It's not solid at all!

And that is how far I got I believe.

IMG_0881.thumb.JPG.593c624bb953918a5720b24ed9c5d5a1.JPGIMG_0882.thumb.JPG.ba6691a66bbd64b8b28b39539bf45e61.JPG

As you can see, a nice amount has been removed. Now, the massive crater I have produced is separated by a piece of steel that separates the bottom of the crossmember from the part that links with the wheelarch. There aren't any holes to let in water down there but I imagine water was seeping in from the top where the radiator is mounted. Fortunately it doesn't seem to arduous to weld and make good again, however the sooner the better. I know a friend of mine is doing well with his welding so I might invite him round or stump up the money to get a professional to make it sound.

IMG_0884.thumb.JPG.137492fb1eac99a3908a45e1e0bcff10.JPG

The smaller hole is instead an ad hoc drain hole. The reason why its there is because the other drain holes were blocked completely by the factory installed undertrays.

IMG_0885.thumb.JPG.2a02cced7bfdfe415fa4ed29c72e11d8.JPG

By comparison, the other side shows mere scabbing so I think I got lucky here. Sooner or later I'll strip back the crossmember and paint it and undercoat it properly so I shouldn't need to worry too much until Mr. MoT man tells me about it!

IMG_0886.thumb.JPG.29e52fc772c109b8b7b2a8682ea76342.JPG

So here's where we stand. As long as the car isn't driven in the salt and is allowed to dry out, I'll do my best to make sure what is there doesn't grow any bigger and hopefully, new metal will be put in soon to replace what the tinworm got rid of!

Share this post


Link to post
Share on other sites

have a good look behind the back bumper and the bits behind the back wheels ,

may also be worth taking the wipers off and the scuttle cover and checking along and under the windscreen for rot ...

floor tends to be quite solid apart from the sills below the rear windows

 

Share this post


Link to post
Share on other sites
4 minutes ago, MikeR said:

have a good look behind the back bumper and the bits behind the back wheels ,

may also be worth taking the wipers off and the scuttle cover and checking along and under the windscreen for rot ...

floor tends to be quite solid apart from the sills below the rear windows

 

Because the rear was very easy to attack I've already taken the bumper off, had a look behind, sanded and painted what was there and so on. The rear and the sills are surprisingly alright, considering the checked history the K11 has with them. Seatbelt mounts (which killed my parents' Micra) are all solid, factory underseal (which is what killed my sister's Micra) is still there and only peeling a bit, every part of the wheelarch is solid and everything up front bar this small area is fine, so I'm confident that I don't have that much else to be chasing after. I'll make reference to this post a year on from now to see how wrong I am!  I'll check the scuttle at a later date when it isn't constantly wet and cold. As ever with these cars and others like it, I have to be ruthless with the brown stuff or it'll take over the rest of the car pretty quickly!

Share this post


Link to post
Share on other sites

Right, Brother Fumbler is making the motions to emmegrate to Canada to start afresh. It's safe to say he's getting zero job satisfaction and after going to Canada for his masters degree, he's set his heart on going out there. In a move to get the funds to be eligible for invitation, the Land Cruiser will come up for sale at some point in March/April. There's still some servicing and post winter looking at to do, but that's what the general intention is. In the meantime, the Micra's fresh looking wheels are now bubbling up everywhere with rust, so that'll be a summer project for me to do! Haven't looked at the crossmember anymore, but I will at some point with dread and fear.

Share this post


Link to post
Share on other sites

Right so fuck all has happened. Car is pootling along very well. Clutch feels way better than it did when I bought the car 6 months ago. It's now in need of a good cleaning which I hope to do at the weekend. Fitted the correct wipers though! Now I can see where I'm going! Needs a service at some point and some welding, but so far the little thing has been very solid and very kind to my learner driving skills!

Share this post


Link to post
Share on other sites

Great thread and car.. 

 

my Grandad has a green one on a W plate, never changed the oil i think it had around 40k on cheap halfords 15w40 and still ran.. 

Body was destroyed from being driven into a skip "long story" and the rot underneath was not too bad weirdly.. ;) 

 

'Twas sold on, no idea what happened to it, can't remember the plate :( 

Share this post


Link to post
Share on other sites

Two weeks ago we ordered service parts for the LC and Micra. ECP said the parts would arrive on Monday. Come Monday, the "parts" did arrive, but it was just the LC's oil filter. Apparently the rest will arrive this Monday... Anyway, that allowed us to do the oil change on the Land Cruiser:
20200419_143433.thumb.jpg.9b7d3dc7f0943275c53c65b641ad5410.jpg20200419_144319.thumb.jpg.9f5cdec5b949f519c2dca923629c3350.jpg20200419_145328.thumb.jpg.69b07a61780c701e26d13ea2f7e97ef3.jpg

Filled the thing up with 6.7 litres of Tesco 5W40. Ran it around a bit, oil pressure good, all is well. The Dynax undercoat is fairing well too, even after a winter of relentless driving!

Share this post


Link to post
Share on other sites

I was holding off from updating the thread because I had a few goals before I posted again. They were:
1: Service Micra
2: Wash Micra because it's got 7 months' worth of grime on it, poor thing.

The weekend was nice and sunny, so this happened
20200426_145733.thumb.jpg.387c5491baf0369af52f47c17577a1a5.jpg20200426_152220.thumb.jpg.4943fb4f277de6a137c6174473ad8b69.jpg
20200426_160628_HDR.thumb.jpg.b8d6960828495508b85d854798c9eec7.jpg
Finally did an oil change in the car, date stamped the filter (although I'm fairly certain the label will melt like last time), and then used the fairly intuitive dipstick to make sure I had enough 5W-40 in the sump. Incidentally, the drain plug was absolutely mashed in there with an impact wrench by that suspicious MoT and service centre the dealer was partnered with.

____________________________________________________________

Today I washed the thing and proceded to get distracted with the rust on the passenger door
20200427_165426.thumb.jpg.8787fa68ef66c30bacae7b6a4028942e.jpg

The "wastegate" thing (the rigid window beading at the base of the glass aperture) is rubber encased steel and it seems it scratched the paint when it was installed, resulting in a festering wound as such. So off it came and I rubbed the spot down. Quite some serious pitting in places but not anything too concerning. I also filed off the burr which caused the scratch as well so the problem will never happen again.

20200427_170358.thumb.jpg.dd668552662532d1e35247942bda542a.jpg20200427_171338.thumb.jpg.b179a81f3672e4ed192be260772eeca3.jpg
Zinc primer and paint applied. Nice drip too.


20200427_180711.thumb.jpg.fb3158e1d3f2afe53580e9b57b231516.jpg
Lacquer applied and the masking tape peeled off. Looks okay I guess. Could have done better, however its far better than rust being there. I then polished out the lips where the masking tape was, as well as the overspray from the rattle cans. I used a promotional sachet of Meguire's "Ultimate Compound" which claims to be clearcoat safe, however it has the consistecy of watered down T-cut. I've yet more to do but it looks good for now. As the sachet is single-use, I decided to use the rest on the bonnet to get rid of some of the scratches on that. Managed to buff it to a nice shine too!
20200427_183154.thumb.jpg.045ed60e21f2ec8b55710666bd5af3c5.jpg

Washed the door again and waxed everything apart from the door as the lacquer needs to harden for a week. Looks nice and shiny now! Even the wheels are silver... and corroding badly- I need to sort that out.
20200427_191050.thumb.jpg.2bc65129e719a8aef85c0256fbd2c5f2.jpg

 

When I first washed the car at the unit last year, I also undercoated the rear wheelarches, the nearside in Dynax S-50 and the offside in Dynax UB. After washing out the wheelarches today, here are the results:
20200427_195824.thumb.jpg.150916e2a8b76720a70016b55cda9bc5.jpg20200427_195929.thumb.jpg.458c7e8ec821bfa77aad59d6e865814b.jpg

       NS                                                                                                                OS

So as @Shirley Knott predicted, the S-50 did indeed wash off, albeit more slowly than I thought. I'll try not to use it too much until I can get the compressor out and do it properly.
All in, the oil change took a third or the time to wash the car and clear out the rust! Did me some good I suppose, 6 hours outside definitely helped me make the most of what will be the last of the good weather.

Share this post


Link to post
Share on other sites

Weather was absolutely horrible! Fortnately the garage was free so I decided to do some more work to the Micra.

Re-coated the wheelarches with Dynax UB:
20200503_161423.thumb.jpg.b89534dc00a2fe6bd6ea70b1593cd928.jpg20200503_161701.thumb.jpg.b62dddf689a9b72b7cbdd9826b5d8334.jpg

Sorry about the shitty camerawork on the offside photo. Camera just wouldn't work properly!

Then addressed the silver brake drums:
20200503_161717.thumb.jpg.87b03e1260b6c03e050e35f8dbdf4336.jpg20200503_161727.thumb.jpg.48717140f945fd082c70b0a9d09c06fe.jpg

Now painted with red oxide primer

20200503_161739.thumb.jpg.136e79bd56b03d0232987f04c478d0bb.jpg20200503_161744.thumb.jpg.b29ec8837edacbc22fb9690723b1436c.jpg

Did the same thing with the seams on the insides of the wheels. When I get round to getting new tyres for it, I'll respray all of them so they look silver. I'll do it properly this time too.

Share this post


Link to post
Share on other sites

On this day 1 year ago, I bought my Micra.
20200618_184551.thumb.jpg.ea46c9bbfa89294a6aeb1210864c84f1.jpg20200618_184609.thumb.jpg.009ded9bc5b4c67e824420b775d351f1.jpg
Still looking just as happy (if not happier) as it did when we came to collect it. Nice.

Things I've still got to do though:
*Weld sill and crossmember this summer
*Get new tyres
*Repaint the repainting that I did at the rear of the roof which is rusting again
*Repaint wheels
*Replace rear screen weatherstripping because it's shrunk
*Get it on a lift so I can wax the floorpan and the insides of the sills fully

Apart from that, it gives me a smile every time I drive it, and I hope I can say the same thing next year!

Share this post


Link to post
Share on other sites

Meet Wulf the Ovlov
20200711_143218.thumb.jpg.8ea47ae126ed498846b585c7a45e55e1.jpg
Father Fumbler's workhorse of 4 years got new oil, filters and spark plugs. Lucky thing. Here you can see Father Fumbler vacuuming out bits of countryside and West London where it once lived.

First, oil:
20200711_151313.thumb.jpg.c6ddc4b7ad94d5cc7d58397f23a12cdd.jpg20200711_160719.thumb.jpg.e323341d79619b3c6a180b1d6ecf3ac8.jpg
Both the sump plug and the filter housing were an absolute shitting bastard to remove. We had the same problem last year and asked SE Tyres to do the oil change because the plug was rounding over. Only problem I then discovered was that they also torqued both the housing and plug to 6000Nm each instead of the recommended 30. Anyway, I digress.  Filled back up with some 5W40, engine turned smoothly.

20200711_160719.thumb.jpg.e323341d79619b3c6a180b1d6ecf3ac8.jpg
Mess was then disposed of properly*. Oil was a muddy brown and still relatively viscous so nothing abnormal is happening in the bowels of the engine. Always reassuring to know!

20200711_160649.thumb.jpg.9cdbe6beff40ab1e0618c5225a1b5234.jpg20200711_161708.thumb.jpg.78867f0ab218aeead28c9ca55918fb54.jpg
Spark plugs next with a lovely new vs. old. The old ones were snazzy twin cathode jobbies too! Replacement was simple enough... 4th cylinder plug decided it liked the coilpack boot so much it stuck itself to it so that was fun to remove. All new plugs fitted and torqued. We kept the old ones in case of failure but I doubt we'll ever need them again.

20200711_162419.thumb.jpg.bc747ac73e056a5a6252e32215a04fcc.jpg
The cable conduits for the coilpacks had also disintegrated into a powder so more vacuuming was done to make it all nice and clean. A few pieces did get into one of the cylinders but the car started and ran just fine so I can only imagine the piece was smashed and burned to pieces in a few seconds.

20200711_160634.thumb.jpg.98c2b72ac9db4a76a83854d3fa3a54b3.jpg
Barely run in at 82000 miles. Bought it at 50000 for £400 and the only expensive fault it's ever had was a broken steering rack! Swedish quality at its best.

It'll be coolant time next week so that'll be interesting to do.

Share this post


Link to post
Share on other sites

I was invited round to a friend's house to help fix this woefully unhappy '08 Clio 3. It's a bit shit.

20200731_145720.thumb.jpg.e4174e9ddeda40da5a61d09af98df2cc.jpg
I got the car running last Sunday with the help of the equally grimy (but soooo much nicer) i10 that's just behind it but when I started it, it threw a hissy fit, was misfiring, and complained of an injector fault and wouldn't rev above 3000RPM. A quick consultation of the Interweb and it reveals it is wither a fuel pump issue or fault with the spark plug boots not making a good connection.  Needless to say I came back with tools!

20200731_145725.thumb.jpg.0499175ff4e7fa98d1e9cbf336845b14.jpg
Whipped* this engine cover off which also contains the air filter element.  Everything is shrouded in plastic or is electronically controlled in this car: electric doorlocks with no manual release, electric boot, electric throttle etc. so when the battery goes flat only the passenger door will open as it can be opened by the key. After finding out that I didn't have a long enough extension for my spark plug socket, I reseated the HT leads at the plugs and at the coil as it was all I could do at the time. Refilled the coolant tank with water as there was nothing in there at all and it was time to jumpstart it again.

20200731_145731.thumb.jpg.131485db2a2d8f78065d52fbc645c536.jpg
Surprise surprise it was happy this time! No misfire, no instrument warning lights (of which there are many) lit and the engine was smoothly idling. Moved it backwards and forwards, the brakes work and the handbrake didn't seize up this time. Win-win! Managed to get it up to operating temperature to open up the thermostat and witnessed the expansion tank burping away, so that was good to see.

It does make this horrendous noise though, I suspect it's either the tensioner pulley or the alternator bearings are going nasty on us. See what you think!

My job on this is to make it saleable. Further jobs to do are:
+ Inflate OSF tyre or replace it with inflated spare;
+ Drive it around the massive garden to charge the battery some more. It cranks over once now and then clicks like crazy so the battery is charging and isn't fully dead... yet;
+ Perform coolant and oil change;
+ Fix the broken boot if I can get it open, that is;
+ Wash it and fix the interior issues;
+ Perhaps fix the heater blower not working on speed 4 and unlock the security coded radio.
 

Share this post


Link to post
Share on other sites

Was invited to a family friend's private collection. These new additions caught my eye!
20200812_163929.thumb.jpg.6efe5bd01cee59d969cd8ac09d16340c.jpg

Nut-and-bolt locally restored Michelin 1954 2CV van (acadiane?) with suicide doors!11!!!1!!!. 595CC and fun to bomb around in apparently.

20200812_170125.thumb.jpg.7bdc00b840ef5c9f5f6fe229b4fbe6f4.jpg

Very early suicide door 1964 Fiat 500. Another regularly used classic. Also the youngest thing in the collection!
20200812_171842.thumb.jpg.8fb590916310385e884dc440be471434.jpg

I think the clock was returned to 0 post restoration.

Edited by Fumbler
Bollocking shitty images wouldn't upload properly

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Zelandeth
      Well I've been meaning to sign up here in forever, but kept forgetting. Thanks to someone over on another forum I frequent poking me about it recently the subject was forced back into my very brief attention span for long enough to get me to act on the instruction.

      I figure that my little varied fleet might bring you lot some amusement...

      So...we've got:

      1993 Lada Riva 1.5E Estate (now fuel injected, as I reckon the later cars should have been from the factory...).
      1989 Saab 900i Automatic.
      1987 Skoda 120LX 21st Anniversary Special Edition.
      1985 Sinclair C5.
      2009 Peugeot 107 Verve.

      Now getting the photos together has taken me far longer than I'd expected...so you're gonna get a couple of photos of each car for now, and I'll come back with some more information tomorrow when I've got a bit more time...

      Firstly...The Lada. Before anyone asks - in response to the single question I get asked about this car: No, it is not for sale. Took me 13 years and my father's inheritance to find the thing.


      Yes, it's got the usual rusty wings...Hoping that will be resolved in the next couple of months.

       






      Next, a proper old Saab. One of the very last 8 valve cars apparently, and all the better for it. I've driven two 16v autos and they were horrible - the auto box works sooooo much better with the torque curve of the 8 valve engine. Just wish it had an overdrive for motorway cruising...









      Next up a *real* Skoda...back when they put the engine where it belongs, right out the back. In the best possible colour of course...eye-searingly bright orange.







      Seat covers have been added since that photo was taken as it suffers from the usual rotting seat cloth problem that affects virtually all Estelles.

      Then we have possibly the world's scruffiest Sinclair C5...



      Realised when looking for this that I really need to get some more photos of the thing...I use it often enough after all! We have a dog who's half husky, so this is a really good way of getting him some exercise.

      Finally - again, I really need to take more photos of - we have the little Pug 107.



      Included for the sake of variety even if it's a bit mainstream! First (and probably to be the only) new car I've bought, and has been a cracking little motor and has asked for very little in return for putting up with nearly three years of Oxford-Milton Keynes commuter traffic, before finally escaping that fate when my housemate moved to a new job. Now it doesn't do many miles and is my default car for "when I've managed to break everything else."

      I'll fill in some more details tomorrow - I warn you though that I do tend to ramble...
    • By scdan4
      That bit hiding up behind the air filter and infront of the turret



      made a prolonged, loud, farty vibratey noise (loud enough to be clearly audible in the cabin with the radio on) twice today, both times it did it the nose was pointing down a steep hill and we had just parked and turned off the engine.

      It goes on for best part of a minute, so managed to track it down. Initial impressions are fuck knows what it is but it's clearly been bodged in the past. The yellow hose has clearly been disconnected sometime, by someone, for some reason, somewhere.



      Thats the blighter.

      Does someone want to tell me why it's blowing raspberries at me?


    • By Peter C
      Woke up this morning, had a little time before I had to leave the house for work, had a quick look at what’s new for sale on Retro Rides and saw an ad for a W124 200E manual, located 15 miles from home. I had no intention of buying a car today but I had to have it! I called the seller and arranged a viewing.
       
      Faults:
       
      2 x rusty front wings (TADTS)
      1 x rusty rear arch
      Needs a polish
      Tracking is out because new track rod end was fitted for MoT
      Engine has oil leak/s
       
      Good points:
       
      It’s a W124 200E!
      5 speed manual transmission
      New clutch
      Brand new MoT
      Superb MoT history
      4 x as new Continental tyres
      Last owner for 15 years, her husband before that for 4 years
      Very tidy MB-Tex interior
      Drives well
      All electrics work
       
      The dealer kindly delivered the car to my house but I managed a pez station shot on route:
       

       
      Plans:
       
      Remove front wings, cut away rust and apply plenty of wob.
      In-situ similar repair for rear arch
      Clean and polish
      Service engine
      Adjust tracking
      Leave patina and enjoy the car as it is
       
      I will update this thread once progress is made.
       

       

       

       

       

       

       

       

       

       
      Hopefully these two will become good friends.
       

    • By cobblers
      Train tickets booked from a train station 30 miles away to save £9 on the recommendation of the Mrs
      Mrs booked and primed ready to drop me off at said train station.




      Mobile tool kit primed and ready, missing almost every vital component due to EU regulations about leccy tape and screwdrivers on trains (I left them all at my mums house yesterday).
      If I do break down, I should have something to listen to while I work out whether I'm with the AA or RAC or none of the above.


      Not pictured: pile of cash
×
×
  • Create New...