Jump to content
1970mgb

Marina-Should I do it or Not(possible project) UPDATED: IT'S HERE

Recommended Posts

30 minutes ago, quicksilver said:

Wow, an American Marina! It looks so different with those massive bumpers and the indicators in the grille. Interesting looking trailer it came home on too, I doubt that would be legal in the UK.

You'd be surprised what you're allowed to hitch up and tow here, even just on a regular car license. 

 

Glad to see this made it into good hands though. I've never seen a Marina here. Don't think they sold well at all down south. Doubt you'd be bothered by the cops, it's a shiny classic that's being carefully maneuvered by some non-hooligans.

It'snot a complicated setup, I forget if you said it's still got all the smog crap bolted to it though?

 

Phil

Share this post


Link to post
Share on other sites
6 hours ago, jonny69 said:

I think I’d be inclined to just put a new battery on it and be done with, even if that means changing the leads if US batteries use different terminals. It’ll mean peace of mind in the long run - I can’t be doing with weak batteries. 

I think that's probably a solid idea. There's nothing unusual about the terminals-they're the standard US style lead clamps. I do need to put a new terminal on the positive cable, which is a couple of dollars and a simple/quick swap.

Share this post


Link to post
Share on other sites
33 minutes ago, PhilA said:

 

Glad to see this made it into good hands though. I've never seen a Marina here. Don't think they sold well at all down south. Doubt you'd be bothered by the cops, it's a shiny classic that's being carefully maneuvered by some non-hooligans.

It'snot a complicated setup, I forget if you said it's still got all the smog crap bolted to it though?

Fair enough on not getting hassled for expired tags on this particular car.

It was desmogged a long time ago. I did find an EGR valve in the trunk if I want to install one, but I think I'll pass :) .

Most of it is very familiar given the amount of time I've spent on MGB engines.

Share this post


Link to post
Share on other sites

Glad you got it ok. I'm really looking forward to how this develops.

I rather like the look of the Coupe Marina. The only thing that maybe compromises it a bit is that (I think) Leyland used saloon doors to keep costs down so they perhaps look a bit short. Still looks good though ;)

Are the U.S. interiors any different to U.K. ones apart from the wheel being on the other side ?

Share this post


Link to post
Share on other sites

I'm away from the car until Monday, but as I mentioned did bring the battery with me.

I stopped by Autozone, and they reported it being completely open circuit-I'm guessing that ~10 years of being dead combined with multiple summers and winters had sulfated it to the point that it was beyond any hope. I don't have a true battery charger, but have a nice Tektronix bench PSU that I can press in to service for this kind of stuff(even though it would take a long time to charge a car battery). I THOUGHT about taking it back and seeing if I could "jump" it with 20V or so. My local AZ, though, turned up a "used" battery, which just means one that they've had on the shelf for over a year. It was a Duralast Gold, which is a Johnson Controls battery with a 5 year warranty-normally a $160 battery-although with the used marking it drops back to a basic 30 day(I think) warranty. I'm not super concerned about that, but with a quick top-up charge I was on my way for $50. That's better than a $50 Wal-Mart battery, even though the ones I get here NORMALLY are J-C also.

So, we'll see what happens. I'm going to toss a couple of gallons of gas in the tank on Monday, file the points, and just go for broke and see if it starts. If it doesn't, I suspect the points are the issue, but I'll have to see. I might take the lazy way out and put the Pertronix 25D4 distributor I have on it(which is a piece of junk). Of course, it's also worth at least doing a basic check on the coil-I've never heard of one going bad from sitting, but I wouldn't want to chase my tail assuming it's good-I do need to check the wiring diagrams and see if the coil is ballasted. If nothing else, I'll yank the complete ignition system out of my MG and try it.

Share this post


Link to post
Share on other sites
1 minute ago, bunglebus said:

US spec really adds another level of ugly to European cars - looks like a 70s Chevy Nova from the front. 

Hope the wheels are staying because they're great!

Yeah, I've been getting a lot of "just what is that" questions, since it has kind of the same generic front end as American econoboxes from the era(Nova, Gremlin, Pinto).

I really like the wheels also. The seller offered me a choice of those or the standard disk wheels, and I'm glad I opted for the turbines!

Share this post


Link to post
Share on other sites

So, a bit of progress...

With the new battery, it cranks vigorously. I have a new set of points on the way, but sanded the old ones and got it sparking. It will catch and run for a few seconds on ether, which is more than it's done in 10 years!

Unfortunately, I have a fuel delivery problem. The PO had fitted an electric fuel pump, but it doesn't seem to be working. Also, a bunch of other stuff doesn't work with the key "on", although the horn works(and the wipers work when cranking, so go figure). It seems like there are a bunch of electrical gremlins to work out, although I shouldn't be surprised.

I did drop ~2 gallons of gas in the tank, and I'm thinking about tossing a mechanical fuel pump on it. I don't like mechanical pumps in general, but at least that's one electrical item I don't have to worry about.

Share this post


Link to post
Share on other sites
On 7/3/2019 at 3:28 AM, Skut said:

Always a car that screamed out for a small block Chevy transplant. Even the 1.8  looks lost in the engine bay.  The Aussies got a 2.2 E6 option I believe. 

At best they handle like a shot giraffe. With a big heavy V8 upfront you would be a jibbering wreck trying to remain alive.

Share this post


Link to post
Share on other sites
5 hours ago, Bren said:

At best they handle like a shot giraffe. With a big heavy V8 upfront you would be a jibbering wreck trying to remain alive.

The B series is not exactly svelte is it. With ancillaries it apparently weighs about the same as an LS1 with ancillaries. It is lighter than a Chevy small block its true by about 90 kilos. Just Internet research, I could be wrong. 

My dad had a 1975 1.3 deluxe coupe in blaze orange so it's strange to see a federalized Marina. It always seemed such a parochial car. 

 

Share this post


Link to post
Share on other sites
7 hours ago, Skut said:
12 hours ago, Bren said:

 

The B series is not exactly svelte is it. With ancillaries it apparently weighs about the same as an LS1 with ancillaries. It is lighter than a Chevy small block its true by about 90 kilos. Just Internet research, I could be wrong. 

A fully dressed engine in an MGB is a bit over 400lbs.

I once moved a short block in the trunk of my daily. The shop used an engine lift to put it in, and I had the bright idea that I could lift it out myself. I ended up having to borrow a lift from work to get it. Even without intake, exhaust, most of the accessories, and head it's still over 300 lbs. The 3 main block(only) have in storage awaiting a good project is a bit over 120lbs-I think a bare 5 main is closer to 140lbs.

The aluminum Buick/Rover V8 I think is about 40lbs less than a B series, although with all the other accessories added in MGB V8 GT trim it weighs a bit more. It's still not enough not really upset the balance of the car, though. That was a big deal considering that the previous attempt at more power-the MGC-which resulted in 700lb engine with extra weight in the wrong places.

I'm not surprised that the aluminum LS1 is about the same as a B series.

Share this post


Link to post
Share on other sites

First thing, no telling what crap is in the tank- I'd drain it out and put something fresh in there before drawing several tablespoons of rust through with half a quart of water before you get anything that vaguely resembles gasoline...

 

--Phil

Share this post


Link to post
Share on other sites
1 hour ago, PhilA said:

First thing, no telling what crap is in the tank- I'd drain it out and put something fresh in there before drawing several tablespoons of rust through with half a quart of water before you get anything that vaguely resembles gasoline...

The tank was actually empty, which was a nice surprise. I tried both sucking it out with a Mightvac and blowing it out through the Evap line...the latter just got a rush of faintly gassy-smelling air through the fuel line.

After I put a gallon in yesterday, what I sucked out with the Mightyvac looks a BIT more yellow than what went in, but it wasn't terrible. I'm thinking I'll pump that out(through the line to give it a good cleaning) and then add a few gallons back in.

This nice surprise was waiting for me behind the fuel filler door...fortunately there were no signs of life from it, and a screwdriver had things good and clear.

IMG_0206.thumb.jpg.43c219d6836347f3d90f517ba8959114.jpg

Share this post


Link to post
Share on other sites

The electrical system on the Marina seems to be FUBAR and at the moment I'm just trying to make heads or tails of it.

For starters, I think that the ignition switch has issues. I sort of started getting clued in to it since the wipers would only work if I held the key just a bit past "on" but not quite to "start". A bit more probing around showed me that the coil was only getting power when cranking(it's ballasted, so the cranking power goes through its own circuit that bypasses the resistor), most of the fuse box is dead, and honestly just a lot of things that SHOULD get power just aren't. I popped the steering column cowling off, and not only was I not measuring any voltage at the back of the switch unless I flipped it over to crank, but the back of the ignition switch was also partially off!

I pulled it to bring it inside away from the heat/humidity(it was a hair over 90ºF when I got in from work this evening) and only succeeded in turning the ignition switch into a big pile of parts. Fortunately, Skip saves the day, as I texted him and he reported that he has a bunch of NOS red box Lucas ones.

I still need to sort out some other odds and ends that just don't make sense. As an example, there's a light green and red wire fastened together with a quick splice(I hate those things) running to the starter, but there's no indication that either of those wire colors should be anywhere near that part of the car.

I need to head to Harbor Freight and get another test light(my last one got eaten by the engine fan on the MG a few years ago). I know it's a lot more low tech than a voltmeter, but fundamentally it gives the same information and  has a much greater range of visibility than the little LCD on a voltmeter. Sometime tells me I have a LOT of wire tracing ahead of me before I can even drive this.

Share this post


Link to post
Share on other sites
2 hours ago, eddyramrod said:

My dad used to make his own test lights for free, using any old bulb and wire that he had hanging around.  Why spend money?

because @1970mgb knows that if he grabs "any old bulb" ill spend the next 20 minutes asking for pictures of it and asking questions about it :mrgreen:

Share this post


Link to post
Share on other sites

Nicely bought - will be following this thread with interest!

I've done a spot of work here and there on a friend's '73 Marina 1.3 Coupe, and in my experience they're not too tricky - but after so much MGB experience, you'll be well used to British Leyland's little idiosyncrasies...

IMG_20160807_155010.thumb.jpg.36c7bdf217aa79e23c1b1b96fc1e7584.jpg

Best of luck with getting yours running!

Share this post


Link to post
Share on other sites

As tempting as it is to use "any old bulb and wire" for $3 at Harbor Freight I get:

1. A nice sturdy alligator clip to clip wherever convenient

2. A long, sharp probe that's easier to maneuver than a bare wire end

3. The bulb is "buried" well enough in the handle that I don't have to worry about breaking it

Also, I'm slowly rebuilding my tool supply since my box was stolen back in January. I stopped in at NAPA yesterday for some fuel hose and a fuel filter, but while I was there picked up a new dial-back timing light and a compression gauge. I still need to replace my home-made leakdown tester, but I might actually buy one this time around. Oh, I also picked up another 1 5/16" socket, which is the size of crankshaft nut on the front of B series engines.

The new points, cap, and rotor arrived today. The ignition switch should be here on Friday, so hopefully things are coming together. I'm going to try and get the mechanical fuel pump installed before then, but it's still miserably hot out there so my time working is limited. I did get the MG going again(finally got everything ironed out with the radiator) so that's off my plate for now.

While I'm waiting on the other parts, I'm going to try and at least do an oil change in the Marina. I need to go to the dollar store and get some "John Wayne" toilet paper for the Frantz filter, while there are a few Bosch branded spin-ons in the trunk. I had bought some Supertech(Wal-Mart) 20W-50 for my most recent oil change in the MG, but decided to go with tried-and-true VR-1 instead. I'll probably use that oil in the Marina for a short change interval to clean things up after sitting for 10 years, although honestly it looks pretty clean now.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Fumbler
      To mark the genesis of my fleet project thread I here present my new car: a 1997 Nissan Micra Shape-


      It really looks that good. There is a reason for this: its previous owner was an old lady who loved the thing so much so she made every effort to keep it in good shape. It originally came from Fleet in the GU postcode which suggests to me it was bought by the present dealer at auction, hence arriving down here in Kent. Before seeing the car I checked its MOT history and its only fails were thanks to broken stoplights, which shows me that it was very well cared for. I suppose an example of this was that on the last MOT, an advisory was a corroded rear silencer. The silencer on the car when I saw it was new. Methinks the lady wanted to keep it as good as possible. It was kept in a garage and so all the bumpers and black trim are very black and the tyres are in very good condition. Spare never used! Also included a free Dettol first aid kit from 1997.
      This car has 15000 genuine miles on the clock. We clocked over 15000 during the test drive! The lady owner really only trundled around her village in it and the MOT shows that it only did some meagre miles between tests. This, of course, came at a price. We saw a cherry red Micra from 2002 at the same dealer. Paint was shoddy and when they washed it the boot had massive sections of bare metal and it wasn't very happy. This car, however, is in fabulous condition and there was no contest between the two cars- it really is that good, inside and out. Immaculate interior, driver's airbag, cassette player... all there and all functioning (apart from cassette thanks to new battery and failed display). This meant that I bought it for £1600, £100 over what was my uppermost limit, but I knew I wouldn't see another like this that was in as good shape for a fair while. It was priced very ambitiously, at £1990, so I'm content in the fact I managed to slash a few hundred off the price. There wasn't that much paperwork though. All the dealership received was the logbook with 3 service stamps from 1998, 1999 and 2000, the radio key pass, a National Trust sticker, and the original paperwork holder. I suspect the old lady died and had her car auctioned, and the massive file of paperwork is now someone's egg carton, along will everything else she owned.

      As always, this car isn't exactly in showroom condition. While the inside is great and the floor is solid, and the underseal is in great shape, the not undersealed parts need a small looking at. Mainly the rear of the driver's side sill. It's really the only bubbling on the car. I suspect a well aimed stonechip managed to fester over the wintery salted roads, making it rust even more. It's around the size of a 5p piece, and will give me the opportunity to spray the insides of the sill with some chain oil to prevent any further corrosion. Behind the fuel tank there are a few rusty joints- places where the spraygun cannot get paint onto- which some Vactan and Dynax should put to rights. Alternator belt looks original because of the cracking and Nissan badges and will need doing soon as well as the front plate. As much as I like the 90's font and original dealer surround, the dishevelled R and general water ingress is a persistant MOT advisory. It could be the MOT station being strict (and most likely is considering there's a Saxo down the road with far worse blackening), however for the sake of peace of mind and all that, I'll get a new one made. The rear has already been replaced indicating this has happened before.
      All in all, I think this is a nice plucky motor. I'll have it by the end of the week; just got to sort out tax, insurance, and it's going to have an MOT. As part of the deal it's getting the MOT and an oil and filter change which will be something ticked off the list. It has some love scratches and chips here and there, but it drives well, is stiff and controllable, and should make out to be a nice summer project!
    • By Zelandeth
      Well I've been meaning to sign up here in forever, but kept forgetting. Thanks to someone over on another forum I frequent poking me about it recently the subject was forced back into my very brief attention span for long enough to get me to act on the instruction.

      I figure that my little varied fleet might bring you lot some amusement...

      So...we've got:

      1993 Lada Riva 1.5E Estate (now fuel injected, as I reckon the later cars should have been from the factory...).
      1989 Saab 900i Automatic.
      1987 Skoda 120LX 21st Anniversary Special Edition.
      1985 Sinclair C5.
      2009 Peugeot 107 Verve.

      Now getting the photos together has taken me far longer than I'd expected...so you're gonna get a couple of photos of each car for now, and I'll come back with some more information tomorrow when I've got a bit more time...

      Firstly...The Lada. Before anyone asks - in response to the single question I get asked about this car: No, it is not for sale. Took me 13 years and my father's inheritance to find the thing.


      Yes, it's got the usual rusty wings...Hoping that will be resolved in the next couple of months.

       






      Next, a proper old Saab. One of the very last 8 valve cars apparently, and all the better for it. I've driven two 16v autos and they were horrible - the auto box works sooooo much better with the torque curve of the 8 valve engine. Just wish it had an overdrive for motorway cruising...









      Next up a *real* Skoda...back when they put the engine where it belongs, right out the back. In the best possible colour of course...eye-searingly bright orange.







      Seat covers have been added since that photo was taken as it suffers from the usual rotting seat cloth problem that affects virtually all Estelles.

      Then we have possibly the world's scruffiest Sinclair C5...



      Realised when looking for this that I really need to get some more photos of the thing...I use it often enough after all! We have a dog who's half husky, so this is a really good way of getting him some exercise.

      Finally - again, I really need to take more photos of - we have the little Pug 107.



      Included for the sake of variety even if it's a bit mainstream! First (and probably to be the only) new car I've bought, and has been a cracking little motor and has asked for very little in return for putting up with nearly three years of Oxford-Milton Keynes commuter traffic, before finally escaping that fate when my housemate moved to a new job. Now it doesn't do many miles and is my default car for "when I've managed to break everything else."

      I'll fill in some more details tomorrow - I warn you though that I do tend to ramble...
    • By TripleRich
      Hi all, new to the forum.  Thought you might be interested in what I've got myself into
      I'd been after my first classic car for a while.  If it's big and made in the 70s I'm interested.  Looked at few things like P6s, Zodiacs, Victors, SD1s and various other things.  Problem was I didn't want to spend a boatload of money on something that looked alright but underneath was actually a total heap.  The solution was to buy a complete heap in the first place and spend the money fixing it.
      So in January I went ahead and bought this from a colleague at work who was moving away and needed to get shot of it.

      It's a part finished restoration (I prefer not started) and it needs a whole load of help if it's going to stand any chance of using a road again.
      Pros
      It's right up my street.  Granada Coupes are quite odd and certainly stand out from the norm.
      It still has the original engine, box, interior and most trim.
      It came with loads of panels I need to repair it (mostly original Ford stock).
      It came with so many spares I could probably build a few Granadas and still have stuff left over.
      It was cheap.
      Cons
      Most of the front end has been cut off.
      Most of the body structure is quite rotten.
      It's going to take me ages.
      I work at a restoration company and my boss kindly allows me to keep the car there.  So I've got access to all the gear I need to restore it.  I've been busy on the car for a while now so will post more pics over the coming days.
      Cheers 
    • By strangeangel
      I thought I'd start a thread for this as I'll probably end up asking all sorts of questions, given that this is my first 'proper' Citroën.
       
      So... the ground clearance lever won't go all the way to the highest setting (all others work), which is bad 'cos the book says I need it to do that in order to check the LHM level. It feels like something's seized, so I don't want to force it. Any ideas for a plan of attack would be much appreciated.
       
      Next up are the wheels. I now have a set of 205 pepperpots that have just gone off for powder coating & I need to get some tyres for them. The handbook says the car should have 165/70R14s on, the wheels came with 185/65R14 on. Any thoughts about what size I should get please? Cheers.
       
×
×
  • Create New...