Jump to content
Pillock

Welcome to the new forum! Here's some tips and tricks

Recommended Posts

I seem to remember there being a plugin available which changed the default behaviour for clicking on a topic title to take you to the newest unread content rather than the first post.  

 

Is there any chance this could be installed?  On a touch screen (both my phone and my laptop), managing to select the tiny brown dot is incredibly difficult and I end up instead viewing 15 profiles a day as my fat fingers miss and click the name of the most recent poster instead.

Share this post


Link to post
Share on other sites

On mobile. Firefox on android. I just tried to write a post tagging another user, once I chose the user to tag I was no longer able to continue writing the post.

Any ideas?

 

Edit: ffs the image uploader is also playing silly buggers on mobile too.

Share this post


Link to post
Share on other sites

I don't think it's the only problem with Firefox on Android. It gets confused about the navigation to the open forums or clicking anything in the lower third of the screen for ne. Chrome doesn't seem to have the same problems although I prefer FF so just put up with it. Not sure about tagging people, I don't even get that option with the stock gboard input...

Share this post


Link to post
Share on other sites

A query. How do I follow a thread without commenting? Last week there was a button so thread could be followed. But this seems to have gone. Using mobile phone via google and chrome. Ta

Share this post


Link to post
Share on other sites

Jesus fscking Christ... that's twice today the damned editor has eaten about 70% of a long post completely at random while typing because I had the audacity to hit return to start a new line.

Does anyone have the foggiest idea what the cause of this is?  It happens in both Chrome and Firefox on mobile, both using the on-screen or a Bluetooth keyboard (as I did wonder if it was some touch screen issue).  I've not been aware of it happening on my desktop, but it's only once in a blue moon I'm lucky enough to have a chance to actually use a proper computer these days so there's serious observation bias there as my usage is probably 98% mobile, 2% desktop.

It seriously has to be *the* most annoying bug on here... I'll even stop complaining about the diabolically clunky image handling if that could be fixed...

 

Share this post


Link to post
Share on other sites
14 minutes ago, Zelandeth said:

Jesus fscking Christ... that's twice today the damned editor has eaten about 70% of a long post completely at random while typing because I had the audacity to hit return to start a new line.

Does anyone have the foggiest idea what the cause of this is?  It happens in both Chrome and Firefox on mobile, both using the on-screen or a Bluetooth keyboard (as I did wonder if it was some touch screen issue).  I've not been aware of it happening on my desktop, but it's only once in a blue moon I'm lucky enough to have a chance to actually use a proper computer these days so there's serious observation bias there as my usage is probably 98% mobile, 2% desktop.

It seriously has to be *the* most annoying bug on here... I'll even stop complaining about the diabolically clunky image handling if that could be fixed...

oh  so im not the only one that happens to! (and I can confirm it does happen in chrome on a desktop/laptop machine sadly)

thankfully a hasty control/command Z normally gets my content back, but also brings the bug back with it, but as you say its fucking annoying especially when it does eat your post and you cant recover it (not sure how you undo on an Android device but on an iOS device shake it like your pissed off at it and it asks you if you want to undo LOL)

as for getting round the bug, I find that bringing the cursor out of the text box and even clicking to a different app will suddenly get a bunch of text highlighted "exposing" the bug (said highlighted text being the text that gets nuked when you hit carriage return because its highlighted but you just cant see it thanks to the shitty text editor)

then I click elsewhere in the text box to un highlight the text and finally I can hit carriage return without all my previous text getting nuked

@tobyd your the one moderator who knows computers/does the technical stuff right? any chance this bug could be looked into? (or just implement a better/plain text editor option!)

granted knowing what I know about this forum software package, the text editor is just plain garbage and nothing can be done about it sadly, I REALLY wish whoever did the software update researched that before upgrading autoshite to this particular forum software!

 

(this bug is also why when im typing up a particularly lengthy post, ill every now and then hit control/command A and then C to save everything to my clip board so I can paste it all back in should the shitty text editor eat it all!)

Share this post


Link to post
Share on other sites

Do you mean upgraded (as in, version specific) or migrated to? 

 

I reckon the current set up is the best we've ever had. The only bug which really gets me now is when you tag a user and the latter half of their name gets added on the end of the name every time you try to do anything e.g.

@Mr FluffyballsFluffyballsFluffyballsFluffyballs

Share this post


Link to post
Share on other sites

The editor isn't something that the forum software lets you swap out for a simple input or swap for a different editor. Switching for a plain text input would remove a lot of features, like

Quote

quotes (even though they get used to re-post picture heavy threads but I am looking at resolving that honest!)

clickable links and the preview button and all formatting.

The software in general has a few issues on mobile (especially on firefox) and, unfortunately, they are mostly just bugs to be filed with the forum-software developer. Its difficult to send them a bug reporting saying "The forum dog ate my homework post" with no evidence or reproduction steps and getting reliable repro steps on a phone is a nightmare. Take the Tapatalk issue raised a while back - I can't make it go wrong, works just fine for me on my phone but has problems on a different handset. I think mobile will incrementally improve with software updates and I'm happy to raise any issues we can reliably provide repro steps for but well understand that after its eaten half an hours typing trying to figure out at what point it borks is rarely a concern.

There are very limited options for full, rich-text browser text editors that still work (to some degree) on mobile and support older browsers as a prebuilt option. I suspect if you waste spend  some time on QuillJs, TinyMce or CKEditor's demo sites sooner or later one will react badly and I'd suggest that usually a condition outside the editors control, such as a missing tap on a touchscreen, is causing the mobile browser to misbehave. Seems a bit harsh to condemn this one (ckeditor, probably the same or a slightly newer version that what was in the previous forum version) as garbage. The editor is effectively a WYSIWYG website builder given it has to convert all this text into what can amount to fairly complex HTML. Bear in mind it fully supports pasting in the answer to this Stack Overflow post.

Share this post


Link to post
Share on other sites
14 hours ago, loserone said:

Do you mean upgraded (as in, version specific) or migrated to? 

 

I reckon the current set up is the best we've ever had. The only bug which really gets me now is when you tag a user and the latter half of their name gets added on the end of the name every time you try to do anything e.g.

@Mr FluffyballsFluffyballsFluffyballsFluffyballs

as in previously the forum was on a set of forum software then got upgraded to the current forum software

I aint got a problem with the forum software (apart from the thumbnail issue), its just the text editor that I have a problem with from time to time 

 

12 hours ago, tobyd said:

The editor isn't something that the forum software lets you swap out for a simple input or swap for a different editor. Switching for a plain text input would remove a lot of features, like

clickable links and the preview button and all formatting.

The software in general has a few issues on mobile (especially on firefox) and, unfortunately, they are mostly just bugs to be filed with the forum-software developer. Its difficult to send them a bug reporting saying "The forum dog ate my homework post" with no evidence or reproduction steps and getting reliable repro steps on a phone is a nightmare. Take the Tapatalk issue raised a while back - I can't make it go wrong, works just fine for me on my phone but has problems on a different handset. I think mobile will incrementally improve with software updates and I'm happy to raise any issues we can reliably provide repro steps for but well understand that after its eaten half an hours typing trying to figure out at what point it borks is rarely a concern.

There are very limited options for full, rich-text browser text editors that still work (to some degree) on mobile and support older browsers as a prebuilt option. I suspect if you waste spend  some time on QuillJs, TinyMce or CKEditor's demo sites sooner or later one will react badly and I'd suggest that usually a condition outside the editors control, such as a missing tap on a touchscreen, is causing the mobile browser to misbehave. Seems a bit harsh to condemn this one (ckeditor, probably the same or a slightly newer version that what was in the previous forum version) as garbage. The editor is effectively a WYSIWYG website builder given it has to convert all this text into what can amount to fairly complex HTML. Bear in mind it fully supports pasting in the answer to this Stack Overflow post.

I have tried to screen record the issue, however in doing so it "fixes" the issue meaning I can't screen record it LOL!

(its actually how I discovered the work around for when it does happen)

however I have just remembered that I can do a screen recording solely by keyboard commands and screen overlays, so I dont have to click away from the browser to record my screen 

so next time it happens ill try and record it (with my damn Phone If I have to LOL) 

i aint saying getting rid of the this text editor, im just wondering if as a toggle you could offer a plain text editor? :) 

Share this post


Link to post
Share on other sites

Has anyone else been noticing embedded images being really slow to load this last couple of days?  I thought it was just my phone acting up until yesterday evening when I was on the laptop but encountered exactly the same behaviour.

Just a white rectangle sitting where the image should be for several seconds before it eventually loads.  Causes the page to jump around quite a bit if images upstream of where you're viewing a thread are still loading in too as it doesn't seem to reserve the screen space for the actual image dimensions until it loads.

Performance has never really been an issue on here so I think that makes it all the more noticeable. 

Here's where I find the problem is actually local to me and I've a networking bottleneck I need to spend the next week hunting...

Share this post


Link to post
Share on other sites

A month or so back I enabled lazy-loading of images so that until you get near an image it won't download from wherever it lives. Has the benefit that on picture heavy threads your phone isn't preloading masses of content you might not ever look at and should save your data allowance - trade off is that performance can suffer. On desktop it should* be unnoticable.

Trouble with it reserving space is that the server would have to download the image, record the sizing for it, hope the image isn't resized at somepoint (or removed) and every-so-often work through the process to ensure its still up-to-date. For every post that contains images.

This was as much a trial as anything, if people don't like it I can turn it off again - I do find scrolling bottom-to-top it janks about a bit on a phone.

Share this post


Link to post
Share on other sites

Yep...the scrolling up thing is definitely really noticeable, as is the page jumping around if you load in mid way down a thread (i.e. if clicking the "first unread" link).  You get about two words into reading before the page jumps around and suddenly you're reading five paragraphs away from where you started.

It's more pronounced on mobile but I was definitely seeing similar behaviour on my desktop as well.  I'll make a point of trying to watch more carefully what it's up to next time I'm at my workstation.

Share this post


Link to post
Share on other sites

Maybe a slight suggestion for those using the otherwise impressive mobile site, can we move the sign out button to somewhere else. I can never remember my password when I've accidentally signed out when checking the notifications by mistapping the button. Or even a "are you sure you want to sign out" pop up to confirm. 

 

 

Screenshot_20200318_094528.jpg

Share this post


Link to post
Share on other sites

I hve quston. How does one remove attachments from one's profile? I have a lot of attachments from threads that have long since disappeared (cars and girls, the un-woke [email protected] thread) that I'd like to clear out so; no one can see them now (nothing NSFW) but using a fair bit of my allocated attachment space up.

Share this post


Link to post
Share on other sites

@dozeydustman for threads that are unlocked if you follow the attachment link to the post itself, edit it you can delete the attachment from there. For locked threads a mod would need to do it - if you have a list of the ones you want removing I can take a look. I don't think there should be any sort of quota on uploaded stuff though.

Share this post


Link to post
Share on other sites

Interesting...can you reliably reproduce that and does it do it in Firefox? It looks like its getting confused over some selected text when its doing its 'new paragraph instead of newline' thing.

 

 

Share this post


Link to post
Share on other sites
On 3/31/2020 at 11:15 PM, tobyd said:

@dozeydustman for threads that are unlocked if you follow the attachment link to the post itself, edit it you can delete the attachment from there. For locked threads a mod would need to do it - if you have a list of the ones you want removing I can take a look. I don't think there should be any sort of quota on uploaded stuff though.

It's a list of attachments from now locked, closed and deleted posts, plus a few I no longer want to see (those I will do myself)

I'll compose the list and send it to you by PM

Share this post


Link to post
Share on other sites
3 hours ago, tobyd said:

Interesting...can you reliably reproduce that and does it do it in Firefox? It looks like its getting confused over some selected text when its doing its 'new paragraph instead of newline' thing.

sadly I have not figured out how to reproduce it reliably, it just happens just frequently enough to get really annoying at time LOL 

luckily these days im pretty good at catching it and hitting undo before I type more and lose all my text

if I then bring up another window outside the browser then click back to the browser the text that gets eaten is suddenly highlighted then if I un highlight it, the text editor stops eating my text thankfully

which is easy enough for me to do on a desktop Operating system, but you would be pretty stuffed in a mobile OS!

(no idea if it happens in firefox sadly as I dont use that web browser frequently, although going by @Zelandeth's post above it does seem to happen in Firefox mobile)

3 hours ago, loserone said:

Bloody hell, I though I was bad with lots of chrome tabs open.  Have you tried turning on tab grouping?

you think thats bad? thats just my laptop I use after 10PM you should see my desktop! :)

image.thumb.png.33688444ba4247a66b1df67247049dc5.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Stanky
      Hi all,
      Apologies for the downtime, there was some routing issues with our hosting provider which meant the server was cut off from the outside world. I'm finding out what went wrong and how we can avoid a repeat.
       
    • By pauldoubleyou
      A proper shite 90s jet ski just came up by me and I’m sorely tempted. Looks like a decent version of the year, a seadoo spi.
       
      Seems rotax powered which I remember from my karting days and I’m hoping to go and see it tomorrow. Looks like a two cylinder carb fed job.
       

       
      Anyone played with them?
       
      As usual the engines in bits and it’s missing the jet whatever that is. Presume where the prop fires water down?
       
      Are there any rules to it’s use or can I just get it running and blast about on it on the local water and lochs?
       
       
      Sent from my iPhone using Tapatalk
    • By pauldoubleyou
      So I’ve held off here for a month now but I’m stuck and need advice.
       
      Some of you might remember I had a Golf Turbo estate for sale in Jan. Well I sold it to Exiled_Tat_Gatherer and he paid for it with the intention of collection.
       
      But, I haven’t had a message off him in nearly 4 weeks now and I’ve messaged loads. I’ve phoned him and got voicemail. Now I’m not trying to muddy the lads credibility at all, he’s done his bit but I’m worried about not being able to get in touch.
       
      He’s in Belgium and intended to fly over and collect. I’m aware he bought numerous other cars off here and wanted to collect them all in a oner but he’s now not posted in ages.
       
      What the hell do I do? I really need the car shifting but he’s paid for it. I can’t store it forever and I’m still paying tax on it so it can be legal for him to collect.
       
      Really stuck. Any advice appreciated. I’m erring towards selling it on and refunding him if I can get hold of him but don’t want to be the arsehole.
       
      Sorry if this isn’t the way to do things but I’m really at a loss.
       
       
      Sent from my iPhone using Tapatalk
    • By pauldoubleyou
      Seen on Facebook. No pics of the monza / manza
       

       
       
      Sent from my iPhone using Tapatalk
    • By pauldoubleyou
      Is anyone else into their kits? In new money, that’s scale models.
       
      Is anyone selling any? I have an unhealthy collection that I can’t particularly let the wife see.
       
      Latest Abrams about ready to be weathered and next oldie but goody..
       

       

       
       
       
       
      Sent from my iPhone using Tapatalk
×
×
  • Create New...