Jump to content
inconsistant

Volvo V70 D5: Dark Beast gone Scotch

Recommended Posts

Good work on the lights.  I tried fixing the ones on my old Rover 75 but ended up making them ten times worse.  Wet n dry paper plus impatience doesn't end well.

Share this post


Link to post
Share on other sites

I think this stuff is just a very very mildly abrasive liquid. I suppose brasso or toothpaste would also work on that basis but I thought I'd start mild and work up from there.

Did you use that shine juice on a cloth by hand or did you use a pad on a polisher/drill man?

Share this post


Link to post
Share on other sites

A very kind 'shiter delivered this this morning, they're in better nick than the wheels on the car although there are still one or two kerb grinding marks, but still they're brighter and don't have the peeling lacquer or other assorted marks that the current ones have. Huge thanks to Shedenvy for the early morning delivery mission, again a reflection of how great this place is.

 

post-16950-0-26284200-1554982611_thumb.jpg

 

I'll swap all four over, but keep two of the existing tyres as they've got plenty of life in them. I might have a look at local alloy refurbishers to see how much it will cost to get them closer to perfect. These should make a big difference because the wheels really let the car down at the moment as they're so tatty.

 

There are still a few scratches dotted around that I might have a go at rubbing some black T-cut into to make them less obvious, then there's the fog lamp/lower bumper to replace:.

 

Good side:

post-16950-0-72130200-1554983104_thumb.jpg

 

Oops side:

post-16950-0-40453800-1554983116_thumb.jpg

 

post-16950-0-03058100-1554983126_thumb.jpg

 

post-16950-0-26082500-1554983142_thumb.jpg

 

 

Other than that, this car seems to hide its age and mileage really well.

 

 

Share this post


Link to post
Share on other sites

A little update on the DB. Trying to get some of the issues sorted asap so we don’t get used to them and end up living with them. Here’s a brief list:

 

Jobbies done:

1. service and check over

2. fix handbrake. Hardly works at all

3. fill coolant and monitor for leaks

4. dry out & monitor coolant levels in passenger footwell

5. 2 tyres close to wear limit. (more news in a bit)

 

1. Car has been serviced. I managed to get Mann oil, air, fuel and pollen filters for cheap pounds from EPC. What are the chances... they only had a sale on the day I ordered them! Result! I let our friendly ace mechanic do the service coz I wanted him to have a look over the car to check for any issues, as my wife will be using this to get to her work placement/dodge transits 5 days a week so we really need this to be as reliable and problem free as an £800 car can possibly be. Things he noticed were all on the MOT advisory sheet: slight play in front suspension, reg plate light not working, steering rack boot needs replacing, rear discs and shoes deteriorated.

 

2. He checked over the handbrake, re-fitted a retaining spring but will need more work to get it working properly. It does work if you yank it fully up to the last ratchet but I don’t trust it enough to go up any steep hills.

 

post-16950-0-22453700-1555801795_thumb.jpg

 

3&4 Oil change done too, and he’s changed the coolant and topped it up to the top of the X of max so I can keep an eye on whether it’s leaking into the passenger footwell, PO thought it was leaking through a not properly fitting seal from a matrix replacement a couple of years ago. I’ve had some newspaper down and a Poundland moisture trap in the footwell and it’s definitely dryer than when I picked up the car, just a slightly oily feel to the carpet. I replaced the pollen filter myself so I could a have a look behind the glove box but I can’t see any leaks or drips but will keep an eye on it. 

 

5. I used man maths on the tyre issue and it’s worked out really well. Not financially though. Two new tyres was going to be about £200. Shedenvy let me have his spare set of alloys & tyres for £100 and they had 2 tyres that still have few mms of life left in them. So I could just put two of the new ones on and be quids in. But no, the new alloys are much better condition than the ones on the car, which are also a slightly different tone of silver. They’ve got some kerbing scuffs too, but again not as bad.

 

post-16950-0-10582300-1555802277_thumb.jpgpost-16950-0-36902700-1555802285_thumb.jpgpost-16950-0-58865600-1555802296_thumb.jpgpost-16950-0-38332100-1555802304_thumb.jpg

post-16950-0-57346600-1555802321_thumb.jpgpost-16950-0-75942600-1555802332_thumb.jpg

 

So I thought I might get these new ones refurbed so they look nice too. And then the car will look nicer. So I was recommended a great bloke called Bruce who does alloys. He said he could refurb them for a bit under £50 a wheel, and spray them too. Ooh, I thought! so we looked at colours, and I thought a nice dark silver/ anthracite would be nice with the black. I’m not a fan of black wheels, especially not matt black but I thought going a bit darker would make the Dark Beast look a bit more mean and moody. So I got them back from Bruce and popped down to the tyre place to get the best four tyres swapped onto the moody alloys and balanced, which was £50.

 

post-16950-0-15240600-1555802569_thumb.jpg

 

post-16950-0-71431600-1555802578_thumb.jpg

 

I also decided to buy a new jack, because my old Clarke one is rubbish and I hate it and it doesn't make me confident about jacking cars. I got a nice aluminium racing SGS jack, and I have to say it's brilliant. I managed to find the jacking points on the V70 and it works a treat.

 

post-16950-0-77423000-1555801699_thumb.jpg

 

post-16950-0-86487100-1555801719_thumb.jpg

 

post-16950-0-54297600-1555801732_thumb.jpg

 

post-16950-0-34411600-1555802675_thumb.jpg

 

So sorting out the two tyres wasn’t really that cheap, but I reckon it does look well awesome. When I’d fitted them I decided to give it a wash and wanged a bit of tyreshite on it too so I could get some nice photos.

 

post-16950-0-65373000-1555803231_thumb.jpg

 

post-16950-0-19550300-1555803238_thumb.jpg

 

post-16950-0-36053800-1555803244_thumb.jpg

 

post-16950-0-63281500-1555803251_thumb.jpg

 

post-16950-0-66262400-1555803258_thumb.jpg

 

post-16950-0-89657200-1555803270_thumb.jpg

 

post-16950-0-13611200-1555803278_thumb.jpg

 

post-16950-0-33912200-1555803286_thumb.jpg

 

It definitely hides it's mileage and cheapness even better now. I just hope it does so mechanically too, at least for the next 3 months while we need to depend on a car.

 

Jobbies still to do:

6. blower fan doesn’t work for first 10-15 mins 

7. aircon sometimes turns on but can’t be turned off again.(these possibly connected?)

8. leccy passenger seat won’t go forwards or back

9. front fog lamp damage repair

10. rear parking sensor needs fixing. maybe not bother though.

11. maybe sell the tatty set of wheels/tyres

 

post-16950-0-55561200-1555803650_thumb.jpg

Share this post


Link to post
Share on other sites

I spent ages and ££ fiddling with the handbrake on mine, replacing most of the mechanism from front to back, but the problem seems to be that Volvo deleted the adjuster to replace it with a metal strut (shaped like a stretched H).  

 

Replace it with one of these adjusters from an XC70 and you will soon have a working handbrake.  (I used the one for an 850, but I reckon they're all the same judging from the ebay listings).

Share this post


Link to post
Share on other sites
On 4/21/2019 at 12:42 AM, inconsistant said:

...my wife will be using this to get to her work placement 5 days a week so we really need this to be as reliable and problem free as an £800 car can possibly be.

It definitely hides it's mileage and cheapness ... I just hope it does so mechanically too, at least for the next 3 months while we need to depend on a car.

It's been more than 3 months now since I bought it, my wife has finished her teacher training course and is now a fully employed teacher. So the stress of being skint but needing reliable daily transport has passed. The Dark Beast has been awesome. Here's an update:

I think I mentioned previously that we got it serviced as it was well overdue. The mechanic had a go at adjusting the handbrake but made almost no difference. We live on top of a hill so a handbrake is useful. We’ve been taking different routes home to avoid the steeper hills.

After 500 miles the coolant had gone down a bit. It was at the top of MAX and had dropped by about 5mm.

IMG_7922.thumb.JPG.17b690b525efee023438c59f13c1f2eb.JPG

I fitted a pollen filter, as it was missing and I felt this job was well within my capabilities. To do this I took glove box off.

IMG_7873.thumb.JPG.6dc8f65169691917687f97a11f7080cb.JPG

IMG_7874.thumb.JPG.137c4a01470782123e16ae929f0d5eb9.JPG

IMG_7877.thumb.JPG.996988a74319a529ea87ce7c22e6ed1b.JPG

While I was under there I decided to investigate the coolant leak as there were stains on the plastic panels that I had to remove from the footwell to get to the pollen filter housing so I started to remove more stuff to check out just how soggy with coolant  the footwell is from the previous/current coolant leakage and to see if it was obvious where it was/had been leaking. I wiped up all the wet bits under the carpet and removed all the legacy white tide marks and stains, they’re quite extensive so I assume they are probably from when the matrix went in 2015 as they are in places where they don't match which bits are wet now. Hopefully with all the mess tidied up, wipes down and the carpet marks hoovered it will now be easier to trace where the current leaks are coming from if I leave it a couple of months and have another look.

IMG_7887.thumb.JPG.9089998d0b00f576278369690dde742c.JPG

IMG_7890.thumb.JPG.5ef4476e200f0afc8d02b4da54187984.JPG

IMG_7891.thumb.JPG.405a2b2c09b9bf00de4bef01707402d3.JPG

IMG_7893.thumb.JPG.0fbeec99ca2e7ff7306698baf8123a59.JPG

IMG_7894.thumb.JPG.180b2d802c16bd9c2ec17d9bfbb02a31.JPG

IMG_7897.thumb.JPG.7f047a9403ca17a3d4b0cfec982f820c.JPG

IMG_7905.thumb.JPG.fd9108c168d2ce81daeb761d5a97c9e0.JPG

IMG_7906.thumb.JPG.a56f4f1bacfae9c632393de550d79772.JPG

 

IMG_7909.thumb.JPG.d1d28f2fdd64e1477b039d5ddac9ba54.JPG

 

IMG_7915.thumb.JPG.3489aa893aeb2aeb10825673e64bffc0.JPG

IMG_7917.thumb.JPG.812be95dee9b8580c4b95d09e1913aac.JPG

IMG_7918.thumb.JPG.c779dbb04fb43e3bb392e1aaa9a11ade.JPG

IMG_7919.thumb.JPG.e698e0243084bd974db9a4a320fefb69.JPG

While I was being handy and was in a dismantling mood I decided to have a go at pulling out the dashboard air con module to see if there was an obvious reason why the fan was playing up. It doesn’t really work until about 15 mins into the journey, but the windscreen demist button works fine and the other buttons seem to turn on the a/c, and it can be turned between a/c and normal ventilation, it’s just that the fan comes on full blast and can’t be turned down or off unless you either wait for 15 mins or turn the car off and re start it so the a/c resets itself. The ventilation, stereo and phone all comes out in one massive module. My amateur guess would be that it’s the controls rather than the actual fan itself, although I’m wondering if it might be a similar problem to the one we had in the v40 when the fan wouldn’t work at all and it was the fan resistor pack that had failed. I need to do some research into this as although it’s livewithable it’s a bit annoying. I thought I would pull the whole unit out of the dash so I could also see if I could see the heater matrix & pipes more clearly too.

IMG_7923.thumb.JPG.352b0df0587f4482e1909f419247612c.JPG

IMG_7924.thumb.JPG.4e1a945df6a4378f05b584b042e0e33e.JPG

IMG_7925.thumb.JPG.0a7bdb2e8cb2fe375c9ae2c32210bb61.JPG

IMG_7926.thumb.JPG.2e48cd88c44c386a07143859b80ce866.JPG

IMG_7932.thumb.JPG.e53f7292060ae1f14b525b4b00697541.JPG

IMG_7937.thumb.JPG.deaefefd197b29ff17726d194c5aa999.JPG

IMG_7929.thumb.JPG.db27ead8b4d5d8c370dd6667c85b39fd.JPG

Conclusion: Inconclusive.

In May I took the Dark Beast for a hoof up the M40 to Gaydon for the annual UK Sort Car festival. This was the only long run its done so far in our ownership other than picking it up. It ran faultlessly, the dash told me 54mpg which must be a lie, and it was a thoroughly competent and relaxing motorway trundler.

Bumped into known Autoshitter GarethJ and we shared an expensive coffee.

1589732653_IMG_8082copy.thumb.JPG.b4de85fb19745573bf7472f459b388da.JPG

 

I love all the toys. bASe spec is great but I do like a ridiculously well equipped vehicle. I think that's inevitably what happens when you're brought up on Ford Orion Ghias. I've learned how the memory seats work, I like having my own number. I'm number three. I've also been playing with the cruise control, my first time ever. I like cruise control!

Its got a big sub woofer in the spare wheel well and it sounds excellent, especially loud. I like the 6 cd player but i don’t like that there isn’t room for 6 cd cases. I don’t like that it hasn’t got a tape player. The V40 had a tape player so we used a tape adapter to connect ipod or phones to play music from. Need to look into options.

I checked the coolant level again  and after losing a few mm it is now back up to the top of the X of MAX. This might be magic, but is more likely that the previous time I checked it was parked at a slight slant with the drivers side slightly lower than the other. In which case it hasn’t lost any coolant at all. Ace!

I bought new front bumper lip bit for £35 on ebay which is silver but undamaged. I bought a black sapphire metallic spray can £15 so I’ll have a go at spraying it and swapping with the damaged one over the summer. I also got hold of a front drivers side fog light for £25 so hopefully both of those will sort the front lower bumper damage and smarten up the front a bit.

55248636_ScreenShot2019-07-23at17_09_52.png.378aa7af934a982c418f8fd58c75223b.png

933606973_ScreenShot2019-07-23at17_07_45.thumb.png.d08bc383e2af248aecb4d3e8e47ddb71.png

1861028478_IMG_7618copy.thumb.JPG.b56c4de6def6839fe1a1ba07ebc72023.JPG

I bought some lovely new mats off ebay. A full set with the locating studs for £14.37 seemed like a bargain, and I wasn't disappointed: the quality was exactly as expected for £14.37. I think the grey trim is a tad more lairy than pictured in the listing.

847311514_ScreenShot2019-07-23at17_03_41.thumb.png.4e80686e04f3c538efdd68ebc851488b.png

IMG_8424.thumb.JPG.34d4335b91210667765c31263845b1ff.JPG  IMG_8422.thumb.JPG.10923749fbc31038d8414f2e775f2473.JPG

IMG_8423.thumb.JPG.80679e0b5a495d08856f6918b5d7095f.JPG

The handbrake is much improved after fitting the adjusters recommended by Dead_E23 above, which I got a mechanic to fit. He’s going to give them another minor adjustment shortly to get them working as well as possible but we've pretty much got a fully operating handbrake again now. Big thanks to Dead_E23.

1888111259_ScreenShot2019-07-23at17_02_15.thumb.png.0990e200608e04a12336477a9a6ead95.png

So, we've had it 3 months, which is the 3 months we really needed it to be dependable. And it's been pretty much dependable.

IMG_8427.thumb.JPG.a29a450d1f9c459886eedb3f8f47e4d9.JPG

IMG_8185.thumb.JPG.0a5d868eb2a5d8d04440311ef955e9b9.JPG

IMG_8186.thumb.JPG.e5c643b10c01a551d77374458107f5bd.JPG

It has now done nearly 2500 miles of mostly surburban commuting along with the odd motorway trip, and all seems fine. I haven’t topped up the coolant in 3 months and it’s dropped by less than 1cm. (max to min is about 10cm) I'll keep an eye on it but I don’t think losing that amount even counts as a problem on a 15 yr old car. It uses a bit of oil too but nothing major. 

My wife has lightly kerbed 3 of the 4 lovely refurbished alloys, but I'm not even mentioning it because we bought the car on the basis that it's bigger than the v40 and it might get a bit scratched on the narrow country lanes that made up her commute but it's a cheap car. So it's likely to be more my fault than hers, despite there not being any kerbs I can think of along the narrow country lanes around here.

1218154781_IMG_8476copy.thumb.JPG.2d78233b5400bfb4c1c07036c03ae305.JPG

Anyway, we love it, and keep finding new gadgets, like the stereo volume buttons on the steering wheel, or the yellow button on the key fob that turns on the interior lights before you unlock it. There is almost nothing we don't like. The size is easy to get used to, 5 of us went camping in it recently and it swallowed everything with ease. The sound of the 5 cylinder when you floor it, along with the whistle of the turbo, and the cars behind getting smaller in the rear view mirror is enjoyable. The turning circle is terrible. It's pretty much the only problem with the V70. 

So it's done what we wanted it for, and anything from now on is a bonus. A driving holiday will be happening soon, so we'll see how it manages when the miles get piled on. It certainly doesn't feel anything like a car near the end of it's life. There is no discernible difference between the way this car feels and the way our V40 felt with 100,000 fewer miles on it. The Dark Beast is a better car than when we bought it and has benefitted form a bit of attention and TLC, so I'll continue to try to sort some of the small niggly jobs so when it's time to move it on it will make a really nice car for someone. Although we might never sell it, we like it that much. And if we do, we'd replace it with another V70. I can see how people get hooked on these things.

 

Share this post


Link to post
Share on other sites

Glad to hear the Dark Beast is going well. Looks a lot better than when I had it, and glad you're investigating the niggles that I was too lazy to! I do miss it, although after five V70 D5s it was time for a change. I'm sure I'll end up back in one - for the money it's very difficult to do better.

PS - is my gaffer fix still doing a sterling job in the drivers window? 😊

Share this post


Link to post
Share on other sites

I had problems with my interior fan and I traced it to the fan controller, I also fitted a little unit from ebay that acts like a cd changer and allows you to stream music and calls from your phone.  It was very clever it used the up/down discs buttons to control functions.

I really miss my Volvo! :( 

Share this post


Link to post
Share on other sites
39 minutes ago, rainagain said:

I also fitted a little unit from ebay that acts like a cd changer and allows you to stream music and calls from your phone.

I knew I'd forgotten something. On Monday I fitted one of these from recommendations on another thread.

598462829_ScreenShot2019-07-24at13_53_05.thumb.png.42e20cd6596d61f46ef84d0dc6532432.png

I managed to get hold of a cheap used one of these, doesn't have the phone handsfreeness features but we only wanted music so it's fine.

Easy to fit too, and there's traces of one being fitted before. It works a treat, and doesn't interfere with the 6 cd changer functions which is great.

plugs into the spare 8 pin plug, taps power from the red live wire, and hides behind the stereo

IMG_8604.thumb.JPG.29825bf202267ae84265e6edc7d13515.JPG

IMG_8603.thumb.JPG.cd5ec6c433bee0c6a8461e1cd218d778.JPG

IMG_8605.thumb.JPG.bb4b74eb228558619425c86d4b27861c.JPG

IMG_8607.thumb.JPG.8b1b32481f0f87783b4a264cd2e6c208.JPG

IMG_8609.thumb.JPG.3852c0c0f7c66aef2d0ea3763bcc5ddf.JPG

I forgot to take an after shot but the headphone socket is routed into the centre console storage bin just behind the gear knob.

 

 

 

 

Share this post


Link to post
Share on other sites
15 hours ago, JayB said:

PS - is my gaffer fix still doing a sterling job in the drivers window? 😊

A weird thing happened last week, the drivers window auto close started shutting the window but immediately bouncing the window back down as if it had hit an obstruction. My immediate thought was that the silver gaffer tape fix was stopping it shutting properly, but when I looked it had fallen out. Gone. Lost forever! Haven't noticed any whistling in my right ear though.

The window still shuts ok if you nudge it up a bit at a time but I've had a quick look and I can't see what's fooling the auto close into thinking there's a tiny child finger sized object in the way. 

 

Share this post


Link to post
Share on other sites
On 7/24/2019 at 2:10 PM, inconsistant said:

A weird thing happened last week, the drivers window auto close started shutting the window but immediately bouncing the window back down as if it had hit an obstruction. My immediate thought was that the silver gaffer tape fix was stopping it shutting properly, but when I looked it had fallen out. Gone. Lost forever! Haven't noticed any whistling in my right ear though.

The window still shuts ok if you nudge it up a bit at a time but I've had a quick look and I can't see what's fooling the auto close into thinking there's a tiny child finger sized object in the way. 

 

Try getting the window to the top, then pull the switch up as if you were closing the window and keep the switch up,  this can/should reset the memory, then push the switch down to auto open the window all the way down, then try putting the window up and see if that works,  I remember this working on VAG vehicles but might also work on ovlovs?

If it doesn't work take the door card off and disconnect the motor and then re try the above, while the door card is off check the mechanism for dry grease and the runners up the sides of the door glass for dirt etc, 

Silicon spray the rubbers in the door if it has them? I can't quite remember as it's been a long time since I was inside a V70's door, 

I too think that I will end up with a V70 D5 as I need a bit more room than I currently have in my Skoda Fabia 6y estate,  need an estate with seats in the back that lay flat for the occasional sleeping in, good luck with the dark beast!

Share this post


Link to post
Share on other sites

Thanks for the window tip, didn't work but I've noticed the rubber on the top corner of the window has folded in on itself and is stopping the window from shutting completely so I think it will need a bit of fiddling with when we get home.

Anyway, another geographical update... the Dark Beastie made it even further north, to this gorgeous bit of north east Scotland, so that's just over 850 miles since leaving home.

IMG_8777.thumb.JPG.c2f586072d9a363bb1159136c79bc47a.JPG

Time for some economy calculations: we managed 700 miles on a tank of diesel. The in-car trip computer said we'd averaged 54mpg over a tank full which I thought was a bit chinny-reckon so working out miles from brim to brim I made it 45mpg exactly. That’s quite a big difference, not just a bit of manufacturers optimism, more like blatant lying, naughty Volvo. But 45mpg is still pretty good though for a big heavy car full of people and spare pants and buckets and spades and whisky and stuff and only about 2-3 mpg less than the v40 which would do about 47-48mpg over that sort of journey so I’m still pretty impressed.

When we were driving in torrential rain from Edinburgh to Aberdeen I was in the passenger seat barefoot and noticed that the passenger footwell was quite wet. I had a feel and a sniff of fingers and it smelled of coolant so I was a bit anxious that it was coolant leaking and we were going to break down in really awful weather so I kept one eye on the map and one eye on the engine temperature. It was fine so the next morning I bought some coolant anticipating needing to top it up but it was still the same level as when we left.

IMG_8772.thumb.JPG.df4ac85ed2e694f758f785d18bc38c94.JPG

I assume then that the stormy weather was finding it’s way in somehow and because the carpets still had a bit of dried coolant from previous leaks the wet carpets still smelled a bit of it. So a nice relief but should probably look to see where it might be coming in (maybe the scuttle panel, or through the pollen filter and dripping from there?) and seal it before the winter. 

Time to give the car a rest before the return journey and enjoy the awesome beaches and peace & quiet you only find on the edge of a continent.

IMG_8803.thumb.JPG.61fb30e7b70d5f0ab836ac63f485f691.JPG

Share this post


Link to post
Share on other sites

IMG_9038.thumb.JPG.891acd6618d5c6edd4207ecd9535e111.JPG

Another update to add that we made it back home from Scotch hols after doing a total of 1778.1 miles in 2 weeks, taking the mileage over 215,000. I was going to take a photo of the front showing the coating of millions of dead bugs and beasties covering it but my other half cleaned the car before I got a chance. I think she may have bonded with it, as she never, ever cleans our cars.

IMG_9039.JPG.d652595b65c6ee10b3d4a8cd5c7320a4.JPG

The car didn’t let us down, but there's now a blot on it’s record, and it was the A/C .

On the last day our journey south from Glasgow was 8 hours on a rather hot day, about 33C outside. I’ve already mentioned the fan sticking on as a known problem when we bought it, but usually only happens if you turn the A/C on with the Auto button, or one of the 3 below it to direct air to top middle or feet. If we use the window desist button or press A/C on and then turn up the fan it's OK. Even if it does stick on full blast after about 15 mins it becomes turn-offable again.

I accidentally pressed the auto button as we left Glasgow and the fan started on full power. It stayed on full power (and therefore full noise too) until about Cambridge, 6 hours later. That’s a lot of noise. Unfortunately things got worse after we stopped at Scotch Corner to swap drivers when the fan, still at full power, gradually started increasing the temperature until it was blowing hot air at full blast. So we had several hours of hot noisy driving with all 4 windows down to try to keep cool, which wasn’t the most relaxing journey.

Things randomly started working again after Cambridge, we had fan control and cool air again, but the journey was quite unpleasant and uncomfortable indeed.

It could be the car naturally objecting to being driven away from its' natural habitat, but I'm assuming it's the control panel that's faulty so I’ve found a replacement A/C front panel on ebay for £20 with the same combo of option button on as ours, my thinking is that if it was the A/C mechanical bits it wouldn’t have started working again, so I’m hoping it’s the control panel. And if it isn’t then it shouldn’t be too much time and money wasted swapping the new one in.

1519877745_ScreenShot2019-09-05at10_20_41.thumb.png.77e972808bcbab0107e5157bb3478d75.png

If anyone has any other thoughts I'm all ears.

Share this post


Link to post
Share on other sites

The fan on my s80 only worked on one speed regardless of the controls. Even turning the fan speed off it kept running. I changed the transistor control that was bolted to it. It was fine after that. Might be worth checking in yours. 

Share this post


Link to post
Share on other sites

Yes to all this.  I am fully aware now of the possible miseries that I have taken on, but oh my GOD the level of (yesterday’s) spec is unreal.  Grom bluetooth kit, motorised uppy downy (with separate remote control) dash satnav, fully heated leather electric seats etc etc and aye, that engine...

I have now been fully schooled in how much it may die soon, but for now it’s amazing.  Need to do some big miles in it soon as the commute is just not enough.  

Current chagrin is the mismatched HID headlight replacements.  Need that shit gone.  Am sure the original set up would have been fine.  The right hand lens washer was unplugged too.  Plugged it back in and it went a bit mad.  So at least the motor works.  Some fuckery has happened I guess, and also guess that it was the HID shite.   Wanted ad for headlight unit now placed.  

Still have more fun stuff to find though, pointless gadget-wise.

Steering has a ‘blip’ (can’t quite describe) when turning right.  Gonna live with that rather than talk about new racks ha ha.

Will it make it to May’s MOT? 

Prace Bets Now.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...