Jump to content
Floatylight

Floatylights Fleet - Saab shanigigans & Picasso plight

Recommended Posts

As far as i am aware the dpf is intact; it was jet washed out 2-3 years ago by the fitters at work. It was Passive and active regenerating as it should under normal driving conditions. Since changing the manifold it would do a big clear out of black smoke every now and then before settling back to normal or doing a full on grey smoke regen.

 As it doesn’t do a wastegate/dump valve whoosh on gear change that was the next thing I was going to investigate. Last fault codes I had were p0400 (failed EGR) and p0234 (turbo overboost )

Share this post


Link to post
Share on other sites

Update time.

Replacement second hand intercooler arrived and was fitted today. Went for a drive and it threw P0234, cleared it, went for another drove and seems much happier, definitely more boost. Will check and the small sensor pipes. Tomorrow hope to fit the £10 droplinks and lubricate the heater fan.

May press into work use on Monday for a trip to Bedford and see how I get on.

Suspect the thermostat is stuck open as it only get to 50 degrees according to the obd, unfortunately doesn't seem possible to get just a thermostat and comes as a complete assembly at £60!

Sent from my Moto G (5) using Tapatalk

Share this post


Link to post
Share on other sites

First day out and about in the Saab today, running much better but still a bit slow to spool up the turbo at lower revs, sometimes throws an eml if revved to the red line. Need to check some of the smaller pipes for leaks but now the bloody bonnet release won't work... FFS!!!

Sent from my Moto G (5) using Tapatalk

Share this post


Link to post
Share on other sites

Managed to open Bonnet & adjust release mechanism.

 

Decided to do an oil & filter change before putting into work use so bits ordered! Also ordered a rear wiper blade from ECP for under £4!

 

Back using Picasso for work, as log as I take it easy it keeps on plodding on..

 

Sent from my Moto G (5) using Tapatalk

 

 

 

 

Share this post


Link to post
Share on other sites

This weekend's updates:- Saab heater fan replaced with one which was in the boot which after a bit of lubrication was squeek free, replaced a small piece of hose which seemed a bit damaged in the boost circuit and put on a spare battery borrowed from[mention=17429]sutty2006[/mention] while I sort warranty replacement from Tayna.

 

Went for a drive, still not boosting properly and when revved to 4k throws an eml, ungrateful baxtered! Also still letting water in from what seems to be driver's a pillar but not sign of any drains in that area..

 

In other news Smoll FL's C3 has an intermittent injector fault...

 

Sent from my Moto G (5) using Tapatalk

 

 

 

 

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...