Jump to content
JoeyEunos

Joey Eunos's Web Of Shite- Volvo Servicing

Recommended Posts

I should probably just get my lazy arse up to the Volvo breakers near the A1 but I've heard they're a bit arsey

 

A few people have mentioned that, TBF when I spoke to them on the phone earlier in the week they seemed perfectly cordial and very helpful. I think you've just got to 'Take as you find' sometimes ;)

Share this post


Link to post
Share on other sites

A few people have mentioned that, TBF when I spoke to them on the phone earlier in the week they seemed perfectly cordial and very helpful. I think you've just got to 'Take as you find' sometimes ;)

 

I've been there several times, and I've found the guys there perfectly pleasant, especially if you're buying something. They'll even lend you tools if you ask nicely.

 

As an aside, the guys at the Saab specialists Two Stroke To Turbo near Royston are incredibly friendly, helpful and enthusiastic. I wish that they were my mates.

Share this post


Link to post
Share on other sites

^ I'm 99% certain that's the exact colour of the seats in the breaker I've been rummaging in, it's a 1990 740 GL saloon...

 

Unfortunately whilst the car is good and seems to have been scrapped despite it's last MOT in 2012 only showing 79k miles, the drivers seat looks to be completely covered in grime, maybe even oil? Frustratingly all other seats seem A-ok :(

 

If you'd like I can buy the seat (Probably very cheaply indeed) and have a go at cleaning it up with washing powder/stiff brush/jet-wash? If I can get the muck out then good, if not I can dispose of it?

 

Early 940 GLs and SEs had the same seat fabric, as opposed to 740 GLs and SEs, which were totally different (tweed versus plush).

 

The seat you describe sounds interesting. Does it have any damage, or is it just dirty? I imagine that the muck would come off using a foam upholstery cleaner and perhaps a bit of white spirit; Volvo seat fabric is pretty tough :)

Share this post


Link to post
Share on other sites

Early 940 GLs and SEs had the same seat fabric, as opposed to 740 GLs and SEs, which were totally different (tweed versus plush).

 

The seat you describe sounds interesting. Does it have any damage, or is it just dirty? I imagine that the muck would come off using a foam upholstery cleaner and perhaps a bit of white spirit; Volvo seat fabric is pretty tough :)

 

No obvious damage I could see, all looked good from a structural perspective but I must admit I didn't scrutinize it that carefully. I was preoccupied with doorcards at the time! I'll most likely be going back to see what else I can find on the car next weekend so will have a look and report back then ;)

 

Meanwhile, and with my interior is sorted thoughts are turning to the oily bits. I'm planning a service next weekend and could do with some advice...

 

Oil? I'm told any old 10W40 of a decent brand will do?

 

Plugs? ECP seems to recommend both NGK BPR6ES and BPR6E for the B230fk engine but despite much googling I'm unable to fathom what the difference is between them, or which would be best... Any ideas?.Also, default gap is 0.9mm, will the gap need adjusting or should they be good to go out of the box?

 

Filters? I've always used MANN for oil/air filters n the past and plan to continue to do the same with the Volvo... Good call?

 

Coolant? This one seems to be a complete minefield -_-  VAG stuff is so simple, you just stick G12 in and all is fine. Having done  a bit of googling most folk on Volvo forums seem to have posted multiple contradictory recommendations of what to use! One thing they all seem to agree on is that it must be phosphate and silicate free, so that's ruined my plan of just using bog standard blue ethylene glycol :ph34r:  What sort of antifreeze do I need?

 

TIA chaps :)

Share this post


Link to post
Share on other sites

Oil - I get a good quality 10W40

Plugs - usually NGK for me. The extra letters I think relate to the plugs heat range.

Oil Filter - try to get a genuine Volvo filter. Volvo still do them off the shelf and it’s not much more than non OE. They’re better quality though and have the all important non return valve inside.

Coolant - get the old blue ethylene glycol stuff.

 

Fuel filter? If you can’t find any history of it being done get one of those too. Easy to change and located inside the little cage thing under the passenger rear floor.

Share this post


Link to post
Share on other sites

Cheers.

 

Receipt for fuel filter in the paperwork 6 months ago and it looks brand new so all's well there.

 

Are you gapping the plugs before fitting or just installing straight out of the box?

 

Also, the blue stuff isn't phosphate and silicate free :?  My temptation was to use that too, but the various Volvo forums I've browsed have all contained dire warnings that the phosphate and silicate contained within it will cause kittens to die/bad things to happen etc so I'm feeling slightly dubious about it...

Share this post


Link to post
Share on other sites

Cheers.

 

Receipt for fuel filter in the paperwork 6 months ago and it looks brand new so all's well there.

 

Are you gapping the plugs before fitting or just installing straight out of the box?

 

Also, the blue stuff isn't phosphate and silicate free :?  My temptation was to use that too, but the various Volvo forums I've browsed have all contained dire warnings that the phosphate and silicate contained within it will cause kittens to die/bad things to happen etc so I'm feeling slightly dubious about it...

Yeah gap the plugs. I can’t remember the gap (I can’t even remember my own phone number!). You should always gap them really.

 

The blue or green stuff is fine in these old red block engines. My current ones had it in for ever and the previous saloon I had had it in for as long as I had it at least. And my 244 before that... it’ll be fine!

Share this post


Link to post
Share on other sites

I've been using Halfords 'Cla$$ic' 20W50 motor oil (with a genuine Volvo filter - an absolute must) in The Volvo for the past two years, due to it having done almost 250,000 miles. It's consuming far less oil as a result and is running beautifully ^^

Share this post


Link to post
Share on other sites

New tyres fitted to the brick this week...

 

41646455844_936bb081f3_h.jpg

 

Frustratingly despite having loads of tread left the old tyres showed some pretty gnarly perishing and DOT date suggested they were made in 2004  :ph34r: I've gone for 'Barum Brilliantis 2' all round on the basis I could get four for just over £150 and having had them before I know as cheaper tyres go they're actually pretty decent.

 

Also, yesterday saw an impromtu minor service take place. This was pretty much a 'spur of the moment' type of affair so in spite of advice to use Volvo parts for this I went ahead and used what was available locally (Apologies to the Volvo massive/Shep/Dan etc who may not approve of this!)...

 

41466811645_fa9105fde7_h.jpg

 

The car actually came with a receipt for plugs/filters/oil dated November of last year, it's probably only done about 300 miles since then. I couldn't help it, I was overcome by an irrational need to get stuck in and provide myself with a kind of 'ground zero' to start from. Now at least I can be sure of what's in there and when it all happened ;)

 

Pela pump in service again...

 

28496095478_458f5dab2f_h.jpg

 

I use the Pela for all my oil changes but for the first go I will always use the sump plug after vacuming oil with the Pella so as to see what it's missed and therefore guage it's suitability for any given car... On the Volvo it must have been less than an egg cup's worth of oil that dribbled out so I shall be removing the oil via suction from here on in ^_^

 

Unfortunately the filter placement (B230FK) makes necessary  to get under the car either way but at least removing the old stuff via vacum saves mess and also fannying about with sump plugs. As mentioned, oil filter is located quite in inconveniently just forward of the bell housing...

 

42320648762_41734578c1_h.jpg

 

Having spent more time that I'd like to admit crawling round under various ropey/elderly cars on the drive, I still found it slightly intimindating getting under the Volvo. It's properly huge and I found getting underneath it quite unpleasant...

 

42320632942_2515d45ff1_h.jpg

 

Disappontingly (But predicatably) the air filter that came out looked brand new. I fitted the new one anyway... At the point I removed the first plug and found it was exactly the same type of NGK I was about to fit and also looked new with a perfect gap etc I decided enough was enough and put it back in. I shall save the four plugs I bought for next year's service rather than waste them where they're not needed.

 

I'm getting closer to a stage where I'm happy with the car! Timing belt is on the list and also a coolant flush/change, other than that there's dent in the rear hatch to deal with but once all that's done it'll be pretty much 'job jobbed'.

Share this post


Link to post
Share on other sites

Excellent job. Sounds like your cars been looked after in the past!

The MANN filters do have the non return valve btw, so should be fine. I had one on mine for the first 6 months it went back on the road, I used that filter and some of the cheap ECP own brand 10w40 oil just to flush everything through for a few hundred miles (old oil before that was very old and dirty!).

After that I used the same oil you have + Volvo filter. I tend to buy two or three at a time and keep them in stock at home! You can get them from Volvo parts counter or Volvo specialists easy enough.

Speaking of which, here’s a couple I’ve bought from before if you need stuff;

 

http://www.partsforvolvosonline.com

 

http://www.skandix.de/en/

 

They carry a bit more than normal parts shops. I’ve also bought a fair bit from Rockauto.com. It’s American, so you’ll have to pay extra for importing whatever you buy but they seem to have lots available for these cars that we don’t here so much! Though the parts prices can often be much cheaper than here.

https://www.rockauto.com/en/catalog/volvo,1995,940,2.3l+l4,1289101 Should take you straight to the 940 parts lists!

 

 

Must admit I don’t mind being under my ovloV too much. The one of mine I hate being under is the Mercury! Is fucking huge and very heavy! I always feel a bit uncomfortable underneath it despite using stands and the jack etc.

Share this post


Link to post
Share on other sites

Thanks chap :) Some cracking links there, should come in handy!

 

TBH I've pretty much used MANN stuff in eveything since before the begining of time now, that said the only filter I've ever come across that was sans return valve was a Hlaford's special that I briefly had fitted to a 1.4 Golf many years ago. The tappets sounded like an AK47 on full chat for about 2 mins on cold start :ph34r: Never again.

 

Rather you than me hanging about underneath a Mercury for any length of time  :wacko:  TBH no matter how careful I've been with stands/jacks/safety etc I'm never completely at ease under any car irrespective of it's size these days. Wierdly, when I was younger it didn't bother me. Read into that what you will...

Share this post


Link to post
Share on other sites

More scrap yard rummaging this morning...

 

41797479164_2542a6c318_b.jpg

 

This one died far too young...

 

42520180151_6ebca54c24_b.jpg

 

I nabbed a set of none wrinkly doorcards from this about a fortnight ago and given I know it's about to be cubed soon I couldn't resist another visit to grab a host of other bits that I don't need and probably never will. It appears I've now started hoarding 940 parts as well as VAG stuff.

 

Volvo bits seem to be daft money on Ebay so I thought I'd best strike while the iron's hot!  Unfortunately my loft is completely full at present and overflow has started creeping into my already packed shed :ph34r:

 

42468530502_70cf11b2f0_b.jpg

 

 

Looking on the bright side, I have a spare PAS pump, complete set of mint door seals, near complete set of interior plastics in the correct (Grey) colour as well as this awesome piece of grill bling...

 

42520175581_1a0b85eb09_b.jpg

 

 

After some googling it's clear Volvo were pioneers of the lambda sensor and were proud of it (I think they actually won an award FWIW) Apparently cars of the right era were bestowed with a badge for bragging rights, it's a funny old world...

 

On a serious note, my hoarding/rummaging escapades are causing some real tension with Mrs Eunos at present so I'm going to have to 'wind my neck in' for a few months at least -_-

Share this post


Link to post
Share on other sites

That badge brings back memories of my Mum's silver 240GL.  H186 XUL.  Best car my parents ever owned.  They shifted it after it needed a second new steering rack.

 

Saw an L-reg white 240SE yesterday.  Wanted to go over and offer the giffer driving it cold, hard, cash.  Was restrained by Lady Grumpius.

Share this post


Link to post
Share on other sites

That badge brings back memories of my Mum's silver 240GL.  H186 XUL.  Best car my parents ever owned.  They shifted it after it needed a second new steering rack.

 

Saw an L-reg white 240SE yesterday.  Wanted to go over and offer the giffer driving it cold, hard, cash.  Was restrained by Lady Grumpius.

 

The 240's are awesome, I like them more and more as time goes on.

 

Bad times RE rack based woes. FWIW I've noticed an intermittent (But subtle) whining in mine, even without Mrs Eunos in tow, dependent on revs and usually under partial lock, hence the purchase of PAS pump... Perhaps I'd better give some thought to liberating the rack from the breaker car before it goes for good <_<

 

The weird thing is that only a couple of months ago I was all about heritage VAG/Mazda stuff. I joined Autoshite and about three weeks later ended up  buying a Volvo estate. Funny how it all works out...

 

 

Shame that scrapper had to die, it’s barely even run in! Still, at least it’s given you (and several others by the look of it!) plenty of useful bits.

 

Yes, it's been pillaged incredibly quickly, it didn't look at all like that a fortnight ago....

 

When I turned up this morning the wings (Rust fee) were being boxed up and sent to Spain at great expense. TBF I think they've sold the parts too cheaply... IIRC I've had four mint non peeling door cards, a PAS pump, pretty much all interior plastics/trim pieces, badges and owners manuals/toolkit and gloves for £60 all in. When I called Lakes Volvo they wanted £120 for some decent doorcards alone, and after all of that and several repeat calls, after checking they didn't have any in stock  :rolleyes:

Share this post


Link to post
Share on other sites

Another weekend= more Volvo tinkering.

 

I've been struggling with a rough idle and some hunting recently. Weirdly when cold the car has been lurching up and down the rev range without any throttle input, often shooting up to 2000rpm+, holding itself there for a few seconds and then crashing back down to near stall levels. Pretty scary! In stop start traffic, having to constantly have your foot on the clutch in-case it surges and sends you into the back of the car in front is far from ideal  :ph34r:

 

Oddly, it settles right down when warmed up and where as the idle isn't exactly stable (Probably 700-900rpm with some occasional wobbles) after 10 mins or so of running the massive surges stop. My thought are that it has to be temperature related....

 

The first course of action was to spray 'Easy start'  around all of the hoses/manifold/injectors, engine note didn't change and revs didn't increase so I think I'm ok there. Next step was to whip off the ICV and clean it...

 

It did look pretty grubby...

 

 

41979332154_e2785dc954_b.jpg

 

 

 

After some cleaning it looked much better...

 

 

41979331364_7a4cb331f0_b.jpg

 

 

Unfortunately this didn't improve matters, it actually made them worse :rolleyes:  First test drive having made these improvements resulted in a massive surge session followed by a stall whilst doing 50mph on a dual carriageway, FML.

 

I continued to test the car and took it took work on Friday, the troubles continued with occasional surging for the first 5-10 mins settling down into a plain old slightly dicky idle once up to temp. On the way home from work it decided to show the green triangular warning light on the dash (The engine warning/Lambda light I've later learned).

 

The really fun part is that this is a 1996 model, it's the year that Volvo switched to OBD2 and wait for it.... OBD2 readers won't speak to them, it's actually more of an OBD1.5. If you want to know the codes then you pretty much have to build your own diagnostics box. Once again, FML.

 

At this point I'd reached 'Desperate stab in the dark mode'. My coolant had always looked like over-brewed tea, I already had a new thermostat/antifreeze and a coolant temperature sensor in stock so I decided given the surging was only really present for the first 5-10 mins when warming up, new antifreeze/thermostat/cts might be a good call...

 

I flushed the system once with plain water and then three times with de-ionized...

 

 

41797959795_f3ca605805_b.jpg

 

 

Removed the old CTS and fitted a new one. Unfortunately the new sensor is aftermarket (FAE branded?), but hopefully ok, either way it was all I could get in a hurry. Old sensor was covered in baked on ginger nastiness and didn't look too clever...

 

 

41979328494_acf84b0661_b.jpg

 

 

Old thermostat, also covered in ginger/rusty filth, this was probably the 1996 original and was Calorstat branded...

 

 

41979327304_402a9bb044_b.jpg

 

 

The old 'stat was working well, but given the cooling system was getting a complete drain it seemed to be a good time to switch it. The item came direct from my local Volvo stealers and despite being the same 87 degree model, this time it was a Wahler item...

 

 

41979330554_dc20ac23ac_b.jpg

 

 

After multiple flushes it was time for new antifreeze. I've gone for Comma's 'Super-Coldmaster'. Basically it's blue 2 year stuff...

 

 

41979324814_6f293f75ef_b.jpg

 

 

System bled off and lovely fresh coolant...

 

 

27828711577_ba99a11dac_b.jpg

 

 

After this I pulled fuse No1 to clear the codes/light.

 

This brings me up to present date and as of yet the car is untested on the open road. Idle still seamed unsteady whilst bleeding and flushing but no surging, it would be amazing if the CTS/fresh coolant had stopped the massive surging/hunting during warm up but I recon it's pretty unlikely... I have a tip run planned this morning so that will provide an opportunity for a more thorough test.

Share this post


Link to post
Share on other sites

Thats a very interesting post. last year, my 92 Rover 820 did the same thing. revving high, and then almost stalling. I reckon that it was caused by a low coolant level uncovering the temperature sensor. That was a few months back now and fingers crossed, it has behaved perfectly since filling the overflow tank right to the top. (Volvo 850 tank) Fingers crossed that your coolant change and top up will have solved your problem. Let us know how things go.

Share this post


Link to post
Share on other sites

Thats a very interesting post. last year, my 92 Rover 820 did the same thing. revving high, and then almost stalling. I reckon that it was caused by a low coolant level uncovering the temperature sensor. That was a few months back now and fingers crossed, it has behaved perfectly since filling the overflow tank right to the top. (Volvo 850 tank) Fingers crossed that your coolant change and top up will have solved your problem. Let us know how things go.

 

Hmm...

 

I'm literally just about to set off in the car to the tip to get rid of some garden rubbish.

 

This is the first proper test since making changes with the CTS/thermostat/coolant, I've got the level up to the max mark on the tank so we'll see what happens...

Share this post


Link to post
Share on other sites

Right, after a dose of redex and a 10 mile run things seem to be somewhat improved. Idle settled into 1100rpm ish when warming up with no real surging, then down to circa 900 rpm or so once up to temperature. Idle is still not fantastic, but acceptable.

 

To early to say if things are better for good though...

 

Next step, throttle body cleaning.

Share this post


Link to post
Share on other sites

900 revs warm tick over sounds about right and its always a good idea to clean the throttle body. Depending how fastidious the last owner was with oil changes, it could be well gummed up. How about the distributor cap, is it in good shape? I presume you have changed the plugs and gapped them correctly.

Share this post


Link to post
Share on other sites

900 revs warm tick over sounds about right and its always a good idea to clean the throttle body. Depending how fastidious the last owner was with oil changes, it could be well gummed up. How about the distributor cap, is it in good shape? I presume you have changed the plugs and gapped them correctly.

 

Plugs/distributer and leads are all less than 6 months old, receipts from previous owner show this and they also look fresh.

 

Meanwhile, throttle body came off this afternoon...

 

 

40908999440_8e5fe35c14_h.jpg

 

 

As expected it was pretty filthy....

 

 

27850297117_4860191d3c_h.jpg

 

 

After some scrubbing things looked much better...

 

42670199732_453ab706ce_h.jpg

 

 

With throttle body out access to the oil separator box was much improved so thought I may as well whip that out too. Some clear evidence that this had been leaking around the base point where the box meets the block...

 

42670198622_2060e80b79_h.jpg

 

I've been slowly pillaging parts from a local breaker car and one of the bits I'd knabbed was a spare separator box. Despite the fact that this came from a 1990 NA model the part number was a match to mine and the box looked far less oily than the one that came from my car. I plugged the holes, filled it with brake cleaner and then blasted it through to ensure cleanliness...

 

 

40908908550_15d1dbfe31_h.jpg

 

 

The network of pipes that come from the breather box were also removed and cleaned...

 

42670196232_28b070bf94_h.jpg

 

 

No flametrap to clean on this car as it's a turbo model, I did however find the hose that comes from the intake manifold nipple and joins the Y shaped section of the breather pipe was split. I trimmed it and re- fitted it but the hose does seem quite hard with age so I shall look to replace it...

 

42670195262_cd7038149b_h.jpg

 

 

At this stage I sprayed the TPS and IAC plugs with contact cleaner and re-connected then reassembled everything. I struck me that I should perhaps have had the battery disconnected during all of this? I'm not sure of the ECU's capacity to learn/adjust when changes have been made on these cars?

 

Either way I'll probably pull fuse 1 for a few minutes before re-starting.

 

Unfortunately I was called in to attend to Sunday dinner so at this point the car remains untested, we shall see tomorrow how and if the changes I've made have effected running.

Share this post


Link to post
Share on other sites

This morning I pulled fuse #1 for a few minutes to reset the ECU and then took the car out for a 20 mile jaunt, wow, the change is profound! No more surging at all, nil, zero. Also the idle seems almost locked into 900 rpm with very little fluctuation :)

 

I'm not going to utter the 'F' word yet, but the initial signs are very promising indeed. I think the ECU at present will be in a kind on 'learn' mode having been reset too, so hopefully over the next couple of tanks of fuel it will get used to the changes made and settle into behaving itself on a full time basis...

 

Next steps: Replace lots of the 22 year old hoses, the turbo engine reaches some high temperatures so this seems to be good preventative maintenance. Also, my radiator fan seems to run from the get go and appears to be driven directly from the AUX belt... I'm not sure if they're designed to always be running whenever the engine is on so will have to do some digging to gain clarity on that too.

Share this post


Link to post
Share on other sites

The viscous fan should spin all of the time but the fan clutch does eventually fail so the fan is fully engaged all of the time rather than free wheeling.

 

Interesting...

 

So I should be able to spin it freewheel, by hand with the engine off to test the clutch is working?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Similar Content

    • By Zelandeth
      Well I've been meaning to sign up here in forever, but kept forgetting. Thanks to someone over on another forum I frequent poking me about it recently the subject was forced back into my very brief attention span for long enough to get me to act on the instruction.

      I figure that my little varied fleet might bring you lot some amusement...

      So...we've got:

      1993 Lada Riva 1.5E Estate (now fuel injected, as I reckon the later cars should have been from the factory...).
      1989 Saab 900i Automatic.
      1987 Skoda 120LX 21st Anniversary Special Edition.
      1985 Sinclair C5.
      2009 Peugeot 107 Verve.

      Now getting the photos together has taken me far longer than I'd expected...so you're gonna get a couple of photos of each car for now, and I'll come back with some more information tomorrow when I've got a bit more time...

      Firstly...The Lada. Before anyone asks - in response to the single question I get asked about this car: No, it is not for sale. Took me 13 years and my father's inheritance to find the thing.



      Yes, it's got the usual rusty wings...Hoping that will be resolved in the next couple of months.







      Next, a proper old Saab. One of the very last 8 valve cars apparently, and all the better for it. I've driven two 16v autos and they were horrible - the auto box works sooooo much better with the torque curve of the 8 valve engine. Just wish it had an overdrive for motorway cruising...






      Next up a *real* Skoda...back when they put the engine where it belongs, right out the back. In the best possible colour of course...eye-searingly bright orange.





      Seat covers have been added since that photo was taken as it suffers from the usual rotting seat cloth problem that affects virtually all Estelles.

      Then we have possibly the world's scruffiest Sinclair C5...



      Realised when looking for this that I really need to get some more photos of the thing...I use it often enough after all! We have a dog who's half husky, so this is a really good way of getting him some exercise.

      Finally - again, I really need to take more photos of - we have the little Pug 107.



      Included for the sake of variety even if it's a bit mainstream! First (and probably to be the only) new car I've bought, and has been a cracking little motor and has asked for very little in return for putting up with nearly three years of Oxford-Milton Keynes commuter traffic, before finally escaping that fate when my housemate moved to a new job. Now it doesn't do many miles and is my default car for "when I've managed to break everything else."

      I'll fill in some more details tomorrow - I warn you though that I do tend to ramble...














    • By strangeangel
      I thought I'd start a thread for this as I'll probably end up asking all sorts of questions, given that this is my first 'proper' Citroën.
       
      So... the ground clearance lever won't go all the way to the highest setting (all others work), which is bad 'cos the book says I need it to do that in order to check the LHM level. It feels like something's seized, so I don't want to force it. Any ideas for a plan of attack would be much appreciated.
       
      Next up are the wheels. I now have a set of 205 pepperpots that have just gone off for powder coating & I need to get some tyres for them. The handbook says the car should have 165/70R14s on, the wheels came with 185/65R14 on. Any thoughts about what size I should get please? Cheers.
       
    • By Peter C
      Woke up this morning, had a little time before I had to leave the house for work, had a quick look at what’s new for sale on Retro Rides and saw an ad for a W124 200E manual, located 15 miles from home. I had no intention of buying a car today but I had to have it! I called the seller and arranged a viewing.
       
      Faults:
       
      2 x rusty front wings (TADTS)
      1 x rusty rear arch
      Needs a polish
      Tracking is out because new track rod end was fitted for MoT
      Engine has oil leak/s
       
      Good points:
       
      It’s a W124 200E!
      5 speed manual transmission
      New clutch
      Brand new MoT
      Superb MoT history
      4 x as new Continental tyres
      Last owner for 15 years, her husband before that for 4 years
      Very tidy MB-Tex interior
      Drives well
      All electrics work
       
      The dealer kindly delivered the car to my house but I managed a pez station shot on route:
       

       
      Plans:
       
      Remove front wings, cut away rust and apply plenty of wob.
      In-situ similar repair for rear arch
      Clean and polish
      Service engine
      Adjust tracking
      Leave patina and enjoy the car as it is
       
      I will update this thread once progress is made.
       

       

       

       

       

       

       

       

       

       
      Hopefully these two will become good friends.
       

×
×
  • Create New...