Jump to content
dozeydustman

Saab 93 - Smuts and knocks. Also fridge.

Recommended Posts

Shiny noo zorst.

IMG_7304.thumb.JPG.60a10c68e57e672bfd04a4a636e2637f.JPG

All torqued up.

IMG_7305.thumb.JPG.e12df56e03dcad71984171f37afdb0f8.JPG

I see no smoke at tickover either. Quick blat around the block, only a few whisps of smoke on acceleration. I really hope this is it. Goes back to the garage tomorrow for MoT over the weekend or Monday.

Share this post


Link to post
Share on other sites
16 minutes ago, snagglepuss said:

well done chap! Worth the battles 

Indeed it was.

The garage was pretty impressed with my work as I'd asked them just to check the torques on all the fittings I had replaced before they sent it round for the test. Not blowing my own trumpet.

It's funny how different garages pick up different things. The NS suspension arm is barely noticeable by all accounts so may last the year out, the rest can be sorted as and when.

I'm now giving it a blez up to Kent for a couple of days. Then next Sunday the Corolla's balls get replaced, so another thread on some genuine shite to update!

Share this post


Link to post
Share on other sites

Result of blat to Kent. Bit flat because bad connection to swirl flap motor (I know this is broken wire) so power is a bit hit and miss.

39DB2655-6975-47FE-96CA-6FAD62E9EF29.thumb.jpeg.046f576e6fd8e6c8388a9da63ac3c742.jpeg

Just a smidge under 60mpg is best i’ve ever had coming up to kent. Happeh

Share this post


Link to post
Share on other sites

With a year's ticket and a 200 mile shakedown over the last couple of days, time for a new list of jobs to do on this car over the next year.

  1. Full service including alternator belt, cam belt and water pump.
  2. Replace bottom engine pulley as I think the rubber damper in the middle of it is getting a bit knackered after 205 and it seems to vibrate a little.
  3. Sort our O/S wing repeater - the lens is cracked and mouldy, and the bulb holder is a bit grotty and has a iffy connection somewhere
  4. Check swirl flap motor connector and wiring, I think it has a broken wire or a poor connection; failing that reinstate old swirl flap motor.
  5. Replace both rear tyres - I may put the 2 y/o fronts on the back as they're about 3-4mm tread.
  6. Replace leaking headlamp washer pump
  7. Replace rear wiper blade
  8. Clear any codes that may have picked up
  9. Replace rear number plate bulbs (I have 2x 5w capless, but I'm looking at replacing with LED)
  10. Keep an eye on the rear suspension bushes and the steering inner joints as advised at MoT
  11. Replace any missing trims.
  12. Replace O/S/F front hub (that will be a mission as the driveshaft splines are still seized/rusted into it)

I'm hoping now with all the work I've done the car will be on the road for a few more years yet, if I can get her to 250k in my ownership I'll be chuffed. Going to take a few days away from car tinkering, plus the Corolla's MoT is higher priority now.

Share this post


Link to post
Share on other sites

Mrs_d used the Saab this evening to go to her new evening job.

Got a phone call at 9:15ish from her telling me the car conked out. I knew it was low(ish) on fuel, about half a gallon left in the tank but she promised to put some diesel in on the way home. Went to petrol station with jerry can. Found mrs_d, and the Saab, and a puddle of diesel on the floor.

Cylinder No.3 has spat out its leak off t-piece again. Bodged it to get home but I'll have to assess the damage (if any) tomorrow.

I had the Corolla destined for some garage action tomorrow. Pah.

Share this post


Link to post
Share on other sites

Did you put a new leak off kit on? If so, wondering if the engine cover maybe is knocking it somehow?

I assume all the mounts are still on it? The cover on the one I had was on+off so many times with the car breaking, I gave up putting it back on! A bit noiser (because its there for acoustic reasons too) but not excessive. 

Share this post


Link to post
Share on other sites

New leak off connectors and hoses, I think I still have a good T-shaped one from the old set. It had actually come out of the injector, so wondering if the O-ring or R-clip are wanky.

cover has its 4 rubber mounts so i’ll check make sure everything is in place. On Tacho break at work so won’t know until I get home and have a look

Share this post


Link to post
Share on other sites

Put a new O-ring seal on the loose T-piece, seems to be a better fit and no leaks etc.

Something I'll have to keep an eye on though. I can't find the old ones so looks like I need to buy a few spares.

Share this post


Link to post
Share on other sites

A smoll drive around yesterday evening and the diesel leak from No3 injector leak off system has returned. It's only a drip as opposed to pissing everywhere but nevertheless I don't want my car dripping fuel everywhere, especially as I have seen the mess diesel spills, unexpected rain or damp and motorcycles make when combined. It appears to be coming from where the hose and t-piece join, so I'm hoping it's just the hose being less than perfect as opposed to another t-piece being needed. I have spare hose but need to order more t-pieces, so I may get a set of the brass ones I have seen on the Bay of E, which means I can also jubilee clip the leak off hoses to them as opposed to interference fit with the plastic ones.

Can't do much with it today as I'm off to see my dad for his birthday!

Share this post


Link to post
Share on other sites

I replaced the small piece of hose on injector number 3 and the leak went.

After a short drive, injector number 2's leak off popped out. Exactly the same issue as last Thursday - the R-clip has slipped and the T-connector jumped out. I noticed that Injector No 4's clip wasn't where is should be.

As posted in Ask a shiter? have I got crap R-clips or is something more serious the issue?

Share this post


Link to post
Share on other sites

What about creative use of zip ties to hold the T connectors down? Does sound like the r-clips are a bit pants if they're coming off. Tried squidging them to close them up a bit and make a tighter fit?

Share this post


Link to post
Share on other sites

I think it's a mix of poor quality R-clips and t connectors, despite them being GM branded parts. Well, they came in GM packaging. I'm hoping where I've changed all 4 o-rings and squeezed the clips a little they are holding today. Fitter at work owes me a favour so he's going to peek under the lid tomorrow see if I've done anything wrong as he knows these engines pretty good as we have a couple Fiat vans with the 8v version of the engine.

Share this post


Link to post
Share on other sites

I'm hoping I've sorted out the injector leak off problems on this old crate now. After a new set of retaining clips proved to be as much use as a chocolate teapot, I bought another set, this time from a Saab Specialist on eBay for £4 posted.

IMG_7384.thumb.JPG.4654ae0380f4da834123a4a8ce0ce1cd.JPG

Spot the difference. The new ones are a much better fit, but No 3 injector's leak off was still dribbling. This is the one I'd replaced the o-ring on a week ago.

IMG_7385.thumb.JPG.c6d7561fa449427dd62057101ff5f3d0.JPG

Luckily I had managed to not throw out the old leak off connectors so I just whacked these back in with new o-rings from a jumbo pack I got from Lidl last summer (last 2) and they are snug, don't rattle about and no moar leeks by the looks of it. I am still tempted to get a set of metal connectors. Hopefully next month water pump, cam belt and alternator belt. Which I'm sure will be fun.

Share this post


Link to post
Share on other sites

The hoses between the central T-piece and the connections on 3 & 4 are the replacement parts that, despite being GM 'genuine' parts, are utter shit (lower 2 injectors). I swapped the replacement hoses for 1 & 2 for the good originals that were in the garage in an old margarine tub.

Share this post


Link to post
Share on other sites
3 hours ago, SiC said:

No sorry I meant the electrical connector!

Yep they're original as far as I am aware. One has a dicky lock tab so cable ties may be needed soon.

Share this post


Link to post
Share on other sites
On 5/22/2019 at 3:57 PM, dozeydustman said:

With a year's ticket and a 200 mile shakedown over the last couple of days, time for a new list of jobs to do on this car over the next year.

  1. Full service including alternator belt, cam belt and water pump.
  2. Replace bottom engine pulley as I think the rubber damper in the middle of it is getting a bit knackered after 205 and it seems to vibrate a little.
  3. Sort our O/S wing repeater - the lens is cracked and mouldy, and the bulb holder is a bit grotty and has a iffy connection somewhere
  4. Check swirl flap motor connector and wiring, I think it has a broken wire or a poor connection; failing that reinstate old swirl flap motor. ✔︎
  5. Replace both rear tyres - I may put the 2 y/o fronts on the back as they're about 3-4mm tread.
  6. Replace leaking headlamp washer pump
  7. Replace rear wiper blade
  8. Clear any codes that may have picked up ✔︎
  9. Replace rear number plate bulbs (I have 2x 5w capless, but I'm looking at replacing with LED)
  10. Keep an eye on the rear suspension bushes and the steering inner joints as advised at MoT
  11. Replace any missing trims.
  12. Replace O/S/F front hub (that will be a mission as the driveshaft splines are still seized/rusted into it)
  13. Force a Regen

I'm hoping now with all the work I've done the car will be on the road for a few more years yet, if I can get her to 250k in my ownership I'll be chuffed. Going to take a few days away from car tinkering, plus the Corolla's MoT is higher priority now.

 

I have managed to get my flaps flapping at last, but we now have a new issue.

EML came on today on way home, no limp mode. Popped round to a work colleague who has a code reader that apparently only works on Fords and Peugeots, but not his Nissan. Worth a try.

We have P1901 which is something to do with the DPF - could be a knackered sensor, broken wire or something similar. Wondering if the middle box on the system is clogged a bit as the one directly under the turbo is new(ish) and Possibly why the Flexi failed on my old exhaust. Need to study the book of lies and see how the exhaust system is configured on this car.

Might also see if I can remove this middle box and steam clean it internally at work if it is that which is clogged. It's probably more important that I get a water pump and an alternator belt and do those soon.

Share this post


Link to post
Share on other sites

Cataclean and a blast might do it, or some equivalent dpf snake oil.  I think Wynn’s do one but no idea if it’s any good

Share this post


Link to post
Share on other sites
7 minutes ago, Parky said:

Cataclean and a blast might do it, or some equivalent dpf snake oil.  I think Wynn’s do one but no idea if it’s any good

I got some Seafoam additive I've been meaning to pop in the tank. It's the 'all rounder' for oil and fuel. Meant to put some pre-mot in the corolla but seeing as that runs as sweet as a nut emissions wise, I may save it for this oil burning beauty!

 

Last time I popped into Chalmers in Gravesend before the car got MoT'd, I got something they had on a promo from the states. Put the can in and I've never seen so much crap come out of a diesel (was around November last year). I was driving home to Sussex after I popped this stuff in before I left in the evening - I remember it did a pretty fierce regeneration as glowing smuts came out the tailpipe when I pulled over thinking the car was on fire! Shame I can't remember what it was.

Share this post


Link to post
Share on other sites

It would appear I need a new EGR or at least give the one installed a real thorough cleanout again. There's no 'whoosh' on acceleration and turbo is now lagging a bit. I seem to remember the last time I needed an EGR the car behaved like this. What is more important though

The DPF does regenerate so I doubt it's blocked, I remember when putting the exhaust mid-section on the honeycomb was black but there were not blocked cells in the mesh. And the last regen the car did had nice smuts coming out the exhaust.

I need to get a water pump and alternator belt for this soon, possibly an alternator belt tensioner; I've still got Saabnut's cam timing tool and feel a bit guilty that I've not used it yet or sent it back.

This morning on a quick run to town the suspension has made a knocking noise from the offside. I'm hoping it's just some of the siezed/rusted together bits I couldn't remove have freed and just need torquing up again.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By RobT
      As posted in News 24, a cheap non-running Senator proved too much to resist.  So here it is.  Egg also owns half, so the pair of us can share the joy/despair of getting it roadworthy.

      It was advertised as a non-runner, but the seller said it had ran previously.  His son replaced the fuel pump and filter, but managed to wire it up incorrectly.  I only noticed this as the buzz of the fuel pump happened after the engine was cranked, and not before.  Yep, bit crusty under there but it's mostly sound underneath.

      But it still wouldn't fire.  I did some random loosening of fuel hoses by the fuel rail, just in case there was an air lock or something, and after plenty more cranking it fired up!  No idea if the random stuff helped, or if it just needed loads of cranking.  Exhaust is shot, but after a brief drive around the block I felt buoyed up so went back later for a Vauxhall 1,2 rescue mission.

      This proved optimistic, as upon return it was misfiring like a bastard and would barely manage the block run.  12 miles like that is asking too much (it has an MoT, somehow).  Recovery it is then...
    • By Shirley Knott
      Greetings all.
       
      After lurking here for a short while, frankly liking what I see and enjoying the various shite, the site has well and truly struck a chord with me. I'm a serial buyer of ropey sub £1k vehicles, don't have to but genuinely enjoy it.
       
      I feel like I might (Just might) have found my 'spiritual' home here
       
      I've been posting across the web on owner specific forums (Usually using either my JoeyEunos or RandomPrecion handles) for a while now, but from here-on-in I will pull my threads together and merge them here into one ghastly topic.
       
      My current steeds...
       
      Lupo 1.7 SDI
       
      SAM_5560 by
       
      and the work/story so far...http://forums.clublupo.co.uk/index.php?/topic/102863-joeyeunoss-sdi-beater/
       
      Golf Mk4 SDI
       
       
      SAM_5531 by
       
      and the thread.... http://uk-mkivs.net/topic/597074-project-slow/
       
      Early (1989) Mk1 Eunos (This one was recently sold)
       
      SAM_4656 by
       
      the thread...http://www.mx5nutz.com/forum/index.php?showtopic=213274
       
      Other shite I've owned and moved on in the last year include this ropey Passat...
       
      SAM_6011 by
       
      and this legendary £300 Fiesta Finesse...
       
      Festa by
       
      Cars I'd like to own/actively looking for in the forthcoming weeks/months/years...
       
      Rover 75 (Dizzler)
      Peugeot 405 (XUD)
      Mk1 Octavia (Estate/dizzler, pre pd or SDI)
      Honda CRV (Gen1)
      Volvo 240/850
    • By Zelandeth
      Well I've been meaning to sign up here in forever, but kept forgetting. Thanks to someone over on another forum I frequent poking me about it recently the subject was forced back into my very brief attention span for long enough to get me to act on the instruction.

      I figure that my little varied fleet might bring you lot some amusement...

      So...we've got:

      1993 Lada Riva 1.5E Estate (now fuel injected, as I reckon the later cars should have been from the factory...).
      1989 Saab 900i Automatic.
      1987 Skoda 120LX 21st Anniversary Special Edition.
      1985 Sinclair C5.
      2009 Peugeot 107 Verve.

      Now getting the photos together has taken me far longer than I'd expected...so you're gonna get a couple of photos of each car for now, and I'll come back with some more information tomorrow when I've got a bit more time...

      Firstly...The Lada. Before anyone asks - in response to the single question I get asked about this car: No, it is not for sale. Took me 13 years and my father's inheritance to find the thing.



      Yes, it's got the usual rusty wings...Hoping that will be resolved in the next couple of months.







      Next, a proper old Saab. One of the very last 8 valve cars apparently, and all the better for it. I've driven two 16v autos and they were horrible - the auto box works sooooo much better with the torque curve of the 8 valve engine. Just wish it had an overdrive for motorway cruising...






      Next up a *real* Skoda...back when they put the engine where it belongs, right out the back. In the best possible colour of course...eye-searingly bright orange.





      Seat covers have been added since that photo was taken as it suffers from the usual rotting seat cloth problem that affects virtually all Estelles.

      Then we have possibly the world's scruffiest Sinclair C5...



      Realised when looking for this that I really need to get some more photos of the thing...I use it often enough after all! We have a dog who's half husky, so this is a really good way of getting him some exercise.

      Finally - again, I really need to take more photos of - we have the little Pug 107.



      Included for the sake of variety even if it's a bit mainstream! First (and probably to be the only) new car I've bought, and has been a cracking little motor and has asked for very little in return for putting up with nearly three years of Oxford-Milton Keynes commuter traffic, before finally escaping that fate when my housemate moved to a new job. Now it doesn't do many miles and is my default car for "when I've managed to break everything else."

      I'll fill in some more details tomorrow - I warn you though that I do tend to ramble...














    • By dome
      This evening I venture forth into hitherto unknown lands (Kirkintilloch) to collect my latest acquisition.

      Which, naturally, has issues.

      I have purchased my first line of defence.



      Which appears to have antigravity properties

      More will follow this evening...
×
×
  • Create New...