Jump to content
dozeydustman

Saab 93 - Injector woes sorted?

Recommended Posts

Just about an hour ago I went to start my car up, had Mrs Dustman with me, to go and pick Miss Dustman up from work. Turned over fine but took a while to fire up.

 

Steering felt heavy. Thought maybe as it's currently -5 + wind chill it's just cold & the fluid is thick.

 

Started reversing out my bay then I was greeted with:
"DING DONG" - ABS fault.

"DING DONG" - ESP fault

"DING DONG" - headlamp auto levelling not working, contact service.

 

I shut the car down straight away and we went in Mrs D's Corolla.

 

Alternator is less than 2 months old, it's a recon unit from Alternator Man in Portsmouth. Hoping the cold isn't killing the battery and it's taking the 'nator out with it (battery passed the drop test last time the no-charge warning came up). Looks like a session with the multimeter after work tomorrow.....

 

MEH.

Share this post


Link to post
Share on other sites

Check the battery, a failing alternator killed mine - and the cold will make things a lot worse too.

 

However worth testing the current as the alternator might be broken still - someone else on here (I can't recall who, but it was a Rover I think) got a recon alternator with a warranty and it turned out to be DOA I think. He got it replaced no questions asked I think - these things happen.

Share this post


Link to post
Share on other sites

It is cold.

I have seen an engine freeze up so water pump won't turn, so belt slips and no charge. etc.

 

Have a look at the coolant?

 

 

Driven off the cam belt on the diseasel engine I believe. Coolant and pump less than a month old, was done with cam belt/EGR/DPF change a few weeks back.

 

Looks like I'll be getting the battery drop tested as well then tomorrow.

 

The 'nator isn't a particular pain to change on this motor, but it's hassle I could do without at the moment.

Share this post


Link to post
Share on other sites

Well, I went to go and test the alternator this afternoon after work, and engine won't even turn. I'm hoping the battery is knackered as opposed to being the alternator. It was tested when the old alternator packed up in late December, and was deemed OK.

 

Going to whip it off tomorrow and see if I can get it load tested again

Share this post


Link to post
Share on other sites

Wouldn't surprise me if it has finally died SiC, it's a very old Bosch battery with a supposed lifetime guarantee, but as it put on by previous owner I'm not sure if the guarantee passes to me - need to do some research and find the receipt. Still waiting for my neighbour to return home as he borrowed my charger a couple of weeks back and foolishly thought I'd not need it for some time!

 

Decent 096 batteries ain't cheap. I've fitted off-brand batteries to previous cars in the past and some have barely lasted a year before they've packed up - doesn't matter if my wheels are a pile of shite or something decent, I always buy the best I can afford.

 

The car has had none of the weird symptoms prior to failure it had in December when it was the alternator (trip computer mess-arsing about, speedo dropping to 0 and back to current speed etc.) - just hoping it's not some major electrical fault 'cause if that's the case I'll be buggered.

Share this post


Link to post
Share on other sites

I believe these are 096 batteries:

https://www.coxmotorparts.co.uk/honda-shop/genuine-honda-civic-2-2-diesel-battery-2006-2011/

 

Unfortunately just under the free delivery threshold.

 

Saabs of this vintage tend to go a bit crazy when the batteries die. They also sometimes a power cycle on the battery when they start being silly - especially if they don't shut themselves into low power mode when the ignition turns off.

 

Maybe teaching to suck eggs, but make sure you disconnect the battery from the car before connecting the charger.

Share this post


Link to post
Share on other sites

An overnight charge appeared to succeed as battery took a charge according to the charger's gauge, soon as it went on the car and turned over for 2 seconds then died, so sounds like a dead cell. New battery it is.

 

Just hope it hasn't taken the alternator out with it.

Share this post


Link to post
Share on other sites

Enormous Varta 78Ah battery ordered from Tayna for the same price the local motor factors wanted for a 65A Banner brand - I don't particularly like fitting cheap batteries to cars, even shitemobiles. I've had cheap batteries last less than 6 months in the past. Let's see how we get on when it arrives, hoping running it for no more than 30 seconds before the electrics went haywire didn't ruin the alternator.

Share this post


Link to post
Share on other sites

New battery. Hoorah!

 

post-24583-0-38304300-1520354025_thumb.jpg

 

I don't like the look of that voltage. I'm thinking 13.5-14v is correct. A quick 10 minute run didn't make the lights come on, and the battery has remained at 12.7v after switching off, and again half an hour later. I don't think there's a discharge anywhere, so looks like the 2 month old alternator is not healthy.

 

Bummer.

Share this post


Link to post
Share on other sites

Is that 13.08v with the engine running? If so, how long has the engine been running for when you took that reading?

 

 

Yep with the engine running. That was after 10-15 minutes driving down the A27 and back. It was fluctuating between 12.8 and 13.0 before I set off. Granted it's not a long run, when I fitted the alternator back in January it read 13.7 at tickover before I took it for a run, and a heady 13.9 after a good half an hour.

 

Connections to the 'nator and battery are secure, so I can only assume it's failed.

Share this post


Link to post
Share on other sites

I'd be giving the place that rebuilt it a ring and explain patiently what has happened - I'm sure they will be happy to exchange it for another one.

 

I know a weird man in a shed in mid-hampshire who rebuilds them if you are interested. He is properly weird though.

Share this post


Link to post
Share on other sites

I'd be giving the place that rebuilt it a ring and explain patiently what has happened - I'm sure they will be happy to exchange it for another one.

 

I know a weird man in a shed in mid-hampshire who rebuilds them if you are interested. He is properly weird though.

 

 

Thanks for that Stanky, if I get no joy from the place I bought it from (based in Pompey) I'll give you a shout.

 

Thinking about whipping it off and getting an independent check it over with a verdict.

Share this post


Link to post
Share on other sites

£215 for a reconditioned Bosch (excluding deposit/surcharge) from ECP. Same price for a brand new Denso and no surcharge.

 

 

Just wondering why the recon one I purchased was only £100ish. Think it's a Denso unit I got back.

 

Give me a Lucas ACR any day. Much simpler

Share this post


Link to post
Share on other sites

And about a third of the output on a good day if the charge light wasn’t glowing faintly

 

 

I've never had a Lucas ACR be unreliable. Had them on my Scimitars and a number of tractors I've looked after in the past, only failed due to worn brushes, which are easily replaced.

Share this post


Link to post
Share on other sites

I've never had a Lucas ACR be unreliable. Had them on my Scimitars and a number of tractors I've looked after in the past, only failed due to worn brushes, which are easily replaced.

But a Lucas ACR has no chance in providing enough capacity to power a modern car - especially one laden with electronics like the Saab 9-3 is.

 

There isn't really too much in design between a ACR and the alternator on your Saab though tbh. Just tighter packed to get more power out of it.

Share this post


Link to post
Share on other sites

What's more annoying is the place I bought it from just hangs up when they answer the phone, or go direct to voicemail, and hasn't returned my message. Two days have passed since leaving a voicemail

 

Has anyone here used AlternatorMan in Portsmouth?

Share this post


Link to post
Share on other sites

Yes I have, just goes through to voicemail on either. When I bought the alternator he at least sent me a text to say he was out for lunch. Conveniently his website has stopped working as well, and his eBay shop has closed down.

 

My dad called me up earlier to see how things were and he reckons the guy has either shut up shop or is purposefully ignoring me. Might take a trip down there after work on Friday see if the place is Mother Hubbard.

Share this post


Link to post
Share on other sites

if you're coming over this far might be worth taking a small detour afterwards to this chap

 

http://www.jasm.co.uk

 

He's the funny guy I took my Geep starter motors to. He told me what was wrong and that it would be cheaper for me to fix it myself, and explained how. He was right and it was free to fix.

 

Are you mobile without the Saab? its not likely to be a drive-in drive-out job.

Share this post


Link to post
Share on other sites

Yeah I have Mrs Dustman's corolla as she's not working this week, I'll contact your man at some point tomorrow or Friday and see what he says.

 

I have been put in touch with a garage nearby who specialise in the Swedish marques, and as I work with the bloke's brother he's going to swap it over for mates rates (£75), if I can supply a new/recon alternator that works.

 

I'll probably get all this done and then in April find it needs half a million quid to get it through the MoT.....

Share this post


Link to post
Share on other sites

If your Alternator is only charging at 13.05 volts, then you have a problem. It should charge at a minimum of 14.00 volts, otherwise there is not enough of a gradient so that the energy can flow into the battery and keep it fully charged. At rest, a fully charged battery will show 12.7 to 12.8volts.Charge state can also be verified by a hydrometer test on a lead acid type battery. Not possible to test a sealed Calcium type with a hydrometer for obvious reasons.

 

If you want to test that the alternator is not shorting the battery to ground, then I tested mine in the following manner: Using analogue meter set to the 10 amp scale, I disconnected the negative battery terminal. Connect one lead from the meter to the battery post and the other to the battery negative lead. If all is well, you will get a very slight movement on the meter needle. If a small swing, switch now to the 1 amp scale to read the discahrge, it will be around 50 milliamps, depending on your cars equipment. But if the alternator diodes are faulty, then the needle will show a much larger swing. In my case, I got a swing of over 1 amp, which showed that the alternator diodes were faulty and were allowing current to pass back to the battery and draining it to ground. It drained a new battery in under 24 hour.

 

This was a brand new reconditioned Alternator supposedly reconditioned by a reputable supplier. I sent it back for an exchange and the next alternator worked perfectly. End of charging problem. But I wasted hours of time before reaching the correct conclusion that the supplied alternator was faulty. I really cursed that supplier!.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Similar Content

    • By dozeydustman
      Mrs Dustman has a dash cam she wants me to fit to her '99 frog face Corolla. It came with a hard wire kit as opposed to the usual fag lighter lead, so I might as well make a decent* job of it and hide the wiring completely. Trouble is I can't remember how I got the radio pod out when I fitted the DAB unit she now has. I've also got a few dash illumination bulbs to change so I might as well do it all in one hit while it's a sunny afternoon.
       
      A bit of googling comes up with the US spec dash which appears to be different from the European model, or the 2002-on model. I seem to remember spudging out the dash vents to access some bolts/rivets.
       
      Failing that, is there an easier place to get a switched live from (besides the radio) that doesn't involve destroying the car's interior?
    • By Broadsword
      Hot on the heels of last week’s collectioneering of a Xantia, another collection starts here and now. Well it is probably a collection as long as the car is as described, but I am optimistic.

      Clues. It’s enormous yet quite cramped. Never had one before and it could be considered blessed, saintly even!
    • By Tickman
      First some background:
      I was brought up with no car interest, a car was transport and nothing more which resulted in a selection of poor cheap cars being the cars of my youth.
       
      Fast forward many years (just over 9 years ago) and I have a wonderful* Vauxhall Vectra estate to carry us about. Unfortunately it is crap and throws fault codes at us with nothing being there when it is checked (even at Vauxhall)
       
      As Mrs T is the main pilot of this chariot with the two little miss T's on board, it has to go.
      The hunt is on for the new steed to safely and comfortably carry the family around. I have a company car at the time so big journeys are not an issue.
       
      ebay is my weapon of choice to find the new family car. It has to be good value cheap for no other reason than I am tight.
       
      Weeks of research with lots of cars that are too expensive and too far away for easy collection end up in my watch list.
      Finally a possible is spotted in Fife. I go and have a look and find a poor looking but solid car. One previous owner and lots of history.
       
      The auction was to end on the Saturday at midday, we were going to be out! I decided on how much I was willing to gamble on it and on the Saturday morning I put in my max bid but straight away it went to my max bid, I was winning but it had three hours to go with no room for me to go up! We went out anyway.
       
      I spent the next three hours kicking myself for not bidding more while we were out as it was the first car I had seen that fitted my criteria. Fate was in charge.
       
      On returning home I go straight on ebay to find 'Congratulations.............'
      For the grand total of £500 I had just won this fine vehicle!
       

       
      It has 5 months MOT and after fitting seat belts in the rear for the girls car seats it is pushed into daily service.
      My gamble and subsequent use results in a perfectly reliable car that actually does what it is supposed to do.
       
      Even more importantly Mrs T loves it so a win all round.
       
      All my cars have names (most are earned over a bit of time) and this one is called 'Gwendolen' ( G reg car and from Wales originally. I hate the name but I am not going to argue)
       
      That sums up part one, more will be along later (probably much later)
×
×
  • Create New...