Jump to content
dozeydustman

Saab 93 - Flaps are flapping. EML came on. Joy.

Recommended Posts

The cheapest place for carb cleaner is toolstation, about £2 a can there. I buy it for mowers.

 

That does sound like dying battery related lolz to me, get a secondhand one from a breakers with a 3 month warranty. How much is it to plug into the tech2 at the local place? If its >£10 then buy a knock-off op-com from ebay and I'll bring my 'dirty' laptop for diagnostics over and we can play about with seeing what codes it has?

Share this post


Link to post
Share on other sites

Main battery is near enough brand new - massive Varta lump I got back in march from Tayna. Consulting HBoL and goggling the interwebs there is apparently a separate battery just for the alarm siren. I have a long run planned this weekend up to Kent, so 80 miles each way, poor thing has only done 300 miles since we moved 5 weeks ago, mainly to the shops and back once a week and 2 trips to work - not good for the battery in a weasel engined car. Get no other faults come up, just this alarm one. If it is the battery at least it has some guarantee with it.

 

Just a thought. It's not the heat is it? Once the day cools down in the mid-late evening I can engage the alarm and it doesn't go off all night. Seeing as previous charging issues with the new alternator and battery were down to bad earths, I might have to go over every earthing point in the next few weeks.

Share this post


Link to post
Share on other sites
Guest Hooli

If it's like the alarm on a 9-5 then it does have a battery within the siren. SiC turned the siren etc off on mine before I got it (using Tech2 I think) to solve what I think I remember as a similar issue.

Share this post


Link to post
Share on other sites

I should break cover and delurk...

 

I’ve got a 9-5 with more or less the same engine - which generated tons of black smoke on acceleration. It would also go into limp mode pretty regularly and traced this to a hole in the intercooler about 1cm long.

 

The easy test is to pull off the hoses from the turbo and the inlet manifold, and fashion a bicycle inner tube into a ghetto boost leak tester. You need 2 sections about a foot long one with the valve in it. On the valve end roll up one end to seal the tube and pull it condom fashion over the smaller hose. Slice open the other bit and tie wrap it on to the other end. Pump and see if it hold pressure. If not you need to replace something.

 

Or rent a boost leak tester, it’s probably less of a pain in the tits.

Share this post


Link to post
Share on other sites

Just done a quick goggle search, I can find kits for the 1st gen 93, but not the 2nd gen (which mine is).

Looks like a simple soldering job, some new lithium cells and a few capacitors.

 

Weirdly, it's also sorted out the accelerator fault for the time being, went for a good hour and a half's drive after work and no limp-home mode. Doesn't mean it won't come back, and knowing this car, it'll do it at next year's MoT.

Share this post


Link to post
Share on other sites
Guest Hooli

¿Que?

 

Referencing Barefoot's strange noise in his Jag that turned out to be loose oranges in the boot.

Share this post


Link to post
Share on other sites

Had 4 days of no limp-home mode, no electrical weirdness at all. Alarm no longer setting itself off at random either, but still won't save its settings. I'm putting it down to the excessive heat and/or a fly being trapped in the car!

My trip to Kent has been abandoned due to yesterday's heatstroke/hyponatremia incident as still not feeling 100% the ticket, so spent the morning studying the HBoL to see how to reinstate the air conditioning pump. I seem to remember when I had the system checked over last year that the system had coolant in it, no leaks, but wasn't compressing when AC switched on, hence thinking the pump was shot.

Would a faulty pump clutch relay show up a diagnostic code if I put a reader on the diagnostic socket? I also don't have a working outside temperature sensor either if this is part of the problem, which on some cars I know is linked in with the air con system.

Share this post


Link to post
Share on other sites

The diesel compressors on these are a simple on/off clutch arrangement. The petrols have a variable deplacement pump that doesn't engage in or out as such.

 

For the diesel, I don't think it knows if the clutch is dead or not. (i.e. open circuit). Would have to check wiring diagrams to see how clever it is wired up. Have you checked to see if the belt goes round it? Sometimes people get a shorter belt if it siezes up to save replacing the compressor.

 

Likely the lack of working outside air temp sensor could be causing problems. Usually the system won't/can't engage in sub-zero temps, so no sensor means it can't check that and defaults off. Would again have to check the Saab Workshop manual for that. I'm not near my computer with it, so can't easily.

Share this post


Link to post
Share on other sites

The belt goes round the compressor and it spins nicely - I think I'll try a temp sensor as they are not expensive plus I need to take the front bumper off anyway to sort the headlamp washers from pissing out whenever the wash/wipe reservoir is filled up.

 

Hopefully something I can source this week. Unfortunately HBOL has a "typical" wiring diagram for the climate control, but it does incorporate an external temperature sender. Looks like they're only a tenner or so. Had a look in the front grill of the car it appears to be missing. If it hasn't fallen out and broken a wire that it...

Share this post


Link to post
Share on other sites
Guest Hooli

Likely the lack of working outside air temp sensor could be causing problems. Usually the system won't/can't engage in sub-zero temps, so no sensor means it can't check that and defaults off. Would again have to check the Saab Workshop manual for that. I'm not near my computer with it, so can't easily.

 

That'd I'd say is likely, I've heard of it on a few cars causing the AC to stop engaging.

Share this post


Link to post
Share on other sites

I've managed to order an external temperature sensor from eBay for £5 inc P&P, it's a Corsa/Astra/Vectra part, but same as the Saab part number and £10 cheaper. We shall see what it does.

 

I can whip the front bumper off, sort out the wheel arch liners and glue up the few broken bits of plastic which join the bumper and arch liners together. I have millions of imitation araldite - even if it keeps everything held together for a few months and the aircon working.

I've also seen while googling a non-functioning external temperature sensor can make influence the mixture and help with excessive smoking etc. which does sound a little far fetched that I'm not ruling out egr/manifold/swirl flaps/generally worn engine though.

Share this post


Link to post
Share on other sites

Saab has been dead for a week. No electrics at all when key turned, but central locking still worked on the remote. Thankfully I have a working pushbike for work and now with access to the Corolla for the time being, a poor connection on cylinder 4 spark plug saw rude health being resumed this afternoon. Could do with new leads though.

 

Voltage tested battery and was showing 12.4v, not excessively flat but not enough to crank over a diseasel. Battery is now on a trickle charge overnight. Also noticed there is a big multi-plug on the side of the battery box. It looks wonky. and dirty. It also looks like the main feed from the battery +ve.

 

I've had enough of cars for today though, so tomorrow will involve checking this multi-plug for connectivity and corrosion, reinstalling the battery, and take a dismantled bed to the tip - it's been sitting in the car for 8 days now!

 

I'll report back tomorrow.

Share this post


Link to post
Share on other sites

Is the key turning? If so, quite a few systems must be coming alive for it to do that. They're fussy at the best of times to allow that key to disengage and turn.

 

Have you tried disconnecting the battery for a bit? Sometimes a full power cycle and reboot can solve gremlins in these.

Share this post


Link to post
Share on other sites

Battery charged up last night, just fitted to Saab, started fine and a lovely healthy 13.7v on the meter at tickover.

 

Blipped the throttle - donk donk donk

 

Noticed engine cover wasn't level, took off and realised whoever had taken it off last (probably me) hadn't put the rubber spacers in correctly.

 

Then I noticed this.

 

post-24583-0-38211900-1532010699_thumb.jpeg

 

Soot should not be around there.

 

Then I noticed swirl flap actuating rod has gone missing, and No 4 swirl flap spinning round with the engine ticking over. It's a shit photo but best I can manage with phone.

 

post-24583-0-86072400-1532010782_thumb.jpeg

 

Probably explains the limp-home mode, the boomy exhaust and the excessive smoke. I'm not sure what type of flaps this engine has, but looks like I need to whip the manifold off now and fit a blanking kit. Or new flaps.

 

Bollocks.

Share this post


Link to post
Share on other sites

Saying that, I think parts for Saabs do a blanking kit for not much. It's a known weak spot on them apparently, the rod (or ends) on earlier ones are plastic and break for fun. Later ones are metal and are a bit better. Actuator fails too.

Share this post


Link to post
Share on other sites

Phew. that means if I've got the flap system I think I have, I don't need to remove the manifold to put the blanks in. Bet I've got the ones with the screws that hold the flap to the spindle.

 

Then again, a full manifold removal will give me a good chance to clear out all the soot and give the EGR a good seeing to.

Share this post


Link to post
Share on other sites

Full manifold removal on this requires fuel pump off. Which is a cambelt job.

 

However there are repair kits that can fit onto the remains of the existing spindle. The original rod bar is likely there still, just fallen deep into that well. You can get it out, just requires patience.

 

My 9-3 had this happen and twice too. First time with my parents it was sorted under Saab warranty. Second time was with me and it was long out of warranty at that point. As the repair kits didn't exist at the time, I used numberplate caps glued on to the rod. Worked fine and put another 15k or so on it. Until it got rear ended and written off.

 

The car is still on the road somewhere so can't be that bad!

Share this post


Link to post
Share on other sites

Like I said, you don't need to have the manifold off to reattach swirl flap rod.

 

 

my fingers are huge.

 

Then again cambelt is due a change I think. last changed at 150k, it's at 200k now. And I want to go down the total deletion of flaps route if possible.

 

Number 4 cylinder (furthest from gearbox) is actually blowing soot out of its housing with the engine running.

 

Then again I am tempted to fuck the car off and get that Samba on the tat thread

Share this post


Link to post
Share on other sites

Spent a couple of hours this afternoon in a shady spot with my head under the Saab's bonnet. No sign anywhere of the flap actuation rod. It would also appear that the swirl flap for No 4 cylinder has now jumped right out of its port. Buggerations.

 

I've also got 3 new faults which appear at random, but when they do, it's all at the same time. ABS, ESP and Traction Control failure. Going to trace more wiring diagrams tonight in the HBOL, I'm hoping again it's a dodgy connection or faulty ESP switch on the dash (had this before). Sometimes it's when I start the car, they're there immediately. Other times I could be driving for an hour and half with no fault.

 

However I'm now getting to the point of real frustration with this car, the Mrs no longer trusts it, and has started losing coolant and oil.

 

With MoT until mid May next year, I might put £100 a month by until then and get something a bit better. I think it's got to the point of not worth fixing TBH, unless there is a really brave shiter who wants to take it on?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Similar Content

    • By scdan4
      That bit hiding up behind the air filter and infront of the turret



      made a prolonged, loud, farty vibratey noise (loud enough to be clearly audible in the cabin with the radio on) twice today, both times it did it the nose was pointing down a steep hill and we had just parked and turned off the engine.

      It goes on for best part of a minute, so managed to track it down. Initial impressions are fuck knows what it is but it's clearly been bodged in the past. The yellow hose has clearly been disconnected sometime, by someone, for some reason, somewhere.



      Thats the blighter.

      Does someone want to tell me why it's blowing raspberries at me?


    • By Fumbler
      To mark the genesis of my fleet project thread I here present my new car: a 1997 Nissan Micra Shape-


      It really looks that good. There is a reason for this: its previous owner was an old lady who loved the thing so much so she made every effort to keep it in good shape. It originally came from Fleet in the GU postcode which suggests to me it was bought by the present dealer at auction, hence arriving down here in Kent. Before seeing the car I checked its MOT history and its only fails were thanks to broken stoplights, which shows me that it was very well cared for. I suppose an example of this was that on the last MOT, an advisory was a corroded rear silencer. The silencer on the car when I saw it was new. Methinks the lady wanted to keep it as good as possible. It was kept in a garage and so all the bumpers and black trim are very black and the tyres are in very good condition. Spare never used! Also included a free Dettol first aid kit from 1997.
      This car has 15000 genuine miles on the clock. We clocked over 15000 during the test drive! The lady owner really only trundled around her village in it and the MOT shows that it only did some meagre miles between tests. This, of course, came at a price. We saw a cherry red Micra from 2002 at the same dealer. Paint was shoddy and when they washed it the boot had massive sections of bare metal and it wasn't very happy. This car, however, is in fabulous condition and there was no contest between the two cars- it really is that good, inside and out. Immaculate interior, driver's airbag, cassette player... all there and all functioning (apart from cassette thanks to new battery and failed display). This meant that I bought it for £1600, £100 over what was my uppermost limit, but I knew I wouldn't see another like this that was in as good shape for a fair while. It was priced very ambitiously, at £1990, so I'm content in the fact I managed to slash a few hundred off the price. There wasn't that much paperwork though. All the dealership received was the logbook with 3 service stamps from 1998, 1999 and 2000, the radio key pass, a National Trust sticker, and the original paperwork holder. I suspect the old lady died and had her car auctioned, and the massive file of paperwork is now someone's egg carton, along will everything else she owned.

      As always, this car isn't exactly in showroom condition. While the inside is great and the floor is solid, and the underseal is in great shape, the not undersealed parts need a small looking at. Mainly the rear of the driver's side sill. It's really the only bubbling on the car. I suspect a well aimed stonechip managed to fester over the wintery salted roads, making it rust even more. It's around the size of a 5p piece, and will give me the opportunity to spray the insides of the sill with some chain oil to prevent any further corrosion. Behind the fuel tank there are a few rusty joints- places where the spraygun cannot get paint onto- which some Vactan and Dynax should put to rights. Alternator belt looks original because of the cracking and Nissan badges and will need doing soon as well as the front plate. As much as I like the 90's font and original dealer surround, the dishevelled R and general water ingress is a persistant MOT advisory. It could be the MOT station being strict (and most likely is considering there's a Saxo down the road with far worse blackening), however for the sake of peace of mind and all that, I'll get a new one made. The rear has already been replaced indicating this has happened before.
      All in all, I think this is a nice plucky motor. I'll have it by the end of the week; just got to sort out tax, insurance, and it's going to have an MOT. As part of the deal it's getting the MOT and an oil and filter change which will be something ticked off the list. It has some love scratches and chips here and there, but it drives well, is stiff and controllable, and should make out to be a nice summer project!
    • By clayts450
      With the recent addition of the 420 to the fleet it's high time I started a project thread devoted to all four Rovers.
       
      I've done some half-hearted attempts in the past, then done a few updates on the News 24 as and when I remembered.
       
      Today will be an intro to the fleet only with a little potted history about things wot I've done, and then I'll aim to be more blog-like in my approach to my skillful* fettling.
       
      So without further ado, welcome to the fleet.
       
      2004 Streetwise S - purchased May 2017
       

       
      It was a toss up between this and a top spec K11 Micra, but this won the day. This car marked my return behind the wheel after almost 18 years and thus was a monumental step forward for me.
       
      I'd given up driving mainly because public transport is so good in Nottingham but when my parents relocated to Newmarket from St Albans, the train journey to Suffolk was ridiculously long-winded and incorporated 55 minute waits at Cambridge to catch the connecting train to Newmarket, so enough was enough.
       
      Purchased from a shady man in East Leake ('which car ?' when I rang up) who was dealing from his front garden, this Streetwise stole my heart from day one. Annoyingly I missed out on getting it for £250 when this guy bought it and flipped it, and span a tale of a part exchange in Manchester where his old car lot had been. I wanted to call bullshit, but the price was right, £420 exchanged hands, and this came home with me.
       
      There were some issues, notably no horn nor rear fog lights (fucked Pektron BCU) but that aside, this car has wanted nothing other than consumables (tyres, exhaust, brake pads) and has never FTP (apart from user error - leaving the boot open and the dashcam on drained the battery on two occasions). The willing puppy and commutawagon, until recently this has always been my goto car, which I can always rely upon.
       
      It will continue to serve as commutawagon, not least due to its petiteness which ensures parking is easy, and its miserly fuel sipping.
       
       
    • By Zelandeth
      Well I've been meaning to sign up here in forever, but kept forgetting. Thanks to someone over on another forum I frequent poking me about it recently the subject was forced back into my very brief attention span for long enough to get me to act on the instruction.

      I figure that my little varied fleet might bring you lot some amusement...

      So...we've got:

      1993 Lada Riva 1.5E Estate (now fuel injected, as I reckon the later cars should have been from the factory...).
      1989 Saab 900i Automatic.
      1987 Skoda 120LX 21st Anniversary Special Edition.
      1985 Sinclair C5.
      2009 Peugeot 107 Verve.

      Now getting the photos together has taken me far longer than I'd expected...so you're gonna get a couple of photos of each car for now, and I'll come back with some more information tomorrow when I've got a bit more time...

      Firstly...The Lada. Before anyone asks - in response to the single question I get asked about this car: No, it is not for sale. Took me 13 years and my father's inheritance to find the thing.



      Yes, it's got the usual rusty wings...Hoping that will be resolved in the next couple of months.







      Next, a proper old Saab. One of the very last 8 valve cars apparently, and all the better for it. I've driven two 16v autos and they were horrible - the auto box works sooooo much better with the torque curve of the 8 valve engine. Just wish it had an overdrive for motorway cruising...






      Next up a *real* Skoda...back when they put the engine where it belongs, right out the back. In the best possible colour of course...eye-searingly bright orange.





      Seat covers have been added since that photo was taken as it suffers from the usual rotting seat cloth problem that affects virtually all Estelles.

      Then we have possibly the world's scruffiest Sinclair C5...



      Realised when looking for this that I really need to get some more photos of the thing...I use it often enough after all! We have a dog who's half husky, so this is a really good way of getting him some exercise.

      Finally - again, I really need to take more photos of - we have the little Pug 107.



      Included for the sake of variety even if it's a bit mainstream! First (and probably to be the only) new car I've bought, and has been a cracking little motor and has asked for very little in return for putting up with nearly three years of Oxford-Milton Keynes commuter traffic, before finally escaping that fate when my housemate moved to a new job. Now it doesn't do many miles and is my default car for "when I've managed to break everything else."

      I'll fill in some more details tomorrow - I warn you though that I do tend to ramble...














    • By TheDoctor
      As you may have read in the 'Can we save this?' thread, the answer was 'Yes we can!'
      Someone on this forum who wishes to remain nameless, fronted the cash to rescue this little Mazda from certain doom at the hands of a banger racer. I've taken custody of the car, but will make sure they get their money back as soon as is physically possible.
      Perhaps once it's running right, I'll look at some sort of roffle to find it a new home and pay back what it owes me and them.
       
      Although it had been sitting 5 years or so, it went through an MOT, so that's a good start.
       
      Known faults.
      - Alternator is kaput. Shouldn't be too hard to find a refurbished one. Presume battery knackered too.
      - Wheel bearing grumbling. 
      - Running like crap. Will replace fuel and vacuum pipes and add fuel filter. Then perhaps a carb strip down and rebuild. Aisan 980 carb as far as i know, same as the Toyota was,
      - Flat tyre. 
       
      It's currently sitting outside with a flat battery and no fuel, so that's not a good start!
       
       
      As I have very little talent, time or money, and suggestions / help greatly appreciated.
       
      These are the pictures I have so far - looks good but it's a lot more dull in real life...
       





×
×
  • Create New...