Jump to content
dozeydustman

Saab 93 - Flaps are flapping. EML came on. Joy.

Recommended Posts

Just about an hour ago I went to start my car up, had Mrs Dustman with me, to go and pick Miss Dustman up from work. Turned over fine but took a while to fire up.

 

Steering felt heavy. Thought maybe as it's currently -5 + wind chill it's just cold & the fluid is thick.

 

Started reversing out my bay then I was greeted with:
"DING DONG" - ABS fault.

"DING DONG" - ESP fault

"DING DONG" - headlamp auto levelling not working, contact service.

 

I shut the car down straight away and we went in Mrs D's Corolla.

 

Alternator is less than 2 months old, it's a recon unit from Alternator Man in Portsmouth. Hoping the cold isn't killing the battery and it's taking the 'nator out with it (battery passed the drop test last time the no-charge warning came up). Looks like a session with the multimeter after work tomorrow.....

 

MEH.

Share this post


Link to post
Share on other sites

Check the battery, a failing alternator killed mine - and the cold will make things a lot worse too.

 

However worth testing the current as the alternator might be broken still - someone else on here (I can't recall who, but it was a Rover I think) got a recon alternator with a warranty and it turned out to be DOA I think. He got it replaced no questions asked I think - these things happen.

Share this post


Link to post
Share on other sites

It is cold.

I have seen an engine freeze up so water pump won't turn, so belt slips and no charge. etc.

 

Have a look at the coolant?

 

 

Driven off the cam belt on the diseasel engine I believe. Coolant and pump less than a month old, was done with cam belt/EGR/DPF change a few weeks back.

 

Looks like I'll be getting the battery drop tested as well then tomorrow.

 

The 'nator isn't a particular pain to change on this motor, but it's hassle I could do without at the moment.

Share this post


Link to post
Share on other sites

Well, I went to go and test the alternator this afternoon after work, and engine won't even turn. I'm hoping the battery is knackered as opposed to being the alternator. It was tested when the old alternator packed up in late December, and was deemed OK.

 

Going to whip it off tomorrow and see if I can get it load tested again

Share this post


Link to post
Share on other sites

Wouldn't surprise me if it has finally died SiC, it's a very old Bosch battery with a supposed lifetime guarantee, but as it put on by previous owner I'm not sure if the guarantee passes to me - need to do some research and find the receipt. Still waiting for my neighbour to return home as he borrowed my charger a couple of weeks back and foolishly thought I'd not need it for some time!

 

Decent 096 batteries ain't cheap. I've fitted off-brand batteries to previous cars in the past and some have barely lasted a year before they've packed up - doesn't matter if my wheels are a pile of shite or something decent, I always buy the best I can afford.

 

The car has had none of the weird symptoms prior to failure it had in December when it was the alternator (trip computer mess-arsing about, speedo dropping to 0 and back to current speed etc.) - just hoping it's not some major electrical fault 'cause if that's the case I'll be buggered.

Share this post


Link to post
Share on other sites

I believe these are 096 batteries:

https://www.coxmotorparts.co.uk/honda-shop/genuine-honda-civic-2-2-diesel-battery-2006-2011/

 

Unfortunately just under the free delivery threshold.

 

Saabs of this vintage tend to go a bit crazy when the batteries die. They also sometimes a power cycle on the battery when they start being silly - especially if they don't shut themselves into low power mode when the ignition turns off.

 

Maybe teaching to suck eggs, but make sure you disconnect the battery from the car before connecting the charger.

Share this post


Link to post
Share on other sites

An overnight charge appeared to succeed as battery took a charge according to the charger's gauge, soon as it went on the car and turned over for 2 seconds then died, so sounds like a dead cell. New battery it is.

 

Just hope it hasn't taken the alternator out with it.

Share this post


Link to post
Share on other sites

Enormous Varta 78Ah battery ordered from Tayna for the same price the local motor factors wanted for a 65A Banner brand - I don't particularly like fitting cheap batteries to cars, even shitemobiles. I've had cheap batteries last less than 6 months in the past. Let's see how we get on when it arrives, hoping running it for no more than 30 seconds before the electrics went haywire didn't ruin the alternator.

Share this post


Link to post
Share on other sites

New battery. Hoorah!

 

post-24583-0-38304300-1520354025_thumb.jpg

 

I don't like the look of that voltage. I'm thinking 13.5-14v is correct. A quick 10 minute run didn't make the lights come on, and the battery has remained at 12.7v after switching off, and again half an hour later. I don't think there's a discharge anywhere, so looks like the 2 month old alternator is not healthy.

 

Bummer.

Share this post


Link to post
Share on other sites

Is that 13.08v with the engine running? If so, how long has the engine been running for when you took that reading?

 

 

Yep with the engine running. That was after 10-15 minutes driving down the A27 and back. It was fluctuating between 12.8 and 13.0 before I set off. Granted it's not a long run, when I fitted the alternator back in January it read 13.7 at tickover before I took it for a run, and a heady 13.9 after a good half an hour.

 

Connections to the 'nator and battery are secure, so I can only assume it's failed.

Share this post


Link to post
Share on other sites

I'd be giving the place that rebuilt it a ring and explain patiently what has happened - I'm sure they will be happy to exchange it for another one.

 

I know a weird man in a shed in mid-hampshire who rebuilds them if you are interested. He is properly weird though.

Share this post


Link to post
Share on other sites

I'd be giving the place that rebuilt it a ring and explain patiently what has happened - I'm sure they will be happy to exchange it for another one.

 

I know a weird man in a shed in mid-hampshire who rebuilds them if you are interested. He is properly weird though.

 

 

Thanks for that Stanky, if I get no joy from the place I bought it from (based in Pompey) I'll give you a shout.

 

Thinking about whipping it off and getting an independent check it over with a verdict.

Share this post


Link to post
Share on other sites

£215 for a reconditioned Bosch (excluding deposit/surcharge) from ECP. Same price for a brand new Denso and no surcharge.

 

 

Just wondering why the recon one I purchased was only £100ish. Think it's a Denso unit I got back.

 

Give me a Lucas ACR any day. Much simpler

Share this post


Link to post
Share on other sites

And about a third of the output on a good day if the charge light wasn’t glowing faintly

 

 

I've never had a Lucas ACR be unreliable. Had them on my Scimitars and a number of tractors I've looked after in the past, only failed due to worn brushes, which are easily replaced.

Share this post


Link to post
Share on other sites

I've never had a Lucas ACR be unreliable. Had them on my Scimitars and a number of tractors I've looked after in the past, only failed due to worn brushes, which are easily replaced.

But a Lucas ACR has no chance in providing enough capacity to power a modern car - especially one laden with electronics like the Saab 9-3 is.

 

There isn't really too much in design between a ACR and the alternator on your Saab though tbh. Just tighter packed to get more power out of it.

Share this post


Link to post
Share on other sites

What's more annoying is the place I bought it from just hangs up when they answer the phone, or go direct to voicemail, and hasn't returned my message. Two days have passed since leaving a voicemail

 

Has anyone here used AlternatorMan in Portsmouth?

Share this post


Link to post
Share on other sites

Yes I have, just goes through to voicemail on either. When I bought the alternator he at least sent me a text to say he was out for lunch. Conveniently his website has stopped working as well, and his eBay shop has closed down.

 

My dad called me up earlier to see how things were and he reckons the guy has either shut up shop or is purposefully ignoring me. Might take a trip down there after work on Friday see if the place is Mother Hubbard.

Share this post


Link to post
Share on other sites

if you're coming over this far might be worth taking a small detour afterwards to this chap

 

http://www.jasm.co.uk

 

He's the funny guy I took my Geep starter motors to. He told me what was wrong and that it would be cheaper for me to fix it myself, and explained how. He was right and it was free to fix.

 

Are you mobile without the Saab? its not likely to be a drive-in drive-out job.

Share this post


Link to post
Share on other sites

Yeah I have Mrs Dustman's corolla as she's not working this week, I'll contact your man at some point tomorrow or Friday and see what he says.

 

I have been put in touch with a garage nearby who specialise in the Swedish marques, and as I work with the bloke's brother he's going to swap it over for mates rates (£75), if I can supply a new/recon alternator that works.

 

I'll probably get all this done and then in April find it needs half a million quid to get it through the MoT.....

Share this post


Link to post
Share on other sites

If your Alternator is only charging at 13.05 volts, then you have a problem. It should charge at a minimum of 14.00 volts, otherwise there is not enough of a gradient so that the energy can flow into the battery and keep it fully charged. At rest, a fully charged battery will show 12.7 to 12.8volts.Charge state can also be verified by a hydrometer test on a lead acid type battery. Not possible to test a sealed Calcium type with a hydrometer for obvious reasons.

 

If you want to test that the alternator is not shorting the battery to ground, then I tested mine in the following manner: Using analogue meter set to the 10 amp scale, I disconnected the negative battery terminal. Connect one lead from the meter to the battery post and the other to the battery negative lead. If all is well, you will get a very slight movement on the meter needle. If a small swing, switch now to the 1 amp scale to read the discahrge, it will be around 50 milliamps, depending on your cars equipment. But if the alternator diodes are faulty, then the needle will show a much larger swing. In my case, I got a swing of over 1 amp, which showed that the alternator diodes were faulty and were allowing current to pass back to the battery and draining it to ground. It drained a new battery in under 24 hour.

 

This was a brand new reconditioned Alternator supposedly reconditioned by a reputable supplier. I sent it back for an exchange and the next alternator worked perfectly. End of charging problem. But I wasted hours of time before reaching the correct conclusion that the supplied alternator was faulty. I really cursed that supplier!.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

  • Similar Content

    • By davehedgehog31
      I've had various threads on the go for different collections this year, but thought I'd condense my threads into one manageable thread to document my ham-fisted tinkering.

      At the turn of the year I was driving a nice, dependable, modern 2011 Peugeot 407 and no other vehicle. It was nice enough, but boring as feck. I'd bought it after a series of disastrous heaps in the awkward age bracket of being new and valuable enough to worry about but old enough to be fucked. The 407 was just too new, too bloated and dull. I had a hankering for old metal, my Mineral Oil withdrawal pangs were strong.

      From January I started looking, there were eBay bids, missed reserves, wasted trips from Gumtree and other such nonsense. I happened on an automatic Rover 216 GSI with one giffer owner from a year old. The chap was giving up driving at 93 years old and his grandson was moving it on. I bid, and failed. It was in London though, about 420 miles away so I wasn't all that bothered. Of course when he offered it to me for my losing bid after the winning buyer was a no show I said yes. I was on the Megabus down to that London overnight for about £15. I hung about in Liverpool Street station like a mad shivering jakey until my train out to the suburb for my first sight of the new steed. It was battered outside but had been well looked after. A frankly insulting amount of cash changed hands and I was away up the road.

      We had many adventures together, it was dependable and it whet my appetite for interesting old motors again and proved that the very bottom end of the market was navigable if I had the patience to wade through the sea of shit to find the odd pearl.



      The 407 was still on the fleet at this point but I was covering a lot of miles in the Rover, with a long commute though the fuel economy wasn't ideal. When a friend's mother was looking for a new diesel saloon to replace the faithful old Xsara she had a scheme was concocted. I sold the 407 to her and was on the hunt for an interesting replacement.

      When I was growing up my dad had a succession of hopeless shitters, indeed I was brought home from the hospital as a newborn in a brush painted Skoda Super Estelle. The best car he had was a red XUD Peugeot 405 with air conditioning and electric windows. So when I found a 1994 GTXD advertised by someone who could actually compose a car advert in the fashion you would expect of a human being educated to a Primary School level, I pounced.

      Of course I couldn't buy a car just down the road so it was on the train to Birmingham. First class no less. I stayed in an absolute flea pit of a hotel and drove up the road the next day. This was a proper bit of nostalgia and a really practical borderline classic car. It had been fastidiously maintained by the previous owner. Apart from there being a hole where there was once a stereo and the lack of working air con it was a pleasant drive home.

      Given their relative scarcity and how dependable this one has proven so far, it's a keeper, I'd struggle to part with it.



      Two cars just wasn't enough to worry about, so this Citroen C1 was acquired. Pure Aleppo spec. A camel can go for weeks, or months without stopping at a watering hole, the C1 has a similar thirst for Motor Spirit. Man maths were employed and worked out that it would easily* pay for itself.




      There have been further movements, I'll recap them shortly. I should probably do some work.
    • By Fumbler
      To mark the genesis of my fleet project thread I here present my new car: a 1997 Nissan Micra Shape-


      It really looks that good. There is a reason for this: its previous owner was an old lady who loved the thing so much so she made every effort to keep it in good shape. It originally came from Fleet in the GU postcode which suggests to me it was bought by the present dealer at auction, hence arriving down here in Kent. Before seeing the car I checked its MOT history and its only fails were thanks to broken stoplights, which shows me that it was very well cared for. I suppose an example of this was that on the last MOT, an advisory was a corroded rear silencer. The silencer on the car when I saw it was new. Methinks the lady wanted to keep it as good as possible. It was kept in a garage and so all the bumpers and black trim are very black and the tyres are in very good condition. Spare never used! Also included a free Dettol first aid kit from 1997.
      This car has 15000 genuine miles on the clock. We clocked over 15000 during the test drive! The lady owner really only trundled around her village in it and the MOT shows that it only did some meagre miles between tests. This, of course, came at a price. We saw a cherry red Micra from 2002 at the same dealer. Paint was shoddy and when they washed it the boot had massive sections of bare metal and it wasn't very happy. This car, however, is in fabulous condition and there was no contest between the two cars- it really is that good, inside and out. Immaculate interior, driver's airbag, cassette player... all there and all functioning (apart from cassette thanks to new battery and failed display). This meant that I bought it for £1600, £100 over what was my uppermost limit, but I knew I wouldn't see another like this that was in as good shape for a fair while. It was priced very ambitiously, at £1990, so I'm content in the fact I managed to slash a few hundred off the price. There wasn't that much paperwork though. All the dealership received was the logbook with 3 service stamps from 1998, 1999 and 2000, the radio key pass, a National Trust sticker, and the original paperwork holder. I suspect the old lady died and had her car auctioned, and the massive file of paperwork is now someone's egg carton, along will everything else she owned.

      As always, this car isn't exactly in showroom condition. While the inside is great and the floor is solid, and the underseal is in great shape, the not undersealed parts need a small looking at. Mainly the rear of the driver's side sill. It's really the only bubbling on the car. I suspect a well aimed stonechip managed to fester over the wintery salted roads, making it rust even more. It's around the size of a 5p piece, and will give me the opportunity to spray the insides of the sill with some chain oil to prevent any further corrosion. Behind the fuel tank there are a few rusty joints- places where the spraygun cannot get paint onto- which some Vactan and Dynax should put to rights. Alternator belt looks original because of the cracking and Nissan badges and will need doing soon as well as the front plate. As much as I like the 90's font and original dealer surround, the dishevelled R and general water ingress is a persistant MOT advisory. It could be the MOT station being strict (and most likely is considering there's a Saxo down the road with far worse blackening), however for the sake of peace of mind and all that, I'll get a new one made. The rear has already been replaced indicating this has happened before.
      All in all, I think this is a nice plucky motor. I'll have it by the end of the week; just got to sort out tax, insurance, and it's going to have an MOT. As part of the deal it's getting the MOT and an oil and filter change which will be something ticked off the list. It has some love scratches and chips here and there, but it drives well, is stiff and controllable, and should make out to be a nice summer project!
    • By Zelandeth
      Well I've been meaning to sign up here in forever, but kept forgetting. Thanks to someone over on another forum I frequent poking me about it recently the subject was forced back into my very brief attention span for long enough to get me to act on the instruction.

      I figure that my little varied fleet might bring you lot some amusement...

      So...we've got:

      1993 Lada Riva 1.5E Estate (now fuel injected, as I reckon the later cars should have been from the factory...).
      1989 Saab 900i Automatic.
      1987 Skoda 120LX 21st Anniversary Special Edition.
      1985 Sinclair C5.
      2009 Peugeot 107 Verve.

      Now getting the photos together has taken me far longer than I'd expected...so you're gonna get a couple of photos of each car for now, and I'll come back with some more information tomorrow when I've got a bit more time...

      Firstly...The Lada. Before anyone asks - in response to the single question I get asked about this car: No, it is not for sale. Took me 13 years and my father's inheritance to find the thing.



      Yes, it's got the usual rusty wings...Hoping that will be resolved in the next couple of months.







      Next, a proper old Saab. One of the very last 8 valve cars apparently, and all the better for it. I've driven two 16v autos and they were horrible - the auto box works sooooo much better with the torque curve of the 8 valve engine. Just wish it had an overdrive for motorway cruising...






      Next up a *real* Skoda...back when they put the engine where it belongs, right out the back. In the best possible colour of course...eye-searingly bright orange.





      Seat covers have been added since that photo was taken as it suffers from the usual rotting seat cloth problem that affects virtually all Estelles.

      Then we have possibly the world's scruffiest Sinclair C5...



      Realised when looking for this that I really need to get some more photos of the thing...I use it often enough after all! We have a dog who's half husky, so this is a really good way of getting him some exercise.

      Finally - again, I really need to take more photos of - we have the little Pug 107.



      Included for the sake of variety even if it's a bit mainstream! First (and probably to be the only) new car I've bought, and has been a cracking little motor and has asked for very little in return for putting up with nearly three years of Oxford-Milton Keynes commuter traffic, before finally escaping that fate when my housemate moved to a new job. Now it doesn't do many miles and is my default car for "when I've managed to break everything else."

      I'll fill in some more details tomorrow - I warn you though that I do tend to ramble...














    • By scdan4
      That bit hiding up behind the air filter and infront of the turret



      made a prolonged, loud, farty vibratey noise (loud enough to be clearly audible in the cabin with the radio on) twice today, both times it did it the nose was pointing down a steep hill and we had just parked and turned off the engine.

      It goes on for best part of a minute, so managed to track it down. Initial impressions are fuck knows what it is but it's clearly been bodged in the past. The yellow hose has clearly been disconnected sometime, by someone, for some reason, somewhere.



      Thats the blighter.

      Does someone want to tell me why it's blowing raspberries at me?


×
×
  • Create New...