Jump to content
HMC

HMC motors- Merc one in, one out!

Recommended Posts

19 hours ago, gadgetgricey said:

That looks lovely.....

Heated seats for the win..

What's up with the roof\boot seal. Easy fix or just park it uphill?

With the roof untensioned I pushed it back and with the root tensioned it puts pressure on it to hold it in place- not sure why it had worked it’s way out

Share this post


Link to post
Share on other sites

Dailying the clk cabrio has reminded me what a great autumn/ winter car they are. Counter intuitive I know. A compact cabin, efficient warm up ( thankyou 3.2 v6) and heated seats see to that. 

The autobox (Mb 722.6) has been having a few “ moments”. When cold it can occasionally occasionally hold onto gears and not shift up at all. Manual selection sometimes seems to help but not always. Other times it’s perfect. I’m hoping that a “megaflush” and transmission service with oft used local specialist Cornwall and Devon transmissions will help. It’s something that is usually overlooked. Previous research when I last had a clk a208 showed that they are not affected by the valeo radiator problem of the time where the rad helpfully* allows atf and coolant to mix. I’m hoping that this 98% fluid change will help. I’ll keep you posted. I know it seems a bit frivolous but by virtue of design it will never need a cambelt or clutch/dmf and is due for a bit of TLC.

25C30417-ADCA-49B8-8D47-139B8E28F2D4.jpeg

Share this post


Link to post
Share on other sites

Took the CLK to a transmission place where a flush, fluid and filter change has made the gearchanges smoother and sorted out the odd behaviour of the gearbox (not kicking down sometimes, but also not changing up sometimes) 

The waiting area hadn’t been recently updated and hence was worth of a few pics...

B7A36631-89EE-45FD-8395-73A42F2DCC21.thumb.jpeg.8ed9c14e49f37ac209f7f30a527bdfba.jpeg

1BCB53B9-E27F-402A-96E4-168D624EDEB0.thumb.jpeg.05847531de0e6c4c08df8b3f93c4ede1.jpeg

E89DD037-2C76-41D9-A356-7492E1A77EA8.thumb.jpeg.6a71910db37a8e67f07fdcd2a3630b72.jpeg

4E4AC3E5-9931-4904-B2B3-E4C630E9ED7F.thumb.jpeg.4262cf67efa2421cdc38dd60693028cf.jpeg

9EC993FA-A76C-42DA-BDE2-0128C5FC7700.thumb.jpeg.7a14dfc9fb2602d202536006318e7649.jpeg

Share this post


Link to post
Share on other sites
16 hours ago, HMC said:

I’m not fussy, as long as it gets me home, I’m your man. Save me from a Kia shuma locally that has had Alfa Romeo front seats fitted hamfistedly (why?)

2002 Micra 1.0 CVT? In Yeovil, Somerset. £800 smackers for a shiter if you're interested (it's not the one pictured in the link btw!). Photos at the bottom of the 1st page.

 

Share this post


Link to post
Share on other sites

There's a *nice Pug 205 CJ (1.6i cabriolet) which goes but has a loud big bore exhaust and no tow bar  so may have to depart due to no tow bar. If interested I can go find tomorrow and get some pics and make up some details?

 

Share this post


Link to post
Share on other sites
8 hours ago, Tomtation said:

2002 Micra 1.0 CVT? In Yeovil, Somerset. £800 smackers for a shiter if you're interested (it's not the one pictured in the link btw!). Photos at the bottom of the 1st page.

 

Thanks but as much as I’m a fan of these not for me at the money Thanks.

Share this post


Link to post
Share on other sites

Took the clk up to The NEC show with the gearbox still misbehaving. No shifting up when cold; unless you manually went through the box. Random starting in what felt like third with no kickdown. Not always going into 5th. Starting to sound expensive!

I Had already changed a seal on the box that had allowed ATF to leak through the wiring loom. A new seal and lots of electrical contact cleaner later and it was still looking expensive.

A fluid and filter change also was hopefully done but still it continued.

I stripped down the selector and it was very worn between D and 4 where you go to then manually shift the gears. Pressure on the shift handle would make the illuminated light behind the gear display flicker and go out. Cause or effect? (Was the selector knackered from the need to shift manually across the gait every cold start I thought; or was this the cause of it all) More being out of ideas than inspiration I got a second hand selector off e bay for £30. Handily it was near where I’m staying so I collected it and changed it in the car park. So far it’s driving perfectly so I’m hopeful that I can call that a fix. Will keep you posted on my extended test drive back home!

5164B0BE-9D01-4F9B-9B8F-7BC8040327E6.jpeg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...