Jump to content

Zel's Motoring Adventures...Jag, Citroen, Mercedes & AC Model 70 - 16/09 - Temporary Driveway Visitor...


Recommended Posts

Only had an hour or so today to allocate to car stuff, but did manage to give the Skoda a bit of a pre-MOT once-over.  Most importantly I had a crawl around underneath...

IMG_20171109_151159.jpg

...and am happy to report that there doesn't appear to have been any material degradation since the last MOT.  Still plenty of surface rust, especially on the suspension components, but nothing that a wire brush and treatment shouldn't put stop to.  A few nasty looking areas on the sills revealed some peeling underseal, but nothing horrible underneath - I'll be going back and treating that in the next couple of days.  Most importantly though, despite being quite firm with the screwdriver I use for testing for nasty rust, I didn't poke holes in anything!

 

I'm also going to get a set of brake hoses ordered in because these are the originals and I don't trust them (once I ascertain exactly which set I need), and I've already got a new thermostat on the way to replace the current one which appears to be sticking occasionally.

 

Really do need to figure out a better way of securing the ramps...getting on and off them is a royal pain.  Both of these launched themselves into the garage the moment I started driving off them. 

 

I never realised before how ridiculously long the rear suspension springs on these cars are...they must be a foot and a half even when fitted to the car...No wonder the ride's quite soft...

 

Hopefully getting quite close to being ready to move on to her new home now.

Edited by Zelandeth
Fixed broken image embedding
Link to post
Share on other sites

So today I went to do some work on the Skoda, my intention being to replace the suspect thermostat and to refit the original water pump given that it's now been proven to be nothing to do with the overheating problem.  The fact that the aftermarket one on there (which came on my original 130GL) lacks the grease cup and that being missing bothers my sense of OCD.

Difference between the original pump (left) and the aftermarket one (attached to engine) below...

IMG_20171114_140439.jpg

 

I wound up giving up on that today...Turns out that the tiny smear of gasket sealant I put on the seal when I fitted it apparently forms a *really bloody strong* bond after a couple of years, so it really didn't want to come off.  So have filed that under "come back to later."  Likely with the engine still warm too as that will hopefully soften the sealant a bit.

Only took me half an hour to get that horrible little 2" bit of hose between the water pump and the rigid line to the heater return line back on after one of the hose clips fell to bits.  Third rear engined Skoda, and that bit of pipe has been an equal pain in the proverbial rear on every one of them when I've had to disturb it.

Anyhow, got back to the main tasks of the day - to flush the system out and to change the 'stat.  Glad to report that the coolant that came out both when initially drained down and when reverse flushed was spotlessly clean - so guess I did a good job last time.

The thermostat which came out is a Mahle one, so has been changed at some point before.

IMG_20171114_155701.jpg

Certainly not the worst looking one I've ever seen, wasn't obviously clogged up or collapsed...I'll test it tomorrow to see whether it opens/closes properly.  If so I'll keep it as a spare.  Annoyingly it didn't come with a replacement gasket, so I had to bodge things back together with the old one - I've ordered a new one though (all of GBP1.69), so will get that tidied up as soon as that turns up.

 

Then just had to wait an eternity while the thing warmed up after refilling the system.  Takes a fair while to heat up 11 litres of coolant to full operating temperature when you can't actually take the car out the driveway!  Heater nice and hot though (orders of magnitude better than that on either of the previous Estelles I've had), and about as much air as I'd expect bled out and it seems to be sitting right where it should on the gauge...Guess we'll find out once booked in for the MOT whether it behaves itself on the way there!  Will ring the garage up and book it in tomorrow.

Edited by Zelandeth
Fixed broken image embedding
Link to post
Share on other sites

Okay, booked in for an MOT tomorrow.  Had a quick additional look over this afternoon, fluid check etc and gave the washer motor the obligatory once-a-year thwack with the screwdriver to get it to work again.  Also checked all the lights over and stuff so I don't wind up with a fail for something daft like that.  Nearside numberplate lamp, I'm looking at you.

 

Will need to stick a fresh set of wiper blades on in the morning (have them here, just need to clip them on - it's tipping it down outside just now though) as one of the blades is falling to bits, and stick a bit of air in the tyres, then we'll be off.  Fingers crossed, ending up with a fresh test an hour later - not breaking down in a cloud of steam half way to the test station.

 

As soon as that's done I'll also be taking the Activa in for its test - will be the first time I'll have ever even sat in the car, so quite looking forward to that.  Not expecting any drama on that for the test given the attention to detail that's gone into the work done on the car by the previous owner.

Link to post
Share on other sites

Sorry for the delay, been a manic day!


Skoda needs two patches to the offside inner sill but otherwise went through fine - and celebrated by bursting the hydraulic line for the clutch as I backed out of the test centre.  Was only slightly embarrassing...


The Activa unsurprisingly flew straight through the test with a clean sheet, unsurprisingly to me given the attention to detail of her previous owner.  Drove home like a new car too.  Doesn't half feel quick...

IMG_20171116_231703.jpg

IMG_20171116_231610.jpg

No photo of any fuel stop en route as the tank is full.

The only brief failure to proceed is the fact that I now need to wait a bit for the DVLA to get their act together before I can tax it... hopefully won't take them too long.

More to follow soon.

Edited by Zelandeth
Fixed broken image embedding
Link to post
Share on other sites

It is a very nice place to be.  Having previously owned an S2 Xantia it's quite an interesting game spotting all the detail differences.  Most obvious so far being the lack of the clever door pockets and a comically tiny glove box.  Other differences are the mechanical rather than digital odometer, thermometer in the rev counter rather than by the clock, slightly different typeface on the instruments, the rear window heater having its own switch rather than a button on the wiper stalk an IR rather than RF remote for the central locking and of course the numeric keypad for the immobiliser.

 

The aux in socket on the stereo will be a bonus, and from what I recall it's not a bad sounding system.

 

Just a shame that cruise wasn't offered on the Activa, despite pretty much all of the other toys (including a rear windscreen sun shade) being ticked by default.

Link to post
Share on other sites

The Lada appears to have a vacuum leak again.  It's idling about 500rpm fast and missing like a Mini on a wet morning at idle.  Seems fine when driving, just at idle it's sounding like a sack of spanners.  I'll investigate that shortly.

 

Haven't had a chance to drive the Xantia yet thanks to the DVLA having got themselves tied in a knot (now sorted we hope), but having had a poke around I've unsurprisingly not come up with a particularly large to do list.  Just an exterior good clean to shift some green gunk from around window seals etc and to get some wax on the paint before the weather gets too much worse.

 

The battery sounds like it's struggling a bit on a cold start, but I know she's not been driven properly in a while so probably just needs a proper charge.  Likewise the cold idle stumbled a bit for a few minutes - again I'm not going to even bat an eyelid at that until she's had a proper run and an Italian Tuneup.

 

The interior really is a lovely place to be...

Link to post
Share on other sites

The bodywork is in a lot better order than I was expecting given I've heard stories of rampant laquer peel.  The door tops and one B pillar are the only really bad bits.  The bootlid is probably the most mangled bit, but it's actually pretty well hidden by the spoiler.  That bit actually looks like the paint has reacted with the base coat or something.  Reckon the roof and bonnet have been resprayed at some point...

 

I think everything on the car will welcome a bit of a spirited shuffle along a nice twisty road.  Brakes need a bit of work to get them bedded in properly aside from anything else as they currently are a little lacking in bite.  In a "new pads that need bedding in" sort of way rather than "something's wrong" sort of way if you know what I mean.

 

Long term, if I bond with the car as well as the four or so miles from the test station back home suggest, I'll need to think about the cosmetics.  Realistically, she wants (and deserves) a proper respray to get back to really A1 condition...though that then raises the thorny old question of colour.  I actually really like the original Dante Red, though a proper Ferrari red would suit the car very well (especially I think with the more aggressive stance of the V6/Activa)...though I also can't get that orangey-yellow colour that used to be seen on Saxos, or possibly that deep coppery gold Peugeot used on the 306 out of my head...big car for it, but I think it would show up the lines well.  I'm pretty set that it really should be a PSA colour though.  Anyone got a Xantia brochure?  Would be interesting to see the original colour choices.

 

This car is *not* getting modified into something that looks like it's been driven at high speed down the tacky accessories aisle at Halfords...Plus to my eyes the Xantia has always been a very handsomely designed car.

 

Probably got a couple of years to figure that out though, as it will take a while to save up for a proper professional respray.

 

In the short term though it's going tonne seeing a LOT of underbody sealant and cavity wax.

 

Right now though I'm looking forward to driving it!

Link to post
Share on other sites

I think you will enjoy giving her an Italian tune up. There’s surprisingly little difference in the handling of Gabby with wider tyres on and an activa, apart from the lack of body roll on the activa. It’s all in the tyres I think. When I got my activa it was on new nexen on the front and old Pirelli on the back, and the nexens were hopeless for grip. They were changed to 17” uniroyal rain experts all round and the difference was immense. These are the wheels and tyres currently on Gabby. I also tried a different set of 17” alloys and tyres, can’t remember the make but they were not as good as the uniroyal but better than the nexen/Pirelli mix. And the 17” wheels did not harm the ride much, very slightly firmer and they improve steering feel. However that’s the uniroyal, them on the standard 15” size may also be good.

 

As you know the activa you have had not had a lot of use lately, and will be none the worse for a decent run with spirited driving. If you find a “runway” to try it out, my one with the same boost controller yours had clocked 145 on the runway! So they are not slow lol. Mind you mine was driven as intended by me, and its previous owner to me for most of the time.

 

I also have lacquer peel, I am going to do the bonnet and roof in a satin black, probably a wrap but possibly paint. I was going to do the whole car, but the sides are all ok and have a good shine when cleaned.

 

 

Sent from my iPhone using Tapatalk

Link to post
Share on other sites

Actually had a surprisingly productive day around the house today. However does mean that I didn't really have much time to do anything car related.

I did however get two tasks done. Firstly to plug the Saab into the battery charger as it's rather flat and I really don't want to kill a year old battery.

Second was to attack the Activa with the pressure washer. Now...How do you go about pressure washing a Dante Red Citroen? VERY CAREFULLY...That's how. Luckily I've been playing this game long enough to be pretty good at that.

The car in general wasn't actually too grubby to be honest, save for a couple of fingerprints on the wings that were the inevitable result of the recent work on the front brakes and driveshafts. What there was however was a lot of green gunk growing in all the window seals, the roof gutters, around all the bumper/door trims and around the sunroof.

Easy enough to deal with though!

IMG_20171121_153914_scaled.jpg

 

IMG_20171121_153920_scaled.jpg


Then a quick skim over with the microfibre wash mitt and this stuff...

IMG_20171121_154833.jpg


(I've been using that for about two and a half years now - that should give you an idea how long it lasts)


...Which overall made more of a difference than I was really expecting.

IMG_20171121_153907_scaled.jpg

If time and weather permit I'm hoping to give it a quick skim over with the polish and wax tomorrow.

Edited by Zelandeth
Fixed broken image embedding
Link to post
Share on other sites

Well didn't really get a chance to do much as we've had a friend staying with us who's having some health problems so I've been helping keep an eye on them.

I couldn't resist sneaking out for half an hour though and seeing how things would come up...This should give an idea how well a lot of the paintwork is going to shine up I think...

IMG_20171122_155308.jpg

Should look pretty good when I'm done I reckon.

Link to post
Share on other sites

Aaaaaand we have a V5.  Less than a week's turnaround including complications in the middle due to an odd situation, hats off to the DVLA for actually being efficient...I have to admit I was quite ready for them to have been really helpful on the phone and for the V5 to then never appear!

 

£1300 a year between the Activa and the 107...Adrian Flux are having a laugh.  Will be shopping around come renewal time this time!  Didn't have the opportunity last year because the world was ending and saving a few quid on insurance was utterly at the bottom of the priority list at the time.  Likewise the year before, so they seem to think that they can just get away with charging me the earth.  That's social/pleasure use only as well, no business or commuting etc even on it...

 

The Lada is now officially off the road until spring time rolls around.  Quite well timed as I've got quite a few new bits on the way for it - and I need to figure out why it's idling like crap again - Vacuum leak most likely, usually is!

 

Edit: only had chance to take it out for a quick run round the block this evening, will go out for a proper run tomorrow.  

 

One thing is immediately very difficult to my old TD - that's the sheer magnitude of the torque surge when the turbo spools up.  The Activa really is properly fast.  There's a tricky to define line between "quick" and "fast" for me.  This is definitely in the latter category.

 

Going to go for a run over to see a mate in Banbury tomorrow I think...and see if I can avoid those cursed 50mph bits as far as possible.

Link to post
Share on other sites

Just a really quick update today...

The only real mark on the interior was a bit of a scuff on the usual bit of the seat bolster on the driver's seat.

Bit of black leather dye on there quickly sorted that out.  It's still there obviously, but now you really wouldn't see it unless you were specifically looking for it.

IMG_20171201_140056_scaled.jpg

Not much else been going on really other than driving the thing, still hoping to get out for a proper longer run at some point...

Link to post
Share on other sites
  • 5 weeks later...

Given there's a show over at Stoney Stratford on New Year's Day I'd hoped to get some cleaning/polishing done today.  However by the time I'd dispatched my various tasks for the day and walked the dog I had about 30 minutes worth of useful daylight left.

So instead I contented myself with doing the usual weekly walkround checks.  While I was at it, I finally gave in to my OCD and tidied up the additional wiring around the battery for the headlights and gave the top of the LHM tank a wipe down.

IMG_20171230_154046_scaled.jpg

I also noticed that the front indicators had turned a distinctly pastel shade of orange, so stuck a fresh set of lamps in there.

Much better...

IMG_20171230_162814_scaled.jpg


Did discover though that I appear to have one S1 indicator and one S2 indicator...

Link to post
Share on other sites

Aha! Now I realise that is Jim's old Activa! It's a fabulous car and was a regular at Citroen Car Club events. In case you didn't know, the annual Citroen DS and 'Chevrons' (all models) weekend rallies are held at Little Horwood, about 6 miles from MK. In 2018, the DS rally is June 9th/10th and the Chevrons Rally is September 8th/9th. Xantias are welcomed at both, of course!

 

IIRC, the Dante Red was unique to the Activa, along with the charcoal/black headlining. There is some interesting information about the make-up of the Dante Red colour here:

https://frenchcarforum.co.uk/forum/viewtopic.php?t=27691

Link to post
Share on other sites

Will hopefully get along to both of those events!

 

It is indeed Jim's one, not a car I'd been looking for nor ever expected to have a chance to own, but it was one of those situations where the pieces just fell into place perfectly!

 

Didn't realise that Dante Red (on the S1 at least) was an Activa exclusive.

Link to post
Share on other sites

Loving that Xantia and the plate just finishes it off nicely. I'd love to have a go in an Activa sometime - I've been watching videos of them and they confuse my brain. I can hear the tyres squeal but with no body roll they just don't seem to be going very fast even when flat out.

Link to post
Share on other sites

The body control is uncanny, the best test I find is the way you can chuck it into and off a roundabout.  There's no lurching or pitching during the weight transfer.  It really does make anything else - even stiffly sprung cars like modern Audis - feel utterly under damped.

 

Can definitely see how it could get you into trouble though, I doubt there's a huge amount of warning when you get to the limit of grip.  I'd really like to have a chance to find out where that is somewhere with plenty of room - appears to be well beyond the realms of commonsense on the road though!

 

Always welcome to take a look at this one if you're in the area, that's half the fun of owning rare cars, getting to share the experience with others.

Link to post
Share on other sites

The only downside (aside from its thirst!) is that I have a distinct suspicion that it's not going to be a kind car to tyres!

 

It's the ultimate jack of all trades I think.  You can trundle around town, paste it round a track, load it to the roof with shopping or waft along the motorway, it just doesn't care.

 

Shame Citroen have chosen to kill the system off.

 

I've long believed that the Xantia in general is a massively underrated car in any form.

Link to post
Share on other sites

I totally agree with your last sentence Zel. Activas are hard on front tyres, I found running 17” wheels with 215/45/17 tyres improved the steering feel and the grip a bit more and did not upset the ride too much. Uniroyal rain expert was my tyre of choice. Those wheels are currently on your old td, uniroyal on the back and vredestien winters on the front and she never loses grip. I actually rate the 1.9td higher than the activa. That’s perhaps because of the leather interior in her now. It’s the comfiest car I have ever had, and she has done over 5000 miles in 3 months on mostly veg without missing a beat. Utterly brilliant cars.

 

 

Sent from my iPhone using Tapatalk

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Similar Content

    • By davidfowler2000
      Edit: This is longer than initially anticipated.
      As some will have noticed, Mr cms206 of this parish reckons the death knell for the SVM is close with his recent purchase of a Saab. Going with the fact I still have a 100% Volvo fleet, as does Mr rml2345 of this parish I would personally say it's just diversification. Especially considering the amount of non Volvos cms206 has had these days.
      This aforementioned diversification continues a pace. Although the paperwork still needs to be done, I have some non Volvo incoming.

      Background:
      My aunt got the above pictured 205 back in about 2002 and ran it for about 3 years. By her accounts she put it in the lockup, got a Nissan Almera for whatever reason and basically put the 205 in to the long term deal with pile. It was initially SORN on the blue log book. Back when there was a theft of blue V5s at Swansea and everyone in the country got sent one of the new red ones, one never arrived for the 205 and after that it was properly forgetten about. Well she did. I've been keeping it in my mind every day since then. During a discussion over my birthday dinner a few weeks ago, she mentioned that she was going to pay the gardener she gets in to trim the trees to break in to the lockup because the padlock had rusted solid and she was desperate to use the space in the lockup. I said I'd do it free if I could assess the car. If it was completely fucked, it would have to get dragged out and put on a truck to go to the scrap heap. If I could get it moving, I would make it a project.
      Next day - 18th January:


      Time to break open the padlock then. Big screwdriver through the hasp and burst it within 3 seconds. Now to have a look at the car. It's dirty, 3 tyres are flat, one of them creased and the 4th is still at about 10psi. After FIFTEEN YEARS! A gentle rock confirms suspicions that all the wheels are locked so time to get all the wheels off and set about the brakes with a big swing press.
      The back wheels moved eventually. Judicious use the big hammer, two wheel bolts reinserted and a breaker bar as a lever got the back wheels turning. While the wheels were off I thought I'd see if they held air.
        
      All 4 tyres held 35psi. None of them appear to be cracked and the rubber is still "soft" to the scrape of a finger nail. Lack of sunlight attacking them I suppose but it'll get 4 new ones if it becomes roadworthy.
      After doing the back wheels, the front wheels quickly proved they could be a major problem. I took the calipers, pads and discs completely off the car and even with 2 wheel studs inserted and using the 3/4 drive breaker bar with an extra foot of length over the 1/2 bar, neither wheel / shaft would turn. So either the bearings had seized, the CV joints in the driveshafts had seized or something very sinister was happening inside the gearbox. By this time it was getting dark and cold so time to put it all away for another day.
      Another day - 24th January:
      Various discussions were had on the Scotoshite WhatsApp chat and the end result being Mr 320Touring of this parish agreed to come round for a shufty. He was wanting to check up on another car in a lockup only a mile or so away so it was a no brainer.
      As before, front wheels off, bar on the wheel bolts... nothing. What to do next? We need to use the car's own power to try to free off whatever is seized on the front wheels but the car is nose in to the lockup so we can't get jump leads to it. We need to drag it out but we don't have a tow rope however we manage to find what appears to be a self tightening dog collar / leash in the car and decide to cue MAXIMUM SKETCHINESS!!!

      A gentle tug from the ML of doom proved the NSF wheel is tight but not seized however the OSF is not moving. Fuck it... drag it while pushing from the front. If we need to shove it back in there's an old tyre in a pile of rubbish waiting to get uplifted by the council that can act as a cushion and the ML will do the job no bother. We also took the front brake discs off to minimise any drag from those.

      We decided to drag it out just enough to get my jump leads on to the battery. We had already taken the battery out to try it on the leads outside the car. Surprise surprise* it was so dead it had gone open circuit so there was absolutely no magic pixies flowing in to it. Luckily I had an old battery from the 740 that was the same size so that was obtained, inserted and then put to work. Time to leave it to charge for a wee bit.

      Now that we've got some electricity going from the ML in to the 205 it's time to see what will happen. Thanks to Mr Touring for providing the videos...
       
       
       
       
      At one point we were vexed by the daft French screw on battery terminals
      We were getting a bit desperate by this point. We used quite a lot of "easy start" and the amount of electricity was causing problems.
      We took a break at this point for 10 mins or so. Mainly to make sure we didn't get too frustrated but also to make sure the maximum possible amount of electricity was in the actual battery so that the leads were just there as a boost. This was clearly a good idea...
      Learning from all the antics of the last 15 mins or so we left it for another 5 mins. Using a clamp meter we let it get to the point that almost no electricity was flowing in the leads and therefore an almost complete charge and spraying the "easy start" ahead of time, results were finally had...
      YAY! MUCH ELATION! Oh and that old diesel stinks. Time to get the leads off, move the ML and let the 205 tick over for a few minutes to let the engine settle. Next we found out why the front wheels were not for turning...
      So yeah. All the CV Joints were completely solid. But anyways it was mission accomplished for the day. We got it moving and a general once over suggests that it should be easily salvageable therefore if auntie wants the space in the lockup, it's going to have to go somewhere. Time to put it back in and wrap up for the day.

      Thanks to 320 Touring in assistance. The list of work is substantial but not insurmountable. It needs - a battery, front discs, front pads, front calipers, front lower arms, front driveshafts, possibly bearings, rear drums, rear shoes, rear fitting kit, probably handbrake cables, flexi hoses all round, 4 new tyres, 3 of the 4 doors don't work properly, a water leak at the water pump but that can get done with a new cam belt, probably a thermostat, engine oil, filters all round, fresh fuel, a good clean, handbrake light, oil pressure light and a rear screenwash leak inside the tailgate.
      Oh and a sidelight bulb...

      Interim time:
      Lockup secured in Cumbernauld.
      Car transporter trailer booked for Wed 12th Feb to move it. The V70 will do the honours.
      Another bit of tinkering - 4th February
      So it has been agreed the V5 will be transferred in to my name. With an impending trailer move, I thought I'd go back and have another look at things and reassemble the front brakes. I've already installed a new battery so it can be started without the need for leads and it does so quite happily even though the fuel coming from the tank smells like paint. I drove it about in circles for 5 - 10 mins to free up the CV joints and scrape the rust off the brake discs. I also did some straight line tests pulling away in 2nd which seemed to free up the turbo actuator.
      I also found the radio code so I got that working but you'll have to take my word on it 'cos YouTube will just give me a copyright flag.
      I shall leave this one here just now. Not much will happen for a while. There will of course be the drama of the trailer move but once it's in the lockup a plan of action will need to be drawn up. A sensible first course will be, I think, to find someone who will give it a once over for MoT viability before any new parts are obtained. All the obvious stuff should be easily DIYable but I don't know what lurks underneath. Some things like the timing belt and water pump will be paid for but the rest will just get picked away at in due course.
      I also found some period souvenir parking tickets...

      ---ENDS---

    • By captain_70s
      Hullo,
       
      I'm a masochist from Leeds who is running two rusty, worn out Triumph Dolomites as my only transport in rural Aberdeenshire. You might recognise me from various other forums and Facebook groups. Realistically I need to buy a modern car of some sort, but instead I find myself looking at £300 Citroen BXs and Triumph Acclaims on Gumtree and thinking "yeah, that'd fit right in with the rest of the broken cars I can't afford".
       
      On to the cars, the main attraction being my 1976 1850HL "50 Shades of Yellow" that I bought for £850 and is currently my daily driver, here is a picture of it before I sanded off some surface rust and sprayed it badly in the wrong shade of yellow with rattle cans:
       

       
      Within a month of purchase I managed to plant it in to a steel fence backwards after a botched gear change on a wet roundabout and ruined the N/S rear wing, although judging by the other dent that's packed with filler it looks like somebody had already done the same. I also managed to destroy a halfshaft and one of my Sprint alloys (good for an extra 15hp) in the incident, so now it's sitting on it's original steelies but painted black (good for an extra 5hp).
       
      It's only broken down on me twice. once with some sort of fuel delivery related problem which may or may not have been an empty fuel tank and once when the thermostat jammed shut and it overheated and blew out some O-rings for the cooling system. It has recently developed a taste for coolant and oil which is rather annoying, although it's done 89,300 miles which is about 80,000 more miles than BL engineering is designed to last, I'm keeping my eye on eBay for replacement engines... 
      I tried to keep ahead of the rust a bit by rubbing down the arches and re-painting them, but apparently rattle can paint isn't great when you are spraying it at -5C, it also highlighted how although my car might have been Inca Yellow in 1976 it's now more of a "cat piss" sort of shade. So I ended up with the wrong shade of yellow which has rust coming back through after 5 weeks. Did I mention I'm incompetent?
       
      The other car is the first "classic" car I bought, so I can't bear to sell it. It's a '77 Dolomite 1300 and it cost £1400 (about £400 too much) and has been nothing but a pain in the arse:
       

       
      It looks much prettier (from 100 yards) but that's most due to the darker paintwork hiding the rust. It lives a mollycoddled life in my garage, where it somehow still manages to rust, and is utterly rubbish. 0-60 is measured on a calendar, top speed is 80ish but at that point it uses more oil than petrol, it rarely ventures over 50mph and if you encounter an incline of any sort you can kiss that sort of speed goodbye, along with about £20 of 20W50 as it vanishes out of the exhaust in the form of blue smoke.
       
      One of the PO's had clearly never heard of the term "oil change" so it developed into brown sludge that coated everything internally with the next owner(s) blissfully pouring fresh oil on top of it. This lasted until about 600 miles into my ownership when there was muffled "pop" from the engine bay and the car became a 3-cylinder. The cause was catastrophic wear to the top end causing a rocker arm to snap:
       

       
      As this was my first classic car I'd assumed it was supposed to sound like the engine was full of marbles, it wasn't.
       
      I put the engine back together with second hand bits declared it utterly fucked and promptly did another 5000 miles with it. After about 3500 of those miles the oil burning started, valve seals have gone so it's been relegated to my parent's garage as a backup car and something to take to local car shows as the 1850 is now embarrassingly ugly. I'm keeping my eye on eBay for replacement engines (deja vu, anybody?) Oh, I also recently reversed it into a parked Ford Fiesta and royally fucked up the rear bumper, rear panel and bootlid. Did I mention I'm incompetent?
       
      There have been two other cars in my life. My first car, a 2008 Toyota Yaris 1.0 an it's replacement a 2012 Corsa 1.4T. I didn't really want either of them, but it's a long story involving my parents and poor life choices. Ask if you want to hear it!
       
      So that's a brief summary of my current shite. If you want more pictures or details of anything do say as I've got photos of almost everything I'd done with the cars.
    • By Peter C
      Woke up this morning, had a little time before I had to leave the house for work, had a quick look at what’s new for sale on Retro Rides and saw an ad for a W124 200E manual, located 15 miles from home. I had no intention of buying a car today but I had to have it! I called the seller and arranged a viewing.
       
      Faults:
       
      2 x rusty front wings (TADTS)
      1 x rusty rear arch
      Needs a polish
      Tracking is out because new track rod end was fitted for MoT
      Engine has oil leak/s
       
      Good points:
       
      It’s a W124 200E!
      5 speed manual transmission
      New clutch
      Brand new MoT
      Superb MoT history
      4 x as new Continental tyres
      Last owner for 15 years, her husband before that for 4 years
      Very tidy MB-Tex interior
      Drives well
      All electrics work
       
      The dealer kindly delivered the car to my house but I managed a pez station shot on route:
       

       
      Plans:
       
      Remove front wings, cut away rust and apply plenty of wob.
      In-situ similar repair for rear arch
      Clean and polish
      Service engine
      Adjust tracking
      Leave patina and enjoy the car as it is
       
      I will update this thread once progress is made.
       

       

       

       

       

       

       

       

       

       
      Hopefully these two will become good friends.
       

    • By SiC
      Go to this link to avoid the 4 page chat on the buying process: https://autoshite.com/topic/41278-2002-renault-clio-ii-172/?do=findComment&comment=2092395
       
      Decided now is definitely the time I need to scratch this itch. I don't suppose anyone has one going or thinking of going at the moment?
      Really need to sell the Laguna before I pull the trigger but if someone is getting rid for a decent price...
    • By New POD
      Car : y reg Omega 3.2 MV6 196K
      Rocker Gaskets replaced last summer at about 183K with genuine parts.
      Proper cleaned out breather tubes on top of engine. .
      Oil changed at 193K with genuine GM Fully Syth and Filter. (Cast Housing)
       
      No leaks until 3 weeks ago. Started small, I always check the oil before a long journey (and I do a lot of them) and I've been adding a bit more often but now on Thursday I had to top up after 100 miles into a Journey, and Then again 80 Miles later (on Sunday) and again this morning at 70 miles into a Journey, AND then another 70 miles this afternoon, and now 70 miles on it needs more. I calculate about 6 litres for about 450 miles. That's a lot of rust proofing on the exhaust and lots of it on the floor.
       
      I've not had it up on the ramps, (as Snow and rain and doesn't fit in my garage) but had it running and had a look at the filter housing area, and seems to be pouring down the back of the engine.
       
      At first I wondered if the little wiring plug next to the Oil Filter Housing is likely to leak? but seems to be above that. (Car is too low to see without ramps)
       
       
       
      When the Rocker gaskets were leaking before it was all very slow. Yes there was an advisory on the MOT, but nothing like this.
       
      And it hasn't been leaking in at least 12K since I did them.
       
      So what are we thinking ?
       
      I blame JohnK !!!!!
       


       
      There is oil on the rocker cover because Spillage

×
×
  • Create New...