Jump to content

Schaefft's Bargain Barge Extravaganza - W140 Rear Suspension Refresh Cont.


Recommended Posts

Big thanks to Mr. @Six-cylinder for picking up the set of coilovers for me today, it really is very much appreciated. :) 

Of course its typical that the opportunity to buy a reasonably priced set of decent 1st gen LS400 BC coilovers only comes along the moment I'm installing my Ebay specials, I've had search alerts up since 2018. However, it will be a great opportunity to compare both brands with each other and see how much additional comfort/durability you get from a set that would overwise cost about 5 times as much. The BCs will also have adjustable damping which should make a huge difference.

The coilovers are not the only area that still need some attention on the Celsior. The car had an illuminated ABS light since I got it, I innitially thought the wire coming out of the front sensors were just cut off, as it turns out these ABS sensors have two wires, and the cut wire is easily replaceable as its just a second connector on top of the actual ABS sensor!

ABS.jpg.48b10c0d0cde371cdf858fe1232427a8.jpg

Does anybody have a clue what this could be for? Seems to be independent from whether the car has Traction Control or not, second connector was added with the facelift for some reason.

Hopefully finding a replacement cable will prove easier than finding a sensor.

Link to post
Share on other sites

It is indeed! I've had another look yesterday to confirm, the '92-94 LS400 brake pad wear sensors do indeed use the ABS sensor wiring loom, and therefore use a connector that is sitting directly on top of the ABS sensor. Which is great news as the wires werent cut, its just the front wear sensors that for some reason weren't connected back onto the brakepads, making it look like the ABS sensor wires were damaged.

I've switches around the struts yesterday and removed the last original strut in the front, which to my surprise was still having a largely intact spring. Removing the others was easy since they were shattered to pieces, this one needed a little bit of creative thinking however to get out... Once again my Dremel gas soldering iron game in handy as mini torch to heat up seized nuts.

50871108043_c06efc3dcb_z.jpg

Can you believe that this was the most well preserved strut in this car...?

50871811986_719b2edf7c_b.jpg

This is how the car is sitting right now, with the trunk full of stuff. I thought before doing any further adjustments I'd take the car around for a drive around the estate amd see how these 132 quid coilovers feel.

50871107613_92f8189857_h.jpg

A few takeaways: The car feels pretty wallowy, more than I would actually expect from it, also compared to my other cars. I have the feeling that the spring rate is too soft for the weight of the car, it could also be caused the garbage tires so its hard to tell without having a direct comparison to stock. There's also some pretty noticeable clunking noises. Now Im pretty sure I've tightened everything up properly so I am not sure where exactly whats causing that noise. It could be caused by an unknown shot bush somewhere or somehow something is still lose so I will need to investigate whats going on next weekend, I do have the feeling that it is the coilovers though.

Also the car developed a very noticeable misfire so Im going to change the fuel filter, spark plugs and wires soon and probably do an oil change. This didnt happen before I ran out of fuel so the pump might have sucked up quite a bit of ancient gunk or something, I just hope that I don't need to take the injectors out, I wouldn't be surprised about one of them being gummed up now.

The tint will get removed asap as well, it looks ghetto and I can't image it being legal, its a pita to look out of and makes the inside too dark and gloomy.

Link to post
Share on other sites
  • Schaefft changed the title to Schaefft's Bargain Barge Extravaganza - JDM Barge Revival

The noise on my rear shock has stopped..which is good as my replacement hasn't arrived yet, starting to wonder if it will (coming from Hongkong apparently but no tracking info after asking a million times). I assume its bedded in or something.

Interesting your idea to swaperoo the springs? (And black portion of the strut?)  Certainly confirms how it looked like my LS tripped headfirst into the ground when I first put them on.  I'm tempted to copy you. 

Link to post
Share on other sites
19 hours ago, Gerrymcd said:

The noise on my rear shock has stopped..which is good as my replacement hasn't arrived yet, starting to wonder if it will (coming from Hongkong apparently but no tracking info after asking a million times). I assume its bedded in or something.

Interesting your idea to swaperoo the springs? (And black portion of the strut?)  Certainly confirms how it looked like my LS tripped headfirst into the ground when I first put them on.  I'm tempted to copy you. 

I've read so many people suggesting doing this on the LS400 FB groups, I really can't make much sense of a weaker, shorter spring being in the front where most of the weight of the car sits. Its basically the whole strut assembly I switched around, with the longer bottom mount still in the back, the short one in the front. That way it sits at a reasonable height with lots of adjustability left.

I've ordered new plugs, wires, distributer caps and rotors, injector seals, fuel filter, brake pads, hoses and wear sensors plus a few other things this morning. Most of the stuff is coming from rockauto as, despite shipping from the US and VAT, its still significantly cheaper than buying stuff on ebay, autodoc or carparts4less. Especially consumables cost next to nothing for this car, and I definitely tried to go with decent brands, so Im quite happy about that.

Link to post
Share on other sites

Found a set of wheels with apparently good tires a bit south of York, the tires I have on the car right now are completely shot, the front passenger side loses air rather quickly. Any shiters who happen to come through Yorkshire anytime soon?

Link to post
Share on other sites

Good to see the Celsior getting some TLC, I hope it all works out OK.

I've done nothing with my LS since the MoT lapsed at the end of December, other than letting it run for a bit and taking it up and down the track one day. There seems little point busting a gut to get it MoTed when I won't be using it for the foreseeable future......

Link to post
Share on other sites
3 minutes ago, Spottedlaurel said:

Good to see the Celsior getting some TLC, I hope it all works out OK.

I've done nothing with my LS since the MoT lapsed at the end of December, other than letting it run for a bit and taking it up and down the track one day. There seems little point busting a gut to get it MoTed when I won't be using it for the foreseeable future......

I feel the same about my S8, I could take it further and make sure that everything gets fixed that's left on it to be ready for an MOT, right now there's just not much of a point though. The Celsior needs enough work to keep me busy for a while though before that is ready for any inspection.

Link to post
Share on other sites

New news!

The BC Coilovers Mr. @Six-cylinder has generously picked up for me have arrived a few days ago. I've since soaked them in penetating fluid to free up the threads, they generally seem to be in very good condition, I might give the springs a coat of paint if I can be bothered, for now the Maxpeedingrods will do until I got enough of them/they decided to call it a day.

50891906731_5d345449f6_h.jpg

Also I've used the day to finally remove the window tint on the car and jesus christ what it difference it makes! I don't know how but I think it has improved the cars looks so massively that I like it about twice as much now! You can actually look inside the car, and even look outside of it! It wasn't much of struggle to get it off either, the heatgun did a good job and the tint was high quality enough to leave very little residue. I'm very please with the result and its a real motivation boost.

50892022062_3affb312b8_h.jpg

50892022667_3970e003cf_h.jpg

For comparison:

50891906401_2efc2e52d5_c.jpg

50892021702_3e0013a033_c.jpg

This is a totally new Toyota world to me:

50892021617_ef47f8b94f_b.jpg

I used that motivation to start disassembling all the covers and air intake to get to the spark plugs which was definitely needed. Since I decided to replace the leads, distributor cap and rotors there is a bit of effort involved just to get access to all bolts. It was quite a pita to be honest, and definitely more of an ordeal than with the S-Class that has a very similar setup.

50891194053_ea4d0244f6_h.jpg

I did get a chance to look at the timing belt though and it seems to look pretty decent, I couldn't spot any cracks at all. It will get done sometime down the line though.

I've also done some cleaning while in there. Unlike certain other manufacturers Toyota was smart enough to design the spark plug hole valve cover gaskets in a way that would prevent leaks and there was no oil inside the tubes.

Filth:

50892021347_39fa89f7e1_b.jpg

Clean, and this was the proper grungy side where people couldn't aim for the oil filler hole properly...

50891194328_1e2c6fd165_h.jpg

Also my wheels I bought on Facebook marketplace arrived a few days ago and I think I really made a score there. All tires are in good condition, a pair of them is barely 3 years old, the others are from 2014, plus a fullsize spare. Considering I've only paid 100 quid plus shipping for them, and considering that I've got several hundred pounds worth of parts with those wheels which the owner wanted to get rid of, I really can't complain.

Since the entire steering column, steering wheels, ignition lock and everything else was included, it also came with this nice (and moldy) Lexus key ring:

50891195458_6102b02966_b.jpg

After a bit of cleaning my Toyota has a proper identity crisis now:

50891195278_59b0bfea41_h.jpg

Thats it for today, I'll see if I can make some progress tomorrow. If anyone needs a '95+ LS400  cluster, ECU, AC compressor, powersteering pump, reservoirs, steering column, steering wheels or entire oem exhaust system from the middle back, please let me know😂

Link to post
Share on other sites
  • Schaefft changed the title to Schaefft's Bargain Barge Extravaganza - Unpimp ze Auto!
  • 2 weeks later...

Some minor Celsior related news. I picked up a set of center caps for the wheels I previously bought. They are chrome while my wheels are painted (grey from the factory) but I think they might still work fairly well together. They werent in the best shape and still arent after quite excessive polishing attempts but considering these are just a temporary solution Im happy with them. The guy I bought these from had a few LS400s, I actually tried to buy one like mine from him years ago but the deal fell through. I was quite surprised to find out it was the same guy.

Before. For some reason all of them came with these googly eyes glueed on them?!

50920182167_80ab8215a2_c.jpg

After. Protip: DO NOT use rubbing alcohol on them, apparently the clearcoat on them is quite alergic to it. Ask me how I know.

50919358193_d53826296a_c.jpg

In other news despite the shit weather I pulled the E39 into the drive yesterday to start replacing my rear suspension components. I bought a set of poly bushes for the rear swing arms years ago. I felt like it was finally time to replace them together with the rose bushes, integral links, drop links and the thicker swaybar before getting it all aligned to sort out my extreme unvoluntary tire wearn situation in the back.

50920181797_db3cde0370_h.jpg

It all came apart fairly easily which was a nice surprise and as it turned out, none of the components I am planning to replace looked too bad. Its hard to tell whether it was all still original, if that was the case it all held up remarkably well for almost 170k miles. One of the integral links definitely got replaced at some point as it was a Febi part (if someone wants it for the price of postage, let me know before it goes in the bin, its still good). In either case anything back there was at least 7 years and 40k miles old so Im not feeling too bad about it. I will if it turns out that the side to side swing Im feeling in the back is actually coming from the rear subframe bushings😬

Even with the right tool it was still an absolute ballache to get these out:

50919358788_dc8351ff87_b.jpg

It took a bit of experimentation to figure out the best way how to remove them. Drilling about a million holes into them worked out best in the end:

50920181397_270aa77992_b.jpg

The remaining outer casing could easily be cut with a metal saw blade and chiseled out:

50920181177_0b51614a6c_c.jpg

The new poly bushes were a pain to get in as well, despite cleaning and greasing everything before. One set still isnt quite flush, no clue why (probably trapped air?) but Im hoping that it'll be fine once I put them back on the car.

50920180837_bf16c148cd_c.jpg

I'll finish painting my swaybar the coming week so itll be ready for installing. By then my droplinks and a self locking nuts should be here. Everything I ordered for Celsior has arrived by now as well so once the MOT work on the BMW is done I can start concentrating on that again.

Link to post
Share on other sites
  • Schaefft changed the title to Schaefft's Bargain Barge Extravaganza - MOT Preparations

Unfortunately this kitchen is doubling as workshop right now, I wish I was in a situation where I would finally know whether Im going to move soon or not. No garage until then!

And a garage would really have helped this weekend as I've frozen my ass (and toes) off trying to reassemble the rear suspension on the BMW at freezing temperatures. Getting those rear swing arms in was an absolute pita. I only noticed Friday evening that I was still waiting for my droplinks to arrive,  which didnt happen on Saturday either. I'll order a set of TRW ones from Carparts4less should they not be here by tomorrow...

Old Mazda floor mats arent particularly great at shielding your backend from the coldth btw.

50943722117_a1f91b4c43_b.jpg

I did manage to reassemble everything with the old droplinks in place, nothing has been torqued yet though. I used the chance to replace my rusty old standard 13mm swaybar with a used 15mm one from an M-Tech II E39 which should go along well with the M-tech dampers and lowering springs that have been in the car for years. The bushes obviously are new, too, I've even replaced the locking nuts for the swing bolts with new ones (from the dealer even) although I was too cheap to replace the overpriced bolts as well. WCPGW

50943722297_0f94678a9c_h.jpg

Hopefully everything will be back together next weekend, I can put some new tires on the back, get an alignment and then book it in for an MOT, although I have the feeling that my crusty sills and fuel lines might be getting a little borderline now...

Bonus frosty Toyota:

50942922913_528d235a15_h.jpg

Link to post
Share on other sites

All suspension bits went in yesterday, including the drop links that arrived too late. CP4L/ECP actually screwed up as well and only sent me one droplink at first, since I finally recieved my order from ebay a day before I initiated a return, a few minutes before DPD came to pick it up the second droplink arrived... Off it went, too.

Anyway, went to Tyrespot to have a 4-wheel alignment done, then they realized they somehow don't have the specs for LHD E39s on their machine... Because what are online databases?!

Went to Kwikfit instead, they did have the specs but appeared incapable of actually aligning the rear wheels. After having posted about the event on my German E39 FB group it seems like they simply didn't have a clue how to do it properly, despite there only being two bolts to adjust, having to go back and forth between the two to get it right... I'll go to a BMW specialist next. Unless my subframe really is warped (which is highly unlikely, there is no damage on any of the relevant components) its just one more example of why I can't trust a single garage in Newcastle/Gateshead to do a half decent job.

Today I've done the fuel lines on the car. They were rather crusty and Scaryoldcortina did point them out a few months ago. Since they are stupid money from BMW I ordered 2m of 8mm anodized aluminium piping and a meter of high quality fuel hose. I also ordered a cheap set of flaring and pipe bending tools, all of this cost my a fraction of the cost of two pipes from BMW alone. 

Naturally this is a job you should do on a lift ideally, instead it was just a pain from the start to the end as all fasteners were as rotten as the pipes themselves. Eventually they came out though, they actually looked worse than in the photo:

50966885696_fc7d08e07a_h.jpg

The bending tool did its job wonderfully, longer line so I could cut off the end of a fuel hose I couldn't replace without removing the tank:

50966181468_563e9cbd13_b.jpg

The flaring tool did its job decently, its a pretty straight forward tool where you squeeze the pipe into a block, put a little insert into its end and just squeeze it in there. Its not always pressing in perfecly straight but its good enough:

50966993867_0f13b3cf87_z.jpg

All shiny and put back together. Note the ziptie around the clip, that bolt snapped off and I have no hope of ever being able to remove it myself. New hose clamps, too.

50966993647_b1385dbe42_h.jpg

Since I've only ordered 1m pipes (anything longer would probably be expensive to ship) I had to extend the hose of the return line, I replaced all fuel hoses that were easily accesible anyway. I even put some rubber around the extended hose where there was a risk of clamps rubbing through them. Filter was replaced at the same time, what a pain that clamp was...

50966993512_8606d4ffb6_h.jpg

Jobs a guddun. I replaced my faulty reg plate bulb (replacement was waiting 7 years in the glovebox for this day!) and cleaned out my washer nozzles. Hopefully thats all to make it through the MOT for another year!

Link to post
Share on other sites

No progress on the BMW, couldn't get an alignment booked in for Saturday so it'll have to wait until Thursday or so. I did however use the time to give the Mercedes a bit of tlc as it needs an MOT as well.

First thing I noticed was that the doors on the passenger side decided to not open anymore. Great! The front passenger door could be opened from the inside, the rear passenger door wouldn't open at all, no matter what. Which meant that I had to remove the door card with the door closed, something thats possible but certainly not easy. Fortunately I found some decent photos of the inner door mechanism online and was able to pry away the door panel enough to have a peek inside, not that it helped as it didn't really make much of a difference however hard I pulled on the rods leading to the latch. In the end I just sprayed everything in there with dry lube which fortunately was the solution to end this misery. I did the same with the latch mechanism of the front door which hopefully solves the problem long term. Probably not.

50989494448_5151456881_h.jpg

When pulling off the door panel I noticed that it was soaking wet at the bottom, in fact the cardboard was so soaked that all mounting points basically came off of it. I've ordered some two component epoxy glue that hopefully will fix this once everything is dry again, no clue how it got this wet in the first place but I'll make sure the plastic membrane thing thats supposed to keep the moisture out will be properly glued shut...

The next thing was the parking brake, the pedal more or less goes straight to the floor which made me think that something wasn't hooked up or adjusted correctly. A look underneath the car didn't reveal much aside from the fact that the adjustment mechanism was putting as much tension on the cable as it could (which apparently wasnt much), and that this mechanism was literally centimeters away from the drive shaft and exhaust, making it nearly impossible to reach and adjust. Thanks Mercedes! I'll call a local Mercedes specialist tomorrow, they can deal with that and replace the snapped rear springs while they are at it.

I've also had a look at the ignition distributor since I do have an odd misfire once in a while that comes as suddenly as it goes, generally after a short drive. Apparently condensation can build up inside the distributor cap which obviously messes with the rotors ability to deliver spark where it needs to go. I've properly cleaned it all up but couldn't really find much wrong with it, maybe the seals just aren't sealing properly anymore and moisture gets in?🤷‍♂️ It runs pretty smoothly when its not causing trouble.

50990194381_30966e6653_h.jpg

Last but not least I cleaned the car for the first time in a long time and finally gave it a quick cut and polish. The car was covered in scratches caused by people furiously knocking doors into the car and what looks to be a bush scratching up the entirety of the passenger side. 5 hours later and the cars looks properly transformed, despite this hardly being the most thorough job. I can't polish rust and missing paint either. Im happy though!

50990204261_6362034762_h.jpg

50990317997_9021867f54_h.jpg

50990204081_fc6f64b5c7_h.jpg

50990317642_c355b48033_h.jpg

50990204791_9ad4748278_h.jpg

50990205371_17e0d35868_h.jpg

50989504798_97dd987ed7_h.jpg

50990318442_b939ec6d9b_h.jpg

Link to post
Share on other sites
  • Schaefft changed the title to Schaefft's Bargain Barge Extravaganza - Merc Maintenance

Only some minor updates, BMW this time. Second tire place had issues with getting the alignment in the back done as well, something is wrong but nobody has any clue what the reason would be, even after a close inspection. Since this really is getting annoying now I just ordered a pair of adjustable toe links (somehow they arrived from Poland within two days, quicker than most UK sellers). My old one looked fine, once again it was hard to tell whether they've been replaced before or not. Removing the old one turned out to be the biggest pita I had with any suspension component yet, it literally took me 5 hours to replace one side as access was poor and the old bolts were fighting me every single step of the way.

New arms. Polybushes smell a bit weird but aside from that they look solid.

51013248656_8ced7f6267_h.jpg

Fire fixes everything:

51013248421_f0391bb5a1_z.jpg

Eventually I had the nut off, thats the moment where the real struggle started. No matter what, the bolt wouldnt slide out. Trying to pry it out with a crowbar would only flex the aluminium subframe, somehow the bolt fused with that bushing. Its possible that it partially melted, unfortunatly it probably took me two hours before I realized that I could probably just unscrew it from the bushing, something that only partially worked. I actually cannot remember how it came out in the end, I must have blacked out or something...😂

51013336337_c74c8169c7_b.jpg

But this was only one side. The other side was the same bs. The nut came off fairly easily, the steel stud of the balljoint however must seized in place due to corrosion in ways I couldn't even imagine. No matter how many hammer blows it received, it would not even move a single mm. Eventually a combination of prying and hammering the shit out of it got it out, but boy was this a struggle. Its jobs like this where you really feel like you can achieve anything afterwards.

51013248041_d5858f7e04_b.jpg#

Old vs. new. I've adjusted the new arm to more or less match the length of the old one. I still have to replace the other side, Im hoping that things will be a little easier next time... After that I can get an alignment done.

51013249101_64b8ac2600_b.jpg

Not surprisingly the ABS sensor didn't survive. Judging by the state of the rubber wire insulation it might have been the original sensor, the cable probably got disturbed or the sensor couldn't handle the hammering for much longer. I bet it'll be fun getting that one out...

51013336942_a2cd9528c3_b.jpg

Link to post
Share on other sites
  • 2 weeks later...

2 weeks have passed and more progess has been made! The original ABS sensor didnt survive the installation of the first toe link so it got replaced yesterday. I actually didnt check if the ABS light was gone but I'll just go ahead and assume so. As always getting the old sensor out was an absolute pita as it predictably fell apart the moment you looked at it. Not only the bolt snapped instantly, the entire sensor did, too!:

51059349838_13eb8f0c61_c.jpg

I drilled the remains of what was left out, the remains of the bolt actually didn't take too much force to come out oddly enough. As you can see, the sensor wiring has had it:

51059349673_f8ea0ea299_b.jpg

I've also replaced my leaky mirror glass (electro-chromatic/Self dimming), the fluid between the two layers of glass has a habit of leaking out after 20 years.

On the Merc side I've reinstalled the Merc's door panel, just waiting for a new window lifter switch to arrive now. I planned to have the springs replaced by a Merc specialist earlier this week. However, the list of things that need fixing was so long that they called me asking whether I might wanna have a look at the list of issues first before going forward. Long story short: I needs some suspension components and welding. Lots of welding... I've ordered most of the parts. The welding hopefully isn't MOT relevant, however it does come somewhat unexpectedly and will need to happen at a later point.

Aside from those unpleasant news I installed spark plugs, wires and new caps and rotors on the Clesior, still runs like crap so I removed the fuel rails and injectors which Im going to clean over the next few days. My theory still is that running the tank dry sucked up a bunch of gunk thats now preventing the injectors from doing their job. That or one of few important sensor (Cam/MAF) decided to give up on life right at that moment, leading me down a path of suffering I really didn't deserve. I should have it all back together by next weekend hopefully, then I'll know if I need to add a sensor to the shopping list or not. Considering I found this inside the fuel rail, I think I might be right in my assumptions though:

51060153067_1bf4011c04.jpg

Everything that got replaced in the end. Getting the wires right took a bit of concentration.

51059350033_caa60a774e_b.jpg

DIstributors. Quite a lot more of a pain to reach compred to the Merc's. Timing belt actually looks decent:

51059350503_463ff3ff98_b.jpg

51059350303_8de8e6d96b_b.jpg

Old vs. New:

51059350193_3a119a4daf_b.jpg

Spare plugs looked pretty coked up. I think its simply due to the poor idle and short runs.

51060071836_7969052a13_z.jpg

Also, while removing the fuel rails I noticed a bunch of leafs and stuff underneath my intake manifold. Turns out something build a next in the valley of the engine, which is actually rather deep, meaning that I've spent at least half an hour vauuming leafs, dirts, a ton of snail shells and other unidentifiable garbage out of my engine. Nasty:

51060153257_93c2ba2599_b.jpg

Link to post
Share on other sites

Is the ABS sensor on the E39? When I changed a rear on my 530d touring it snapped in and after I'd drilled it out the swarf that gone into the hub freaked out the ABS, very juddery! Access was difficult to clean it out, it took a combination of a blade raking about from underneath and pulling the sensor out several times to clean it.

Link to post
Share on other sites

It seems like any debris just fell out of it, you can reach the abs ring from underneath the car, I'd hope that all this garbage is just getting flung out once I drive the car. The sensor itself seated perfectly fine so I hope thats all that was needed!

Link to post
Share on other sites

I'm pretty sure my sensor sensed off the bearing with no abs ring there and the magnetic sensor picked up the small whiskers of steel once I started driving. I have a pair of new rear wheel bearings that came with the 1/1999 530d if you want.  The owners diagnostics were wrong, - the gearbox grenaded after he bought them!

Link to post
Share on other sites
On 3/22/2021 at 12:45 PM, spike60 said:

I'm pretty sure my sensor sensed off the bearing with no abs ring there and the magnetic sensor picked up the small whiskers of steel once I started driving. I have a pair of new rear wheel bearings that came with the 1/1999 530d if you want.  The owners diagnostics were wrong, - the gearbox grenaded after he bought them!

It might or might not need a rear wheel bearing eventually, its a bit hard to tell as long as the rear wheels arent aligned perfectly, the tires could be making all the noise for what I know. The place that was supposed to do the alignment yesterday couldn't because their machine broke (apparently they called me but I never got that call from them...) so it might take a little longer before I know for sure. Happy to take them if the bin is the only other fate for them:D No ABS light though so its seems all good really.

The car did pass its MOT though! With a slight delay, but better late than never! It needs its brake pipes sorting out asap though, they've really reached the end of their life now and the tank will need to come out to do the job. Fun times.

51066857636_75d8352894_h.jpg

Link to post
Share on other sites
  • 2 weeks later...

Lots more progress done over the long weekend. The Celsior had its fuel system reassembled and runs properly again, I think the actual main issue was that it was running out of fuel again... I did check all injectors and they all seemed to be fine. Unfortunately one of the lower injector isolators ripped while installing the fuel rail, resulting in an air leak which I need to sort out when parts are here. New wheels are on as well, cant wait to give this a wash and polish:

51094848082_4b895cfb85_h.jpg

The Mercedes is now receiving quite a lot of attention as well. A friend of mine asked me whether he could borrow it as wedding car for a mate's wedding in 3 months so it needs an MOT soon. The rear springs in the back need replacing for that, so do the lower control arms. While getting these out I figured I might as well replace the shocks and drop links, in reality everything underneath there needs to be renewed as all bushes look rather original and everything is properly crusty... Front ball joints were replace with the help of my mates yesterday, god were those a struggle😬 Hopefully I can get it all sorted over the next 2 weeks or so, should make quite the difference to ride and handling!

Getting these new bushes in was a even worse than in the E39. A real test to material and mind, Im not surprised that Mercedes specialist wanted me to get new arms.

51094838117_f84bc9bd45_b.jpg

Complete destruction:

51094742901_50e57cb3d1_b.jpg

I bought these arms from a Mercedes breaker to replace the bushes before I got the old ones out. They were a bit crusty but cleaned up fairly well. With 2 layers of POR15 these should last another 15 years I'd hope. And yes, Im quite proud of my eco friendly painting booth.😂

51094742616_697a96c1e9_z.jpg

Nothing is indicating that these have ever been replaced before. Lower coils of both springs snapped, all bushes are completely torn up, the shock absorbers are still surprisingly good though, no leaks despite their looks!

51095285023_a9428b54fb_b.jpg

Rear brakes and a bunch of other items will get replaced while its all apart:

51095286288_3006c58dac_b.jpg

In other news, the black Mark VIII LSC makes a return for spring and has finally received a bath! I originally parked it up since I thought a wheel bearing was on its way out. Turns out 4 of 5 wheels bolts somehow came lose, and these weren't touched since I had the tires balanced all the way back in Germany last September😬

51094743306_c666faf109_h.jpg

51095286128_58cfd2ebb5_h.jpg

Also, more cheap parts for the E39! UK headlights I'll restore to replace my LHD spec lights, plastic covers/arch liners that were shredded by the po on mine and an OEM sport bumper to replace my crappy aftermarket one. Things arent going to slow down anytime soon...

51094821369_e1b858ab85_b.jpg

Link to post
Share on other sites

Once again Rockauto delivered in record time. Replaced the lower injector seal today (I can get that fuel rail out pretty swiftly by now), all good again without any noticeable vacuum leaks.

It took a little while to go from this:

51106948167_68b22bf846_h.jpg

Back to this:

51107422668_3a3131cc5e_h.jpg

Also, the UK spec trunklid I bought recently won't work.😐 I did some research before to make sure that I can just transfer my JDM/US spec inner tails onto the Euro version but one thing or another, maybe with the facelift, must have changed and none of the bolt holes line up. Since I only bought it to save myself a respray theres no point in modifying it to fit, it would just start to rot around the cuts eventually.

Oh well, in case someone needs a Mk1 trunklid in dark blue...

Link to post
Share on other sites
  • Schaefft changed the title to Schaefft's Bargain Barge Extravaganza - Toyota Tinkering

Planned to wash and polish the Celsior today, it was too cold and it started to randomly snow so I polished these instead. I recently saw WatchJRGo's (highly recommended YT channel) headlight restoration comparison and while I liked my 3M kits for a long time, this Turtle Wax one actually came out on top above it. With it being significantly cheaper than the 3M one (and CP4L having a sale on) I thought I'd give it a go:

51109410112_1b5b4f2b35_z.jpg

Before:

51109976496_3d07c01a84_h.jpg

51109722944_64a0e1f80e_b.jpg

51109722474_1dcf5ed0da_b.jpg

After:

51109409192_13f6a379fa_h.jpg

The reflections dont help but they really turned out great despite the filth on the inside, as close to new as you'd ever realistically get and easily as good as the 3M kit. 5* m8.

Also boat:

51109881148_eae86379d7_b.jpg

Link to post
Share on other sites

Finally gave the Celsior a wash and polish this weekend! And boy did it need both. I've spent 7 hours polishing the hell out of this car today and haven't even touched the lower semi-gloss cladding yet. Any recommendations how to polish these parts would be super helpful, I want to avoid them turning to normal high gloss clear. They are similr to the semi-gloss you can find on older Mercs.

The whole process also gave me enough time to find out more about the history of the car. It definitely has been resprayed at some point judging by the clearcoat edges peeling in some areas. The car has also received some attention on the driver rear quarter/rear door as the paint match definitely isn't perfect. The rear bumper has been repainted (very poorly), possibly after the former work was carried out but I knew that already. It really would need an entire respray to be decent but thats not going to happen anytime soon. Might buy some touch up paint to fill the chips along the door edges though, this kit seems quite decent.

The upper surfaces of the car are painted in Midnight Indigo Pearl, now that the paint isn't as dull anymore its really starting to shine (compare the below to the car a few posts earlier)!

51123767159_a26b14f544_h.jpg

51123453972_afde4be7f7_h.jpg

Some before and afters:

51123768039_b856279ef1_b.jpg

51123928223_bfda1a4d6f_b.jpg

51123767969_0323d96d6d_b.jpg

51124019871_0273e41082_b.jpg

The next few photos show a deep scratch going all the way to the back from some d'ickhead keying the car sometime before I bought it. I can probably get it out a little more, I was just worried about buring through the clearcoat (which in the end turned out to be unjustified, it felt like it would take ages). You can see some weird discoloration underneath the clearcoat in the second photo though, I'm not sure what might have caused this.

51123929318_3fdd033c6b_b.jpg

51123928318_ea49d03119_b.jpg

51124021116_82015ab8d0_b.jpg

51123928103_79fb7b3fc7_b.jpg

51124021031_85f90471c7_b.jpg

Clearcoat peeling away from the scratch, revealing more clearcoat!

51123766649_db30b3ce2e_b.jpg

Ding from when a storm knocked the bin over...

51124825135_f925c585d1_b.jpg

51124823905_2c22e7a9ee_b.jpg

51123928973_61a023b02b_b.jpg

51123927833_0e7d09d675_b.jpg

51123928768_b466cb0f96_b.jpg

51124823790_8a97520a52_b.jpg

51123767309_6390e8dacb_b.jpg

51124019541_c45c63cdd2_b.jpg

51123928578_f453bc2d6f_b.jpg

51124825710_2f6fa34d2e_b.jpg

Link to post
Share on other sites
15 hours ago, Spottedlaurel said:

Looks great!

You can come and do the same to mine if ever you get bored, athough I fear that much of my paint is beyond salvation and the best I can do is keep it vaguely clean.....

I can't imagine that its much worse than mine.😄 White hides imperfections a lot better than a dark color, too!

Link to post
Share on other sites

More things!

 

Finally got some of the plastic bits I recently bought for the E39 on the car.

51138844494_afaef32f24_b.jpg

Of course things quickly spiraled out of control, at least I now know that my jacking points really are as bad as they appeared to be.

51138288003_e091b4f9b7_b.jpg

Oh boy... Funny that I'm currently selling my way more desirable manual 540i for exactly the same issues... 

51138068696_7cc83ea190_b.jpg

In better* news, look at all this trash I managed to finally replace on the car:

51138844024_32d92960ea_b.jpg

The previous owner really did take great care of it.

The Lincoln received some attention as well. The evap canister tray on the '97 and '98s likes to rot out quite badly. I ordered mine from the states a little while ago. While it was supposed to be rust free it did have a few spots I had to clean up. Ended up respraying the whole thing, this time using etch instead of the zinc primer I used on other things before. This stuff better does the job...

51138287613_4c3c061b7a_b.jpg

51137393137_1429f923da_b.jpg

Much better:

51138843664_46965c739e_b.jpg

This should last a while, especially since Im not driving this one during winter. Also bonus Celsior:

51139175030_c4aa3f371b_h.jpg

Link to post
Share on other sites
  • Schaefft changed the title to Schaefft's Bargain Barge Extravaganza - W140 Rear Suspension Refresh Cont.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...