Jump to content

1975 Ford Granada Coupe - First 1k miles achieved


TripleRich

Recommended Posts

I was running BP ultimate with Millers VSPe fuel additive when I broke down.  It still boiled but the engine was certainly running too hot.  Having a mechanical pump bolted to the site of the block doesn't exactly help.

Main goal is to get the engine temp down as  I don't like running cologne V6s hot.  They can't take the abuse like an essex, much more fragile.  

Link to comment
Share on other sites

82 stat should help- I have an 82 in the Chieftain and that doesn't make too much heat into the carb, though the metal line that runs under the engine boils up where it's not in airflow from the fan. 

It's downright dirty but my solution is a low pressure, draw-through electric pump up by the tank that's on a switch under the dash. Generally it only needs it in really hot idling traffic or after the car's been sat up for a few minutes and the heat soak gets to the fuel. Since hooking that up I've had zero problems with new fuels.

 

Phil

Link to comment
Share on other sites

Does this vehicle run flow only, or flow-and-return to the tank?  If it's on flow only, adding a return to the tank would save a lot of vapour lock problems, as you're constantly flowing fuel around, meaning it doesn't have time to get too hot.

I know you're going for originality on this, but a small mod like that to allow compatability with modern fuels might be essential.

Link to comment
Share on other sites

2 hours ago, Talbot said:

Does this vehicle run flow only, or flow-and-return to the tank?  If it's on flow only, adding a return to the tank would save a lot of vapour lock problems, as you're constantly flowing fuel around, meaning it doesn't have time to get too hot.

I know you're going for originality on this, but a small mod like that to allow compatability with modern fuels might be essential.

Not if it was boiling in the float bowl... On a flow-only system your only hope is to pump enough liquid fuel to blow the vapor out and cool it down to the point the fuel remains liquid.

Link to comment
Share on other sites

41 minutes ago, PhilA said:

Not if it was boiling in the float bowl... On a flow-only system your only hope is to pump enough liquid fuel to blow the vapor out and cool it down to the point the fuel remains liquid.

True, but if there was a flow-and-return system in the first place, the fuel would likely enter the carb quite a bit cooler than if not, meaning you'd still be less likely to get vapour locks.

Link to comment
Share on other sites

1 minute ago, Talbot said:

True, but if there was a flow-and-return system in the first place, the fuel would likely enter the carb quite a bit cooler than if not, meaning you'd still be less likely to get vapour locks.

It would help, certainly. If the body of the carburetor has absorbed that much heat there is a problem. Either inadequate airflow around it or it needs a shield to keep the radiated heat from the manifold off it.

Adding the factory option heat shield to mine helped immensely.

 

Phil

Link to comment
Share on other sites

4 hours ago, JimH said:

The issue is clearly one of dwell time so the answer is to up the flow through the carb which is easily achieved by driving faster.

Officer.

I did try driving quite a bit faster to get more cool fuel in the carb but I think it was too little too late.  Many pops and bangs were had before it died at about 50mph.  Handy as I could just roll to the nearest farm gate and stop.

It already has a fuel return and the fuel boiled as a result of the engine just getting too hot.  I'd rather it cut out and vapor lock before actually overheating in a cloud of steam and head gaskets.  Its only a little engine so I expect the fuel in the float bowl lasts quite a while.  I can help cool the carb by fitting a spacer block between it and the inlet.   

20201107_193324.thumb.jpg.2ecff425cc921c9a58e1e65c35126890.jpg20201110_200424.thumb.jpg.f15a0b060f84b6b1652aff1f5ff89105.jpg

Fitting a revotec fan or similar is an option but the thermostat just opens too late for the cooling system to do anything.  I'd just be cooling a radiator that's not being allowed to flow into the engine.  Since wedging the thermostat open it runs cold at the bottom of the gauge.  I can't even get a quarter on the gauge in stationary afternoon traffic.  

I'll do the thermostat and progress from there.  Think I have a spacer block for the carb in my pile of bits so will try that if I continue to get problems with a stat fitted.  

Link to comment
Share on other sites

20 hours ago, PhilA said:

Yeah, a nice phenolic block to reduce heat transfer from the manifold to the carb should help. I would've thought it was a continental offering from Ford.

From hazy memories of my Scimitar with the same engine, if they didn’t come as standard with a phenolic block then they were often substituted, as it got bloody hot in the cramped engine bay surrounded by fibreglass bodywork.

Link to comment
Share on other sites

1 hour ago, Lankytim said:

Wrap the fuel pipes in foil?

That works quite well, there's fireproof orange jacketing that's used on piston engine aircraft for the same reason too which is highly effective.

products_194552_5fbb1959c3ca55b2f806a397b7588a2c.jpeg.aa6ac6a93a07089cfb35b8528b139988.jpeg

This kinda stuff too.

 

Phil

Link to comment
Share on other sites

What fuel are you using?  Another member had vaporisation issues with his SD1 and they seemed to improve by changing from premium unleaded to regular.

The reason for this is super unleaded has acetone in it and is more inclined to evaporate in hot temperatures.  Maybe try some regular stuff while it’s hot, you never know it might save having to strip things down.

EDIT - just read previous page which suggested Esso super has no ethanol in it so maybe that ones ok.  Either way try and find out which ones have ethanol / acetone in them, and avoid those that do

Link to comment
Share on other sites

  • TripleRich changed the title to 1975 Ford Granada Coupe - First 1k miles achieved

I fitted an 82 stat on Friday night before the show.  I forgot how tricky these are to blead but I got there eventually.  You always get a nasty airlock in the heater matrix on mk1s when the coolant is drained.  Ford fitted a blead valve in the affected hose on later cars.

20210730_193336.thumb.jpg.d3a9d482608c5d22541652455e77d2a3.jpg

Ran it round the block a few times and the temp stayed at half, with the 87 stat it would sit at 2 thirds or more.   

Set off the following morning on the 70 odd mile trip to FOTU.  Performed really well on the A1 with the temp sitting at half or slightly under.  Cruised at 70 running about 3k rpm thanks to 5th gear.  Plenty of stop start traffic too and it wasn't bothered.  I turned it off a few times in the queue to get in and it fired straight back up each time.  That should be an end to any vapor locks issues, queue was quite handy to test that on reflection.

IMG-20210731-WA0005.thumb.jpg.40c839456a22c5facc6cb62f9601089d.jpg

A quick wax and rough clean of the engine bay to get rid of the water stains from the previous evening's thermostat fun and we're sorted.

20210731_102633.thumb.jpg.72658f5446d4a9dd16320932bb1acdf6.jpg20210731_134330.thumb.jpg.8b7ea3fae227448c7dbf6b5a7970fdcf.jpg

On the way back I passed the 1k mile mark since the restoration.  I've not had any major issues and the car has gained my trust.  I'll thin out the tool kit in the boot now!  

20210730_192955.thumb.jpg.2f3633f135069c19bfd34e3f6b14b7c8.jpg

Link to comment
Share on other sites

Good news!  The sun has revived the original dealer sticker in the back window.  When I put the window in this looked really brown and washed out.  Slowly over the past couple of months it's been coming back to life in the sun.  No idea how that that works but I'm pleased.

20210804_172255.thumb.jpg.f4cbd18bd79c87589e3e9c738dd3936e.jpg

Here it is with a colleagues Maxi, doing our best to bring some style to the otherwise modern car park.  Maxi gives the Granada a good run for its money on the twisty roads.  Good fun!

20210802_133700.thumb.jpg.0ef84c7a18928bcfeb18e9cb4710d121.jpg   

Done another 150 miles or so since the show.  Still running well and I make sure to give it a good workout each time without thrashing it.  Getting about 28mpg, on a run driving gentle I should be able to get 30 out of it. 

Link to comment
Share on other sites

10 hours ago, Talbot said:

That's remarkable.  I thought the official fuel consumption figures for a 2.3 granada were in the low 20s, and even that was if driven carefully.

I did just over 200 miles on a mix of roads and used 33 litres of fuel.  I'm sure 5th gear is really helping the figures.

A German roadtest of a 2.3 Granada got 32 mpg on a long run at a constant speed.  Around town it was right down in the low 20s.

Link to comment
Share on other sites

  • 5 weeks later...

375 miles covered since the last post.  I put the daily driver in the garage and used the Granada instead.  Its been very enjoyable and I've been keeping a close eye on how its doing.

Since FOTU I've noticed a very slight hesitation just as you get on the throttle.  It only existed in 3rd gear going from a 30 to a 60 and was barely noticeable so I didn't think too much of it.  Last week on the way to work it turned into a more severe splutter/ hesitation at various speeds.  Only when slightly on the throttle and you could just power through it.

Knew it wasn't right so decided to take a look. 

20210904_111755.thumb.jpg.7d61c185b3eff2f5291cea9288d7aa69.jpg

First thing I found was a slight vacuum leak from the line running between the carb and the airbox.  The airbox is very old so I wasn't surprised, blocked it off and adjusted the tune.  

20210904_111747.thumb.jpg.17ab7cf7834471098ed85e38d975c80d.jpg

Went for a drive and it wasn't that so I set to looking at the ignition as its running points and a host of ancient NOS components.

The points were starting to pit a fair bit.  I'd expect them to be better than that given the mileage.  Usually means a bad condenser so I replaced both. 

20210904_122848.thumb.jpg.29610fa1b4f86e2d17575c82be857fe0.jpg

I gapped the points and set the dwell.  Handy to have this book as a cologne engine with points wasn't available on UK Granada's.  It should be 38 degrees according to this.

20210904_132012.thumb.jpg.d92aefd34f45db16bb9060509f81e29d.jpg

Went for a drive and it wasn't that so I decided the swap the coil.  A weak one can cause issues with acceleration and while I had my doubts it only takes a minute to test.  Went for a drive and sure enough it wasn't that so I changed the spark plugs just to be sure and it wasn't those either.

I'd been thinking fuel for a while but didn't investigate as the fuel system is spotless and has been filtered since day one.  The filter is before the pump for max protection and the pump is a new item.

With the ignition system out of the picture it must be fuel related so I took the carb top off and removed the float to check the jets.

20210905_193313.thumb.jpg.cabed64d1e7e4c3a9fa5598c09c3f2f6.jpg

Wedged in one of the main jets was what looked like some blue gasket sealer.

20210905_193348.thumb.jpg.48aec9c25f005d880d9d415c61879afc.jpg

No idea where that came from as I didn't use any on the restoration but there it is.

20210905_193408.thumb.jpg.c40b5865d63fa29386d09536862a4fa4.jpg

The rest of the carb was squeaky clean so I put everything back together and went for a drive.  It was indeed that starving the engine for fuel.  I reckon I've picked up 15HP!

It's always something stupid and I'm glad to have found it relatively quickly.  I'll use the car again next week.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Similar Content

    • By juular
      Old car - check
      Full of rust - check
      Siezed engine - check
      Cheapest on the internet - check
      Bought sight unseen - check
      No space for it - check
      Poo count - 1.5
       
    • By 320touring
      A long time ago, in a galaxy far away, The Burd and I went to see the Skizzer to start getting a MK1 Golf Convertible that had been off the road for 10years..
      After a couple of sessions in deepest darkest Wales , coupled with some sterling help and fettling by Skizzer himself, it was time for us to head down and bring the thing back up.
       
      This went well:
      New tyres were procured and fitted

      The in-game tank pump was pulled out and a new filter fitted

       
      Then I got in touch with my Inuit side, using brand new* magnets to undertake "tank shite" fishing


      A full check over and a couple of test drives showed it fit to play.
      We set off for sunny Oswestry, only to have both front calipers sticking after 120 miles. Some water and time to collect down saw them free off and cause no further problems.
       
      Upon getting just past Tebay, it started running rough - nicking into Todhills rest area and luzzing in 10L of fuel had it running bang on for the next 70miles before it died.
      This was the final scene on the way home.

      I got to bed at 00:45, and left it to sit until today.
    • By SiC
      So to recap. After a painfully long time (well a month) I finally bought a MGB GT.
       








       
      I've always fancied one and after seeing one at a local garage (which turned out to be a bit shit) the urge sprang up again. Anyway after a lot of searching I ended up with this. Seems pretty straight and underneath don't appear to not been welded too much. Worst point that I've found in the leaf spring mount. I'm not going to cover all the different things and stuff just yet as its already in the thread, so I shouldn't make this too long!
       
      I've not owned a car this old and never something with a carburettor. So I don't quite know what I'm doing with a lot of this, and will have plenty of questions! Part of the reason why I bought it was so I had something that I could fiddle with and learn on. As the other thread got a bit long, I thought it would be a better idea to split and start here.
    • By cobblers
      Right so! I was looking to lease an EV through the business, but completely failed due to hating new car dealers, hating touchscreens and eventually settling on a hybrid which is out of stock until mid-late 2022. 
      So I gave up and decided to get a Land rover. I failed at that too, after my mate sent me a link to the advert for this on ebay, at about 9pm. Ten minutes later I had arranged to drive down to see it the next day.

       
      I'm a glutton for punishment, and I really miss my last t25 so it was pretty inevitable that I'd buy it. It was more money than I'm used to spending on these, but overall I was pleased with the deal.
      A dawn raid by our very own @worldofceri had it delivered on Friday morning:
       






      It's a Swedish van originally, and was imported in 2006. Incredibly solid, never been painted and a fantastic "worn in" look. It's a 2.1 "DJ" engine which is pretty healthy but as usual is weeping coolant from various places, they all do that sir. A friend has a rebuilt engine on his shelf so I budgeted that into the purchase - We'll see how it goes.
      Totally original other than someone put some mega Fox/Gowesty suspension on it, proper mega bypass shocks with external reservoirs and stuff, so I reckon I can probably take it off jumps or something. I won't.
      My plans are to (after cleaning the filthy interior) to just run it about, more or less as it is. It would benefit from a set of tyres - these are worn very ridged on the fronts that makes it even more noisy and harsh to drive, and has no spare wheel.
      I've rotated the tyres so now the front ones are smoother, we'll see how I get on. I do need to source another matching wheel for a spare as these are full time 4wd so you need to keep the tyres rotated regular and within a very similar tread depth. look - there's even a sticker telling you to:

       
      I really need to get some new number plates for it! If anyone knows a place who could make some OE style ones with that font all the VW dealers seemed to use in the 1980s, that would be grand - I want some with the dealers logo putting on the bottom:

       
       
    • By Zelandeth
      Well I've been meaning to sign up here in forever, but kept forgetting. Thanks to someone over on another forum I frequent poking me about it recently the subject was forced back into my very brief attention span for long enough to get me to act on the instruction.

      I figure that my little varied fleet might bring you lot some amusement...

      So...we've got:

      1993 Lada Riva 1.5E Estate (now fuel injected, as I reckon the later cars should have been from the factory...).
      1989 Saab 900i Automatic.
      1987 Skoda 120LX 21st Anniversary Special Edition.
      1985 Sinclair C5.
      2009 Peugeot 107 Verve.

      Now getting the photos together has taken me far longer than I'd expected...so you're gonna get a couple of photos of each car for now, and I'll come back with some more information tomorrow when I've got a bit more time...

      Firstly...The Lada. Before anyone asks - in response to the single question I get asked about this car: No, it is not for sale. Took me 13 years and my father's inheritance to find the thing.


      Yes, it's got the usual rusty wings...Hoping that will be resolved in the next couple of months.

       






      Next, a proper old Saab. One of the very last 8 valve cars apparently, and all the better for it. I've driven two 16v autos and they were horrible - the auto box works sooooo much better with the torque curve of the 8 valve engine. Just wish it had an overdrive for motorway cruising...









      Next up a *real* Skoda...back when they put the engine where it belongs, right out the back. In the best possible colour of course...eye-searingly bright orange.







      Seat covers have been added since that photo was taken as it suffers from the usual rotting seat cloth problem that affects virtually all Estelles.

      Then we have possibly the world's scruffiest Sinclair C5...



      Realised when looking for this that I really need to get some more photos of the thing...I use it often enough after all! We have a dog who's half husky, so this is a really good way of getting him some exercise.

      Finally - again, I really need to take more photos of - we have the little Pug 107.



      Included for the sake of variety even if it's a bit mainstream! First (and probably to be the only) new car I've bought, and has been a cracking little motor and has asked for very little in return for putting up with nearly three years of Oxford-Milton Keynes commuter traffic, before finally escaping that fate when my housemate moved to a new job. Now it doesn't do many miles and is my default car for "when I've managed to break everything else."

      I'll fill in some more details tomorrow - I warn you though that I do tend to ramble...
×
×
  • Create New...