Jump to content
scdan4

V70 tdi. Working. Alternator and abs shenanigans

Recommended Posts

That bit hiding up behind the air filter and infront of the turret

post-19553-0-40422200-1464464872_thumb.jpg

made a prolonged, loud, farty vibratey noise (loud enough to be clearly audible in the cabin with the radio on) twice today, both times it did it the nose was pointing down a steep hill and we had just parked and turned off the engine.

It goes on for best part of a minute, so managed to track it down. Initial impressions are fuck knows what it is but it's clearly been bodged in the past. The yellow hose has clearly been disconnected sometime, by someone, for some reason, somewhere.

post-19553-0-43084100-1464465135_thumb.jpg

Thats the blighter.

Does someone want to tell me why it's blowing raspberries at me?

post-19553-0-01213900-1464465259_thumb.jpg

Share this post


Link to post
Share on other sites

The farting is probably a vac leak via what looks like a previous electrical tape repair.

 

I'd agree that it's most likely an EGR solenoid, possibly a boost control solenoid.

 

See if you can follow the hoses and see what they connect to to be sure.

Share this post


Link to post
Share on other sites

The farting is probably a vac leak via what looks like a previous electrical tape repair.

 

I'd agree that it's most likely an EGR solenoid, possibly a boost control solenoid.

 

See if you can follow the hoses and see what they connect to to be sure.

it is indeed the egr solenoid

Share this post


Link to post
Share on other sites

27242200061_2b1f2a6c5d_b.jpg

 

That's interesting*

 

You've blocked the feed to the valve, mine had the feed to the pipe blocked off (rather than the valve body).

 

So I've really reached deep for engineering professionalism, and fired an 8 x 1 woodscrew up it.

 

post-19553-0-83552200-1464598807_thumb.jpg

 

 

In other exiting* news the bumpers jaunty angle

 

post-19553-0-08564000-1464598994_thumb.jpg

 

is caused by the "they all do that sir" bumper mounts rusting through. 

 

post-19553-0-36550000-1464599096_thumb.jpg

 

The towbar seems to be holding it on and new mounts are £40, so may just ignore that.

Share this post


Link to post
Share on other sites

JD did it before he sold me the car, it's not given any bother so I have left it alone.

 

I might be able to help you with bumper mounts, but probably not. I have a feeling they are just as bad on our spares car.

Share this post


Link to post
Share on other sites

JD did it before he sold me the car, it's not given any bother so I have left it alone.

 

I might be able to help you with bumper mounts, but probably not. I have a feeling they are just as bad on our spares car.

 

I'd be grateful if you have a squiz tho! thanks. 

 

I do have 40 quid, but i'd much rather keep as much of it as possible in my pocket. 

 

 

Sutty - do you happen to know if the previous owner stuck a blanking plate in as well when he blocked off the hoses? 

 

 

Also, brake performance at idle/cold is mega shite (nearly rammed a couple of things wriggling out of tight spots since i've got it. The pedal needs proper standing on and is very wooden. Dodgy hose to the servo would be my first guess. Not looked yet.

Share this post


Link to post
Share on other sites

 

 

Sutty - do you happen to know if the previous owner stuck a blanking plate in as well when he blocked off the hoses? 

 

 

Also, brake performance at idle/cold is mega shite (nearly rammed a couple of things wriggling out of tight spots since i've got it. The pedal needs proper standing on and is very wooden. Dodgy hose to the servo would be my first guess. Not looked yet.

 

Cant remember, I wasnt paying attention to the bloke waffling on about it, just caught evry other bit of interesting information. Fordperv may have been listening more tho.

 

As for the brakes, I seam to remember doing that on my drive but never payed much attention to it, it was always fine half way down my street ..... if you're on Facetube, join a group called volvo V70 owners, theres loads of people on there with these... they might be able to shed some more light. I know a bloke on facebook that brakes these V70s too, he might have some bumper mounts, I'll send him a messarge.

Share this post


Link to post
Share on other sites

Cant remember, I wasnt paying attention to the bloke waffling on about it, just caught evry other bit of interesting information. Fordperv may have been listening more tho.

I was doing the same to be fair, I can't remember what he said regarding the egr

Share this post


Link to post
Share on other sites

Cant remember, I wasnt paying attention to the bloke waffling on about it, just caught evry other bit of interesting information. Fordperv may have been listening more tho.

 

As for the brakes, I seam to remember doing that on my drive but never payed much attention to it, it was always fine half way down my street ..... if you're on Facetube, join a group called volvo V70 owners, theres loads of people on there with these... they might be able to shed some more light. I know a bloke on facebook that brakes these V70s too, he might have some bumper mounts, I'll send him a messarge.

 

Halfway down the street and they're ok, but we're tight on road parking round here, so every driving adventure begins with wiggle forward, full lock, wiggle back, full lock, wiggle forward yada yada yada. I'm finding start, footbrake on (normal pressure like), select gear, handbrake off and OH MY JESUS CHRIST nearly slam it into the neighbours car a bit of a strain on my heart. I'm not as young as I was and can't afford lose any more hair.

 

Mounts would be good if you'd be kind enough to ask. I don't do faceache i'm afraid!

 

It might be the same problem but the servo is driven by a cam driven vac pump on the diesels, they get tired and may take a moment to build up a vacuum.

 

I'm going to have a nose - I hadn't noticed that link wasn't a diesel one! The symptoms he describes are spot on so i'll have a delve and see what I can find / test.

 

Not having a manometer though, i have no idea how i'll test a pumps effectiveness. I did notice some of the vac hoses present were pretty cracked and tatty when I was having a nose at the egr, could have something to do with it.

 

 

In other news, i've done a couple of long trips today and yesterday so used them as a economy run. Sat at 60mph on cruise control it has done...

 

...nearly 60 to a gallon.

 

I'm genuinely a bit gobsmacked about that.

Share this post


Link to post
Share on other sites

I've just had a good look at the brakes and bits.

 

The servo seems to be entirely powered by the cam driven vac pump 

 

The vac pipe to the servo looks old, but also ok as far as i could see. It does have the most tortuous route around the engine bay though, bits are buried under the fuse box and air filter box etc, so can't see them. 

 

So I assume the pump has had it.

 

parts for saabs have one but it's over 100 quid.

 

Do they all do that, or if I get one from a breaker should it be a lot better than the one on there? (which, in mitigation has done 200k)

Share this post


Link to post
Share on other sites

To answer my own questions i did some nosing on the internet. 

 

Lots of vw owners reporting sludge in the pump making it noisey and ineffective.

 

So bravely got stuck in today.

 

The pump is at the front in the middle of the engine, so easy to get at, but also heavily obstructed by fuel lines and the like, which made getting the bottom nut off a complete pig of a job, but managed to slide a spanner down there and tease it off.

 

post-19553-0-16038100-1465500729_thumb.jpg

 

pump off

 

post-19553-0-73964000-1465500784_thumb.jpg

 

stripped and washed - no pics of the sludge im afraid as my hands were very manky by that point, but there was plenty off it.

 

post-19553-0-19487700-1465500828_thumb.jpg

 

Back together was as much of a bitch as taking it off, but fitted.

 

And wayhey. brakes. hurrah for that.

 

job well done and all for nowt. My favourite price. 

Share this post


Link to post
Share on other sites

Just a thought, the same engine is used in various vw's so may be cheaper at a VW breaker?

 

yes, during my searching for this i found out it had an audi engine.

 

was a surprise to me. Will now tell my friends i/ve reached the heady heights of driving an audi.

Share this post


Link to post
Share on other sites

I had a look at the bumper mounts on the breaker at the weekend and they are indeed buggered I'm afraid.

 

Thanks for looking. Flushed with vacuum pump success I've just ordered some new ones off ebay. 

 

35 quid delivered - not the end of the world.

Share this post


Link to post
Share on other sites

I'm tempted to strip down my own vacuum pump now. Was it just a case of taking it to bits, cleaning it and putting it back together?

 

yep. 

 

Popped the top plate off it (6 torx screws) and gave the whole thing a good wash in white spirit.

 

It was all covered in oil sludge, including the 3 little valves, so would explain nicely why it was not very effective.

 

Well worth it for the 3 hours or so it took. (and most of that was doing the bottom mounting nut!)

Share this post


Link to post
Share on other sites

New bumper bracket time.

 

old bumper brackets have seen better days.

 

post-19553-0-94139600-1467918315_thumb.jpg

 

the towbar was the only thing holding it on, so had to be dropped to allow the bumper off

 

post-19553-0-77510400-1467918354_thumb.jpg

 

which allowed me to discover this reassuring delight. 

 

post-19553-0-56090400-1467918445_thumb.jpg

 

(we do have a bit of nose weight in the trailer, yes).

 

Back on was a relative delight with new bolts (some stainless, gurt posh), copperslip and brackets. Nothing seized at all. Marvellous. Went so well that I didn't take any photos of the bumper now back on, lined up, straight and true. But I promise i managed it. 

 

So we took it for a wash to celebrate.

 

post-19553-0-50912800-1467918525_thumb.jpg

 

 

Next on the niggle list is the gear shifter release button has broken. This, obviously, results in the ignition key getting stuck in the ignition. (Took me some working out that one). Anyone got one they don't want?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Broadsword
      I think the Broadsword fleet has become sufficiently complicated to merit a combined thread so that gradually all new additions will appear in one place.
       
      As of Sunday 17th March the situation is interesting.
       
      Two Citoren Xantias (remember the white Xantia of Excellence is for sale people!)
      http://autoshite.com/topic/34699-w-reg-citroen-xantia-20-hdi-xantia-of-excellence-%C2%A3999/
      http://autoshite.com/topic/34596-citroen-xantia-double-madness-rust/page-2
       
      A turquoise XJR6 pending overdue-collection (need that gone now!)
      http://autoshite.com/topic/34003-jaguar-xjr6-double-madness-double-sold
       
      An XJS 3.6 manual project which will get in high gear soonish. Wont be a keeper but will be fun getting it back to something presentable. Drivers fantastic!
      http://autoshite.com/topic/34664-jaguar-xjs-36-manual
       
      A Range Rover P38, which is turning out to be really rather good.
       
      And to mix things up even more I'm off on a collection caper today. Had first refusal on it and was expecting it to come around in a year, but things soon changed and no way was I going to pass up on it. It may well render the second Xantia redundant as I've got a really good feeling about this motor.
       
      In the meantime here are some snaps of the Range Rover. As usual it was a car I said I would probably never buy due to their reliability*. I have said the same of Jag XJR, XJS, XK8 and I have had all of those now. Basically the moment I declare buying a particular car is impractical or improbable, I end up buying one.
       
      Things to note on the P38. It's a nice colour with tidy body. The EAS has been removed. It runs and drives lovely and it doesn't have enough electrical problems to hinder progress. The main one is the driver's side window not working, but that should be fixable. I've tried changing the outstation, that didn't fix it. Might be wiring under the seat. Other than that I bought it and took it for an MOT the very next day, and it passed. Since then it had what seemed like a battery drain, but since unplugging the RF thingy for the remote locking and putting on a proper lead-acid battery, which the car can actually charge, unlike the modern lead-calcium batteries, it has been perfect. I will treat it to a full service soon.
       
      Stay tuned for the latest collection later today!



    • By TripleRich
      Hi all, new to the forum.  Thought you might be interested in what I've got myself into
      I'd been after my first classic car for a while.  If it's big and made in the 70s I'm interested.  Looked at few things like P6s, Zodiacs, Victors, SD1s and various other things.  Problem was I didn't want to spend a boatload of money on something that looked alright but underneath was actually a total heap.  The solution was to buy a complete heap in the first place and spend the money fixing it.
      So in January I went ahead and bought this from a colleague at work who was moving away and needed to get shot of it.

      It's a part finished restoration (I prefer not started) and it needs a whole load of help if it's going to stand any chance of using a road again.
      Pros
      It's right up my street.  Granada Coupes are quite odd and certainly stand out from the norm.
      It still has the original engine, box, interior and most trim.
      It came with loads of panels I need to repair it (mostly original Ford stock).
      It came with so many spares I could probably build a few Granadas and still have stuff left over.
      It was cheap.
      Cons
      Most of the front end has been cut off.
      Most of the body structure is quite rotten.
      It's going to take me ages.
      I work at a restoration company and my boss kindly allows me to keep the car there.  So I've got access to all the gear I need to restore it.  I've been busy on the car for a while now so will post more pics over the coming days.
      Cheers 
    • By Shirley Knott
      Greetings all.
       
      After lurking here for a short while, frankly liking what I see and enjoying the various shite, the site has well and truly struck a chord with me. I'm a serial buyer of ropey sub £1k vehicles, don't have to but genuinely enjoy it.
       
      I feel like I might (Just might) have found my 'spiritual' home here
       
      I've been posting across the web on owner specific forums (Usually using either my JoeyEunos or RandomPrecion handles) for a while now, but from here-on-in I will pull my threads together and merge them here into one ghastly topic.
       
      My current steeds...
       
      Lupo 1.7 SDI
       
      SAM_5560 by
       
      and the work/story so far...http://forums.clublupo.co.uk/index.php?/topic/102863-joeyeunoss-sdi-beater/
       
      Golf Mk4 SDI
       
       
      SAM_5531 by
       
      and the thread.... http://uk-mkivs.net/topic/597074-project-slow/
       
      Early (1989) Mk1 Eunos (This one was recently sold)
       
      SAM_4656 by
       
      the thread...http://www.mx5nutz.com/forum/index.php?showtopic=213274
       
      Other shite I've owned and moved on in the last year include this ropey Passat...
       
      SAM_6011 by
       
      and this legendary £300 Fiesta Finesse...
       
      Festa by
       
      Cars I'd like to own/actively looking for in the forthcoming weeks/months/years...
       
      Rover 75 (Dizzler)
      Peugeot 405 (XUD)
      Mk1 Octavia (Estate/dizzler, pre pd or SDI)
      Honda CRV (Gen1)
      Volvo 240/850
×
×
  • Create New...