Jump to content
vulgalour

1980 Austin Princess

Recommended Posts

If you tried it out and they came out OK then you'd have your own ones, and a flat-ish mould could be stored somewhere in case anyone ever asked for a set after they saw yours? Might the owners club be interested? I don't mean produce them by the thousand, but at £30 a set you'd probably turn £20 profit for slopping some liquid latex into a mould and leaving it for a week to set?

Share this post


Link to post
Share on other sites

All options for the future, I'm sure.  Not sure I can be arsed, personally.

In other Princess news, it works!  Removed the slave cylinder and found that there was some more of the black gungy deposits inside it.  Also found there was some surface rust on the bore and, right at the end where the piston doesn't quite travel to, some minor pitting.  I cleaned up the bore the same as I did for the master cylinder and got it as clean as I could before refitting a new seal to the piston and the new dust boot.  Top tip, if the piston is stuck inside you can remove the bleed nipple and insert a skinny rod (I used an allen key) to push the piston out, works a treat and doesn't do any harm to anything.  Piston had some of the gooey stuff on the edge which was probably why it was a bit stuck and while the old seal was still quite flexible and appeared fine, I replaced it with new anyway.

202007-27.thumb.jpg.17ccfa087aa7f01533c91570720b9692.jpg

Then simply screw the cylinder onto the clutch hose (because it's easier that way), screw the bleed nipple back in hand tight, and put the dust boot onto the push rod rather than the cylinder.  Line up the push rod with the piston, and then the cylinder with the bolt holes and bolt it down.  Ease the dust boot on to the slave cylinder - some I've seen have a metal ring or cable tie to hold the boot in place, most don't, mine never has - and tighten the relevant bits up.  Then spend ages with different pedal techniques to evacuate all the air and that's it, the gears return.

202007-28.thumb.jpg.0ae673c520f41cc496574c5ed536b765.jpg

Drove it around the block and it's fine, gear change is as good as I've ever managed to get it, so it's still got that rubber and yet also notchy first gear selection going on and a general vagueness about where the other gears are in relation to the lever, so it'll do.  I also checked the head bolt torques and they're all correct but I'm still getting a very tiny bit of what seems to be totally plain water appearing at the front of the block at the head gasket seam.  Since it's not overheating, mixing fluids, making clouds of steam, or losing coolant I don't really know what's causing this so I'm just going to keep an eye on it for now.  I've bought a replacement head gasket just in case it turns out the one that's fitted is bad.

Anyway, the Princess now seems to work?  Here's hoping it stays that way for a bit.

Share this post


Link to post
Share on other sites

Probably got the slave cylinder seal on the wrong way around so I have to take that all off tomorrow and redo.  Instructions and diagram in the manual aren't clear, like this is one of those things you're just supposed to know so it isn't mentioned.  I just copied what was there when I took it apart so maybe the seal flipped and that was part of the failure.  Whatever the reason, an easy fix.  The diagram also suggests the hose and bleed nipple are in the wrong holes and should be swapped, which they can be since they're the same thread and go to the same place, so I'll do that too and maybe it'll bleed a little easier.

202007-29.thumb.jpg.7745a31904ab75d0c4a9b475dd8451ef.jpg

Share this post


Link to post
Share on other sites

The flared side of the seal always faces the fluid source i.e. away from the boot. I think you have got it the wrong way round looking at the pictures. Amazing it's working at al!

That type of seal will never be able to flip in service btw, if it was the wrong way round that'll be a previous owner mistake and possibly the reason for your poor gear engagement.

The notable exception to that rule is the front seal on the secondary piston on a tandem master cylinder is always the "wrong" way round.

Share this post


Link to post
Share on other sites

First job today after having had the incorrect seal orientation pointed out was to remove, dismantle, and rebuild the slave cylinder.  A very easy job, happily, and the seal doesn't appear damaged or deformed in any way so I reckon we'll get away with it.

202007-30.thumb.jpg.9178e3ca43c87bba4b75c3205fd7cc16.jpg

What I hadn't expected was how much it would improve the gear change.  The gear change has always been a bit rubbish in this car, I'd been told they were just like that, and the rubbery and then notchy selection of first has been a feature of this car since I bought it back in 2012.  Because that's how I thought it was supposed to be I just accepted it.  Now, the gear change is much improved, the rubberiness is gone, as is quite a bit of the vagueness.  I was honestly quite surprised and it must have had this seal in the wrong way around for at least as long as I've owned the car, and probably for quite a while before that.  Next, I wanted to take the car for a quick test run, and maybe even an errand if I was feeling confident.  First up was I spotted a minor weep from the mechanical fuel pump blanking plate, this is quite common and usually because one of the bolts isn't quite tight enough.  Wound the bolt in a bit further and... it stripped the thread.  That's not the first time this has happened on this particular bolt and I had already fitted two longer matching bolts to compensate.

202007-31.thumb.jpg.b119c0fe91bf778aabcfd0e49f64b5a7.jpg

Had a rummage and could only find a bolt that was too long and some washers, so I got it together well enough for a test run.

202007-32.thumb.jpg.ac49f46f6d0e9458e2344992ed497f3c.jpg

The test run turned into a trundle, the car was behaving really well and I was so impressed with the gear change improvement that it seemed sensible to just get everything done.  Oh yeah, people are staring again, like stopping what they're doing and staring.  How do I forget that keeps happening with this car?  Made it with no bother all the same, the valve train has quietened down a bit too now it's had chance to warm up and cycle the oil about a bit more.  Temperature stayed nice and stable, all the gauges pointed where they should, everything was great.

202007-33.thumb.jpg.fd80f651c1e65e8e806525effce99f26.jpg

I was after some bolts to replace that bodged in one, a length of pipe for the BX to test an air leak theory, and some gloves since I ran out today.  Got two out of three, nowhere had any gloves which really shouldn't have been that surprising.  Trundled home and found that the water or whatever it is appearing at the head gasket join is actually coming from the Wellseal used on some of the joints so I assume it's just a component of it that's running off as it gets warm.  Wiped everything clean and it hasn't reappeared in any noticeable amount so that was reassuring too.  Tok out the bodge bolt and washers and replaced it with one of the new ones and that almost went well too.

202007-34.thumb.jpg.066a9d0cf3e35e21368fcd8cee05b148.jpg

Mmm, bolt nice and snug... what's that noi-fweeeEEEE*pop*.  Er... what?

202007-35.thumb.jpg.38610a313a8af666b15e06a41ac57487.jpg

There's a bit missing on the casting now.  The bolt holes that go in for the mechanical fuel pump plate are blind ones, they don't go into the engine itself, they're just cast on the top like this.  The end of the bolt that's always caused problems and popped a tiny bit of the end of the casting out.  I could see there was something stuck in the bottom of the bolt hole and with a bit of wire, prodded it out and ended up with a blob of white-ish silicone sealant that was so black on one end there's no reason it was never seen by anyone and removed.  This is an old issue, again predating my ownership of the car, since I've never used this sort of sealant before.  I can only assume the blob of sealant is what kept making the bolt undo itself but now I had a brand new bolt in with a presumably better thread, the sealant couldn't push the bolt and instead pushed on a very thin part of the casting.  There's no cracks or leaks, like I say this is a blind hole that doesn't go through into the engine.  I did have the car running for a while at idle and with fast throttle and nothing was pushed out through this hole so I'm confident I don't need to dismantle things to fix it.

Otherwise, the car has behaved impeccably.  It doesn't run on at all which is a problem it's had before, especially on very hot days like today, it manages to keep at a steady temperature even in traffic, and the brakes inspire confidence even when faced with Southerners suddenly appearing alongside and then cutting in front of you.  It's actually been really nice just to get out in the car, even if only for a handful of miles.  I might even treat it to a wash, it's been so good today.

Share this post


Link to post
Share on other sites

That's great news, it good to see something going right for a change, you seemed to be having a run of infuriating niggles with both cars. 

I'm not surprised people stare, I can't remember the last timei saw one of these on the road and I don't ever recall seeing a modified example.

Share this post


Link to post
Share on other sites

id helicoil those 2 fuel pump blank holes. and you can get alloy solder to fill that hole with. nice easy mornings fettling there.

Share this post


Link to post
Share on other sites

Now that we're running again, I can turn my attention back to the cosmetic.  Just ordered some new vinyl for the parcel shelf since the leather that was salvaged off an old sofa has not fared well, shrinking so much it's deforming the parcel shelf board beneath.

202007-36.thumb.jpg.78110a8f5e48e2f8f536d9e44afc4a27.jpg

I also found some parcel shelf speakers I liked for almost nothing.  I had been looking at the really massive options out there and they didn't feel quite right so I'd held off until these little ones popped up for a tenner recently.  I like that they're a bit smaller, they fill the space well without dominating it.  I also like that they're a matched pair, something that I'd been trying to find with the larger options, many of which were just two speakers the same, rather than mirrored like these.  They have a bolt built in so you can bolt them down to the parcel shelf too, which is an improvement over the smaller PYE parcel shelf speakers (which I still have) that the car came to me with.  Suppose I better make up my mind about head units.

202007-37.thumb.jpg.12aadf2e35b517ef7d1f7849669d7b54.jpg

Share this post


Link to post
Share on other sites

They look good, very much in period, but I'd have swapped them over. Not sure why, just the (weird) way I look at things.

Share this post


Link to post
Share on other sites

Been trundling about in the Princess today, trying to get it a bit more on tune.  I had it running far too lean, corrected that and adjusted the idle accordingly.  I'm now presented with a throttle that's sticking open occasionally, raising the idle by about 100rpm or so.  It has done this before when the throttle cable was adjusted too tight, and when it was earthing through the throttle cable because the main earth was bad, this time neither of those things are causing it, it just seems to be a slightly sticky mechanism.

Gave the mechanism a squirt of lubricant which got it to stop sticking almost entirely, it probably just needs me to drive it a bit more to get the thing to free off, it's not sticking so badly the car is running away, and it's not doing it every time I come off the throttle so I don't think it's something to worry about.

As a result of squirting the mech, I also discovered a very minor air leak in the area.  The air leak was probably from the carb spacer since I learned the four nuts holding it down weren't quite as tight as they needed to be.  A repeated squirt didn't improve the revs so maybe that's what it was, maybe  there's a tiny leak at the throttle spindle seal on the carb, I'm not entirely certain.  I'll keep an eye on it for now.

Another thing I noticed is that the side of the gearbox casing that was always a little damp, though the leak was never obvious, is now dry.  Perhaps it's coincidental, or perhaps the slave cylinder seal that I corrected recently was actually letting out a very small amount of fluid for a long time and that's why that area was wet so often.  This discovery also highlighted that the sump gasket is definitely weeping on the front edge, I do have a new gasket ready to go on, and I'll do that when I next do the oil change and I'll take the opportunity to clean out any gunge that might be hiding in the sump.  I've never removed the sump because I wanted to be sure I'd solved all the other leaks (there were so many leaks) first and now I finally feel confident that I can do that when the next oil change is due.

Share this post


Link to post
Share on other sites

The sticky throttle issue seems to have fixed itself today and the car itself just felt better, more in its stride, so getting it out and used seems to be doing it good.  Only difficulty at the moment is getting as many miles on as I'd like to really get things bedded in/tempt fate.

Share this post


Link to post
Share on other sites

Today, the parcel shelf has been sorted out.  This is a very simple job.  I used some art board I had left over from another project to laminate the original parcel shelf board and repair some of the damage to it.  Really, I should replace the entire trim board, it's had a very hard life, this was just easier.  After the two boards were bonded together, I then wrapped the whole lot in some new maroon vinyl I'd bought.  The leather I'd previously covered the board in was very dry and had shrunk a lot due to how insanely hot this part of the interior gets.  With the new vinyl I pulled it tight enough to be smart, and just loose enough that if it does shrink it's not going to warp the boards again, difficult to explain but sort of a 'comfortable fit' without being baggy.
202008-01.thumb.jpg.d7764b2a4278c6dbb44f586de4e647a0.jpg

The vinyl I bought is slightly darker than the dye I'd used on the rest of the interior.  That's not a problem, it looks close enough to not look out of place and BL had a habit of using slightly different shades of the same colour on their interiors anyway.  The other thing to do was remove the extra little bit of vinyl that goes between the rear window and the parcel shelf.  Again, I just cut this to the long curved shape it needed to be, and glued it down in a way that would allow it to stretch and shrink without pulling away, it's held in around the edges by other trim pieces so it's not going anywhere even if I didn't glue it.
202008-02.thumb.jpg.76d6274f3395c07902cb6969a907ce3a.jpg

With that all prepared I could ease the newly covered parcel shelf trim in and bop it down to get the trim clips to sit in their holes.  The new parcel shelf board is quite a bit thicker now and it's a tighter fit, I'm hoping that stops it making the occasional low volume boom over rough surfaces.  I also jabbed two small holes under each speaker so they could be bolted down and have the wires fed into the boot space.
202008-03.thumb.jpg.f1d015aa4fed6f51a92a4f4a971acfa4.jpg

Once I have an amp to go under the rear seat and an electric aerial to go in the rear wing I can look at installing the new head unit up front

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Zelandeth
      Well I've been meaning to sign up here in forever, but kept forgetting. Thanks to someone over on another forum I frequent poking me about it recently the subject was forced back into my very brief attention span for long enough to get me to act on the instruction.

      I figure that my little varied fleet might bring you lot some amusement...

      So...we've got:

      1993 Lada Riva 1.5E Estate (now fuel injected, as I reckon the later cars should have been from the factory...).
      1989 Saab 900i Automatic.
      1987 Skoda 120LX 21st Anniversary Special Edition.
      1985 Sinclair C5.
      2009 Peugeot 107 Verve.

      Now getting the photos together has taken me far longer than I'd expected...so you're gonna get a couple of photos of each car for now, and I'll come back with some more information tomorrow when I've got a bit more time...

      Firstly...The Lada. Before anyone asks - in response to the single question I get asked about this car: No, it is not for sale. Took me 13 years and my father's inheritance to find the thing.


      Yes, it's got the usual rusty wings...Hoping that will be resolved in the next couple of months.

       






      Next, a proper old Saab. One of the very last 8 valve cars apparently, and all the better for it. I've driven two 16v autos and they were horrible - the auto box works sooooo much better with the torque curve of the 8 valve engine. Just wish it had an overdrive for motorway cruising...









      Next up a *real* Skoda...back when they put the engine where it belongs, right out the back. In the best possible colour of course...eye-searingly bright orange.







      Seat covers have been added since that photo was taken as it suffers from the usual rotting seat cloth problem that affects virtually all Estelles.

      Then we have possibly the world's scruffiest Sinclair C5...



      Realised when looking for this that I really need to get some more photos of the thing...I use it often enough after all! We have a dog who's half husky, so this is a really good way of getting him some exercise.

      Finally - again, I really need to take more photos of - we have the little Pug 107.



      Included for the sake of variety even if it's a bit mainstream! First (and probably to be the only) new car I've bought, and has been a cracking little motor and has asked for very little in return for putting up with nearly three years of Oxford-Milton Keynes commuter traffic, before finally escaping that fate when my housemate moved to a new job. Now it doesn't do many miles and is my default car for "when I've managed to break everything else."

      I'll fill in some more details tomorrow - I warn you though that I do tend to ramble...
    • By scdan4
      That bit hiding up behind the air filter and infront of the turret



      made a prolonged, loud, farty vibratey noise (loud enough to be clearly audible in the cabin with the radio on) twice today, both times it did it the nose was pointing down a steep hill and we had just parked and turned off the engine.

      It goes on for best part of a minute, so managed to track it down. Initial impressions are fuck knows what it is but it's clearly been bodged in the past. The yellow hose has clearly been disconnected sometime, by someone, for some reason, somewhere.



      Thats the blighter.

      Does someone want to tell me why it's blowing raspberries at me?


    • By Peter C
      Woke up this morning, had a little time before I had to leave the house for work, had a quick look at what’s new for sale on Retro Rides and saw an ad for a W124 200E manual, located 15 miles from home. I had no intention of buying a car today but I had to have it! I called the seller and arranged a viewing.
       
      Faults:
       
      2 x rusty front wings (TADTS)
      1 x rusty rear arch
      Needs a polish
      Tracking is out because new track rod end was fitted for MoT
      Engine has oil leak/s
       
      Good points:
       
      It’s a W124 200E!
      5 speed manual transmission
      New clutch
      Brand new MoT
      Superb MoT history
      4 x as new Continental tyres
      Last owner for 15 years, her husband before that for 4 years
      Very tidy MB-Tex interior
      Drives well
      All electrics work
       
      The dealer kindly delivered the car to my house but I managed a pez station shot on route:
       

       
      Plans:
       
      Remove front wings, cut away rust and apply plenty of wob.
      In-situ similar repair for rear arch
      Clean and polish
      Service engine
      Adjust tracking
      Leave patina and enjoy the car as it is
       
      I will update this thread once progress is made.
       

       

       

       

       

       

       

       

       

       
      Hopefully these two will become good friends.
       

    • By cobblers
      Train tickets booked from a train station 30 miles away to save £9 on the recommendation of the Mrs
      Mrs booked and primed ready to drop me off at said train station.




      Mobile tool kit primed and ready, missing almost every vital component due to EU regulations about leccy tape and screwdrivers on trains (I left them all at my mums house yesterday).
      If I do break down, I should have something to listen to while I work out whether I'm with the AA or RAC or none of the above.


      Not pictured: pile of cash
×
×
  • Create New...